123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899 |
- Name: kdf
- Summary: File device viewer
- Summary(ja): ファイルデバイスビューアー
- Version: 4.14.3
- Release: 2%{?_dist_release}
- License: GPLv2
- Group: Applications/Accessories
- URL: https://www.kde.org/
- Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: kdelibs-devel >= %{version}
- BuildRequires: soprano-devel
- # when split occurred
- Conflicts: kdeutils < 4.8.0
- Vendor: Project Vine
- Distribution: Vine Linux
- %description
- Kdiskfree is displays the available file devices (hard drive
- partitions, floppy and CD drives, USB sticks, etc) along with
- information on their capacity, free space, type and mount point.
- It also allows you to mount and unmount drives and view them in
- a file manager.
- %prep
- %setup -q
- %build
- mkdir -p %{_target_platform}
- pushd %{_target_platform}
- %cmake \
- -DCMAKE_BUILD_TYPE=release \
- -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
- -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
- -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
- -DLIB_INSTALL_DIR:PATH=%{_libdir} \
- -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
- -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
- ..
- popd
- make %{?_smp_mflags} -C %{_target_platform}
- %install
- rm -rf %{buildroot}
- make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
- %post
- /sbin/ldconfig
- touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
- touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
- %posttrans
- update-desktop-database -q &> /dev/null ||:
- gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
- gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
- %postun
- if [ $1 -eq 0 ] ; then
- /sbin/ldconfig
- touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
- touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
- gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
- gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
- update-desktop-database -q &> /dev/null ||:
- fi
- %files
- %doc COPYING
- %{_bindir}/%{name}
- %{_bindir}/kwikdisk
- %{_libdir}/kde4/*.so
- %{_datadir}/applications/kde4/%{name}.desktop
- %{_datadir}/applications/kde4/kwikdisk.desktop
- %{_datadir}/icons/hicolor/*/*/*
- %{_datadir}/icons/oxygen/*/*/*
- %{_datadir}/kde4/apps/%{name}
- %{_datadir}/kde4/services/*.desktop
- %{_docdir}/HTML/en/%{name}
- %{_docdir}/HTML/en/kcontrol
- %changelog
- * Fri Jul 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
- - rebuild with gcc-5.4.0
- * Fri Jan 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
- - initila build
|