file-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280
  1. %define __libtoolize :
  2. Summary: A utility for determining file types.
  3. Summary(ja): ファイルの種類を判別するユーティリティー
  4. Name: file
  5. Version: 4.21
  6. Release: 3%{?_dist_release}
  7. License: Distributable
  8. Group: Applications/System
  9. URL: http://www.darwinsys.com/file/
  10. Source: ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
  11. Source1: magic.mime
  12. # Source for Vine
  13. Source6: printer-j.magic2
  14. Patch1: file-4.19-debian.patch
  15. Patch3: file-4.21-magic.patch
  16. Patch5: file-4.13-fsdump.patch
  17. Patch6: file-4.13-quick.patch
  18. Patch8: file-4.15-berkeley.patch
  19. Patch12: file-4.16-xen.patch
  20. Patch16: file-4.21-oracle.patch
  21. Patch17: file-4.17-clamav.patch
  22. Patch20: file-4.17-bash.patch
  23. Patch21: file-4.19-ELF.patch
  24. Patch22: file-4.19-ooffice.patch
  25. patch23: file-4.21-core_from.patch
  26. patch24: file-4.21-msoffice.patch
  27. # Vine patch
  28. Patch100: file-4.21-jtext.patch
  29. Patch110: file-4.21-vinemagic.patch
  30. Patch120: file-4.09-vinenames.patch
  31. Buildroot: %{_tmppath}/%{name}-%{version}-root
  32. BuildRequires: automake, autoconf, zlib-devel
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %description
  36. The file command is used to identify a particular file according to the
  37. type of data contained by the file. File can identify many different
  38. file types, including ELF binaries, system libraries, RPM packages, and
  39. different graphics formats.
  40. You should install the file package, since the file command is such a
  41. useful utility.
  42. %description -l ja
  43. ファイルコマンドは、ファイルに含まれるデータの種類によって各ファイルが
  44. どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
  45. ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
  46. を含む、多くの異なるファイルの種類を見分けることができます。
  47. file コマンドは大変役に立つユーティリティーなので、必ずインストールして
  48. ください。
  49. %prep
  50. %setup -q
  51. %patch1 -p1 -b .debian
  52. %patch3 -p1 -b .magic
  53. %patch5 -p1 -b .fsdump
  54. %patch6 -p1 -b .quick
  55. %patch8 -p1 -b .berkeley
  56. %patch12 -p1 -b .xen
  57. %patch16 -p1 -b .oracle
  58. %patch17 -p1 -b .clamav
  59. %patch20 -p1 -b .bash
  60. %patch21 -p1 -b .ELF
  61. %patch22 -p1 -b .ooffice
  62. %patch23 -p1 -b .core_from
  63. %patch24 -p1 -b .msoffice
  64. %patch100 -p1 -b .vinejtext
  65. %patch110 -p1 -b .vinemagic
  66. %patch120 -p1 -b .vinenames
  67. cp -p %{SOURCE6} ./magic/Magdir/printer-j
  68. %build
  69. autoreconf
  70. CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
  71. %configure --enable-fsect-man5
  72. make LIBTOOL=/usr/bin/libtool
  73. %install
  74. rm -rf ${RPM_BUILD_ROOT}
  75. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  76. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
  77. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man5
  78. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/misc
  79. make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
  80. ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  81. ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  82. ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  83. { cd ${RPM_BUILD_ROOT}
  84. strip .%{_bindir}/file
  85. cp %SOURCE1 .%{_datadir}/magic.mime
  86. }
  87. ## remove unuse files
  88. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  89. %clean
  90. rm -rf ${RPM_BUILD_ROOT}
  91. %files
  92. %defattr(-,root,root)
  93. %doc LEGAL.NOTICE README
  94. %{_bindir}/*
  95. %{_libdir}/libmagic.so.*
  96. %{_datadir}/file/*
  97. %{_datadir}/magic*
  98. %{_datadir}/misc/*
  99. %{_mandir}/man[15]/*
  100. %{_includedir}/magic.h
  101. %{_libdir}/libmagic.a
  102. %{_libdir}/libmagic.so
  103. %{_mandir}/man3/*
  104. %changelog
  105. * Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.21-3
  106. - rebuils with rpm-4.8.1
  107. - add environment variable LIBTOOL for make command
  108. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
  109. - spec in utf-8
  110. - removed *.la
  111. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
  112. - applied new versioning policy
  113. * Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
  114. - new upstream release
  115. - import debian/fedora patches
  116. - drop obsolete vine magic.
  117. * Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
  118. - rebuild for VineSeed with new tool chain
  119. * Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
  120. - add patch110 for fix CVE-2007-2799
  121. - add zlib-devel to BuildPreReq tag
  122. * Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
  123. - add patch100 for fix CVE-2007-1536
  124. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
  125. - changed Group to Applications/System
  126. * Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
  127. - new upstream release
  128. - update vine patches
  129. * Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
  130. - update Patch10, use 'size_t' in src/jcode.[ch]
  131. * Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
  132. - update to 4.03
  133. - update Patch0, 1, 10 for 4.03
  134. - s/Copyright/License/
  135. * Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
  136. - update to 4.02
  137. - update Vine patches for 4.02
  138. * Sun Mar 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
  139. - new upstream release
  140. - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
  141. - remove unneeded patches.
  142. - update Vine patches for 3.41
  143. * Mon Apr 1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
  144. - added NPDL2 data [Vine:02348]
  145. * Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
  146. - update to 3.37
  147. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  148. - 3.35-0vl3
  149. - disable some entries in elf for problems on big-endian archs
  150. * Wed Jun 6 2001 Jun Nishii <jun@vinelinux.org>
  151. - file-3.35-0vl1
  152. - ver.up
  153. - added %doc
  154. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  155. - file-3.33-1vl4
  156. - more fix and clean up jtext patch (file-3.33-vinejtext.patch)
  157. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  158. - file-3.33-1vl3
  159. - fix again jtext patch (file-3.33-vinejtext.patch)
  160. - added file-3.33-vinenames.patch to avoid miss-judgement
  161. * Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
  162. - file-3.33-1vl2
  163. - update jtext patch (file-3.33-vinejtext.patch)
  164. * Mon Jan 8 2001 Jun Nishii <jun@vinelinux.org>
  165. - file-3.33-1vl1
  166. - modify description-ja and spec
  167. * Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  168. - file-3.28-2vl2
  169. - fixed %files section to handle compressed man pages
  170. * Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
  171. - marged RH 3.28-2 and Vine 3.27-3vl3
  172. * Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
  173. - add ia64 patch from rth
  174. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  175. - handle compressed manpages
  176. - update to 3.28
  177. * Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
  178. - Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
  179. * Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
  180. - patch dues not apply bug.
  181. * Wed Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
  182. - not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
  183. - ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
  184. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  185. - identify ELF stripped files correctly (#4665).
  186. - use SPARC (not sparc) consistently throughout (#4665).
  187. - add entries for MS Office files (#4665).
  188. * Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
  189. - diddle magic so that *.tfm files are identified correctly.
  190. * Tue Jul 6 1999 Jeff Johnson <jbj@redhat.com>
  191. - update to 3.27.
  192. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  193. - experimental support for realmedia files added
  194. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  195. - auto rebuild in the new build environment (release 5)
  196. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  197. - strip binary.
  198. * Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
  199. - add SPARC V9 magic.
  200. * Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
  201. - update to 3.26.
  202. * Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
  203. - update to 3.25.
  204. - detect gimp XCF versions.
  205. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  206. - translations modified for de, fr, tr
  207. * Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
  208. - updated to 3.24
  209. - buildrooted
  210. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  211. - built against glibc
  212. * Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
  213. - Fixed problems caused by 64 bit time_t.
  214. * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
  215. - Improved recognition of Linux kernel images.