libev-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200
  1. %global source_dir %{_datadir}/%{name}-source
  2. %global inst_srcdir %{buildroot}/%{source_dir}
  3. Name: libev
  4. Version: 4.04
  5. Release: 1%{?_dist_release}
  6. Summary: High-performance event loop/event model with lots of features
  7. Summary(ja): 高機能・高性能のイベントループ・イベントモデル
  8. Group: System Environment/Libraries
  9. License: BSD or GPLv2+
  10. URL: http://software.schmorp.de/pkg/libev.html
  11. Source0: http://dist.schmorp.de/libev/Attic/%{name}-%{version}.tar.gz
  12. Source1: %{name}.pc.in
  13. BuildRequires: automake libtool
  14. %description
  15. Libev is modeled (very loosely) after libevent and the Event Perl
  16. module, but is faster, scales better and is more correct, and also more
  17. featureful. And also smaller.
  18. %description -l ja
  19. libev は libevent および Perl の Event を大まかに参考にして作られましたが、
  20. それらより高速に動作し、よりスケールし、より正確で、より高機能で、
  21. 同時によりコンパクトです。
  22. %package devel
  23. Summary: High-performance event loop/event model with lots of features
  24. Group: System Environment/Libraries
  25. Requires: %{name}%{?_isa} = %{version}-%{release}
  26. Requires: pkgconfig
  27. %description devel
  28. Libev is modeled (very loosely) after libevent and the Event Perl
  29. module, but is faster, scales better and is more correct, and also more
  30. featureful. And also smaller. Development libraries.
  31. %description devel -l ja
  32. このパッケージには libev 用開発ライブラリとヘッダが収録されています。
  33. %package source
  34. Summary: High-performance event loop/event model with lots of features
  35. Group: System Environment/Libraries
  36. %if 0%{?fedora} >= 12 || 0%{?rhel} > 5
  37. BuildArch: noarch
  38. %endif
  39. %description source
  40. This package contains the source code for libev.
  41. Libev is modeled (very loosely) after libevent and the Event Perl
  42. module, but is faster, scales better and is more correct, and also more
  43. featureful. And also smaller. Development libraries.
  44. %description source -l ja
  45. このパッケージには libev のソースコードが収録されています。
  46. %prep
  47. %setup -q
  48. # Add pkgconfig support
  49. cp -p %{SOURCE1} .
  50. sed -i.pkgconfig -e 's|Makefile|Makefile libev.pc|' configure.ac configure
  51. sed -i.pkgconfig -e 's|lib_LTLIBRARIES|pkgconfigdir = $(libdir)/pkgconfig\n\npkgconfig_DATA = libev.pc\n\nlib_LTLIBRARIES|' Makefile.am Makefile.in
  52. aclocal
  53. automake
  54. %build
  55. %configure --disable-static --with-pic --includedir=%{_includedir}/%{name}
  56. make %{?_smp_mflags}
  57. %check
  58. make check
  59. %install
  60. rm -rf %{buildroot}
  61. make install DESTDIR=%{buildroot} INSTALL="install -p"
  62. rm -rf %{buildroot}%{_libdir}/%{name}.la
  63. # Make the source package
  64. mkdir -p %{inst_srcdir}
  65. find . -type f | grep -E '.*\.(c|h|am|ac|inc|m4|h.in|pc.in|man.pre|pl|txt)$' | xargs tar cf - | (cd %{inst_srcdir} && tar xf -)
  66. install -p -m 0644 Changes ev.pod LICENSE README %{inst_srcdir}
  67. %clean
  68. rm -rf %{buildroot}
  69. %post -p /sbin/ldconfig
  70. %postun -p /sbin/ldconfig
  71. %files
  72. %doc Changes LICENSE README
  73. %{_libdir}/%{name}.so.4
  74. %{_libdir}/%{name}.so.4.0.0
  75. %files devel
  76. %{_libdir}/%{name}.so
  77. %{_includedir}/libev/
  78. %{_libdir}/pkgconfig/%{name}.pc
  79. %{_mandir}/man?/*
  80. %files source
  81. %{source_dir}
  82. %changelog
  83. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.04-1
  84. - initial build for Vine Linux
  85. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.04-2
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  87. * Tue Aug 9 2011 Tom Callaway <spot@fedoraproject.org> - 4.04-1
  88. - move man page
  89. - cleanup spec
  90. - update to 4.04
  91. * Mon Jun 13 2011 Matト嬲 Cepl <mcepl@redhat.com> - 4.03-2
  92. - EL5 cannot have noarch subpackages.
  93. * Sat Feb 5 2011 Michal Nowak <mnowak@redhat.com> - 4.03-1
  94. - 4.03; RHBZ#674022
  95. - add a -source subpackage (Mathieu Bridon); RHBZ#672153
  96. * Mon Jan 10 2011 Michal Nowak <mnowak@redhat.com> - 4.01-1
  97. - 4.01
  98. - fix grammar in %%description
  99. * Sat Jan 2 2010 Michal Nowak <mnowak@redhat.com> - 3.90-1
  100. - 3.9
  101. * Fri Aug 10 2009 Michal Nowak <mnowak@redhat.com> - 3.80-1
  102. - 3.8
  103. - always use the most recent automake
  104. - BuildRequires now libtool
  105. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.70-3
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  107. * Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-2
  108. - spec file change, which prevented uploading most recent tarball
  109. so the RPM was "3.70" but tarball was from 3.60
  110. * Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-1
  111. - v3.7
  112. - list libev soname explicitly
  113. * Mon Jun 29 2009 Michal Nowak <mnowak@redhat.com> - 3.60-1
  114. - previous version was called "3.6" but this is broken update
  115. path wrt version "3.53" -- thus bumping to "3.60"
  116. * Thu Apr 30 2009 Michal Nowak <mnowak@redhat.com> - 3.6-1
  117. - 3.60
  118. - fixed few mixed-use-of-spaces-and-tabs warnings in spec file
  119. * Thu Mar 19 2009 Michal Nowak <mnowak@redhat.com> - 3.53-1
  120. - 3.53
  121. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.52-2
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  123. * Wed Jan 07 2009 Michal Nowak <mnowak@redhat.com> - 3.52-1
  124. - 3.52
  125. * Wed Dec 24 2008 Michal Nowak <mnowak@redhat.com> - 3.51-1
  126. - 3.51
  127. * Thu Nov 20 2008 Michal Nowak <mnowak@redhat.com> - 3.49-1
  128. - version bump: 3.49
  129. * Sun Nov 9 2008 Michal Nowak <mnowak@redhat.com> - 3.48-1
  130. - version bump: 3.48
  131. * Mon Oct 6 2008 kwizart <kwizart at gmail.com> - 3.44-1
  132. - bump to 3.44
  133. * Tue Sep 2 2008 kwizart <kwizart at gmail.com> - 3.43-4
  134. - Fix pkgconfig support
  135. * Mon Aug 12 2008 Michal Nowak <mnowak@redhat.com> - 3.43-2
  136. - removed libev.a
  137. - installing with "-p"
  138. - event.h is removed intentionaly, because is there only for
  139. backward compatibility with libevent
  140. * Mon Aug 04 2008 Michal Nowak <mnowak@redhat.com> - 3.43-1
  141. - initial package