lldb-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. Summary: Next generation high-performance debugger
  5. Summary(ja): 高性能デバッガー
  6. Name: lldb
  7. Version: 14.0.5
  8. Release: 1%{?_dist_release}
  9. Group: programming
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: NCSA
  13. URL: https://llvm.org/
  14. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
  15. # patches
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: binutils-devel
  18. BuildRequires: cmake
  19. BuildRequires: ninja
  20. BuildRequires: llvm-devel = %{version}
  21. BuildRequires: llvm-static = %{version}
  22. BuildRequires: clang-devel = %{version}
  23. BuildRequires: clang-tools-extra = %{version}
  24. BuildRequires: ncurses-devel
  25. BuildRequires: swig
  26. BuildRequires: libffi-devel >= 3.3
  27. BuildRequires: zlib-devel
  28. BuildRequires: libxml2-devel
  29. BuildRequires: libedit-devel
  30. BuildRequires: python3-devel
  31. Requires: python3-lldb = %{version}-%{release}
  32. %description
  33. LLDB is a next generation, high-performance debugger. It is built as a set
  34. of reusable components which highly leverage existing libraries in the
  35. larger LLVM Project, such as the Clang expression parser and LLVM
  36. disassembler.
  37. %package devel
  38. Summary: Header files for LLDB
  39. Summary(ja): LLDB のヘッダファイル
  40. Group: programming
  41. Requires: lldb = %{version}-%{release}
  42. %description devel
  43. This package contains header files for the LLDB debugger.
  44. %package -n python3-lldb
  45. Summary: Python3 module for LLDB
  46. Summary(ja): LLDB用Python3モジュール
  47. Group: programming
  48. BuildRequires: python3-devel
  49. Requires: python3-six
  50. Requires: lldb = %{version}-%{release}
  51. %description -n python3-lldb
  52. The package contains the LLDB Python3 module.
  53. %debug_package
  54. %prep
  55. %autosetup -p2 -n lldb-%{version}.src
  56. %build
  57. CFLAGS="%{optflags} -Wno-error=format-security"
  58. CXXFLAGS="%{optflags} -Wno-error=format-security"
  59. %cmake \
  60. -GNinja \
  61. -DCMAKE_BUILD_TYPE=Release \
  62. -DCMAKE_SKIP_RPATH:BOOL=ON \
  63. -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
  64. \
  65. -DLLDB_DISABLE_CURSES:BOOL=OFF \
  66. -DLLDB_DISABLE_LIBEDIT:BOOL=OFF \
  67. -DLLDB_DISABLE_PYTHON:BOOL=OFF \
  68. %if 0%{?__isa_bits} == 64
  69. -DLLVM_LIBDIR_SUFFIX=64 \
  70. %else
  71. -DLLVM_LIBDIR_SUFFIX= \
  72. %endif
  73. \
  74. -DPYTHON_EXECUTABLE:STRING=%{__python3} \
  75. -DPYTHON_VERSION_MAJOR:STRING=$(%{__python3} -c "import sys; print(sys.version_info.major)") \
  76. -DPYTHON_VERSION_MINOR:STRING=$(%{__python3} -c "import sys; print(sys.version_info.minor)") \
  77. -DCLANG_LINK_CLANG_DYLIB=ON \
  78. -DLLVM_LIT_ARGS="-sv \
  79. --path %{_libdir}/llvm" \
  80. %{nil}
  81. %cmake_build
  82. %install
  83. rm -rf %{buildroot}
  84. %cmake_install
  85. # remove static libraries
  86. rm -fv %{buildroot}%{_libdir}/liblldb*.a
  87. # python: fix binary libraries location
  88. liblldb=$(basename $(readlink -e %{buildroot}%{_libdir}/liblldb.so))
  89. ln -vsf "../../../${liblldb}" %{buildroot}%{python3_sitearch}/lldb/_lldb.so
  90. # remove bundled six.py
  91. rm -f %{buildroot}%{python3_sitearch}/six.*
  92. %if %{with test}
  93. %check
  94. %endif
  95. %clean
  96. rm -rf %{buildroot}
  97. %files
  98. %defattr(-,root,root,-)
  99. #doc %{llvmdocdir lldb}/
  100. %{_bindir}/lldb*
  101. %{_libdir}/liblldb*.so.*
  102. %{_libdir}/liblldbIntelFeatures.so.*
  103. %files devel
  104. %defattr(-,root,root,-)
  105. %{_includedir}/lldb
  106. %{_libdir}/*.so
  107. %files -n python3-lldb
  108. %{python3_sitearch}/lldb
  109. %changelog
  110. * Thu Jun 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  111. - new upstream release.
  112. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  113. - new upstream release.
  114. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  115. - new upstream release.
  116. - dropped all patches.
  117. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  118. - new upstream release.
  119. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  120. - devided lldb from llvm.
  121. - new upstream release.
  122. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  123. - enabled to build utils.
  124. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  125. - new upstream release.
  126. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  127. - new upstream release.
  128. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  129. - rebuilt with libffi-3.3.
  130. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  131. - new upstream release.
  132. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  133. - new upstream release.
  134. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  135. - dropped all patches.
  136. - switched build-system to ninja.
  137. - switched python to python3.
  138. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  139. - new upstream release.
  140. - added OpenMP.
  141. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  142. - fixed %%files.
  143. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  144. - new upstream release.
  145. - dropped Patch0, 4, 5, 100 and 200.
  146. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  147. - renamed a subpackage "llvm-libs".
  148. - added a subpackage "lld".
  149. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  150. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  151. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  152. - new upstream release.
  153. - dropped Patch1 and 2: fixed in upstream.
  154. - imported Patch0, 3-5, 100 and 200 from rawhide.
  155. - disabled Patch1002: no longer needed?
  156. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  157. - new upstream release.
  158. - switched to cmake.
  159. - disable ocaml binding as default.
  160. - updated Patch1000 and 1002.
  161. - disabled Patch1000 as default.
  162. - cleanup patches.
  163. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  164. - rebuild with gcc-5.4.0
  165. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  166. - new upstream release
  167. - added BR: ocaml-ctypes
  168. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  169. - new upstream release
  170. - dropt Patch 1, 201 and 1001
  171. - updated Patch 1000
  172. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  173. - updated to 3.5.1
  174. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  175. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  176. - obsoleted clang-doc
  177. - built with ocaml 4.02.1
  178. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  179. - fix <BTS:2832>
  180. - fix configure option "--with-c-include-dirs"
  181. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  182. - update Patch1001: clang-3.5.0-driver-lib64.patch
  183. - update Patch1002: clang-3.5.0-driver-vine.patch
  184. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  185. - update to 3.5.0
  186. - remove Patch11 (clang-hardfloat-hack.patch)
  187. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  188. - rebuild with libffi-3.0.13
  189. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  190. - update to 3.3
  191. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  192. - ld.gold (patch1000,1001)
  193. - add /%{_lib} to ld search path
  194. - add support *-vine-linux gcc (patch1002)
  195. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  196. - update to 3.1
  197. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  198. - updated to 3.0 release
  199. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  200. - added patch 2-4 to support -O4 link-time optimization
  201. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  202. - disable -fno-var-tracking-assignments on ppc
  203. (seems like gcc-4.4.5 still doesn't support this)
  204. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  205. - new upstream release
  206. - add BR: libffi-devel
  207. - add R: libffi-devel to -devel
  208. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  209. - initial build for Vine Linux
  210. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  211. - Update to final 2.7 release
  212. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  213. - Update to first 2.7 pre-release
  214. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  215. - Update to 2.6 pre-release2
  216. - -devel subpackage now virtually provides -static
  217. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  218. - Disable var tracking assignments on PPC
  219. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  220. - Don't adjust clang include dir; files there are noarch (bz#521893)
  221. - Enable clang unit tests
  222. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  223. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  224. - Package Clang's static analyzer tools
  225. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  226. - PIC is now enabled by default; explicitly disable on %%{ix86}
  227. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  228. - First 2.6 prerelease
  229. - Enable Clang front-end
  230. - Enable debuginfo generation
  231. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  232. - Disable assertions (needed by OpenGTL, bz#521261)
  233. - Align spec file with upstream build instructions
  234. - Enable unit tests
  235. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  236. - Only disable PIC on %%ix86; ppc actually needs it
  237. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  238. - Disable use of position-independent code on 32-bit platforms
  239. (buggy in LLVM <= 2.5)
  240. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  241. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  242. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  243. - Remove build scripts; they require the build directory to work
  244. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  245. - Update to 2.5
  246. - Package build scripts (bug #457881)
  247. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  248. - Patched build process for the OCaml binding
  249. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  250. - Update to 2.4
  251. - Package Ocaml binding
  252. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  253. - Add dependency on groff
  254. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  255. - LLVM 2.3
  256. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  257. - fix license tags
  258. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  259. - Fix compilation problems with gcc 4.3
  260. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  261. - Autorebuild for GCC 4.3
  262. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  263. - Fix review comments
  264. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  265. - Initial version