clang-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. # Documentation install path
  6. %global llvmdocdir() %{_docdir}/%1-%{version}
  7. %define _unpackaged_files_terminate_build 1
  8. Summary: A C language family front-end for LLVM
  9. Summary(ja): LLVM の C 言語フロントエンド
  10. Name: clang
  11. Version: 14.0.5
  12. Release: 1%{?_dist_release}
  13. Group: programming
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: NCSA
  17. URL: https://llvm.org/
  18. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
  19. Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
  20. # multilib fixes
  21. Source11: clang-config.h
  22. # Patches for clang
  23. Patch0: 0001-PATCH-clang-Reorganize-gtest-integration.patch
  24. Patch1: 0002-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
  25. Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
  26. Patch3: 0001-Driver-Add-a-gcc-equivalent-triple-to-the-list-of-tr.patch
  27. Patch4: 0001-cmake-Allow-shared-libraries-to-customize-the-soname.patch
  28. # This patch can be dropped once gcc-12.0.1-0.5.fc36 is in the repo.
  29. Patch5: 0001-Work-around-gcc-miscompile.patch
  30. Patch7: 0010-PATCH-clang-Produce-DWARF4-by-default.patch
  31. # Patches for clang-tools-extra
  32. # See https://reviews.llvm.org/D120301
  33. Patch201: llvm-hello.patch
  34. # See https://github.com/llvm/llvm-project/issues/54116
  35. Patch202: remove-test.patch
  36. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  37. BuildRequires: cmake
  38. BuildRequires: ninja
  39. BuildRequires: llvm-devel = %{version}
  40. BuildRequires: llvm-static = %{version}
  41. BuildRequires: libatomic
  42. BuildRequires: libxml2-devel
  43. BuildRequires: perl
  44. BuildRequires: ncurses-devel
  45. BuildRequires: python3
  46. BuildRequires: python3-devel
  47. Requires: llvm = %{version}-%{release}
  48. # clang requires gcc, clang++ requires libstdc++-devel
  49. Requires: libstdc++-devel
  50. # LLVM is not supported on PPC64
  51. # http://llvm.org/bugs/show_bug.cgi?id=3729
  52. ExcludeArch: ppc64
  53. %description
  54. clang: noun
  55. 1. A loud, resonant, metallic sound.
  56. 2. The strident call of a crane or goose.
  57. 3. C-language family front-end toolkit.
  58. The goal of the Clang project is to create a new C, C++, Objective C
  59. and Objective C++ front-end for the LLVM compiler. Its tools are built
  60. as libraries and designed to be loosely-coupled and extensible.
  61. %Package libs
  62. Summary: Runtime library for clang
  63. Summary(ja): Clang のランタイムライブラリ
  64. Group: system
  65. %description libs
  66. Runtime library for clang.
  67. %description libs -l ja
  68. Clang のランタイムライブラリです.
  69. %package devel
  70. Summary: Header files for clang
  71. Summary(ja): Clang のヘッダファイル
  72. Group: programming
  73. Requires: clang = %{version}-%{release}
  74. %description devel
  75. This package contains header files for the Clang compiler.
  76. %description devel -l ja
  77. Clang コンパイラのヘッダファイル集です.
  78. %package analyzer
  79. Summary: A source code analysis framework
  80. Summary(ja): ソースコード分析フレームワーク
  81. License: NCSA
  82. Group: programming
  83. Requires: clang = %{version}-%{release}
  84. # not picked up automatically since files are currently not instaled
  85. # in standard Python hierarchies yet
  86. Requires: python3
  87. %description analyzer
  88. The Clang Static Analyzer consists of both a source code analysis
  89. framework and a standalone tool that finds bugs in C and Objective-C
  90. programs. The standalone tool is invoked from the command-line, and is
  91. intended to run in tandem with a build of a project or code base.
  92. %package -n python3-clang
  93. Summary: Python3 bindings for clang
  94. Group: programming
  95. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  96. Requires: python3
  97. %description -n python3-clang
  98. Python3 bindings for clang
  99. %package tools-extra
  100. Summary: Extra tools for clang
  101. Group: programming
  102. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  103. %description tools-extra
  104. A set of extra tools built using Clang's tooling API.
  105. %debug_package
  106. %prep
  107. %setup -T -q -b 1 -n clang-tools-extra-%{version}.src
  108. %autopatch -m200 -p2
  109. # This test is broken upstream. It is a clang-tidy unittest
  110. # that includes a file from clang, breaking standalone builds.
  111. # https://github.com/llvm/llvm-project/issues/54116
  112. rm unittests/clang-tidy/ReadabilityModuleTest.cpp
  113. # failing test case
  114. rm test/clang-tidy/checkers/altera-struct-pack-align.cpp
  115. pathfix%{python3_version}.py -i %{__python3} -pn \
  116. clang-tidy/tool/*.py \
  117. clang-include-fixer/find-all-symbols/tool/run-find-all-symbols.py
  118. %setup -q -n clang-%{version}.src
  119. %autopatch -M200 -p2
  120. # failing test case
  121. rm test/CodeGen/profile-filter.c
  122. pathfix%{python3_version}.py -i %{__python3} -pn \
  123. tools/clang-format/*.py \
  124. tools/clang-format/git-clang-format \
  125. utils/hmaptool/hmaptool \
  126. tools/scan-view/bin/scan-view \
  127. tools/scan-view/share/Reporter.py \
  128. tools/scan-view/share/startfile.py \
  129. tools/scan-build-py/bin/* \
  130. tools/scan-build-py/libexec/*
  131. sed -i -e 's/"i686-linux-gnu",/"i686-linux-gnu","i686-vine-linux","i686-vine-linux-gnu",/' lib/Driver/ToolChains/Gnu.cpp
  132. sed -i -e 's/"x86_64-linux-gnu",/"x86_64-linux-gnu","x86_64-vine-linux","x86_64-vine-linux-gnu",/' lib/Driver/ToolChains/Gnu.cpp
  133. sed -i -e 's/"ld"/"ld.gold"/' include/clang/Driver/ToolChain.h
  134. %build
  135. # lto builds with gcc 11 fail while running the lit tests.
  136. %define _lto_cflags %{nil}
  137. %ifarch s390 s390x %{arm} %ix86
  138. # Decrease debuginfo verbosity to reduce memory consumption during final library linking
  139. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  140. %endif
  141. %cmake \
  142. -GNinja \
  143. -DLLVM_PARALLEL_LINK_JOBS=1 \
  144. -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
  145. -DCMAKE_BUILD_TYPE=Release \
  146. -DPYTHON_EXECUTABLE=%{__python3} \
  147. -DCMAKE_SKIP_RPATH:BOOL=ON \
  148. -DCMAKE_INSTALL_RPATH:BOOL=";" \
  149. -DLLVM_EXTERNAL_CLANG_TOOLS_EXTRA_SOURCE_DIR=../clang-tools-extra-%{version}.src \
  150. %if 0%{?__isa_bits} == 64
  151. -DLLVM_LIBDIR_SUFFIX=64 \
  152. %else
  153. -DLLVM_LIBDIR_SUFFIX= \
  154. %endif
  155. \
  156. -DLLVM_TABLEGEN_EXE:FILEPATH=%{_bindir}/llvm-tblgen \
  157. -DCLANG_ENABLE_ARCMT:BOOL=ON \
  158. -DCLANG_ENABLE_STATIC_ANALYZER:BOOL=ON \
  159. -DCLANG_ENABLE_ARCMT:BOOL=ON \
  160. -DCLANG_ENABLE_STATIC_ANALYZER:BOOL=ON \
  161. -DCLANG_INCLUDE_DOCS:BOOL=ON \
  162. -DCLANG_INCLUDE_TESTS:BOOL=ON \
  163. -DCLANG_PLUGIN_SUPPORT:BOOL=ON \
  164. \
  165. -DCLANG_INCLUDE_DOCS:BOOL=ON \
  166. -DCLANG_PLUGIN_SUPPORT:BOOL=ON \
  167. -DENABLE_LINKER_BUILD_ID:BOOL=ON \
  168. -DLLVM_ENABLE_EH=ON \
  169. -DLLVM_ENABLE_RTTI=ON \
  170. -DLLVM_BUILD_DOCS=ON \
  171. -DLLVM_ENABLE_SPHINX=OFF \
  172. -DCLANG_LINK_CLANG_DYLIB=ON \
  173. \
  174. -DCLANG_LINK_CLANG_DYLIB=ON \
  175. -DCLANG_BUILD_EXAMPLES:BOOL=OFF \
  176. -DBUILD_SHARED_LIBS=OFF \
  177. -DCLANG_REPOSITORY_STRING="Vine Linux %{version}-%{release}" \
  178. -DCLANG_DEFAULT_UNWINDLIB=libgcc
  179. %cmake_build
  180. %install
  181. rm -rf %{buildroot}
  182. %cmake_install
  183. # remove static libraries
  184. rm -fv %{buildroot}%{_libdir}/libclang*.a
  185. # install clang python bindings
  186. mkdir -p %{buildroot}%{python3_sitelib}/clang/
  187. install -p -m644 bindings/python/clang/* %{buildroot}%{python3_sitelib}/clang/
  188. # install scanbuild-py to python sitelib.
  189. mv %{buildroot}%{_prefix}/lib/{libear,libscanbuild} %{buildroot}%{python3_sitelib}
  190. mv -v %{buildroot}%{_includedir}/clang/Config/config{,-%{__isa_bits}}.h
  191. install -m 0644 %{SOURCE11} %{buildroot}%{_includedir}/clang/Config/config.h
  192. # TODO: Package html docs
  193. rm -Rvf %{buildroot}%{_docdir}/clang/html
  194. rm -Rvf %{buildroot}%{_datadir}/clang/clang-doc-default-stylesheet.css
  195. rm -Rvf %{buildroot}%{_datadir}/clang/index.js
  196. # remove git integration
  197. rm -vf %{buildroot}%{_bindir}/git-clang-format
  198. # remove editor integrations (bbedit, sublime, emacs, vim)
  199. rm -vf %{buildroot}%{_datadir}/clang/clang-format-bbedit.applescript
  200. rm -vf %{buildroot}%{_datadir}/clang/clang-format-sublime.py*
  201. rm -vf %{buildroot}%{_datadir}/clang/clang-format.el
  202. rm -vf %{buildroot}%{_datadir}/clang/clang-format.py*
  203. # remove diff reformatter
  204. rm -vf %{buildroot}%{_datadir}/clang/clang-format-diff.py*
  205. rm -f %{buildroot}%{_datadir}/clang/bash-autocomplete.sh
  206. rm -f %{buildroot}%{_datadir}/clang/clang-rename.el
  207. rm -f %{buildroot}%{_datadir}/clang/clang-rename.py
  208. rm -f %{buildroot}%{_datadir}/clang/clang-include-fixer.el
  209. rm -f %{buildroot}%{_datadir}/clang/clang-include-fixer.py
  210. # Remove clang-tidy headers. We don't ship the libraries for these.
  211. rm -Rvf %{buildroot}%{_includedir}/clang-tidy/
  212. %if %{with test}
  213. %check
  214. %ctest check-clang
  215. %endif
  216. %clean
  217. rm -rf %{buildroot}
  218. %files
  219. %defattr(-,root,root,-)
  220. #doc %{llvmdocdir clang}/
  221. %{_bindir}/clang
  222. %{_bindir}/clang++
  223. %{_bindir}/clang-%{ver_suffix}
  224. %{_bindir}/clang-cl
  225. %{_bindir}/clang-cpp
  226. %files libs
  227. %defattr(-,root,root,-)
  228. %{_libdir}/clang
  229. %{_libdir}/libclang.so.*
  230. %{_libdir}/libclang-cpp.so.*
  231. %files devel
  232. %defattr(-,root,root,-)
  233. #doc %{llvmdocdir clang-devel}/
  234. %{_libdir}/libclang.so
  235. %{_libdir}/libclang-cpp.so
  236. %{_includedir}/clang
  237. %{_includedir}/clang-c
  238. %dir %{_datadir}/clang/
  239. %{_libdir}/cmake/*
  240. %files analyzer
  241. %defattr(-,root,root,-)
  242. %{_bindir}/analyze-build
  243. %{_bindir}/intercept-build
  244. %{_bindir}/scan-build
  245. %{_bindir}/scan-build-py
  246. %{_bindir}/scan-view
  247. %{_libexecdir}/ccc-analyzer
  248. %{_libexecdir}/c++-analyzer
  249. %{_libexecdir}/analyze-c++
  250. %{_libexecdir}/analyze-cc
  251. %{_libexecdir}/intercept-c++
  252. %{_libexecdir}/intercept-cc
  253. %{_datadir}/scan-view
  254. %{_datadir}/scan-build
  255. %{_mandir}/man1/scan-build.1.*
  256. %{python3_sitelib}/libear
  257. %{python3_sitelib}/libscanbuild
  258. %files -n python3-clang
  259. %{python3_sitelib}/clang/
  260. %files tools-extra
  261. %{_bindir}/c-index-test
  262. %{_bindir}/clang*
  263. %exclude %{_bindir}/clang
  264. %exclude %{_bindir}/clang++
  265. %exclude %{_bindir}/clang-%{ver_suffix}
  266. %exclude %{_bindir}/clang-cl
  267. %exclude %{_bindir}/clang-cpp
  268. %{_bindir}/diagtool
  269. %{_bindir}/find-all-symbols
  270. %{_bindir}/hmaptool
  271. %{_bindir}/modularize
  272. %{_bindir}/pp-trace
  273. %{_bindir}/run-clang-tidy
  274. %{_datadir}/clang/clang-tidy-diff.py*
  275. %{_datadir}/clang/run-find-all-symbols.py*
  276. %changelog
  277. * Wed Jun 15 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  278. - new upstream release.
  279. - dropped patch5.
  280. - updated Patch1.
  281. - imported Patch5-202 from rawhide.
  282. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  283. - new upstream release.
  284. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  285. - new upstream release.
  286. - refreshed patches.
  287. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  288. - new upstream release.
  289. - refreshed patches.
  290. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  291. - devided clang from llvm.
  292. - new upstream release.
  293. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  294. - enabled to build utils.
  295. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  296. - new upstream release.
  297. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  298. - new upstream release.
  299. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  300. - rebuilt with libffi-3.3.
  301. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  302. - new upstream release.
  303. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  304. - new upstream release.
  305. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  306. - dropped all patches.
  307. - switched build-system to ninja.
  308. - switched python to python3.
  309. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  310. - new upstream release.
  311. - added OpenMP.
  312. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  313. - fixed %%files.
  314. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  315. - new upstream release.
  316. - dropped Patch0, 4, 5, 100 and 200.
  317. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  318. - renamed a subpackage "llvm-libs".
  319. - added a subpackage "lld".
  320. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  321. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  322. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  323. - new upstream release.
  324. - dropped Patch1 and 2: fixed in upstream.
  325. - imported Patch0, 3-5, 100 and 200 from rawhide.
  326. - disabled Patch1002: no longer needed?
  327. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  328. - new upstream release.
  329. - switched to cmake.
  330. - disable ocaml binding as default.
  331. - updated Patch1000 and 1002.
  332. - disabled Patch1000 as default.
  333. - cleanup patches.
  334. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  335. - rebuild with gcc-5.4.0
  336. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  337. - new upstream release
  338. - added BR: ocaml-ctypes
  339. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  340. - new upstream release
  341. - dropt Patch 1, 201 and 1001
  342. - updated Patch 1000
  343. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  344. - updated to 3.5.1
  345. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  346. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  347. - obsoleted clang-doc
  348. - built with ocaml 4.02.1
  349. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  350. - fix <BTS:2832>
  351. - fix configure option "--with-c-include-dirs"
  352. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  353. - update Patch1001: clang-3.5.0-driver-lib64.patch
  354. - update Patch1002: clang-3.5.0-driver-vine.patch
  355. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  356. - update to 3.5.0
  357. - remove Patch11 (clang-hardfloat-hack.patch)
  358. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  359. - rebuild with libffi-3.0.13
  360. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  361. - update to 3.3
  362. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  363. - ld.gold (patch1000,1001)
  364. - add /%{_lib} to ld search path
  365. - add support *-vine-linux gcc (patch1002)
  366. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  367. - update to 3.1
  368. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  369. - updated to 3.0 release
  370. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  371. - added patch 2-4 to support -O4 link-time optimization
  372. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  373. - disable -fno-var-tracking-assignments on ppc
  374. (seems like gcc-4.4.5 still doesn't support this)
  375. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  376. - new upstream release
  377. - add BR: libffi-devel
  378. - add R: libffi-devel to -devel
  379. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  380. - initial build for Vine Linux
  381. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  382. - Update to final 2.7 release
  383. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  384. - Update to first 2.7 pre-release
  385. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  386. - Update to 2.6 pre-release2
  387. - -devel subpackage now virtually provides -static
  388. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  389. - Disable var tracking assignments on PPC
  390. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  391. - Don't adjust clang include dir; files there are noarch (bz#521893)
  392. - Enable clang unit tests
  393. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  394. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  395. - Package Clang's static analyzer tools
  396. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  397. - PIC is now enabled by default; explicitly disable on %%{ix86}
  398. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  399. - First 2.6 prerelease
  400. - Enable Clang front-end
  401. - Enable debuginfo generation
  402. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  403. - Disable assertions (needed by OpenGTL, bz#521261)
  404. - Align spec file with upstream build instructions
  405. - Enable unit tests
  406. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  407. - Only disable PIC on %%ix86; ppc actually needs it
  408. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  409. - Disable use of position-independent code on 32-bit platforms
  410. (buggy in LLVM <= 2.5)
  411. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  412. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  413. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  414. - Remove build scripts; they require the build directory to work
  415. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  416. - Update to 2.5
  417. - Package build scripts (bug #457881)
  418. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  419. - Patched build process for the OCaml binding
  420. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  421. - Update to 2.4
  422. - Package Ocaml binding
  423. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  424. - Add dependency on groff
  425. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  426. - LLVM 2.3
  427. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  428. - fix license tags
  429. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  430. - Fix compilation problems with gcc 4.3
  431. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  432. - Autorebuild for GCC 4.3
  433. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  434. - Fix review comments
  435. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  436. - Initial version