polkit-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427
  1. %bcond_with systemd
  2. Summary: PolicyKit Authorization Framework
  3. Summary(ja): PolicyKit 認証フレームワーク
  4. Name: polkit
  5. Version: 0.117
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: https://www.freedesktop.org/wiki/Software/polkit
  12. Source0: https://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.gz
  13. Patch0: polkit-0.115-elogind.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: glib2-devel
  16. BuildRequires: expat-devel
  17. BuildRequires: pam-devel
  18. BuildRequires: mozjs68-devel
  19. BuildRequires: gtk-doc
  20. BuildRequires: intltool
  21. BuildRequires: gobject-introspection-devel
  22. %if %{with systemd}
  23. BuildRequires: systemd-devel
  24. %{?systemd_requires}
  25. %else
  26. BuildRequires: elogind-devel
  27. %endif
  28. Requires: dbus
  29. Obsoletes: PolicyKit <= 0.10
  30. Provides: PolicyKit = 0.11
  31. Obsoletes: polkit-desktop-policy < 0.103
  32. Provides: polkit-desktop-policy = 0.103
  33. %if %{with systemd}
  34. %{?systemd_requires}
  35. %endif
  36. %description
  37. PolicyKit is a toolkit for defining and handling authorizations.
  38. It is used for allowing unprivileged processes to speak to privileged
  39. processes.
  40. %package devel
  41. Summary: Development files for PolicyKit
  42. Summary(ja): PolicyKit の開発用ファイル
  43. Group: programming
  44. Requires: %name = %{version}-%{release}
  45. Requires: %name-docs = %{version}-%{release}
  46. Requires: pkgconfig
  47. Requires: glib2-devel
  48. %description devel
  49. Development files for PolicyKit.
  50. %package docs
  51. Summary: Development documentation for PolicyKit
  52. Summary(ja): PolicyKit の開発用ドキュメント
  53. Group: documentation
  54. Requires: %name-devel = %{version}-%{release}
  55. Requires: gtk-doc
  56. %description docs
  57. Development documentation for PolicyKit.
  58. %prep
  59. %setup -q
  60. %if !%{with systemd}
  61. %patch0 -p1
  62. %endif
  63. %build
  64. autoreconf -vif
  65. export CXXFLAGS="%{optflags} -std=gnu++14"
  66. %configure \
  67. --with-os-type=redhat \
  68. --enable-gtk-doc \
  69. --disable-static \
  70. --libexecdir=%{_libexecdir}/polkit-1 \
  71. --enable-introspection \
  72. %if %{with systemd}
  73. --enable-libsystemd-login=yes \
  74. %else
  75. --enable-libelogind=yes \
  76. %endif
  77. --enable-examples
  78. make %{?_smp_mflags}
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. make install DESTDIR=$RPM_BUILD_ROOT
  82. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  83. rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.la
  84. %find_lang polkit-1
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %pre
  88. groupadd -g 27 -r polkitd 2>&1 > /dev/null || :
  89. useradd -u 27 -g polkitd -r -d '/' -s /sbin/nologin -c "User for polkitd" polkitd 2>&1 > /dev/null || :
  90. exit 0
  91. %post
  92. /sbin/ldconfig
  93. %if %{with systemd}
  94. %systemd_post polkit.service
  95. %endif
  96. %if %{with systemd}
  97. %preun
  98. %systemd_preun polkit.service
  99. %endif
  100. %postun
  101. /sbin/ldconfig
  102. %if %{with systemd}
  103. %systemd_postun_with_restart polkit.service
  104. %endif
  105. %files -f polkit-1.lang
  106. %defattr(-,root,root,-)
  107. %license COPYING
  108. %doc NEWS README
  109. %{_libdir}/lib*.so.*
  110. %{_datadir}/man/man1/*
  111. %{_datadir}/man/man8/*
  112. %{_datadir}/dbus-1/system-services/*
  113. %if %{with systemd}
  114. %{_unitdir}/polkit.service
  115. %endif
  116. %dir %{_datadir}/polkit-1/
  117. %dir %{_datadir}/polkit-1/actions
  118. %attr(0700,polkitd,root) %dir %{_datadir}/polkit-1/rules.d
  119. %{_datadir}/polkit-1/actions/org.freedesktop.policykit.policy
  120. %dir %{_sysconfdir}/polkit-1
  121. %{_sysconfdir}/polkit-1/rules.d/50-default.rules
  122. %attr(0700,polkitd,root) %dir %{_sysconfdir}/polkit-1/rules.d
  123. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.PolicyKit1.conf
  124. %{_sysconfdir}/pam.d/polkit-1
  125. %{_bindir}/pkaction
  126. %{_bindir}/pkcheck
  127. %{_bindir}/pkttyagent
  128. %dir %{_prefix}/lib/polkit-1
  129. %{_prefix}/lib/polkit-1/polkitd
  130. %{_libdir}/girepository-1.0/*.typelib
  131. # see upstream docs for why these permissions are necessary
  132. %attr(4755,root,root) %{_bindir}/pkexec
  133. %attr(4755,root,root) %{_prefix}/lib/polkit-1/polkit-agent-helper-1
  134. %files devel
  135. %defattr(-,root,root,-)
  136. %{_libdir}/lib*.so
  137. %{_libdir}/pkgconfig/*.pc
  138. %{_datadir}/gir-1.0/*.gir
  139. %{_includedir}/*
  140. %{_bindir}/pk-example-frobnicate
  141. %{_datadir}/polkit-1/actions/org.freedesktop.policykit.examples.pkexec.policy
  142. %dir %{_datadir}/gettext
  143. %dir %{_datadir}/gettext/its
  144. %{_datadir}/gettext/its/*
  145. %files docs
  146. %defattr(-,root,root,-)
  147. %{_datadir}/gtk-doc/html/*
  148. %changelog
  149. * Fri Aug 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.117-1
  150. - new upstream release.
  151. - dropped Patch1-3: fixed in upstream.
  152. * Sat Jul 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-2
  153. - added systemd support (disabled as default).
  154. - imported Patch1-3 from rawhide.
  155. * Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.116-1
  156. - new upstream release.
  157. * Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-2
  158. - really enabled elogind.
  159. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.115-1
  160. - new upstream release.
  161. - enabled elogind: ConsoleKit is obsolete.
  162. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-2
  163. - new upstream release
  164. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.112-1
  165. - new upstream release
  166. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.110-1
  167. - new upstream release
  168. * Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.107-1
  169. - new upstream release
  170. - add BuildRequires: js-devel
  171. - remove BuildRequires: eggdbus-devel
  172. - remove polkit-desktop-policy subpackage (based on fedora)
  173. - historical changelogs are following:
  174. * Tue May 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.105-1
  175. - new upstream release
  176. * Sat Feb 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.104-1
  177. - new upstream release
  178. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.102-1
  179. - new upstream release
  180. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.99-1
  181. - new upstream release
  182. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.96-2
  183. - build with rpm-4.8.1-1 for pkg-config file
  184. * Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.96-1
  185. - update to 0.96
  186. - BR: eggdbus-devel >= 0.6
  187. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.2.git20090913
  188. - remove Obsoletes:/Provides: PolicyKit*
  189. * Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.95-0.1.git20090913
  190. - initial build for Vine Linux
  191. * Wed Jul 11 2012 David Zeuthen <davidz@redhat.com> 0.107-1%{?dist}
  192. - Update to upstream release 0.107
  193. * Fri Jun 29 2012 David Zeuthen <davidz@redhat.com> 0.106-2%{?dist}
  194. - Add forgotten Requires(pre): shadow-utils
  195. * Thu Jun 07 2012 David Zeuthen <davidz@redhat.com> 0.106-1%{?dist}
  196. - Update to upstream release 0.106
  197. - Authorizations are no longer controlled by .pkla files - from now
  198. on, use the new .rules files described in the polkit(8) man page
  199. * Tue Apr 24 2012 David Zeuthen <davidz@redhat.com> 0.105-1%{?dist}
  200. - Update to upstream release 0.105
  201. - Nuke patches that are now upstream
  202. - Change 'PolicyKit' to 'polkit' in summary and descriptions
  203. * Thu Mar 08 2012 David Zeuthen <davidz@redhat.com> 0.104-6%{?dist}
  204. - Don't leak file descriptors (bgo #671486)
  205. * Mon Feb 13 2012 Matthias Clasen <mclasen@redhat.com> - 0.104-5%{?dist}
  206. - Make the -docs subpackage noarch
  207. * Mon Feb 06 2012 David Zeuthen <davidz@redhat.com> 0.104-4%{?dist}
  208. - Set error if we cannot obtain a PolkitUnixSession for a given PID (#787222)
  209. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.104-3
  210. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  211. * Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-2%{?dist}
  212. - Nuke the ConsoleKit run-time requirement
  213. * Tue Jan 03 2012 David Zeuthen <davidz@redhat.com> 0.104-1%{?dist}
  214. - Update to upstream release 0.104
  215. - Force usage of systemd (instead of ConsoleKit) for session tracking
  216. * Tue Dec 06 2011 David Zeuthen <davidz@redhat.com> 0.103-1%{?dist}
  217. - Update to upstream release 0.103
  218. - Drop upstreamed patch
  219. - Drop Fedora-specific policy, it is now upstream (fdo #41008)
  220. * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.102-3
  221. - Rebuilt for glibc bug#747377
  222. * Tue Oct 18 2011 David Zeuthen <davidz@redhat.com> 0.102-2%{?dist}
  223. - Add patch to neuter the annoying systemd behavior where stdout/stderr
  224. is sent to the system logs
  225. * Thu Aug 04 2011 David Zeuthen <davidz@redhat.com> 0.102-1
  226. - Update to 0.102 release
  227. * Fri May 13 2011 Bastien Nocera <bnocera@redhat.com> 0.101-7
  228. - Allow setting the pretty hostname without a password for wheel,
  229. change matches systemd in git
  230. * Mon May 2 2011 Matthias Clasen <mclasen@redhat.com> - 0.101-6
  231. - Update the action id of the datetime mechanism
  232. * Tue Apr 19 2011 David Zeuthen <davidz@redhat.com> - 0.101-5
  233. - CVE-2011-1485 (#697951)
  234. * Tue Mar 22 2011 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.101-4
  235. - Also allow org.kde.kcontrol.kcmclock.save without password for wheel
  236. * Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-3
  237. - Fix typo in pkla file (thanks notting)
  238. * Thu Mar 17 2011 David Zeuthen <davidz@redhat.com> - 0.101-2
  239. - Nuke desktop_admin_r and desktop_user_r groups - just use the
  240. wheel group instead (#688363)
  241. - Update the set of configuration directives that gives users
  242. in the wheel group extra privileges
  243. * Thu Mar 03 2011 David Zeuthen <davidz@redhat.com> - 0.101-1
  244. - New upstream version
  245. * Mon Feb 21 2011 David Zeuthen <davidz@redhat.com> - 0.100-1
  246. - New upstream version
  247. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-7
  248. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  249. * Fri Jan 28 2011 Matthias Clasen <mclasen@redhat.com> - 0.98-6
  250. - Own /usr/libexec/polkit-1
  251. * Sun Nov 14 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-5
  252. - Enable introspection
  253. * Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-4
  254. - Fix #629515 in a way that doesn't require autoreconf
  255. * Thu Sep 02 2010 David Zeuthen <davidz@redhat.com> - 0.98-2
  256. - Include polkitagentenumtypes.h (#629515)
  257. * Mon Aug 23 2010 Matthias Clasen <mclasen@redhat.com> - 0.98-1
  258. - Update to upstream release 0.98
  259. - Co-own /usr/share/gtk-doc (#604410)
  260. * Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-5
  261. - Rebuid to work around bodhi limitations
  262. * Wed Aug 18 2010 Matthias Clasen <mclasen@redhat.com> - 0.97-4
  263. - Fix a ConsoleKit interaction bug
  264. * Fri Aug 13 2010 David Zeuthen <davidz@redhat.com> - 0.97-3
  265. - Add a patch to make pkcheck(1) work the way libvirtd uses it (#623257)
  266. - Require GLib >= 2.25.12 instead of 2.25.11
  267. - Ensure polkit-gnome packages earlier than 0.97 are not used with
  268. these packages
  269. * Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-2
  270. - Rebuild
  271. * Mon Aug 09 2010 David Zeuthen <davidz@redhat.com> - 0.97-1
  272. - Update to 0.97. This release contains a port from EggDBus to the
  273. GDBus code available in recent GLib releases.
  274. * Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 0.96-1
  275. - Update to 0.96
  276. - Disable introspection support for the time being
  277. * Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-2
  278. - Rebuild
  279. * Fri Nov 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-1
  280. - Update to 0.95
  281. - Drop upstreamed patches
  282. * Tue Oct 20 2009 Matthias Clasen <mclasen@redhat.com> - 0.95-0.git20090913.3
  283. - Fix a typo in pklocalauthority(8)
  284. * Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.2
  285. - Refine how Obsolete: is used and also add Provides: (thanks Jesse
  286. Keating and nim-nim)
  287. * Mon Sep 14 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913.1
  288. - Add bugfix for polkit_unix_process_new_full() (thanks Bastien Nocera)
  289. - Obsolete old PolicyKit packages
  290. * Sun Sep 13 2009 David Zeuthen <davidz@redhat.com> - 0.95-0.git20090913
  291. - Update to git snapshot
  292. - Drop upstreamed patches
  293. - Turn on GObject introspection
  294. - Don't delete desktop_admin_r and desktop_user_r groups when
  295. uninstalling polkit-desktop-policy
  296. * Fri Sep 11 2009 David Zeuthen <davidz@redhat.com> - 0.94-4
  297. - Add some patches from git master
  298. - Sort pkaction(1) output
  299. - Bug 23867 – UnixProcess vs. SystemBusName aliasing
  300. * Thu Aug 13 2009 David Zeuthen <davidz@redhat.com> - 0.94-3
  301. - Add desktop_admin_r and desktop_user_r groups along with a first cut
  302. of default authorizations for users in these groups.
  303. * Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-2
  304. - Disable GObject Introspection for now as it breaks the build
  305. * Wed Aug 12 2009 David Zeuthen <davidz@redhat.com> - 0.94-1
  306. - Update to upstream release 0.94
  307. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
  308. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  309. * Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-2
  310. - Rebuild
  311. * Mon Jul 20 2009 David Zeuthen <davidz@redhat.com> - 0.93-1
  312. - Update to 0.93
  313. * Tue Jun 09 2009 David Zeuthen <davidz@redhat.com> - 0.92-3
  314. - Don't make docs noarch (I *heart* multilib)
  315. - Change license to LGPLv2+
  316. * Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-2
  317. - Rebuild
  318. * Mon Jun 08 2009 David Zeuthen <davidz@redhat.com> - 0.92-1
  319. - Update to 0.92 release
  320. * Wed May 27 2009 David Zeuthen <davidz@redhat.com> - 0.92-0.git20090527
  321. - Update to 0.92 snapshot
  322. * Mon Feb 9 2009 David Zeuthen <davidz@redhat.com> - 0.91-1
  323. - Initial spec file.