rhythmbox-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632
  1. # -*- coding: utf-8-unix -*-
  2. %define desktop_file_utils_version 0.9
  3. %define enable_DLNA_UPnP 0
  4. Summary: Music Management Application
  5. Summary(ja): 音楽管理アプリケーション
  6. Name: rhythmbox
  7. Version: 3.0.1
  8. Release: 2%{?_dist_release}
  9. License: GPL2+ with exceptions and GFDL
  10. Group: Applications/Multimedia
  11. URL: http://projects.gnome.org/rhythmbox/
  12. Source0: http://download.gnome.org/sources/${name}/3.0/%{name}-%{version}.tar.xz
  13. Source101: rhythmbox-png.tar.bz2
  14. Patch0: rhythmbox-3.0-disable-python3.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gtk3-devel
  17. BuildRequires: avahi-glib-devel >= 0.6
  18. BuildRequires: brasero-devel >= 2.32.0
  19. BuildRequires: dbus-glib-devel
  20. BuildRequires: gstreamer1-plugins-base-devel
  21. BuildRequires: json-glib-devel
  22. BuildRequires: libSM-devel
  23. BuildRequires: libgnome-keyring-devel >= 2.30.0
  24. BuildRequires: libgpod-devel
  25. BuildRequires: libgudev1-devel
  26. BuildRequires: libmusicbrainz3-devel >= 3.0.2
  27. BuildRequires: libnotify-devel
  28. BuildRequires: libsoup-devel
  29. BuildRequires: pygobject3-devel
  30. BuildRequires: totem-pl-parser-devel
  31. BuildRequires: WebKit3-gtk-devel
  32. BuildRequires: libpeas-devel
  33. BuildRequires: clutter-gtk-devel
  34. BuildRequires: clutter-gst-devel
  35. BuildRequires: libmx-devel
  36. BuildRequires: check-devel
  37. BuildRequires: libmtp-devel
  38. BuildRequires: libtdb-devel
  39. BuildRequires: grilo-devel
  40. BuildRequires: libdmapsharing-devel
  41. BuildRequires: lirc
  42. BuildRequires: gnome-doc-utils >= 0.3.2
  43. BuildRequires: yelp-tools
  44. Requires: libgpod
  45. Requires: libnotify
  46. Requires: lirc
  47. Requires: libmtp
  48. Requires: brasero
  49. Requires: libgnome-keyring
  50. %if %{enable_DLNA_UPnP}
  51. Requires: python-Coherence
  52. %endif
  53. Requires: desktop-file-utils >= %{desktop_file_utils_version}
  54. # # gstreamer-plugins-ffmpeg and gstreamer-plugins-ugly package provided by
  55. # # self-build-gstreamer-plugins-ffmpeg and self-build-gstreamer-plugins-ugly,
  56. # # respectively.
  57. # Requires: self-build-gstreamer-plugins-ffmpeg
  58. # Requires: self-build-gstreamer-plugins-ugly
  59. Vendor: Project Vine
  60. Distribution: Vine Linux
  61. %description
  62. Rhythmbox is an integrated music management application based on the powerful
  63. GStreamer media framework. It has a number of features, including an easy to
  64. use music browser, searching and sorting, comprehensive audio format support
  65. through GStreamer, Internet Radio support, playlists and more.
  66. Rhythmbox is extensible through a plugin system.
  67. %description -l ja
  68. Rhythmbox は、強力な GStreamer メディアフレームワークに基づいている
  69. 統合音楽管理アプリケーションです。
  70. 見やすいユーザインターフェースを備え、検索や整列ができ、
  71. GStreamer により数多くの音声フォーマットをサポート、
  72. インターネットラジオをサポート、プレイリスト管理などの
  73. 数多くの特徴を持ちます。
  74. %package devel
  75. Summary: Development tools for rhythmbox applications.
  76. Summary(ja): rhythmbox アプリケーションの開発用ファイル
  77. Group: Development/Libraries
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: pkgconfig
  80. Requires: libxml2-devel
  81. Requires: glib2-devel
  82. Requires: gtk3-devel
  83. Requires: libsoup-devel
  84. Requires: totem-pl-parser-devel
  85. Requires: gstreamer1-devel
  86. %description devel
  87. Header files and libraries for building a extension library for the rhythmbox.
  88. %description devel -l ja
  89. %prep
  90. %setup -q
  91. %patch0 -p1
  92. tar xjf %{SOURCE101}
  93. %build
  94. autoreconf -if
  95. intltoolize --force --copy
  96. %configure --with-ipod \
  97. --with-mtp \
  98. --enable-lirc \
  99. --disable-python \
  100. --disable-vala \
  101. --disable-browser-plugin \
  102. --disable-static \
  103. --enable-browser-plugin \
  104. --without-hal
  105. %__make %{?_smp_mflags}
  106. %install
  107. %__rm -rf $RPM_BUILD_ROOT
  108. %__make install DESTDIR=$RPM_BUILD_ROOT
  109. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/*.{a,la}
  110. %__rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/librb-nautilus-context-menu.so
  111. %__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  112. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*.{a,la}
  113. %__rm -f $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/*/*.{a,la}
  114. %__rm -f $RPM_BUILD_ROOT%{_libdir}/librhythmbox-core.{a,la}
  115. %__rm -f $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins/*.{a,la}
  116. ## Don't package DLNA/UPnP plugin
  117. %if !%{enable_DLNA_UPnP}
  118. %__rm -rf $RPM_BUILD_ROOT%{_libdir}/rhythmbox/plugins/upnp_coherence
  119. %endif
  120. %find_lang %{name} --all-name --with-gnome
  121. # Don't package api docs
  122. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/
  123. # And don't package vala
  124. %__rm -f %{buildroot}%{_libdir}/rhythmbox/plugins/libsample-vala.so \
  125. %{buildroot}%{_libdir}/rhythmbox/plugins/sample-vala.rb-plugin
  126. # remove sample plugins
  127. rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/sample-plugins
  128. %clean
  129. %__rm -rf $RPM_BUILD_ROOT
  130. %post
  131. /sbin/ldconfig
  132. update-desktop-database -q
  133. touch --no-create %{_datadir}/icons/hicolor
  134. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  135. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  136. fi
  137. %postun
  138. /sbin/ldconfig
  139. update-desktop-database -q
  140. touch --no-create %{_datadir}/icons/hicolor
  141. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  142. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  143. fi
  144. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  145. %posttrans
  146. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  147. %files -f %{name}.lang
  148. %defattr(-, root, root)
  149. %doc AUTHORS COPYING ChangeLog README NEWS
  150. %{_bindir}/*
  151. %{_libdir}/girepository-1.0/*.typelib
  152. %{_libdir}/lib*.so.*
  153. %{_libdir}/mozilla/plugins/librhythmbox-itms-detection-plugin.so
  154. %{_libdir}/rhythmbox/plugins
  155. %{_datadir}/applications/rhythmbox.desktop
  156. %{_datadir}/applications/rhythmbox-device.desktop
  157. %{_datadir}/dbus-1/services/org.gnome.Rhythmbox3.service
  158. %{_datadir}/glib-2.0/schemas/org.gnome.rhythmbox.gschema.xml
  159. %{_datadir}/icons/*
  160. %{_datadir}/rhythmbox
  161. %{_mandir}/man1/*
  162. %{_libexecdir}/rhythmbox-metadata
  163. %files devel
  164. %defattr(-, root, root)
  165. %{_includedir}/%{name}/*
  166. %{_libdir}/*.so
  167. %{_libdir}/pkgconfig/*.pc
  168. %{_datadir}/gir-1.0/*.gir
  169. %changelog
  170. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-2
  171. - rebuild with VineSeed environment
  172. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.1-1
  173. - new upstream release
  174. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
  175. - new upstream release
  176. - add Patch0 (rhythmbox-3.0-disable-python3.patch)
  177. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.1-1
  178. - new upstream release
  179. - add BuildRequies: yelp-tools
  180. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
  181. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-2
  182. - rebuild with libimobiledevice-1.1.5
  183. * Mon Oct 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.98-1
  184. - new upstream release
  185. - add BuildRequires: grilo-devel, libdmapsharing-devel
  186. * Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.97-1
  187. - new upstream release
  188. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.96-1
  189. - new upstream release
  190. * Sat Jan 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
  191. - new upstream release
  192. - add BuildRequires: gtk3-devel, libtdb-devel, pygobject3-devel
  193. - remove BuildRequires: gnome-vfs2-devel, gstreamer-python-devel, libffi-devel, libgnome-media-profiles-devel, libgnomeui-devel, libsexy-devel, popt-devel, python-devel, pygtk2-devel, sqlite3-devel
  194. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-4
  195. - rebuild with cogl-0.8.0
  196. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-3
  197. - rebuild with libnotify-0.7
  198. - change BuildRequires: libmusicbrainz3-devel instead of libmusicbrainz-devel
  199. - change BuildRequires: libgnome-media-profiles-devel instead of gnome-media-devel
  200. - add BuildRequires: WebKit3-gtk-devel, libpeas-devel, clutter-gtk-devel, clutter-gst-devel, libmx-devel
  201. - add Patch0 (rhythmbox-0.13.3-git20110809.patch)
  202. - add Source101 (rhythmbox-png.tar.bz2)
  203. * Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-2
  204. - add BuildRequires: json-glib-devel
  205. - remove unrecognized configure option (--with-dbus, --with-cd-burning, --with-metadata-helper)
  206. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.3-1
  207. - new upstream release
  208. - change BuildRequires: gstreamer-python-devel instead of gstreamer-python
  209. * Sat Nov 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.2-1
  210. - new upstream release
  211. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-3
  212. - rebuild with brasero-2.32.0
  213. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-2
  214. - rebuild with rpm-4.8.1 for pkg-config file
  215. * Sun Sep 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.1-1
  216. - new upstream release
  217. - fix %files (add rhythmbox-device.desktop)
  218. * Sun Aug 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.13.0-1
  219. - new upstream release
  220. - change BuildRequires: gnome-media-devel instead of gnome-media
  221. - add devel package
  222. - drop Patch0
  223. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.8-1
  224. - new upstream release
  225. - drop Patch1, Patch2, Patch3
  226. - change BuildRequires: nautilus-cd-burner -> brasero-devel
  227. - change Requires: nautilus-cd-burner -> brasero
  228. - change BuildRequires: hal-devel -> libgudev1-devel
  229. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  230. - change Requires: gnome-keyring -> libgnome-keyring
  231. - add configure option (--without-hal)
  232. * Mon Feb 15 2010 Shu KONNO <owa@bg.wakwak.com> 0.12.6-2
  233. - rebuilt with new environment
  234. * Thu Jan 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.6-1
  235. - new upstream release
  236. - dropped upstreamed/obsolete patches
  237. - added patches applied Fedora development
  238. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.5-1
  239. - new upstream release
  240. - added configure options:
  241. --disable-vala
  242. --disable-browser-plugin
  243. * Thu Jul 30 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.12.2-2
  244. - added Japanese description
  245. * Thu Jul 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.2-1
  246. - new upstream release
  247. - dropped rb-disable-power-plugin-by-default.patch
  248. - added BuildRequires:
  249. - libSM-devel
  250. - gnome-media
  251. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.1-2
  252. - rebuild with libgpod-0.7.2
  253. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.12.1-1
  254. - new upstream release
  255. - corrected License tag
  256. - dropped rhythmbox-0.11.6-libmtp.patch
  257. - added BuildRequires:
  258. - sqlite3-devel
  259. - libffi-devel
  260. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-2
  261. - defined enable_DLNA_UPnP = 0: unpacked DLNA/UPnP plugin
  262. - applied rhythmbox-0.11.6-libmtp.patch
  263. - added Requires:
  264. - libgpod
  265. - libnotify
  266. - libsexy
  267. - lirc
  268. - libmtp
  269. - libgnomeui
  270. - nautilus-cd-burner
  271. - gstreamer-python
  272. - gnome-vfs2
  273. - gnome-themes
  274. - gnome-keyring
  275. - python-Coherence, if enable_DLNA_UPnP = 1
  276. - added BuildRequires:
  277. - libnotify-devel
  278. - libsexy-devel
  279. - lirc
  280. - libmtp-devel
  281. - gnome-vfs2-devel, instead of gnome-vfs2
  282. - gnome-keyring-devel
  283. - dropped --with-internal-libsexy in configure options
  284. - added in configure options:
  285. --with-mtp --with-libnautilus-burn --enable-lirc --disable-static
  286. - added %%preun to remove the schema
  287. * Sun Jan 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.11.6-1
  288. - new upstream release
  289. - changed to --with-metadata-helper in configure options
  290. - added BuildRequires:
  291. - gstreamer-python
  292. - intltool >= 0.35.0
  293. - popt-devel
  294. * Sat Aug 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-1vl5
  295. - added BuildRequires: totem-pl-parser-devel, instead of totem-devel
  296. - rebuilt with python-2.5.2
  297. - applied new versioning policy
  298. - spec in utf-8
  299. * Sun Jan 06 2008 Shu KONNO <owa@bg.wakwak.com> 0.11.2-0vl2
  300. - rebuilt with libgpod-0.6.0
  301. * Sun Aug 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.2-0vl1
  302. - new upstream release
  303. * Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.1-0vl1
  304. - new upstream release
  305. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.10.0-0vl2
  306. - rebuilt with new toolchain and libgpod-0.4.2
  307. - add BuildRequires: dbus-glib-devel
  308. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10.0-0vl1
  309. - new upstream release
  310. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl2
  311. - rebuilt for VineSeed
  312. * Wed Mar 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8-0vl1
  313. - new upstream release
  314. - added --enable-python option to %%configure
  315. - added Requires: gnome-python
  316. * Sun Jan 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.7-0vl1
  317. - new upstream release
  318. - built with libsoup 2.2.99
  319. * Thu Nov 23 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl4
  320. - added --with-cd-burner to configure
  321. - added BuildRequires: libsexy-devel hal-devel libsoup-devel
  322. * Wed Oct 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl3
  323. - add BuildRequires:
  324. - gnome-doc-utils >= 0.3.2
  325. - python-devel
  326. - pygtk2-devel
  327. - check >= 0.8.2
  328. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.6-0vl2
  329. - rebuild with gnutls-1.4.1
  330. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6-0vl1
  331. - new upstream release
  332. * Mon Jun 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-0vl1
  333. - new upstream release
  334. - run scrollkeeper-update at %post and %postun
  335. - added BuildRequires: libnotify-devel
  336. * Sun May 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.4.1-0vl1
  337. - new upstream release (dropped patch0)
  338. - added --without-metadata-helper at configure
  339. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.3.1-0vl1
  340. - Initial build for Vine Linux based on FC pacakge
  341. * Fri Mar 03 2006 Ray Strode <rstrode@redhat.com> - 0.9.3.1-2
  342. - add patch from James "Doc" Livingston to stop a hang
  343. for new users (bug 183883)
  344. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.2
  345. - bump again for double-long bug on ppc(64)
  346. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.9.3.1-1.1
  347. - rebuilt for new gcc4.1 snapshot and glibc changes
  348. * Sat Feb 4 2006 Christopher Aillon <caillon@redhat.com> 0.9.3.1-1
  349. - Update to 0.9.3.1
  350. - Use gstreamer (0.10)
  351. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-2
  352. - Remove hack for 173869, as its no longer needed.
  353. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.3-1
  354. - 0.9.3
  355. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060201-1
  356. - Newer CVS snapshot
  357. * Sun Jan 22 2006 Christopher Aillon <caillon@redhat.com> 0.9.2.cvs20060123-1
  358. - Update to latest CVS
  359. - Add hack to workaround bug #173869
  360. * Thu Jan 19 2006 Christopher Aillon <caillon@redhat.com> 0.9.2-8
  361. - Rebuild, now that gstreamer08-plugins has been fixed
  362. * Thu Jan 19 2006 Ray Strode <rstrode@redhat.com> 0.9.2-7
  363. - bonobo multilib issue (bug 156982)
  364. * Wed Jan 04 2006 John (J5) Palmieri <johnp@redhat.com> 0.9.2-5
  365. - rebuild with ipod support
  366. * Tue Jan 03 2006 Jesse Keating <jkeating@redhat.com> 0.9.2-4
  367. - rebuilt again
  368. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  369. - rebuilt
  370. * Mon Dec 5 2005 Matthias Clasen <mclasen@redhat.com>
  371. - rebuild
  372. * Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com>
  373. - rebuild for new dbus
  374. * Wed Nov 30 2005 Matthias Clasen <mclasen@redhat.com>
  375. - Update to 0.9.2
  376. * Tue Oct 25 2005 Matthias Clasen <mclasen@redhat.com>
  377. - Update to 0.9.1
  378. * Fri Sep 02 2005 Colin Walters <walters@redhat.com>
  379. - Add configure flags --with-bonobo --with-dbus
  380. - BR nautilus-cd-burner-devel
  381. - New upstream CVS snapshot for testing
  382. - Drop IDL file and ui .xml
  383. - Add dbus service file
  384. - Drop upstreamed rhythmbox-bluecurve.tar.gz
  385. - Drop upstreamed rhythmbox-0.8.8-cell-renderer.patch
  386. * Mon Jun 13 2005 Colin Walters <walters@redhat.com> - 0.8.8-3
  387. - Add Bluecurve-ized icons from Jeff Schroeder (157716)
  388. - Add rhythmbox-0.8.8-cell-renderer.patch to remove use of custom
  389. cell renderer for playback icon (no longer necessary) and
  390. changes the rating renderer to work with non-b&w icons
  391. * Mon Mar 14 2005 Colin Walters <walters@redhat.com> - 0.8.8-2
  392. - Rebuild for GCC4
  393. * Tue Oct 05 2004 Colin Walters <walters@redhat.com> - 0.8.8-1
  394. - New upstream version
  395. - Remove librb-nautilus-context-menu.so, killed upstream
  396. * Thu Sep 30 2004 Christopher Aillon <caillon@redhat.com> 0.8.7-2
  397. - PreReq desktop-file-utils >= 0.9
  398. * Wed Sep 29 2004 Colin Walters <walters@redhat.com> - 0.8.7-1
  399. - New upstream version
  400. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-2
  401. - Fix postun to use correct syntax, thanks Nils Philippsen
  402. * Sat Sep 18 2004 Colin Walters <walters@redhat.com> - 0.8.6-1
  403. - New upstream version
  404. - Call update-desktop-database in post and postun
  405. * Thu Jun 24 2004 Colin Walters <walters@redhat.com> - 0.8.5-1
  406. - New upstream version
  407. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  408. - rebuilt
  409. * Tue May 18 2004 Colin Walters <walters@redhat.com> - 0.8.4-1
  410. - New upstream version
  411. - Remove backported patches
  412. - Gratuitiously bump various BuildRequires versions
  413. * Mon May 10 2004 Colin Walters <walters@redhat.com> - 0.8.3-4
  414. - Remove code to unregister GConf schema for now (Closes: #122532)
  415. * Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-3
  416. - Apply tiny patch from 0.8 arch to fix GConf key used
  417. for initial sorting
  418. * Fri May 07 2004 Colin Walters <walters@redhat.com> - 0.8.3-2
  419. - Apply patch from 0.8 arch tree to fix a number of memleaks
  420. * Sun May 02 2004 Colin Walters <walters@redhat.com> - 0.8.3-1
  421. - Update to 0.8.3: fixes showstopper bug with internet radio
  422. * Fri Apr 30 2004 Colin Walters <walters@redhat.com> - 0.8.2-1
  423. - Update to 0.8.2
  424. - Fix Source url
  425. - Add smp_mflags
  426. - Bump BuildRequires on gstreamer to 0.8.1
  427. * Fri Apr 23 2004 Colin Walters <walters@redhat.com> - 0.8.1-2
  428. - Uninstall GConf schemas on removal
  429. * Tue Apr 20 2004 Colin Walters <walters@redhat.com> - 0.8.1-1
  430. - Update to 0.8.1
  431. * Fri Apr 16 2004 Colin Walters <walters@redhat.com> - 0.8.0-1
  432. - Update to 0.8.0
  433. * Fri Apr 02 2004 Colin Walters <walters@redhat.com> - 0.7.2-1
  434. - Update to 0.7.2
  435. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-2
  436. - Remove BuildRequires on autoconf and libvorbis-devel
  437. * Mon Mar 29 2004 Colin Walters <walters@redhat.com> - 0.7.1-1
  438. - New major version - I know we are past major version slush, but
  439. this should have been done two weeks ago along with the GNOME 2.6
  440. upload. As upstream author as well, I believe this version is
  441. good enough for FC2.
  442. - Remove --disable-mp3
  443. - Remove id3, flac variables
  444. - Remove GStreamer major version patch
  445. - Fix typo in description
  446. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> - 0.6.8-2
  447. - rebuild for new gstreamer
  448. * Thu Mar 11 2004 Alex Larsson <alexl@redhat.com> 0.6.8-1
  449. - update to 0.6.8
  450. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  451. - rebuilt
  452. * Mon Mar 1 2004 Alexander Larsson <alexl@redhat.com> 0.6.7-1
  453. - update to 0.6.7
  454. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  455. - rebuilt
  456. * Mon Jan 12 2004 Colin Walters <walters@verbum.org> 0.6.4-1
  457. - New upstream version
  458. - Don't re-run the autotools; upstream incorporates newer versions.
  459. * Tue Oct 28 2003 Jonathan Blandford <jrb@redhat.com> 0.5.4-1
  460. - new version
  461. - remove smp_flags
  462. * Fri Oct 24 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-5
  463. - remove the initial iradio channels as they all are mp3 based.
  464. * Wed Oct 8 2003 Matthias Saou <matthias@rpmforge.net> 0.5.3-3
  465. - Fix category from Development/Libraries to Applications/Multimedia.
  466. - Use bz2 instead of gz as ftp.gnome.org has both, 300k saved in the src.rpm.
  467. - Fix SCHEMES vs. SCHEMAS in the post scriplet.
  468. - Added gstreamer-plugins-devel, libvorbis-devel, scrollkeeper and gettext deps.
  469. - Removed unnecessary date expansion define.
  470. - Updated description, including mp3 reference removal.
  471. - Added libid3tag and flac optional support for convenient rebuild.
  472. - Removed obsolete omf.make and xmldocs.make (included ones are the same now).
  473. * Mon Sep 22 2003 Jonathan Blandford <jrb@redhat.com> 0.5.3-1
  474. - new version
  475. - use %{_sysconfdir} instead of /etc
  476. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  477. - rebuilt
  478. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  479. - gave up on other archs for the Beta
  480. - new version
  481. - remove werror and add missing files
  482. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  483. - update to newer cvs snap
  484. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  485. - update to cvs snap
  486. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  487. - use %%(lang)
  488. * Sun Aug 11 2002 Jeremy Katz <katzj@redhat.com>
  489. - fix post to actually install the schema
  490. * Sat Jun 22 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  491. - Added gconf file
  492. - Added i18n directory
  493. * Sat Jun 15 2002 Christian F.K. Schaller <Uraeus@linuxrising.org>
  494. - Updated for new rewrite of rhythmbox, thanks to Jeroen
  495. * Mon Mar 18 2002 Jorn Baayen <jorn@nl.linux.org>
  496. - removed bonobo dependency
  497. * Sat Mar 02 2002 Christian Schaller <Uraeus@linuxrising.org>
  498. - created new spec file