pessulus-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %define basever 2.30
  3. Name: pessulus
  4. Version: %{basever}.4
  5. Release: 3%{?_dist_release}
  6. Summary: A lockdown editor for GNOME
  7. Group: Applications/System
  8. License: GPLv2+
  9. URL: http://live.gnome.org/Pessulus
  10. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{basever}/%{name}-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. BuildArch: noarch
  13. BuildRequires: gtk2-devel
  14. BuildRequires: pygtk2-devel
  15. BuildRequires: gnome-python-devel
  16. BuildRequires: GConf2-devel
  17. BuildRequires: gnome-python-desktop
  18. BuildRequires: perl-XML-Parser
  19. #BuildRequires: pkgconfig
  20. BuildRequires: gettext-devel
  21. BuildRequires: intltool >= 0.35.0
  22. BuildRequires: desktop-file-utils
  23. Requires: gnome-python-desktop
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. Pessulus is a lockdown editor for GNOME, written in python. Pessulus
  28. enables administrators to set mandatory settings in GConf. The
  29. users can not change these settings.
  30. Use of pessulus can be useful on computers that are open to use by
  31. everyone, e.g. in an internet cafe.
  32. %prep
  33. %setup -q
  34. %build
  35. %configure
  36. make %{?_smp_mflags}
  37. %install
  38. rm -rf $RPM_BUILD_ROOT
  39. make install DESTDIR=$RPM_BUILD_ROOT
  40. chmod +x $RPM_BUILD_ROOT%{python_sitelib}/Pessulus/*.py
  41. desktop-file-install --vendor="" --delete-original --remove-category="System" \
  42. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  43. $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
  44. %find_lang %{name}
  45. %clean
  46. rm -rf $RPM_BUILD_ROOT
  47. %post
  48. touch --no-create %{_datadir}/icons/hicolor
  49. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  50. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  51. fi
  52. %postun
  53. touch --no-create %{_datadir}/icons/hicolor
  54. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  55. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  56. fi
  57. %files -f %{name}.lang
  58. %defattr(-,root,root,-)
  59. %doc README AUTHORS COPYING ChangeLog
  60. %{_bindir}/%{name}
  61. %{python_sitelib}/Pessulus/
  62. %{_datadir}/applications/*.desktop
  63. %{_datadir}/%{name}
  64. %{_datadir}/icons/hicolor/*/apps/pessulus.*
  65. %changelog
  66. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-3
  67. - rebuild with VineSeed environment
  68. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-2
  69. - rebuild with python-2.7.2
  70. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-1
  71. - new upstream release
  72. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
  73. - Initial build for Vine Linux
  74. * Tue Apr 06 2010 Haïkel Guémar <karlthered@gmail.com> - 2.30.0-2
  75. - remove gnome-python2-buddy dependency (#579612)
  76. * Tue Mar 23 2010 Haïkel Guémar <karlthered@gmail.com> - 2.30.0-1
  77. - Updated to 2.30.0
  78. - more translations
  79. * Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.29.91-1
  80. - Updated to 2.29.91
  81. * Fri Sep 25 2009 Haïkel Guémar <karlthered@gmail.com> - 2.28.0-1
  82. - Updated to 2.28.0
  83. * Mon Sep 14 2009 Haïkel Guémar <karlthered@gmail.com> - 2.27.92-1
  84. - Updated to 2.27.92
  85. * Wed Jul 29 2009 Haïkel Guémar <karlthered@gmail.com> - 2.27.5-1
  86. - Updated to 2.24.0
  87. - Remove now unneeded pythondir patch (GNOME #549728 fixed upstream)
  88. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.23.1-5
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  90. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.23.1-4
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  92. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.23.1-3
  93. - Rebuild for Python 2.6
  94. * Thu Aug 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.1-2
  95. - fix missing BR, Requires
  96. * Thu Aug 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.23.1-1
  97. - fix license tag
  98. - update to 2.23.1
  99. - install into pythondir (not pyexecdir)
  100. * Mon Apr 16 2007 Damien Durand <splinux@fedoraproject.org> - 2.16.2-2
  101. - Fix desktop-file
  102. * Fri Dec 22 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.2-1
  103. - Upgrade to 2.16.2
  104. - Add gnome-python2-devel in BR
  105. * Sat Sep 23 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.1-1
  106. - Upgrade to 2.16.1
  107. - Fixe #195819
  108. * Sat Sep 23 2006 Damien Durand <splinux@fedoraproject.org> - 2.16-4
  109. - Bump release
  110. * Wed Sep 06 2006 Damien Durand <splinux@fedoraproject.org> - 2.16.0-1
  111. - Upgrade to 2.16 release
  112. - Add gnome-python2-gconf in Requires
  113. * Tue Aug 08 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.91-2
  114. - Bump release
  115. * Tue Aug 08 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.91-1
  116. - Upgraded to 2.15.91
  117. * Fri Jul 28 2006 Damien Durand <splinux@fedoraproject.org> - 2.15.90-1
  118. - Fix URL
  119. - Upgrad to 2.15.90
  120. * Tue Jul 11 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.4-1
  121. - upgrad to 0.10.4
  122. * Tue Jul 04 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-3
  123. - fix debuginfo packages
  124. * Thu Jun 15 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-2
  125. - fix BuildRequires
  126. * Wed May 3 2006 Damien Durand <splinux@fedoraproject.org> - 0.10.1-1
  127. - upgrade version to 0.10.1
  128. * Fri Apr 7 2006 Tom "spot" Callaway <tcallawa@redhat.com> - 0.9-2
  129. - fix BR
  130. - remove unnecessary Requires
  131. - use version-release in changelog entries
  132. - fix directory ownership
  133. - use python_sitearch
  134. - make python "scripts" executable
  135. * Thu Apr 6 2006 Damien Durand <splinux@fedoraproject.org> - 0.9-1
  136. - Initial package