mozjs17-vl.spec 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. Summary: The Mozilla library for JavaScript
  2. Name: mozjs17
  3. Version: 17.0.0
  4. Release: 2%{?_dist_release}
  5. # The sources are triple licensed, but when we link against readline which is
  6. # GPL, the result can only be GPL.
  7. %if 0%{?_without_readline:1}
  8. License: GPLv2+ or LGPLv2+ or MPLv1.1
  9. %else
  10. License: GPLv2+
  11. %endif
  12. Group: Development/Languages
  13. URL: http://www.mozilla.org/js/
  14. Source0: http://ftp.mozilla.org/pub/mozilla.org/js/mozjs17.0.0.tar.gz
  15. Patch0: mozjs17-17.0.0-Makefile.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. Buildrequires: nspr-devel >= 4.7
  18. Buildrequires: readline-devel
  19. BuildRequires: autoconf213
  20. BuildRequires: python
  21. BuildRequires: zip
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: Takemikaduchi
  25. %description
  26. JavaScript is the Netscape-developed object scripting language used in millions
  27. of web pages and server applications worldwide. Netscape's JavaScript is a
  28. superset of the ECMA-262 Edition 3 (ECMAScript) standard scripting language,
  29. with only mild differences from the published standard.
  30. %package devel
  31. Summary: Header files, libraries and development documentation for %{name}
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: pkgconfig
  35. Requires: ncurses-devel readline-devel
  36. Provides: libjs-devel = %{version}-%{release}
  37. %description devel
  38. This package contains the header files, static libraries and development
  39. documentation for %{name}. If you like to develop programs using %{name},
  40. you will need to install %{name}-devel.
  41. %prep
  42. %setup -q -n mozjs%{version}
  43. %patch0 -p1
  44. cd js
  45. # Rm parts with spurios licenses, binaries
  46. rm -rf src/ctypes/libffi src/editline
  47. pushd src
  48. autoconf-2.13
  49. %configure \
  50. --with-system-nspr \
  51. --enable-threadsafe \
  52. %if 0%{!?_without_readline:1}
  53. --enable-readline \
  54. %endif
  55. popd
  56. %build
  57. cd js
  58. %{__make} %{?_smp_mflags} -C src
  59. %install
  60. cd js
  61. %{__make} -C src install DESTDIR=%{buildroot}
  62. %{__rm} -rf %{buildroot}%{_libdir}/*.a
  63. %{__rm} -rf %{buildroot}%{_libdir}/*.la
  64. %clean
  65. %{__rm} -rf %{buildroot}
  66. %post -p /sbin/ldconfig
  67. %postun -p /sbin/ldconfig
  68. %files
  69. %defattr(-,root,root,-)
  70. %doc js/src/README.html
  71. %{_bindir}/js17
  72. %{_libdir}/libmozjs-17.0.so
  73. %files devel
  74. %defattr(-,root,root,-)
  75. %{_bindir}/js17-config
  76. %{_includedir}/js-17.0
  77. %{_libdir}/pkgconfig/mozjs-17.0.pc
  78. %changelog
  79. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.0-2
  80. - rebuild with VineSeed environment
  81. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.0-1
  82. - initial build