maxima-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190
  1. # -*- mode: rpm-spec -*-
  2. # By default, this spec file will generate RPMs for Clisp, CMUCL
  3. # and GCL. This can be changed by modifying the variables below.
  4. %define enable_clisp 1
  5. %define clisp_flags --enable-clisp
  6. %define enable_cmucl 0
  7. %define cmucl_flags --disable-cmucl
  8. %define enable_gcl 0
  9. %define gcl_flags --disable-gcl
  10. # Inhibit automatic compressing of info files. Compressed info
  11. # files break maxima's internal help.
  12. %define __spec_install_post /bin/true
  13. Summary: Maxima Symbolic Computation Program
  14. Summary(ja): 数式処理プログラム Maxima
  15. Name: maxima
  16. Version: 5.16.3
  17. Release: 2%{?_dist_release}
  18. License: GPL
  19. Group: Applications/Engineering
  20. URL: http://maxima.sourceforge.net
  21. Source0: %{name}-%{version}.tar.gz
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. Requires: maxima_exec = %{version}-%{release}
  24. Requires(post): /sbin/install-info
  25. Requires(preun): /sbin/install-info
  26. %description
  27. Maxima is a full symbolic computation program. It is full featured
  28. doing symbolic manipulation of polynomials, matrices, rational
  29. functions, integration, Todd-coxeter, graphing, bigfloats. It has a
  30. symbolic debugger source level debugger for maxima code. Maxima is
  31. based on the original Macsyma developed at MIT in the 1970's. It is
  32. quite reliable, and has good garbage collection, and no memory leaks.
  33. It comes with hundreds of self tests.
  34. %description -l ja
  35. Maxima は高機能な数式処理プログラムです。Maximaを使えば、多項式、行列、
  36. 有理関数、積分、Todd-coxeter、グラフ描画、高精度浮動小数点といった演算
  37. も簡単にこなせます。Maxima のコードに対応したソースレベルの数式デバッ
  38. ガも備えています。Maxima は MIT で1970年台に開発されたオリジナルの
  39. Macsyma がベースとなっています。Maxima はとても信頼性が高く、すぐれた
  40. ガーベッジコレクションを搭載しており、メモリリークを起こしません。この
  41. 信頼性は、数百件に及ぶセルフテストによってもたらされたものです。
  42. %package xmaxima
  43. Summary: Tcl/Tk interface to Maxima
  44. Summary(ja): Maxima 用 Tcl/Tk インターフェース
  45. Group: Applications/Engineering
  46. Requires: %{name} = %{version}-%{release}
  47. Requires: tk > 8.1
  48. Provides: xmaxima
  49. %description xmaxima
  50. Tcl/Tk interface to Maxima.
  51. %if %{enable_clisp}
  52. %package exec-clisp
  53. Summary: Maxima compiled with clisp
  54. Group: Applications/Engineering
  55. Requires: clisp
  56. BuildRequires: clisp
  57. Provides: maxima_exec
  58. %description exec-clisp
  59. Maxima compiled with clisp.
  60. %endif
  61. %if %{enable_cmucl}
  62. %package exec-cmucl
  63. Summary: Maxima compiled with CMUCL
  64. Group: Applications/Engineering
  65. Requires: cmucl
  66. BuildPreReq: cmucl
  67. Provides: maxima_exec
  68. %description exec-cmucl
  69. Maxima compiled with CMUCL.
  70. %endif
  71. %if %{enable_gcl}
  72. %package exec-gcl
  73. Summary: Maxima compiled with GCL
  74. Group: Applications/Engineering
  75. Requires: gcl
  76. BuildPreReq: gcl
  77. Provides: maxima_exec
  78. %description exec-gcl
  79. Maxima compiled with Gnu Common Lisp.
  80. %endif
  81. %prep
  82. %setup -q
  83. %configure %{?cmucl_flags:} %{?gcl_flags:} %{?clisp_flags:}
  84. %build
  85. %__make
  86. %install
  87. %__rm -rf %{buildroot}
  88. %makeinstall
  89. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  90. %post
  91. /sbin/install-info %{_infodir}/maxima.info %{_infodir}/dir
  92. %preun
  93. if [ "$1" = 0 ]; then
  94. /sbin/install-info --delete %{_infodir}/maxima.info %{_infodir}/dir
  95. fi
  96. %clean
  97. %__rm -rf %{buildroot}
  98. %files
  99. %defattr(-,root,root,-)
  100. %{_datadir}/maxima/%{version}
  101. %dir %{_libdir}/maxima/%{version}
  102. %{_libexecdir}/maxima/%{version}
  103. %{_infodir}/*
  104. %{_mandir}/man1/*
  105. %{_bindir}/*
  106. %doc AUTHORS COPYING ChangeLog INSTALL* NEWS README*
  107. %files xmaxima
  108. %{_bindir}/xmaxima
  109. %if %{enable_clisp}
  110. %files exec-clisp
  111. %{_libdir}/maxima/%{version}/binary-clisp
  112. %endif
  113. %if %{enable_cmucl}
  114. %files exec-cmucl
  115. %{_libdir}/maxima/%{version}/binary-cmucl
  116. %endif
  117. %if %{enable_gcl}
  118. %files exec-gcl
  119. %{_libdir}/maxima/%{version}/binary-gcl
  120. %endif
  121. %changelog
  122. * Sat Mar 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-2
  123. - rebuilt with new toolchain, libsigsev-2.8 and clisp-2.48
  124. * Sun Oct 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-1vl5
  125. - new upstream release
  126. * Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 5.11.0-1vl5
  127. - applied new versioning policy, spec in utf-8
  128. * Mon Mar 19 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.11.0-0vl1
  129. - New upstream release
  130. - Change Group
  131. * Fri May 20 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl2
  132. - Japanese Summary and description by rpmSpecTranslate project
  133. * Sat Apr 23 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl1
  134. - New upstream release (for diff() bug fix)
  135. - Tidy up spec file
  136. * Sun Feb 1 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl4
  137. - Change Requires and BuildPreReq clisp (= 2.29 -> >= 2.29)
  138. * Sat Aug 2 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl3
  139. - Add exec-clisp BuildPreReq clisp
  140. - Add xmaxima Requires tk > 8.1
  141. - Remove xmaxima-olderTcl patch
  142. * Fri Jun 6 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl2
  143. - Rebuild for clisp-2.29-0vl1
  144. * Fri May 30 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl1
  145. - Enable clisp only, disable cmucl and gcl
  146. - Add xmaxima-olderTcl patch (for tclversion older than 8.1)
  147. - Remove %{_infodir}/dir file
  148. * Sat Jan 4 2003 James Amundson <amundson@fnal.gov>
  149. - Added doc files
  150. - Added explicit clisp version
  151. - Added conditional to postun
  152. - Renamed exec_* packages to exec-*
  153. - Use rpm macros instead of hard-coded paths
  154. - Thanks to Rex Dieter for helpful suggestions
  155. * Sun Sep 8 2002 James Amundson <amundson@fnal.gov>
  156. - Initial build.