libgpod-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234
  1. %define with_mono 1
  2. Summary: Library to access the iPod
  3. Summary(ja): iPod にアクセスするためのライブラリ
  4. Name: libgpod
  5. Version: 0.8.3
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://www.gtkpod.org/libgpod.html
  10. Source: %{name}-%{version}.tar.bz2
  11. Buildroot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: docbook-style-xsl
  13. BuildRequires: glib2-devel
  14. BuildRequires: gtk2-devel
  15. BuildRequires: gettext
  16. BuildRequires: intltool
  17. BuildRequires: libimobiledevice-devel >= 1.1.4
  18. BuildRequires: libplist-devel >= 1.0
  19. BuildRequires: libusb1-devel
  20. BuildRequires: libxml2-devel
  21. BuildRequires: libxslt
  22. BuildRequires: libffi-devel
  23. BuildRequires: perl(XML::Parser)
  24. BuildRequires: pygobject-devel
  25. BuildRequires: python-devel
  26. BuildRequires: python-mutagen
  27. BuildRequires: sg3_utils-devel
  28. BuildRequires: sqlite3-devel
  29. BuildRequires: taglib-devel
  30. BuildRequires: swig
  31. %if %{with_mono}
  32. BuildRequires: mono-devel
  33. BuildRequires: gtk-sharp2
  34. %endif
  35. Requires: udev
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: daisuke
  39. %description
  40. libgpod is a library meant to abstract access to an iPod content. It
  41. provides an easy to use API to retrieve the list of files and playlist
  42. stored on an iPod, to modify them and to save them back to the iPod.
  43. %description -l ja
  44. libgpod は iPod のコンテンツにアクセスするためのライブラリです。
  45. iPod に格納されているファイルリストやプレイリストを取得し、変更し、
  46. iPod に書き戻すための API が提供されています。
  47. %package devel
  48. Summary: Support files necessary to compile applications with libgpod.
  49. Summary(ja): libgpod を使うアプリケーションのコンパイルに必要なファイル.
  50. Group: Development/Libraries
  51. Requires: libgpod = %{version}-%{release}
  52. Requires: glib2-devel
  53. Requires: gtk2-devel
  54. %description devel
  55. Libraries, headers, and support files necessary to compile applications
  56. using libgpod.
  57. %description -l ja devel
  58. libgpod を使ったアプリケーションのコンパイルに必要なライブラリ,
  59. ヘッダファイルなどが含まれています.
  60. %package -n python-gpod
  61. Summary: Python module to access iPod content
  62. Group: Development/Languages
  63. Requires: %{name} = %{version}-%{release}
  64. Requires: python-mutagen
  65. %description -n python-gpod
  66. A python module to access iPod content. This module provides bindings
  67. to the libgpod library.
  68. %if %{with_mono}
  69. %package sharp
  70. Summary: C#/.NET library to access iPod content
  71. Group: Development/Languages
  72. Requires: %{name} = %{version}-%{release}
  73. %description sharp
  74. C#/.NET library to access iPod content. Provides bindings to the libgpod
  75. library.
  76. %package sharp-devel
  77. Summary: Development files for libgpod-sharp
  78. Summary: C#/.NET library to access iPod content
  79. Group: Development/Languages
  80. Requires: %{name}-sharp = %{version}-%{release}
  81. Requires: pkgconfig
  82. %description sharp-devel
  83. C#/.NET library to access iPod content. Provides bindings to the libgpod
  84. library.
  85. This package contains the files required to develop programs that will use
  86. libgpod-sharp.
  87. %endif
  88. %prep
  89. %setup -q
  90. chmod -x bindings/python/examples/*.py
  91. %build
  92. %configure \
  93. --without-hal \
  94. --enable-udev \
  95. --with-temp-mount-dir=%{_localstatedir}/run/%{name}
  96. make %{?_smp_mflags}
  97. %install
  98. if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
  99. make DESTDIR=%{buildroot} install
  100. %find_lang %{name}
  101. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  102. rm -f $RPM_BUILD_ROOT%{python_sitearch}/gpod/*.{a,la}
  103. %clean
  104. if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
  105. %post -p /sbin/ldconfig
  106. %postun -p /sbin/ldconfig
  107. %files -f %{name}.lang
  108. %defattr(-, root, root, 0755)
  109. %doc AUTHORS ChangeLog COPYING README
  110. %{_bindir}/*
  111. %{_libdir}/lib*.so.*
  112. %dir %{_localstatedir}/run/%{name}
  113. /lib/udev/iphone-set-info
  114. /lib/udev/ipod-set-info
  115. /lib/udev/rules.d/*.rules
  116. %files devel
  117. %defattr(-, root, root, 0755)
  118. %{_libdir}/lib*.so
  119. %{_libdir}/pkgconfig/*.pc
  120. %{_includedir}/gpod-1.0/
  121. %{_datadir}/gtk-doc/html/%{name}
  122. %files -n python-gpod
  123. %defattr(-, root, root, 0755)
  124. %doc COPYING bindings/python/README bindings/python/examples
  125. %{python_sitearch}/gpod
  126. %if %{with_mono}
  127. %files sharp
  128. %defattr(-, root, root, 0755)
  129. %{_libdir}/%{name}/%{name}-sharp*
  130. %files sharp-devel
  131. %defattr(-, root, root, 0755)
  132. %{_libdir}/pkgconfig/%{name}-sharp.pc
  133. %endif
  134. %changelog
  135. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
  136. - new upstream release
  137. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-2
  138. - rebuild with libimobiledevice-1.1.5
  139. * Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.2-1
  140. - update to 0.8.2
  141. - remove Patch0
  142. - add BuildRequires: mono-devel, gtk-sharp2, taglib-devel
  143. - create sharp and sharp-devel package
  144. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-4
  145. - rebuild with libimobiledevice-1.1.4
  146. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-3
  147. - rebuild with python-2.7.2
  148. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
  149. - rebuild with libimobiledevice-1.1.1
  150. * Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-1
  151. - update to 0.8.0
  152. * Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.7.93-2
  153. - rebuilt with rpm-4.8.1 for pkg-config
  154. * Sat Jun 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.93-1
  155. - new upstream release
  156. - add configure option (disable hal, enable udev, specify temp mount dir)
  157. - add python subpackage
  158. - add BR:
  159. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
  160. - new upstream release
  161. - remove static library
  162. * Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-3vl5
  163. - added BuildRequires: libffi-devel
  164. * Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2vl5
  165. - spec in utf-8
  166. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1vl5
  167. - applied new versioning policy
  168. * Thu Jan 03 2008 Satoshi MACHINO <machino@vinelinux.org> 0.6.0-0vl1
  169. - new upstream release
  170. * Tue May 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4.2-0vl2
  171. - for VineSeedPlus
  172. - new upstream release
  173. - built with new toolchain
  174. * Sun Oct 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
  175. - new upstream release
  176. - build with dbus-0.62
  177. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
  178. - new upstream release
  179. - build with dbus-0.61
  180. * Wed Dec 14 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
  181. - initial package