libchamplain-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372
  1. %define ver 0.12
  2. Summary: Map view for Clutter
  3. Summary(ja): Clutter用のマップビューア
  4. Name: libchamplain
  5. Version: 0.12.5
  6. Release: 2%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://projects.gnome.org/libchamplain/
  10. Source0: http://download.gnome.org/sources/libchamplain/0.12/%{name}-%{version}.tar.xz
  11. Requires: gobject-introspection
  12. BuildRequires: clutter-devel
  13. BuildRequires: clutter-gtk-devel
  14. BuildRequires: libsoup-devel
  15. BuildRequires: sqlite3-devel
  16. BuildRequires: gtk-doc >= 1.14
  17. BuildRequires: gobject-introspection-devel >= 0.6.8
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: Takemikaduchi
  22. %description
  23. Libchamplain is a C library aimed to provide a ClutterActor to display
  24. rasterized maps.
  25. %description -l ja
  26. Libchamplain はラスタライズされたマップを表示するために ClutterActor を提供することを目的とした C ライブラリです。
  27. %package devel
  28. Summary: Development files for %{name}
  29. Group: Development/Libraries
  30. Requires: gobject-introspection-devel
  31. Requires: clutter-devel
  32. Requires: sqlite3-devel
  33. Requires: libsoup-devel
  34. Requires: %{name} = %{version}-%{release}
  35. %description devel
  36. This package contains development files for %{name}.
  37. %package gtk
  38. Summary: Gtk+ widget wrapper for %{name}
  39. Group: System Environment/Libraries
  40. Requires: %{name} = %{version}-%{release}
  41. %description gtk
  42. Libchamplain-gtk is a library providing a GtkWidget to embed %{name}
  43. into Gtk+ applications.
  44. %package gtk-devel
  45. Summary: Development files for %{name}-gtk
  46. Group: Development/Libraries
  47. Requires: clutter-gtk-devel
  48. Requires: gtk2-devel
  49. Requires: %{name}-devel = %{version}-%{release}
  50. Requires: %{name}-gtk = %{version}-%{release}
  51. %description gtk-devel
  52. This package contains development files for %{name}-gtk.
  53. %package vala
  54. Summary: Vala bindings for %{name}
  55. Summary(ja): %{name} の Vala バインディング
  56. Group: Development/Libraries
  57. Requires: %{name} = %{version}-%{release}
  58. Requires: %{name}-gtk = %{version}-%{release}
  59. Requires: vala
  60. %description vala
  61. Vala bindings for %{name}.
  62. %package docs
  63. Summary: Documentation for %{name}
  64. Summary(ja): %{name} 用のドキュメント
  65. Group: Documentation
  66. Requires: %{name} = %{version}-%{release}
  67. Requires: gtk-doc
  68. BuildArch: noarch
  69. %description docs
  70. This package contains documentation for %{name}.
  71. %prep
  72. %setup -q
  73. %build
  74. %configure --disable-debug --disable-static --enable-gtk --enable-gtk-doc \
  75. --enable-introspection=yes --enable-silent-rules
  76. # Omit unused direct shared library dependencies.
  77. sed --in-place --expression 's! -shared ! -Wl,--as-needed\0!g' libtool
  78. make %{?_smp_mflags}
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
  82. find $RPM_BUILD_ROOT -type f -name "*.la" -delete
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %post -p /sbin/ldconfig
  86. %postun -p /sbin/ldconfig
  87. %post gtk -p /sbin/ldconfig
  88. %postun gtk -p /sbin/ldconfig
  89. %files
  90. %defattr(-,root,root,-)
  91. %doc AUTHORS
  92. %doc ChangeLog
  93. %doc COPYING
  94. %doc NEWS
  95. %{_libdir}/girepository-1.0/Champlain-%{ver}.typelib
  96. %{_libdir}/%{name}-%{ver}.so.*
  97. %files devel
  98. %defattr(-,root,root,-)
  99. %doc demos/animated-marker.c
  100. %doc demos/launcher.c
  101. %doc demos/markers.c
  102. %doc demos/markers.h
  103. %doc demos/polygons.c
  104. %doc demos/url-marker.c
  105. %{_datadir}/gir-1.0/Champlain-%{ver}.gir
  106. %{_libdir}/%{name}-%{ver}.so
  107. %{_libdir}/pkgconfig/champlain-%{ver}.pc
  108. %dir %{_includedir}/%{name}-%{ver}
  109. %{_includedir}/%{name}-%{ver}/champlain
  110. %files gtk
  111. %defattr(-,root,root,-)
  112. %{_libdir}/girepository-1.0/GtkChamplain-%{ver}.typelib
  113. %{_libdir}/%{name}-gtk-%{ver}.so.*
  114. %files gtk-devel
  115. %defattr(-,root,root,-)
  116. %doc demos/launcher-gtk.c
  117. %doc demos/markers.c
  118. %{_datadir}/gir-1.0/GtkChamplain-%{ver}.gir
  119. %{_libdir}/%{name}-gtk-%{ver}.so
  120. %{_libdir}/pkgconfig/champlain-gtk-%{ver}.pc
  121. %dir %{_includedir}/%{name}-gtk-%{ver}
  122. %{_includedir}/%{name}-gtk-%{ver}/champlain-gtk
  123. %files vala
  124. %defattr(-,root,root,-)
  125. %{_datadir}/vala/vapi/champlain-%{ver}.vapi
  126. %{_datadir}/vala/vapi/champlain-gtk-%{ver}.vapi
  127. %files docs
  128. %defattr(-,root,root,-)
  129. %{_datadir}/gtk-doc/html/libchamplain-%{ver}
  130. %{_datadir}/gtk-doc/html/libchamplain-gtk-%{ver}
  131. %changelog
  132. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.5-2
  133. - rebuild with VineSeed environment
  134. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.5-1
  135. - new upstream release
  136. - create vala, docs subpackages
  137. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.4-1
  138. - new upstream release
  139. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-3
  140. - rebuild with cogl-0.14.0
  141. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-2
  142. - rebuild with cogl-0.12.0
  143. * Tue Jul 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-1
  144. - new upstream release
  145. * Sat Apr 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.2-1
  146. - new upstream release
  147. * Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
  148. - new upstream release
  149. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
  150. - new upstream release
  151. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.1-1
  152. - new upstream release
  153. - add Requires: sqlite3-devel, libsoup-devel (-devel package)
  154. * Tue Oct 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-2
  155. - add Requires: sqlite3-devel, libsoup-devel (-devel package)
  156. - add Requires: gtk2-devel (-gtk-devel package)
  157. * Mon Oct 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  158. - new upstream release
  159. - remove BuildRequires: gir-repository-devel
  160. - fix %files (change version)
  161. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
  162. - rebuild with rpm-4.8.1 for pkg-config file
  163. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
  164. - new upstream release
  165. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
  166. - new upstream release
  167. * Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.5-1
  168. - new upstream release
  169. - fix BuildRequires: gtk-doc >= 1.14
  170. - add Requires: clutter-devel (devel package)
  171. - add Requires: clutter-gtk-devel (gtk-devel package)
  172. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.4-1
  173. - Initial build for Vine Linux
  174. - add BuildRequires: sqlite3-devel, gtk-doc, gobject-introspection
  175. * Thu Oct 29 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.2-1
  176. - Version bump to 0.4.2.
  177. * Fixed acceptable values of "decel-rate". (GNOME Bugzilla #595552)
  178. * Fixed GObject Introspection build failure. (GNOME Bugzilla #598942)
  179. * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.news
  180. * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.2.changes
  181. * Mon Oct 19 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.1-1
  182. - Version bump to 0.4.1.
  183. * Added champlain_view_remove_layer.
  184. * ChamplainSelectionLayer now has a "changed" signal.
  185. * Added champlain_marker_get_highlighted_text_color,
  186. champlain_marker_set_highlighted_text_color and
  187. Added champlain_marker_get_highlighted_color.
  188. * Fixed slowdowns with big caches.
  189. * Don't emit invalid latitude and longitude notifications.
  190. * Ensure map is displayed in Eye of GNOME's champlain plugin. (GNOME
  191. Bugzilla #598106)
  192. * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.news
  193. * http://download.gnome.org/sources/libchamplain/0.4/libchamplain-0.4.1.changes
  194. - Enabled GObject Introspection, and added 'Requires: gobject-introspection'
  195. and 'BuildRequires: gir-repository-devel'. Patched to fix build failure.
  196. (GNOME Bugzilla #598942)
  197. - Explicitly disabled debug code.
  198. - RPaths fixed by upstream. Removed 'BuildRequires: chrpath'.
  199. * Mon Sep 21 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.4.0-1
  200. - Version bump to 0.4.0.
  201. * ChamplainView now has keyboard shortcuts (but not when used with
  202. GtkChamplainEmbed).
  203. * Removed deprecated symbols introduced in 0.3.
  204. * Fixed X error when using GtkChamplainEmbed. (GNOME Bugzilla #590692)
  205. * Events were not being sent until the mouse moved. (GNOME Bugzilla #590727)
  206. * Fixed memory leak in ChamplainLayer. (GNOME Bugzilla #593505)
  207. * Initial center_on should not result on the map being in Antarctica.
  208. (GNOME Bugzilla #594963)
  209. * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.news
  210. * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.92.changes
  211. * Mon Aug 24 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.91-1
  212. - Version bump to 0.3.91.
  213. * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.91.news
  214. * Tue Aug 11 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.90-1
  215. - Version bump to 0.3.90.
  216. * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.news
  217. * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.90.changes
  218. * Mon Aug 3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.6-1
  219. - Version bump to 0.3.6.
  220. * New marker animation API.
  221. * Ported to Clutter 1.0. (GNOME Bugzilla #576391)
  222. * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.news
  223. * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.6.changes
  224. * Sun Aug 02 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.5-1
  225. - Version bump to 0.3.5.
  226. * Marker selection API. (GNOME Bugzilla #577909)
  227. * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.news
  228. * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.news
  229. * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.5.changes
  230. * http://download.gnome.org/sources/libchamplain/0.3/libchamplain-0.3.4.changes
  231. * Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.3.3-2
  232. - Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  233. * Sat Jul 11 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.3.3-1
  234. - Version bump to 0.3.3.
  235. * Support for custom map sources and listing available map sources.
  236. * Smooth movement to a new position. (GNOME Bugzilla #557641)
  237. * Keep the center of the map in the center after a resize. (GNOME Bugzilla
  238. #557642)
  239. * Double click to zoom and center. (GNOME Bugzilla #557644)
  240. * Added a way to know the maximum and minimum zoom level. (GNOME Bugzilla
  241. #557965)
  242. * Fixed unwanted wrap effect when panning at zoom level >= 8. (GNOME
  243. Bugzilla #558020)
  244. * Fixed center on and zooming in behavior. (GNOME Bugzilla #558026)
  245. * Lack of user feedback during loading of tiles. (GNOME Bugzilla #559522)
  246. * Added missing zoom level to OpenStreetMap Mapnik. (GNOME Bugzilla
  247. #559446)
  248. * Fixed wrong elastic effect affecting Emapthy's map view. (GNOME Bugzilla
  249. #561700)
  250. * Added disk cache management. (GNOME Bugzillla #568931)
  251. * Host application should be able to limit the maximum and minimum zoom
  252. levels. (GNOME Bugzilla #571702)
  253. * Allow host applications to draw lines/routes on the map. (GNOME Bugzilla
  254. #572377)
  255. * Support proxies. (GNOME Bugzilla #573937)
  256. * Provide a way to make visible a bunch of markers. (GNOME Bugzilla #574809)
  257. * Do not allow negative zoom levels. (GNOME Bugzilla #575138)
  258. * Fixed corrupted map when double-clicking at maximum level. (GNOME Bugzilla
  259. #575139)
  260. * Prevent ChamplainNetworkMapSource from crashing when setting "proxy-uri".
  261. (GNOME Bugzilla #575902).
  262. * Implemented advanced markers. (GNOME Bugzilla #576055)
  263. * Various memory management fixes for ChamplainTile. (GNOME Bugzilla
  264. #576159)
  265. * Any go_to should stop a previous and not yet finished go_to. (GNOME
  266. Bugzilla #576832)
  267. * Prevent segmentation fault on 32 bit platforms. (GNOME Bugzilla #576698)
  268. * Introduced a new signal called ChamplainView::animation-completed. (GNOME
  269. Bugzilla #577169)
  270. * Set decel-rate correctly. (GNOME Bugzilla #580785)
  271. * champlain_network_map_source_fill_tile should be private. (GNOME Bugzilla
  272. #582786)
  273. * Fixed champlain_view_center_on. (GNOME Bugzilla #583502)
  274. * Fixed "longitude" and "latitude" properties, which were reversed. (GNOME
  275. Bugzilla #584365)
  276. * Make the cache work the first time. (GNOME Bugzilla #584390)
  277. * GNOME Goal: use accessor functions instead direct access. (GNOME Bugzilla
  278. #585698)
  279. - Added 'BuildRequires: chrpath' for removing rpaths.
  280. * Wed Mar 18 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.9-1
  281. - Version bump to 0.2.9.
  282. * Fixed elastic effect.
  283. * Reduced exported symbols.
  284. * Wed Feb 25 2009 Release Engineering <rel-eng@fedoraproject.org> - 0.2.8-3
  285. - Autorebuild for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  286. * Wed Jan 28 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-2
  287. - Removed 'Requires: clutter-devel >= 0.8 pkgconfig' from libchamplain-devel
  288. for all distributions, except Fedora 10.
  289. - Fixed sample code to not use generic headers.
  290. * Wed Jan 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 0.2.8-1
  291. - Initial build. Imported SPEC from openSUSE.
  292. * Added a new constructor for ChamplainMarkers made of an image.
  293. * Double clicking on the map will now zoom and recenter.
  294. * When resizing a ChamplainView, the centered content will still be
  295. centered after the resizing. Can be disabled.
  296. * The Map's license is displayed by default on the lower right corner.
  297. * Fixed map centering on startup.
  298. * Fixed missing zoom level in OpenStreetMap Mapnik.
  299. * Fixed zooming and centering behaviour. (GNOME Bugzilla #558026)