tar-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386
  1. Summary: A GNU file archiving program.
  2. Summary(ja): GNU ファイルアーカイブプログラム
  3. Name: tar
  4. Version: 1.28
  5. Release: 2%{?_dist_release}
  6. License: GPLv3+
  7. Group: Applications/Archiving
  8. Source: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.xz
  9. Patch0: tar-1.13.18-manpage.patch
  10. Patch8: tar-1.20-loneZeroWarning.patch
  11. Patch10: tar-1.15.1-gcc4.patch
  12. #Fix extracting sparse files to a filesystem like vfat,
  13. #when ftruncate may fail to grow the size of a file.(#179507)
  14. Patch11: tar-1.15.1-vfatTruncate.patch
  15. #change inclusion defaults of tar to "--wildcards --anchored
  16. #--wildcards-match-slash" for compatibility reasons (#206841)
  17. Patch12: tar-1.17-wildcards.patch
  18. # Fix for bad cooperation of -C and -u options.
  19. # ~> #688567
  20. # ~> http://lists.gnu.org/archive/html/bug-tar/2012-02/msg00007.html
  21. # ~> still downstream
  22. Patch15: tar-1.26-update-with-change-directory.patch
  23. # adhoc but useful patch for z option accepts bzip2ed tarball.
  24. Patch100: tar-1.13.6-barterly.patch
  25. Patch110: tar-1.22-rtapelib-overflow.patch
  26. Buildroot: %{_tmppath}/%{name}-%{version}-root
  27. BuildRequires: autoconf texinfo gettext
  28. BuildRequires: libacl-devel
  29. Requires(post,postun): install-info
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. %description
  33. The GNU tar program saves many files together in one archive and can
  34. restore individual files (or all of the files) from that archive. Tar
  35. can also be used to add supplemental files to an archive and to update
  36. or list files in the archive. Tar includes multivolume support,
  37. automatic archive compression/decompression, the ability to perform
  38. remote archives, and the ability to perform incremental and full
  39. backups.
  40. If you want to use tar for remote backups, you also need to install
  41. the rmt package.
  42. %description -l ja
  43. GNU tar プログラムは多くのファイルを一つのファイルにまとめたりアーカイブ
  44. から個々のファイルを(または全てのファイルを)リストアしたりします。tar は
  45. また、追加ファイルを加えたりアーカイブファイル中のリストを更新したりする
  46. ために使われます。
  47. tar はマルチボリュームサポート、自動アーカイブ圧縮/伸長、リモートアーカイ
  48. ブの取り扱い機能、そして差分バックアップとフルバックアップをする機能を含ん
  49. でいます。
  50. もしリモートバックアップのために tar をインストールするなら、rmt パッケージ
  51. もまたインストールする必要があります。
  52. %prep
  53. %setup -q
  54. %patch0 -p1 -b .manpage
  55. %patch8 -p1 -b .loneZeroWarning
  56. %patch11 -p1 -b .vfatTruncate
  57. %patch12 -p1 -b .wildcards
  58. %patch15 -p1 -b .update_and_changedir
  59. %patch100 -p1 -b .accept-bz2
  60. %patch110 -p1 -b .CVE-2010-0624
  61. %build
  62. autoreconf
  63. %configure --bindir=/bin --libexecdir=/sbin
  64. make LIBS="-lbsd -lacl" %{?_smp_mflags}
  65. %install
  66. rm -rf $RPM_BUILD_ROOT
  67. make prefix=${RPM_BUILD_ROOT}%{_prefix} \
  68. localedir=${RPM_BUILD_ROOT}%{_prefix}/share/locale \
  69. bindir=${RPM_BUILD_ROOT}/bin \
  70. libexecdir=${RPM_BUILD_ROOT}/sbin \
  71. mandir=${RPM_BUILD_ROOT}%{_mandir} \
  72. infodir=${RPM_BUILD_ROOT}%{_infodir} \
  73. install
  74. ln -s tar ${RPM_BUILD_ROOT}/bin/gtar
  75. ( cd $RPM_BUILD_ROOT
  76. for dir in ./bin ./sbin .%{_prefix}/bin .%{_prefix}/libexec
  77. do
  78. [ -d $dir ] || continue
  79. strip $dir/* || :
  80. done
  81. gzip -9nf .%{_infodir}/tar.info*
  82. rm -f .%{_infodir}/dir
  83. )
  84. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
  85. install -c -m644 tar.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
  86. rm -f ${RPM_BUILD_ROOT}/sbin/rmt
  87. %find_lang %name
  88. %post
  89. /sbin/install-info %{_infodir}/tar.info.gz %{_infodir}/dir
  90. %preun
  91. if [ $1 = 0 ]; then
  92. /sbin/install-info --delete %{_infodir}/tar.info.gz %{_infodir}/dir
  93. fi
  94. %clean
  95. rm -rf ${RPM_BUILD_ROOT}
  96. %files -f %{name}.lang
  97. %defattr(-,root,root)
  98. %doc AUTHORS COPYING ChangeLog* NEWS README THANKS TODO
  99. /bin/tar
  100. /bin/gtar
  101. %{_mandir}/man1/tar.1*
  102. %{_mandir}/man8/rmt.8*
  103. %{_infodir}/tar.info*
  104. %changelog
  105. * Tue Jan 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.28-2
  106. - added LIBS="-lacl" to build on x86_64 (ad-hoc fix, maybe)
  107. - added BR: libacl-devel
  108. * Fri Jan 16 2015 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.28-1
  109. - new upstream release
  110. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.27.1-1
  111. - new upstream release
  112. - remove Patch13 (tar-1.23-oldarchive.patch)
  113. - add Patch15 (tar-1.26-update-with-change-directory.patch) from Fedora
  114. * Wed May 18 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.26-1
  115. - new upstream release
  116. - added BuildRequires: gettext
  117. * Mon Nov 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.25-1
  118. - new upstream release
  119. - changed source archive type (gzip to bzip2)
  120. - modified Patch8 a little
  121. - added Patch11,12,13 from Fedora development
  122. - added BuildRequires: autoconf texinfo
  123. - run autoreconf on %%build
  124. * Tue Mar 16 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.22-4
  125. - add patch110 for fix CVE-2010-0624 (rmt) from fc11
  126. * Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.22-3
  127. - add missing documents
  128. * Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-2
  129. - spec in utf-8
  130. * Mon Mar 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
  131. - new upstream release
  132. - improved tar-1.20-loneZeroWarning.patch (refer to Fedora package)
  133. * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-1
  134. - new upstream release
  135. - remove unneeded patches
  136. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15.1-0vl3
  137. - rebuilt for VineSeed
  138. * Thu Nov 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2.1
  139. - add patch120 for fix CVE-2006-6097
  140. * Sun Sep 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2
  141. - add patch110 for fix CVE-2006-0300
  142. * Mon May 02 2005 Satoshi MACHINO <machino@vinelinux.org> 1.15.1-0vl1
  143. - new upstream release
  144. - fixed patch6 and patch7 for new upstream release
  145. - some patches are imported from fedora package. and fixed
  146. -- stop issuing lone zero block warnings(patch8)
  147. -- fixed testsuite(patch9)
  148. -- don't applyed(patch10)
  149. -- fixed offset had incorrect type(patch11)
  150. * Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
  151. - new upstream release
  152. - some patches are imported from fedora package.
  153. * Fri May 2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.25-8vl4
  154. - rebuild with new toolchain
  155. - update BuildRequire (autoconf253 -> autoconf)
  156. * Thu Oct 31 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.25-8vl3
  157. - add adhoc but useful patch100 for "z" option to accepts bz2 tarball.
  158. * Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl2
  159. - Oops the spec was in Shift-JIS. Fixed.
  160. * Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl1
  161. - based on 1.3.25-8 from Rawhide and built for Vine Linux
  162. - the previous Vine package was 1.3.18-0vl2. Vine's changelog was as follows:
  163. - Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.18-0vl2
  164. - rebuild to remove rpmlib dependancy
  165. - Sat May 26 2001 <sagami@vinelinux.org>
  166. - 1.13.18-0vl1: based on 1.13.18-1 and added Japanese summary and description
  167. - added barterly patch
  168. * Fri Aug 23 2002 Phil Knirsch <pknirsch@redhat.com> 1.13.25-8
  169. - Included security patch from errata release.
  170. * Mon Jul 1 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-7
  171. - Fix argv NULL termination (#64869)
  172. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  173. - automated rebuild
  174. * Tue Apr 9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-4
  175. - Fix build with autoconf253 (LIBOBJ change; autoconf252 worked)
  176. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  177. - automated rebuild
  178. * Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-2
  179. - Don't include hardlinks to sockets in a tar file (#54827)
  180. * Thu Sep 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-1
  181. - 1.13.25
  182. * Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.22-1
  183. - Update to 1.13.22, adapt patches
  184. * Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-6
  185. - Fix #52084
  186. * Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-5
  187. - Fix build with current autoconf (stricter checking on AC_DEFINE)
  188. - Fix segfault when tarring directories without having read permissions
  189. (#40802)
  190. * Tue Mar 6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  191. - Don't depend on librt.
  192. * Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
  193. - langify
  194. * Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  195. - Fix up the man page (#28915)
  196. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  197. - 1.3.19, nukes -I and fixes up -N
  198. - Add -I back in as an alias to -j with a nice loud warning
  199. * Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  200. - 1.3.18
  201. - Update man page to reflect changes
  202. * Thu Oct 5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  203. - Fix the "ignore failed read" option (Bug #8330)
  204. * Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  205. - fix hang on tar tvzf - <something.tar.gz, introduced by
  206. exit code fix (Bug #15448), Patch from Tim Waugh <twaugh@redhat.com>
  207. * Fri Aug 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  208. - really fix exit code (Bug #15448)
  209. * Mon Aug 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  210. - fix exit code (Bug #15448), patch from Tim Waugh <twaugh@redhat.com>
  211. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  212. - automatic rebuild
  213. * Mon Jun 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  214. - FHSify
  215. * Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
  216. - fix for ia64
  217. * Wed Feb 9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  218. - Fix the exclude bug (#9201)
  219. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  220. - man pages are compressed
  221. - fix description
  222. - fix fnmatch build problems
  223. * Sun Jan 9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  224. - 1.13.17
  225. - remove dotbug patch (fixed in base)
  226. - update download URL
  227. * Fri Jan 7 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  228. - Fix a severe bug (tar xf any_package_containing_. would delete the
  229. current directory)
  230. * Wed Jan 5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  231. - 1.3.16
  232. - unset LINGUAS before running configure
  233. * Tue Nov 9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
  234. - 1.13.14
  235. - Update man page to know about -I / --bzip
  236. - Remove dependancy on rmt - tar can be used for anything local
  237. without it.
  238. * Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
  239. - upgrade to 1.13.11.
  240. * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
  241. - update to 1.13.9.
  242. * Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
  243. - update to 1.13.6.
  244. - support -y --bzip2 options for bzip2 compression (#2415).
  245. * Fri Jul 23 1999 Jeff Johnson <jbj@redhat.com>
  246. - update to 1.13.5.
  247. * Tue Jul 13 1999 Bill Nottingham <notting@redhat.com>
  248. - update to 1.13
  249. * Sat Jun 26 1999 Jeff Johnson <jbj@redhat.com>
  250. - update to 1.12.64014.
  251. - pipe patch corrected for remote tars now merged in.
  252. * Sun Jun 20 1999 Jeff Johnson <jbj@redhat.com>
  253. - update to tar-1.12.64013.
  254. - subtract (and reopen #2415) bzip2 support using -y.
  255. - move gtar to /bin.
  256. * Tue Jun 15 1999 Jeff Johnson <jbj@redhat.com>
  257. - upgrade to tar-1.12.64011 to
  258. - add bzip2 support (#2415)
  259. - fix filename bug (#3479)
  260. * Mon Mar 29 1999 Jeff Johnson <jbj@redhat.com>
  261. - fix suspended tar with compression over pipe produces error (#390).
  262. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  263. - auto rebuild in the new build environment (release 8)
  264. * Mon Mar 08 1999 Michael Maher <mike@redhat.com>
  265. - added patch for bad name cache.
  266. - FIXES BUG 320
  267. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  268. - Injected new description and group.
  269. * Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
  270. - bumped spec number for initial rh 6.0 build
  271. * Tue Aug 4 1998 Jeff Johnson <jbj@redhat.com>
  272. - add /usr/bin/gtar symlink (change #421)
  273. * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
  274. - Fiddle bindir/libexecdir to get RH install correct.
  275. - Don't include /sbin/rmt -- use the rmt from dump.
  276. - Turn on nls.
  277. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  278. - translations modified for de, fr, tr
  279. * Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
  280. - updated from 1.11.8 to 1.12
  281. - various spec file cleanups
  282. - /sbin/install-info support
  283. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  284. - built against glibc
  285. * Thu May 29 1997 Michael Fulbright <msf@redhat.com>
  286. - Fixed to include rmt