iputils-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337
  1. Summary: Network monitoring tools including ping.
  2. Summary(ja): ping 等のネットワークモニタツール集
  3. Name: iputils
  4. Version: 20180629
  5. Release: 1%{?_dist_release}
  6. # some parts are under the original BSD (ping.c)
  7. # some are under GPLv2+ (tracepath.c)
  8. License: BSD and GPLv2+
  9. Group: System Environment/Daemons
  10. URL: https://github.com/iputils/iputils
  11. Source0: https://github.com/iputils/iputils/archive/s%{version}.tar.gz#/%{name}-s%{version}.tar.gz
  12. Source1: ifenslave.tar.gz
  13. Source3: rdisc.initd
  14. Source5: rdisc.sysconfig
  15. Source6: ninfod.initd
  16. Source7: ninfod.sysconfig
  17. Source10: bsd.txt
  18. Source11: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
  19. Patch0: iputils-rh.patch
  20. Patch1: iputils-ifenslave.patch
  21. # Vine Source(s)/Patch(es)
  22. Source1000: iputils-s20180629-ja.po
  23. Patch1000: iputils-s20180629-gettext.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  25. BuildRequires: docbook-utils perl-SGMLSpm
  26. BuildRequires: glibc-kernheaders >= 2.4-8.19
  27. BuildRequires: libidn2-devel
  28. BuildRequires: openssl-devel
  29. BuildRequires: libcap-devel
  30. BuildRequires: libxslt
  31. BuildRequires: docbook-style-xsl
  32. Requires(post): chkconfig
  33. Requires(preun): chkconfig
  34. Requires(preun): initscripts
  35. Requires(postun): initscripts
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. %description
  39. The iputils package contains basic utilities for monitoring a network,
  40. including ping. The ping command sends a series of ICMP protocol
  41. ECHO_REQUEST packets to a specified network host to discover whether
  42. the target machine is alive and receiving network traffic.
  43. %prep
  44. %setup -q -a 1 -n %{name}-s%{version}
  45. cp %{SOURCE10} %{SOURCE11} .
  46. %patch0 -p1
  47. %patch1 -p1
  48. #
  49. %patch1000 -p1 -b .gettext
  50. # add ja.po
  51. cp %{SOURCE1000} po/ja.po
  52. %build
  53. %ifarch s390 s390x
  54. export CFLAGS="$RPM_OPT_FLAGS -fPIE"
  55. %else
  56. export CFLAGS="$RPM_OPT_FLAGS -fpie"
  57. %endif
  58. export LDFLAGS="-pie -Wl,-z,relro,-z,now"
  59. make %{?_smp_mflags} arping clockdiff ping rdisc tracepath ninfod
  60. gcc -Wall $RPM_OPT_FLAGS $CFLAGS $LDFLAGS ifenslave.c -o ifenslave
  61. make -C doc man
  62. make -C po
  63. %install
  64. rm -rf ${RPM_BUILD_ROOT}
  65. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  66. mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
  67. mkdir -p ${RPM_BUILD_ROOT}/{bin,sbin}
  68. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  69. install -c clockdiff ${RPM_BUILD_ROOT}%{_sbindir}/
  70. install -cp arping ${RPM_BUILD_ROOT}/sbin/
  71. ln -s /sbin/arping ${RPM_BUILD_ROOT}%{_sbindir}/arping
  72. install -cp ping ${RPM_BUILD_ROOT}/bin/
  73. install -cp ifenslave ${RPM_BUILD_ROOT}/sbin/
  74. install -cp rdisc ${RPM_BUILD_ROOT}/sbin/
  75. install -cp tracepath ${RPM_BUILD_ROOT}/bin/
  76. install -cp ninfod/ninfod ${RPM_BUILD_ROOT}/sbin/
  77. ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}
  78. ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}/ping6
  79. ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
  80. ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}/tracepath6
  81. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
  82. install -cp doc/clockdiff.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  83. install -cp doc/arping.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  84. install -cp doc/ping.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  85. install -cp doc/rdisc.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  86. install -cp doc/tracepath.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  87. install -cp doc/ninfod.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  88. install -cp ifenslave.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  89. ln -s ping.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/ping6.8.gz
  90. ln -s tracepath.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/tracepath6.8.gz
  91. find ${RPM_BUILD_ROOT}%{_mandir} -type f | xargs chmod 644
  92. install -dp ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
  93. install -m 755 -p %{SOURCE3} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/rdisc
  94. install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rdisc
  95. install -m 755 -p %{SOURCE6} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/ninfod
  96. install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ninfod
  97. make -C po install DESTDIR=$RPM_BUILD_ROOT
  98. %find_lang %{name}
  99. %post
  100. /sbin/chkconfig --add rdisc
  101. /sbin/chkconfig --add ninfod
  102. %preun
  103. if [ $1 = 0 ]; then
  104. service rdisc stop >/dev/null 2>&1
  105. service ninfod stop >/dev/null 2>&1
  106. /sbin/chkconfig --del rdisc
  107. /sbin/chkconfig --del ninfod
  108. fi
  109. %postun
  110. if [ "$1" -ge "1" ]; then
  111. service rdisc condrestart >/dev/null 2>&1 || :
  112. service ninfod condrestart >/dev/null 2>&1 || :
  113. fi
  114. %clean
  115. rm -rf ${RPM_BUILD_ROOT}
  116. %files -f %{name}.lang
  117. %defattr(-,root,root)
  118. %doc LICENSE* README.*
  119. %{_sbindir}/clockdiff
  120. /sbin/arping
  121. %{_sbindir}/arping
  122. %attr(4755,root,root) /bin/ping
  123. /sbin/ifenslave
  124. /sbin/rdisc
  125. /bin/tracepath
  126. /sbin/ninfod
  127. %{_sbindir}/ping
  128. %{_sbindir}/ping6
  129. %{_sbindir}/tracepath
  130. %{_sbindir}/tracepath6
  131. %{_mandir}/man8/*
  132. %{_sysconfdir}/rc.d/init.d/rdisc
  133. %{_sysconfdir}/rc.d/init.d/ninfod
  134. %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/rdisc
  135. %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/ninfod
  136. %changelog
  137. * Sat Nov 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20180629-1
  138. - updated to 20180629.
  139. - dropped Patch2-5 (fixed in upstream).
  140. - updated gettext patch and translation.
  141. - added BR:libxslt.
  142. - added BR:docbook-style-xsl.
  143. * Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-2
  144. - fixed initscripts.
  145. * Fri Feb 23 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-1
  146. - updated to 20161105.
  147. - updated gettext patch and translation.
  148. - updated license.
  149. * Sun Jul 13 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 20140519-1
  150. - update to 20140519
  151. - update URL to new upstream
  152. - update gettext patch and translation
  153. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 20101006-1
  154. - new upstream release
  155. - merget with fedora/20101006-8
  156. - update gettext patch and ja.po
  157. * Fri Apr 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-2
  158. - rebuild to add sign..
  159. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-1
  160. - new upstream release
  161. - spec in utf-8
  162. * Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-41vl1
  163. - remove traceroute6 that is now provided by traceroute package.
  164. - merge changes from FC
  165. * Sat Jul 31 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20020927-13vl2
  166. - ppc patch (Patch110) removed (it's no necessary now)
  167. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-13vl1
  168. - update to 20020927 merged with 20020927-13
  169. - update i18n patch, ja.po
  170. * Thu Oct 02 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-12
  171. - Fixed unaligned access problem on ia64 (#101417)
  172. * Wed Sep 10 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-11
  173. - Dont use own headers, use glibc and kernheaders.
  174. * Thu Sep 04 2003 Bill Nottingham <notting@redhat.com> 20020927-10
  175. - fix build with new glibc-kernheaders
  176. * Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9
  177. - Start icmp_seq from 0 instead of 1 (Conform with debian and Solaris #100609).
  178. * Thu Jul 31 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-8
  179. - One more update to ifenslave.c
  180. * Mon Jun 16 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-7
  181. - Updated ifenslave.c and README.bonding to latest version.
  182. * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-5
  183. - Bumped release and rebuilt
  184. * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-4
  185. - Fixed DNS lookup problems (#68212).
  186. - Added warning if binding problem failed on subinterface (#81640).
  187. * Tue May 13 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-3
  188. - Removed bonding tarball and replaced it with ifenslave.c and README
  189. - FHS compliance for all tools, now to be found in /bin with compat symlinks to
  190. old places.
  191. * Fri Nov 29 2002 Phil Knirsch <pknirsch@redhat.com> 20020927-1
  192. - Updated to latest upstream version.
  193. * Tue Jun 18 2002 Phil Knirsch <pknirsch@redhat.com> 20020124-7
  194. - Added new BuildPreReqs for docbook-utils and perl-SGMLSpm (#66661)
  195. - Fixed ipv6 error printing problem (#66659).
  196. * Tue May 21 2002 Phil Knirsch <pknirsch@redhat.com>
  197. - Added a patch to activate the rdisc server (#64270).
  198. - Display the countermeasures warning only in verbose (#55236)
  199. * Thu Apr 18 2002 Bill Nottingham <notting@redhat.com>
  200. - quit trying to build HTML versions of the man pages
  201. * Thu Mar 14 2002 Phil Knirsch <pknirsch@redhat.com>
  202. - Added fix by Tom "spot" Callaway to fix buffer overflow problems in stats.
  203. * Wed Feb 27 2002 Phil Knirsch <pknirsch@redhat.com>
  204. - Update to iputils-ss020124.
  205. * Sat Feb 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl2
  206. - changed Patch110 to have clear_bit() within the ipv6 source for ppc
  207. * Sun Jan 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl1
  208. - based on 20001110-7 from Rawhide
  209. - merged Vine changes from 20001010-1vl4
  210. --- Mon Jul 16 2001 <sagami@vinelinux.org>
  211. - 20001010-1vl4
  212. - use %%{find_lang} to fix so as not to own locale dir
  213. --- Thu Jun 07 2001 <sagami@vinelinux.org>
  214. - 20001010-1vl3: rebuilt for %%{_mandir}
  215. --- Fri Oct 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  216. - 20001010-1vl2
  217. - remove ping6 for ppc
  218. - added Japanese summary and description
  219. --- Thu Oct 26 2000 Jun Nishii <jun@vinelinux.org>
  220. - added ja.po and nls patch
  221. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  222. - automated rebuild
  223. * Mon Aug 27 2001 Philipp Knirsch <pknirsch@redhat.de> 20001110-6
  224. - Fixed buffer overflow problem in traceroute6.c (#51135)
  225. * Sun Jul 01 2001 Philipp Knirsch <pknirsch@redhat.de>
  226. - Made ping6 and traceroute6 setuid (safe as they drop it VERY early) (#46769)
  227. * Thu Jun 28 2001 Philipp Knirsch <pknirsch@redhat.de>
  228. - Fixed ping statistics overflow bug (#43801)
  229. * Tue Jun 26 2001 Philipp Knirsch <pknirsch@redhat.de>
  230. - Fixed a bunch of compiler warnings (#37131)
  231. - Fixed wrong exit code for no packets and deadline (#40323)
  232. - Moved arping to /sbin from /usr/sbin due to ifup call (#45785). Symlink from
  233. /usr/sbin/ provided for backwards compatibility.
  234. * Mon Apr 30 2001 Preston Brown <pbrown@redhat.com>
  235. - install in.rdisc.8c as rdisc.8
  236. * Tue Jan 16 2001 Jeff Johnson <jbj@redhat.com>
  237. - update to ss001110
  238. - doco fixes (#23844).
  239. * Sun Oct 8 2000 Jeff Johnson <jbj@redhat.com>
  240. - update to ss001007.
  241. * Tue Aug 8 2000 Tim Waugh <twaugh@redhat.com>
  242. - fix spelling mistake (#15714).
  243. * Tue Aug 8 2000 Tim Waugh <twaugh@redhat.com>
  244. - turn on -U on machines without TSC (#15223).
  245. * Tue Aug 1 2000 Jeff Johnson <jbj@redhat.com>
  246. - better doco patch (#15050).
  247. * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
  248. - fix include-glibc/ to work with new glibc 2.2 resolver headers
  249. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  250. - automatic rebuild
  251. * Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
  252. - FHS packaging.
  253. - update to ss000418.
  254. - perform reverse DNS lookup only once for same input.
  255. * Sun Mar 5 2000 Jeff Johnson <jbj@redhat.com>
  256. - include README.ifenslave doco.
  257. - "ping -i N" was broke for N >= 3 (#9929).
  258. - update to ss000121:
  259. -- clockdiff: preserve raw socket errno.
  260. -- ping: change error exit code to 1 (used to be 92,93, ...)
  261. -- ping,ping6: if -w specified, transmit until -c limit is reached.
  262. -- ping,ping6: exit code non-zero if some packets not received within deadline.
  263. * Tue Feb 22 2000 Jeff Johnson <jbj@redhat.com>
  264. - man page corrections (#9690).
  265. * Wed Feb 9 2000 Jeff Johnson <jbj@jbj.org>
  266. - add ifenslave.
  267. * Thu Feb 3 2000 Elliot Lee <sopwith@redhat.com>
  268. - List /usr/sbin/rdisc in %files list.
  269. * Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
  270. - add remaining binaries.
  271. - casts to remove compilation warnings.
  272. - terminate if -w deadline is reached exactly (#8724).
  273. * Fri Dec 24 1999 Jeff Johnson <jbj@redhat.com>
  274. - create (only ping for now, traceroute et al soon).