cairo-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381
  1. Summary: Cairo - multi-platform 2D graphics library.
  2. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  3. Name: cairo
  4. Version: 1.12.4
  5. Release: 1%{?_dist_release}
  6. License: LGPL/MPL
  7. Group: System Environment/Libraries
  8. Source0: http://cairographics.org/releases/%{name}-%{version}.tar.xz
  9. # don't use serverside gradients, most drivers don't handle those and are
  10. # really slow, should workaround performances issues for ati, nouveau and nvidia
  11. # https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  12. Patch1: cairo-1.10.0-dont_use_server_side_gradients.patch
  13. URL: http://cairographics.org/
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: pkgconfig
  16. BuildRequires: pixman-devel
  17. BuildRequires: glib2-devel
  18. BuildRequires: libpng-devel
  19. BuildRequires: freetype2-devel
  20. BuildRequires: fontconfig-devel
  21. BuildRequires: libX11-devel
  22. BuildRequires: libXrender-devel
  23. BuildRequires: gtk-doc
  24. BuildRequires: librsvg2-devel
  25. BuildRequires: mesa-libGL-devel
  26. BuildRequires: mesa-libEGL-devel
  27. BuildConflicts: XOrg-compat70-devel
  28. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  29. %description
  30. Cairo provides anti-aliased vector-based rendering for X. Paths
  31. consist of line segments and cubic splines and can be rendered at any
  32. width with various join and cap styles. All colors may be specified
  33. with optional translucence (opacity/alpha) and combined using the
  34. extended Porter/Duff compositing algebra as found in the X Render
  35. Extension.
  36. Cairo exports a stateful rendering API similar in spirit to the path
  37. construction, text, and painting operators of PostScript, (with the
  38. significant addition of translucence in the imaging model). When
  39. complete, the API is intended to support the complete imaging model of
  40. PDF 1.4.
  41. Cairo relies on the Xc library for backend rendering. Xc provides an
  42. abstract interface for rendering to multiple target types. As of this
  43. writing, Xc allows Cairo to target X drawables as well as generic
  44. image buffers. Future backends such as PostScript, PDF, and perhaps
  45. OpenGL are currently being planned.
  46. %package -n compat32-%{name}
  47. Summary: Cairo - multi-platform 2D graphics library.
  48. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  49. Group: System Environment/Libraries
  50. Requires: %{name} = %{version}
  51. %description -n compat32-%{name}
  52. Cairo provides anti-aliased vector-based rendering for X. Paths
  53. consist of line segments and cubic splines and can be rendered at any
  54. width with various join and cap styles. All colors may be specified
  55. with optional translucence (opacity/alpha) and combined using the
  56. extended Porter/Duff compositing algebra as found in the X Render
  57. Extension.
  58. Cairo exports a stateful rendering API similar in spirit to the path
  59. construction, text, and painting operators of PostScript, (with the
  60. significant addition of translucence in the imaging model). When
  61. complete, the API is intended to support the complete imaging model of
  62. PDF 1.4.
  63. Cairo relies on the Xc library for backend rendering. Xc provides an
  64. abstract interface for rendering to multiple target types. As of this
  65. writing, Xc allows Cairo to target X drawables as well as generic
  66. image buffers. Future backends such as PostScript, PDF, and perhaps
  67. OpenGL are currently being planned.
  68. %package devel
  69. Summary: Development files for Cairo library.
  70. Summary(ja): Cairo ライブラリの開発用ファイル
  71. Group: Development/Libraries
  72. Provides: lib%{name}-devel = %{version}-%{release}
  73. Requires: %{name} = %{version}
  74. Requires: libpng-devel
  75. Requires: freetype2-devel
  76. Requires: fontconfig-devel
  77. Requires: libX11-devel
  78. Requires: libXrender-devel
  79. Requires: pixman-devel
  80. Requires: glib2-devel
  81. Requires: mesa-libEGL-devel
  82. %description devel
  83. Development files for Cairo library.
  84. %package tools
  85. Summary: Development tools for cairo
  86. Group: Development/Tools
  87. %description tools
  88. Cairo is a 2D graphics library designed to provide high-quality display
  89. and print output.
  90. This package contains tools for working with the cairo graphics library.
  91. * cairo-trace: Record cairo library calls for later playback
  92. %prep
  93. %setup -q
  94. %patch1 -p1 -b .dont-use-server-side-gradients
  95. %build
  96. %configure --disable-static \
  97. --enable-gtk-doc \
  98. --enable-xlib \
  99. --enable-freetype \
  100. --enable-ps \
  101. --enable-pdf \
  102. --enable-svg \
  103. --enable-tee \
  104. --enable-gobject \
  105. --enable-gl
  106. %ifarch x86_64
  107. cp libtool libtool.old
  108. ldpath="/lib64 /usr/lib64 /usr/lib /usr/X11R6/lib64 /usr/X11R6/lib"
  109. sed "s|^sys_lib_search_path_spec=.*|sys_lib_search_path_spec=$ldpath|" libtool.old \
  110. > libtool
  111. rm libtool.old
  112. %endif
  113. make
  114. %install
  115. rm -rf $RPM_BUILD_ROOT
  116. %makeinstall
  117. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  118. %clean
  119. rm -rf $RPM_BUILD_ROOT
  120. %post -p /sbin/ldconfig
  121. %postun -p /sbin/ldconfig
  122. %post -n compat32-%{name} -p /sbin/ldconfig
  123. %postun -n compat32-%{name} -p /sbin/ldconfig
  124. %files
  125. %defattr(644,root,root,755)
  126. %doc AUTHORS BUGS COPYING COPYING-* ChangeLog NEWS README
  127. %{_libdir}/lib*.so.*
  128. %files devel
  129. %defattr(644,root,root,755)
  130. %{_libdir}/lib*.so
  131. #{_libdir}/lib*.la
  132. %{_includedir}/*
  133. %{_libdir}/pkgconfig/*.pc
  134. #{_libdir}/lib*.a
  135. %{_datadir}/gtk-doc/html/cairo
  136. %files tools
  137. %defattr(-,root,root,-)
  138. %{_bindir}/cairo-trace
  139. %{_bindir}/cairo-sphinx
  140. %{_libdir}/cairo
  141. %if %{build_compat32}
  142. %files -n compat32-%{name}
  143. %defattr(644,root,root,755)
  144. %{_libdir}/lib*.so.*
  145. %endif
  146. %changelog
  147. * Sat Oct 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
  148. - new upstream release
  149. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-2
  150. - add Requires: mesa-libEGL-devel
  151. * Sat Jul 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-1
  152. - new upstream release
  153. - Enable OpenGL backend
  154. - add BR: librsvg2-devel, mesa-libGL-devel, mesa-libEGL-devel
  155. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  156. - new upstream release
  157. * Tue Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-2
  158. - enable tee support
  159. - add configure options specifically
  160. - disable static library
  161. * Wed Jan 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  162. - new upstream release
  163. - add BuildRequires: glib2-devel
  164. - add Requires: glib2-devel (devel package)
  165. * Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
  166. - add patch1 from ubuntu to fix performance regressions
  167. - don't use serverside gradients, most drivers don't handle those and are
  168. really slow, should workaround performances issues for ati, nouveau and nvidia
  169. https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  170. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  171. - new upstream release
  172. - add tools sub package
  173. * Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
  174. - add BuildRequires: fontconfig-devel
  175. - add Requires: fontconfig-devel (devel package)
  176. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
  177. - build with rpm-4.8.1-1 for pkg-config file
  178. * Tue Mar 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
  179. - new upstream release
  180. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  181. - new upstream release
  182. * Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
  183. - applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
  184. - added BuildRequires: gtk-doc
  185. * Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
  186. - new upstream release
  187. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
  188. - new upstream release
  189. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  190. - new upstream release
  191. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  192. - new upstream release
  193. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
  194. - new upstream release
  195. * Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
  196. - add Requires: pixman-devel to -devel
  197. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
  198. - rebuilt with xorg-x11 7.3
  199. - spec in UTF-8
  200. * Thu May 1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
  201. - new upstream release
  202. - removed lib*.la from devel package
  203. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
  204. - used %%{?_dist_release}
  205. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
  206. - new upstream release
  207. * Sun Dec 9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
  208. - new upstream release
  209. * Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
  210. - new upstream release
  211. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  212. - new upstream release
  213. - remove BuildRequires: pango-devel, gtk2-devel
  214. (these are only needed for testing)
  215. * Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
  216. - upstream release
  217. - Patch30 and Patch40 is skipped (not working correctly)
  218. but held in src.rpm
  219. - add BUGS, ROADMAP to %%doc
  220. - add BuildRequires: pango-devel, gtk2-devel
  221. * Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
  222. - rebuild without XOrg-compat70-devel
  223. - add BuildConflicts: XOrg-compat70-devel
  224. * Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
  225. - new upstream release
  226. - remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
  227. * Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
  228. - added Patch40 for 15bpp problem
  229. * Tue Sep 5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
  230. - added ad-hoc Patch30 for 16bpp problem
  231. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
  232. - new upstream release
  233. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  234. - new upstream release
  235. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
  236. - new upstream release
  237. * Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
  238. - added compat32- package for x86_64 architecture support
  239. * Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
  240. - added x86_64 architecture support
  241. * Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
  242. - add Patch20 to fix broken desktop rendering on xorg-x11-6.9
  243. - add X.Org 6.9.0 (6090000) to blacklist
  244. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  245. - new upstream release
  246. * Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
  247. - update Patch10
  248. * Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
  249. - add Patch10 to use embedded bitmap font if available.
  250. (controllable by "embeddedbitmap" in fontconfig)
  251. * Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
  252. - rebuild with new fontconfig
  253. * Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
  254. - add Requires: libpng-devel, XOrg-devel, freetype2-devel
  255. to devel package instead of BuildRequires (typo)
  256. - add Japanese summaries
  257. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
  258. - new upstream release
  259. - remove libpixman dependency (which is now included in cairo)
  260. - obsoletes libpixman <= 0.1.6
  261. - add more BuildRequires
  262. * Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
  263. - new upstream version
  264. * Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
  265. - new upstream version
  266. - fixed License (http://cairographics.org/introduction)
  267. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
  268. - new upstream version
  269. - include gtk-doc files
  270. * Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
  271. - new upstream version
  272. - add Requires: libpixman
  273. * Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
  274. - new upstream version (cairo-0.2.0)
  275. * Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
  276. - rebuilt for VineLinux
  277. * Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
  278. - 0.1.23
  279. - reenable libtoolize
  280. * Wed May 5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
  281. - fix devel provides
  282. - drop redundant buildrequires
  283. - requires new pixman
  284. - autoconf 2.5 macro
  285. - New release 0.1.22
  286. * Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
  287. - build with X11
  288. * Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
  289. - 0.1.17
  290. - provides cairo
  291. - drop patch, use --disable-xlib
  292. - buildrequires
  293. - don't run libtoolize
  294. * Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
  295. - initial mandrake package