libvisio-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246
  1. %global apiversion 0.1
  2. Name: libvisio
  3. Version: 0.1.5
  4. Release: 1%{?_dist_release}
  5. Summary: A library for import of Microsoft Visio diagrams
  6. Summary(ja): Microsoft Visio ダイアグラムをインポートするためのライブラリ
  7. License: MPLv2.0
  8. Group: System Environment/Libraries
  9. URL: http://wiki.documentfoundation.org/DLP/Libraries/libvisio
  10. Source: http://dev-www.libreoffice.org/src/%{name}/%{name}-%{version}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: doxygen
  13. BuildRequires: cppunit-devel
  14. BuildRequires: gperf
  15. BuildRequires: help2man
  16. BuildRequires: libboost-devel
  17. BuildRequires: libicu-devel
  18. BuildRequires: librevenge-devel
  19. BuildRequires: libxml2-devel
  20. BuildRequires: perl
  21. BuildRequires: zlib-devel
  22. %description
  23. %{name} is library providing ability to interpret and import
  24. Microsoft Visio diagrams into various applications. You can find it
  25. being used in libreoffice.
  26. %package devel
  27. Summary: Development files for %{name}
  28. Summary(ja): %{name} の開発用ファイル
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. %description devel
  32. The %{name}-devel package contains libraries and header files for
  33. developing applications that use %{name}.
  34. %package doc
  35. Summary: Documentation of %{name} API
  36. Summary(ja): %{name} API のドキュメント
  37. Group: Documentation
  38. BuildArch: noarch
  39. %description doc
  40. The %{name}-doc package contains documentation files for %{name}.
  41. %package tools
  42. Summary: Tools to transform Microsoft Visio diagrams into other formats
  43. Summary(ja): Microsoft Visio ダイアグラムを他のフォーマットに変換するツール
  44. Group: Applications/Productivity
  45. Requires: %{name} = %{version}-%{release}
  46. %description tools
  47. Tools to transform Microsoft Visio diagrams into other formats.
  48. Currently supported: XHTML, raw, plain text.
  49. %prep
  50. %setup -q
  51. %build
  52. %configure --disable-static --disable-silent-rules
  53. sed -i \
  54. -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
  55. -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' \
  56. libtool
  57. make %{?_smp_mflags}
  58. export LD_LIBRARY_PATH=`pwd`/src/lib/.libs${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  59. help2man -N -n 'debug the conversion library' -o vsd2raw.1 ./src/conv/raw/.libs/vsd2raw
  60. help2man -N -n 'convert Visio document into SVG' -o vsd2xhtml.1 ./src/conv/svg/.libs/vsd2xhtml
  61. help2man -N -n 'convert Visio document into plain text' -o vsd2text.1 ./src/conv/text/.libs/vsd2text
  62. help2man -N -n 'debug the conversion library' -o vss2raw.1 ./src/conv/raw/.libs/vss2raw
  63. help2man -N -n 'convert Visio stencil into SVG' -o vss2xhtml.1 ./src/conv/svg/.libs/vss2xhtml
  64. help2man -N -n 'convert Visio stencil into plain text' -o vss2text.1 ./src/conv/text/.libs/vss2text
  65. %install
  66. rm -rf %{buildroot}
  67. make install DESTDIR=%{buildroot}
  68. rm -f %{buildroot}/%{_libdir}/*.la
  69. # rhbz#1001240 we install API docs directly from build
  70. rm -rf %{buildroot}/%{_docdir}/%{name}
  71. install -m 0755 -d %{buildroot}/%{_mandir}/man1
  72. install -m 0644 vsd2*.1 vss2*.1 %{buildroot}/%{_mandir}/man1
  73. %post -p /sbin/ldconfig
  74. %postun -p /sbin/ldconfig
  75. %check
  76. export LD_LIBRARY_PATH=%{buildroot}%{_libdir}${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  77. # Workaround time formatting problem in the test
  78. export TZ='CET'
  79. make check %{?_smp_mflags}
  80. %clean
  81. rm -rf %{buildroot}
  82. %files
  83. %doc AUTHORS COPYING.*
  84. %{_libdir}/%{name}-%{apiversion}.so.*
  85. %files devel
  86. %doc ChangeLog
  87. %{_includedir}/%{name}-%{apiversion}
  88. %{_libdir}/%{name}-%{apiversion}.so
  89. %{_libdir}/pkgconfig/%{name}-%{apiversion}.pc
  90. %files doc
  91. %doc COPYING.*
  92. %doc docs/doxygen/html
  93. %files tools
  94. %{_bindir}/vsd2raw
  95. %{_bindir}/vsd2text
  96. %{_bindir}/vsd2xhtml
  97. %{_bindir}/vss2raw
  98. %{_bindir}/vss2text
  99. %{_bindir}/vss2xhtml
  100. %{_mandir}/man1/vsd2raw.1*
  101. %{_mandir}/man1/vsd2text.1*
  102. %{_mandir}/man1/vsd2xhtml.1*
  103. %{_mandir}/man1/vss2raw.1*
  104. %{_mandir}/man1/vss2text.1*
  105. %{_mandir}/man1/vss2xhtml.1*
  106. %changelog
  107. * Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.1.5-1
  108. - new upstream release
  109. - remove Patch0 (0001-fix-test.patch)
  110. * Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.1.3-1
  111. - new upstream release
  112. - add Patch0 (0001-fix-test.patch) from fedora
  113. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.1.1-2
  114. - Initial build for Vine Linux
  115. * Fri Jan 02 2015 David Tardon <dtardon@redhat.com> - 0.1.1-1
  116. - new upstream release
  117. * Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 0.1.0-4
  118. - rebuild for ICU 53.1
  119. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-3
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  121. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-2
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  123. * Mon May 26 2014 David Tardon <dtardon@redhat.com> - 0.1.0-1
  124. - new upstream release
  125. * Thu May 22 2014 Petr Machata <pmachata@redhat.com> - 0.0.31-4
  126. - Rebuild for boost 1.55.0
  127. * Wed Apr 09 2014 David Tardon <dtardon@redhat.com> - 0.0.31-3
  128. - generate man pages
  129. * Wed Feb 12 2014 Rex Dieter <rdieter@fedoraproject.org> 0.0.31-2
  130. - rebuild (libicu)
  131. * Mon Sep 02 2013 David Tardon <dtardon@redhat.com> - 0.0.31-1
  132. - new release
  133. * Fri Aug 30 2013 David Tardon <dtardon@redhat.com> - 0.0.30-4
  134. - Resolves: rhbz#1001240 duplicate documentation files / potentially conflicting
  135. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.30-3
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  137. * Tue Jul 30 2013 Petr Machata <pmachata@redhat.com> - 0.0.30-2
  138. - Rebuild for boost 1.54.0
  139. * Mon Jul 15 2013 David Tardon <dtardon@redhat.com> - 0.0.30-1
  140. - new release
  141. * Tue Jul 02 2013 David Tardon <dtardon@redhat.com> - 0.0.29-1
  142. - new release
  143. * Wed Jun 05 2013 David Tardon <dtardon@redhat.com> - 0.0.28-1
  144. - new release
  145. * Thu May 16 2013 David Tardon <dtardon@redhat.com> - 0.0.27-1
  146. - new release
  147. * Tue Apr 23 2013 David Tardon <dtardon@redhat.com> - 0.0.26-1
  148. - new release
  149. * Thu Feb 28 2013 David Tardon <dtardon@redhat.com> - 0.0.25-1
  150. - new release
  151. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.24-2
  152. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  153. * Tue Dec 18 2012 David Tardon <dtardon@redhat.com> - 0.0.24-1
  154. - new release
  155. * Mon Dec 03 2012 David Tardon <dtardon@redhat.com> - 0.0.23-1
  156. - new release
  157. * Thu Nov 29 2012 David Tardon <dtardon@redhat.com> - 0.0.22-1
  158. - new upstream release
  159. * Wed Nov 21 2012 David Tardon <dtardon@redhat.com> - 0.0.21-1
  160. - new upstream release
  161. * Tue Nov 06 2012 David Tardon <dtardon@redhat.com> - 0.0.20-1
  162. - new upstream version
  163. * Fri Jul 27 2012 David Tardon <dtardon@redhat.com> - 0.0.19-2
  164. - rebuilt for boost 1.50
  165. * Thu Jul 26 2012 David Tardon <dtardon@redhat.com> - 0.0.19-1
  166. - new upstream version
  167. * Tue Jul 24 2012 David Tardon <dtardon@redhat.com> - 0.0.18-3
  168. - fix endless loop with text fields in VSD6
  169. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.18-2
  170. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  171. * Fri Jun 22 2012 David Tardon <dtardon@redhat.com> 0.0.18-1
  172. - new upstream version
  173. * Fri Jun 01 2012 David Tardon <dtardon@redhat.com> 0.0.17-1
  174. - new upstream version
  175. * Tue Apr 17 2012 David Tardon <dtardon@redhat.com> 0.0.16-1
  176. - new upstream version
  177. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.15-2
  178. - Rebuilt for c++ ABI breakage
  179. * Tue Feb 21 2012 David Tardon <dtardon@redhat.com> 0.0.15-1
  180. - new upstream version
  181. * Wed Jan 25 2012 David Tardon <dtardon@redhat.com> 0.0.14-1
  182. - bump version
  183. - initial import
  184. * Wed Dec 21 2011 David Tardon <dtardon@redhat.com> 0.0.11-1
  185. - initial import