texlive-common-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224
  1. ## -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. Provides: jadetex
  4. Obsoletes: texlive-common < %{version}
  5. Obsoletes: jadetex tetex dvipdfmx xdvik xdvik-motif
  6. Obsoletes: tetex-latex tetex-afm tetex-type1 tetex-devel
  7. Obsoletes: pTeX pLaTeX2e pLaTeX2e_Macros dvipsk
  8. Obsoletes: dvipdfm texmacro-aps
  9. Obsoletes: makejvf <= 1.1a
  10. Conflicts: task-texmacro-phys < 1.1
  11. %global _use_internal_dependency_generator 0
  12. %global __find_provides %{nil}
  13. %global __find_requires %{nil}
  14. %define tex_destdir %{_datadir}
  15. %define texmf %{tex_destdir}/texmf
  16. %define texlive_src %{tex_destdir}/texlive-sources
  17. %define build_tex_destdir %{buildroot}%{tex_destdir}
  18. %define build_texmf %{buildroot}%{texmf}
  19. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  20. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  21. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
  22. ## NOTE: For only texlive-common, if %exec_fmtutil fails,
  23. ## we show the STDERR of %exec_fmtutil.
  24. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
  25. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  26. %define vartexfonts %{_var}/lib/texmf/fonts
  27. Summary: Common base for all TeX Live packages
  28. Summary(ja): TeX Live パッケージの共通ベース
  29. Name: texlive-common
  30. Version: 2011
  31. Release: 1%{?_dist_release}
  32. License: distributable
  33. Group: Applications/Publishing
  34. URL: http://www.tug.org/texlive/
  35. Requires: texlive = %{version}
  36. Requires(pre,post): texlive = %{version}
  37. Requires: texlive-collection-basic = %{version}
  38. Requires(post): texlive-collection-basic = %{version}
  39. Requires: texlive-collection-latex = %{version}
  40. Requires(post): texlive-collection-latex = %{version}
  41. Requires: texlive-collection-latexrecommended = %{version}
  42. Requires(post): texlive-collection-latexrecommended = %{version}
  43. Requires: texlive-collection-fontsrecommended = %{version}
  44. Requires(post): texlive-collection-fontsrecommended = %{version}
  45. #### $ pdftex -ini -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini
  46. ## dehypht-x-2009-06-19.tex
  47. Requires: texlive-collection-langgerman = %{version}
  48. Requires(post): texlive-collection-langgerman = %{version}
  49. ## catkoi
  50. Requires: texlive-collection-langcyrillic = %{version}
  51. Requires(post): texlive-collection-langcyrillic = %{version}
  52. #### $ xetex -ini -jobname=xelatex -progname=xelatex -etex xelatex.ini
  53. ## unicode-letters
  54. Requires: texlive-collection-xetex = %{version}
  55. Requires(post): texlive-collection-xetex = %{version}
  56. Requires: texlive-collection-langcjk = %{version}
  57. Requires(pre,post): texlive-collection-langcjk = %{version}
  58. BuildArch: noarch
  59. Buildroot: %{_tmppath}/%{name}-%{version}-root
  60. Vendor: Project Vine
  61. Distribution: Vine Linux
  62. Packager: munepi
  63. %description
  64. The TeX Live software distribution offers a complete TeX system for a
  65. variety of Unix, Macintosh, Windows and other platforms. It
  66. encompasses programs for editing, typesetting, previewing and printing
  67. of TeX documents in many different languages, and a large collection
  68. of TeX macros and font libraries.
  69. The distribution includes extensive general documentation about TeX,
  70. as well as the documentation for the included software packages.
  71. This package is a virtual package
  72. to provide a common base for all TeX Live packages.
  73. %description -l ja
  74. TeX Live ソフトウェアディストリビューションは、
  75. さまざまな Unix, Macintosh, Windows、および
  76. 他のプラットホームに対して完全な TeX システムを提供します。
  77. 多くの異なった言語を含む TeX ドキュメントの
  78. 編集、組版、閲覧、印刷するためのプログラム、
  79. そして、TeX マクロやフォントライブラリの大きなコレクションを
  80. 同梱しています。
  81. このディストリビューションは
  82. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  83. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  84. このパッケージは TeX Live パッケージの共通ベースを
  85. 提供ための仮想パッケージです。
  86. %files
  87. %posttrans
  88. %{exec_texhash}
  89. updmap_lock=%{texmf}/updmap.lock
  90. # The packages required texlive-common contained the following maps.
  91. (cat<<EOF
  92. MixedMap cm.map
  93. MixedMap cmextra.map
  94. MixedMap cyrillic.map
  95. Map euler.map
  96. MixedMap latxfont.map
  97. MixedMap symbols.map
  98. MixedMap cmtext-bsr-interpolated.map
  99. MixedMap mflogo.map
  100. Map mathpple.map
  101. Map charter.map
  102. Map fpls.map
  103. Map pazo.map
  104. Map utopia.map
  105. MixedMap cm-super-t1.map
  106. MixedMap cm-super-t2a.map
  107. MixedMap cm-super-t2b.map
  108. MixedMap cm-super-t2c.map
  109. MixedMap cm-super-ts1.map
  110. MixedMap cm-super-x2.map
  111. MixedMap eurosym.map
  112. Map lm.map
  113. Map marvosym.map
  114. Map pxfonts.map
  115. MixedMap rsfs.map
  116. Map qag.map
  117. Map qbk.map
  118. Map qcr.map
  119. Map qcs.map
  120. Map qhv.map
  121. Map qpl.map
  122. Map qtm.map
  123. Map qzc.map
  124. MixedMap tipa.map
  125. Map txfonts.map
  126. MixedMap wasy.map
  127. Map cmcyr.map
  128. Map bkaiu.map
  129. Map bsmiu.map
  130. Map gbsnu.map
  131. Map gkaiu.map
  132. Map garuda-c90.map
  133. Map norasi-c90.map
  134. Map umj.map
  135. Map dgj.map
  136. Map dmj.map
  137. Map mc2j.map
  138. Map mcj.map
  139. Map mr2j.map
  140. Map mrj.map
  141. EOF
  142. ) | while read maptype map; do
  143. %{exec_updmap} --listmaps 2>/dev/null | egrep -q "^#! ${maptype} ${map}" && \
  144. echo -n " " && \
  145. echo -n "Running updmap: enable ${map} ... " && \
  146. %{exec_updmap} --nomkmap --enable ${maptype} ${map} >/dev/null 2>&1 && \
  147. echo "done." && \
  148. touch ${updmap_lock}
  149. done
  150. echo -n " "
  151. echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
  152. rm -f %{texmf}/updmap.lock
  153. echo -n " "
  154. echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  155. exit 0
  156. # %postun
  157. # %{exec_texhash}
  158. # echo -n " "
  159. # echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
  160. # echo -n " "
  161. # echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  162. exit 0
  163. %changelog
  164. * Sat Nov 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  165. - TeX Live 2011
  166. * Mon May 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
  167. - added Requires(post): for all requirements of texlive-collection-*
  168. - added Requires: texlive
  169. * Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
  170. - improved %%post
  171. - checked the maps containing Require(post) dependencies
  172. * Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  173. - added Requires(post): texlive
  174. - changed Requires(pre): -> Requires(post): for all requirements
  175. * Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  176. - added to remove %%{texmf}/updmap.lock in %%post
  177. - When texlive-common is installed, this lock generating
  178. texlive-collection-* leaves.
  179. - dropped %%postun
  180. - added some comments for the definition of %%exec_fmtutil
  181. * Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  182. - changed Requires: -> Requires(pre): for all requirements
  183. - merged dependencies of Provides:/Obsoletes: tags from texlive-vl.spec
  184. * Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  185. - TeX Live 2009