mew-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381
  1. %define _docdir %{_defaultdocdir}
  2. %define _noVersionedDependencies 1
  3. # %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  4. %define origver 6.5
  5. %define pkgver %{origver}
  6. %define origname mew
  7. Summary: Mew - Messaging in the Emacs World
  8. Summary(ja): Emacs でメールを読むためのインターフェース
  9. Name: %{origname}
  10. Version: %{origver}
  11. Release: 1%{?_dist_release}
  12. License: distributable
  13. Group: Applications/Editors/Emacs
  14. URL: http://www.mew.org/
  15. Source0: http://www.mew.org/Release/mew-%{pkgver}.tar.gz
  16. Source1: %{origname}-install.sh
  17. Source2: %{origname}-remove.sh
  18. Source3: vine.dot.mew
  19. Source4: %{name}-init.el
  20. Source5: vine-default-%{name}.el
  21. Patch11: mew-6.3-icondir.diff
  22. Requires: emacsen
  23. Requires: perl >= 5.004_jp-4
  24. Provides: %{origname} = %{origver}
  25. #Conflicts: %{origname}-el
  26. Obsoletes: mew-mule, mew-el
  27. Obsoletes: mew-xemacs, mew-xemacs-extra
  28. Requires: mew-common = %{version}
  29. # PreReq: /sbin/install-info
  30. BuildRequires: emacsen
  31. BuildRoot: %{_tmppath}/%{name}-%{origver}-root
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. %description
  35. Messaging in the Emacs World. It provides a very easy user interface
  36. to e-mail, MIME and PGP (Pretty Good Privacy) on Emacsen.
  37. Please install Perl5 to use mew.
  38. Don't forget to copy %{_docdir}/mew-%{version}/vine.dot.mew
  39. to your ~/.mew.el file, and modify the site configurations, e.g.
  40. (setq mew-mail-domain-list '("your mail domain"))
  41. %description -l ja
  42. 電子メールを Emacs / XEmacs 上で簡単に読み書きすることができるインター
  43. フェース mew です。MIME や PGP にも対応しています。mewを使うためには、
  44. perlが必要です。
  45. %{_docdir}/mew-common-%{version}/vine.dot.mew を ~/.mew.el としてコピー
  46. し、適切に設定してください。
  47. (setq mew-mail-domain-list '("your mail domain"))
  48. %package -n mew-common
  49. Summary: Common files/programs for Mew Emacs/XEmacs
  50. Summary(ja): Emacs/XEmacs 用 Mew 両方で利用するファイル/プログラム
  51. Group: Applications/Internet
  52. Obsoletes: mew-xemacs-extra
  53. %description -n mew-common
  54. This package contains common files/programs for Mew Emacs/XEmacs.
  55. %description -n mew-common -l ja
  56. Emacs/XEmacs 用 Mew に共通するファイル/プログラムです.
  57. %prep
  58. %setup -q -n mew-%{pkgver}
  59. %patch11 -p1 -b .vine
  60. %__cp -a %{SOURCE3} .
  61. %build
  62. %configure
  63. %__make PREFIX=%_prefix CFLAGS="$RPM_OPT_FLAGS" bin
  64. %install
  65. [ "%{buildroot}" != "/" ] && %__rm -rf %{buildroot}
  66. %__mkdir_p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  67. %__mkdir_p %{buildroot}%{emacsen_pkgdir}/install
  68. %__mkdir_p %{buildroot}%{emacsen_pkgdir}/remove
  69. %__mkdir_p %{buildroot}%{_infodir}
  70. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/%{origname}
  71. # install el files
  72. # Add here commands to install the package into debian/mew.
  73. %__cp -a *.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  74. %__cp -a %{SOURCE4} %{SOURCE5} \
  75. %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  76. %__make install-bin prefix=%{buildroot}%{_prefix} \
  77. mandir=%{buildroot}%{_mandir}/man1 \
  78. bindir=%{buildroot}%{_bindir}
  79. # contrib
  80. #install -m 755 contrib/mewinc contrib/incdir contrib/incmbox \
  81. # $RPM_BUILD_ROOT/%{_docdir}/%{origname}/contrib/
  82. ## install icons
  83. %__cp -a etc/*.xpm %{buildroot}/usr/share/pixmaps/%{origname}
  84. %__cp -a etc/*.png %{buildroot}/usr/share/pixmaps/%{origname}
  85. %__cp -a etc/*.img %{buildroot}/usr/share/pixmaps/%{origname}
  86. ## install contrib
  87. #%__cp -a contrib $(CURDIR)/debian/mew/usr/share/doc/mew
  88. # install {info,jinfo} for mew-emacs
  89. %__make infodir="%{buildroot}%{_infodir}" \
  90. INSTALLINFO="/sbin/install-info" install-info install-jinfo
  91. %__rm -f %{buildroot}%{_infodir}/dir
  92. gzip -9nf %{buildroot}%{_infodir}/*
  93. %_installemacsenscript %{origname} %{SOURCE1}
  94. %_removeemacsenscript %{origname} %{SOURCE2}
  95. %post
  96. if [ "$1" = 2 ]; then
  97. %_emacsenPackageRemove %{origname}
  98. fi
  99. %_addemacsenlist %{origname}
  100. %_emacsenPackageInstall %{origname}
  101. /sbin/install-info %{_infodir}/mew.info.gz %{_infodir}/dir \
  102. --section="Message User Agent"
  103. /sbin/install-info %{_infodir}/mew.ja.info.gz %{_infodir}/dir \
  104. --section="Message User Agent"
  105. %preun
  106. if [ "$1" = 0 ]; then
  107. %_emacsenPackageRemove %{origname}
  108. %_removeemacsenlist %{origname}
  109. /sbin/install-info --delete %{_infodir}/mew.info.gz %{_infodir}/dir \
  110. --section="Message User Agent"
  111. /sbin/install-info --delete %{_infodir}/mew.ja.info.gz %{_infodir}/dir \
  112. --section="Message User Agent"
  113. fi
  114. %clean
  115. [ "%{buildroot}" != "/" ] && %__rm -rf %{buildroot}
  116. %files
  117. %defattr(-,root,root)
  118. %{_infodir}/mew.info*
  119. %{_infodir}/mew.ja.info*
  120. %{_datadir}/emacs/site-lisp/%{origname}/
  121. %{emacsen_pkgdir}/install/%{origname}
  122. %{emacsen_pkgdir}/remove/%{origname}
  123. %{_datadir}/pixmaps/%{origname}
  124. %files -n mew-common
  125. %defattr(-,root,root)
  126. %doc 00api 00changes* 00copyright* 00diff 00readme
  127. %doc dot.emacs dot.mew dot.theme vine.dot.mew
  128. %{_bindir}/*
  129. %{_mandir}/man1/*
  130. %changelog
  131. * Tue May 08 2012 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.5-1
  132. - new upstream release
  133. * Tue Mar 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 6.4-1
  134. - new upstream release
  135. - apply new vine-default
  136. - update mew-init.el, vine-default-mew.el
  137. - use %%emacsen_pkgdir macro
  138. - encode vine.dot.new to UTF-8
  139. * Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.3-2
  140. - rebuild with rpm-4.8.1
  141. - change pixmap directory
  142. - fix Patch11
  143. * Mon Dec 21 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.3-1
  144. - new upstream release
  145. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-3
  146. - fixed mew-init.el
  147. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-2
  148. - added mew-init.el, vine-default-mew.el
  149. - updated mew-install.sh, mew-remove.sh for vine-default-mew.el
  150. * Fri Jan 16 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.2-1
  151. - new upstream release
  152. * Sun Jun 15 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-1
  153. - applied new versioning policy
  154. * Tue Jun 10 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-0vl1
  155. - new upstream release
  156. * Thu Aug 30 2007 Shu KONNO <owa@bg.wakwak.com> 5.2-0vl3
  157. - added %%define _lib lib (for x86_64 support)
  158. * Mon Mar 05 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl2
  159. - added support X-Spam-Flag header in vine.dot.mew
  160. * Tue Jan 23 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl1
  161. - new upstream release
  162. * Mon Nov 26 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.1-0vl1
  163. - new upstream release
  164. - modified vine.dot.mew for Mew-5.1 feature support
  165. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl3
  166. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  167. * Tue Jul 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl2
  168. - changed Group to Applications/Editors/EmacsLisp
  169. - changed common package's Group to Applications/Internet
  170. * Mon Feb 14 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.2-0vl1
  171. - source update
  172. * Mon Oct 18 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.1-0vl1
  173. - source update
  174. * Mon Jul 28 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.3-0vl1
  175. - source update
  176. * Thu Mar 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2-0vl1
  177. - source update
  178. - update vine.dot.mew
  179. Obsoleting the following variables:
  180. mew-noreplyto-to-list
  181. mew-noreplyto-cc-list
  182. mew-replyto-to-list
  183. mew-replyto-cc-list
  184. mew-fromme-to-list
  185. mew-fromme-cc-list
  186. And defining the following variables:
  187. mew-reply-all-alist
  188. mew-reply-sender-alist
  189. mew-reply-fromme-alist
  190. * Sat Jan 11 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl3
  191. - added vine.dot.mew(Source3)
  192. * Wed Dec 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl2
  193. - source update
  194. * Tue Dec 03 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl1
  195. - update to mew-3.1
  196. * Thu Nov 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.2
  197. - test package: update to mew-3.1rc2
  198. * Fri Nov 01 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.1
  199. - test package: update to mew-3.1rc1
  200. * Mon Mar 18 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2-0vl4
  201. - changed License to distributable (not GPL2)
  202. * Mon Mar 18 2002 Hironobu MORIGUCHI <moriguti@luna.email.ne.jp> 2.2-0vl3
  203. - incm and man pages are included in common subpackage
  204. * Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 2.2-0vl2
  205. - corrected Group for common subpackage
  206. * Mon Feb 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2-0vl1
  207. - update to mew-2.2
  208. * Thu Feb 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.99.4-0vl1
  209. - update to mew-2.2rc4
  210. * Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2..99.2-0vl1
  211. - update to mew-2.2rc2
  212. * Sun Dec 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl3
  213. - mew-el -> mew
  214. - added Patch11 to set default icon directory for Vine
  215. * Wed Dec 12 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl2
  216. - added Obsoletes: mew-xemacs, mew-xemacs-extra
  217. - install-info gzipped info files :)
  218. * Thu Nov 01 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1-0vl1
  219. - update 2.1
  220. * Sat Oct 6 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0-0vl5
  221. - change package name ( mew -> mew-el)
  222. - apply emacsenc-oomon
  223. * Thu Sep 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
  224. - Oops, forgot to add %%defattr for mew-common. Fixed.
  225. * Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
  226. - split mew-common, obsoletes mew-xemacs-extra
  227. * Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
  228. - 2.0-0vl2: eliminate executable bit in %%doc and bin files install 755
  229. - install info files into %%{_infodir}
  230. * Sun Aug 20 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
  231. - 2.0-0vl1
  232. - update
  233. * Tue Oct 24 2000 Tomoya TAKA <tomoya@olive.plala.or.jp>
  234. - 1.94.2-3
  235. - fixed %files section to handle compressed info pages
  236. * Wed Jun 7 2000 Toru Sagami <czs14350@nifty.ne.jp>
  237. - fix description: mess up with mule/emacs/xemacs...
  238. - added BuildRequires and Conflicts
  239. * Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
  240. - updated 1.94.2
  241. * Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
  242. - added PreReq: /sbin/install-info
  243. - attrib +x for /usr/bin/uumerge
  244. - CFLAGS="$RPM_OPT_FLAGS"
  245. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  246. - 1.94.1-2
  247. - changed destination to /usr/share/emacs/site-lisp/mew
  248. * Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  249. - 1.94.1-1
  250. - updated in sync with 1.94.1 release
  251. - fixed %post and %preun section
  252. - Obsoletes: mew now changed to Obsoletes: mew-mule
  253. * Fri Oct 8 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
  254. - fixed info path & install info
  255. - fixed '%description'
  256. * Sat Oct 2 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
  257. - removed extra packages
  258. - fixed char-set "euc" of the spec file.
  259. - slight modifications for Vine-1.9
  260. * Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  261. - 1.94-3
  262. - package name changed from mew-emacs to mew
  263. - make info, make jinfo now processed even under emacs
  264. * Thu Sep 16 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  265. - Released as version "1.94-2".
  266. Changed from "mew-emacs 1.94-1".
  267. - Deleted "NoSource: 0", the definition part of data.
  268. - Revised some, the definition part of data.
  269. - Revised some, part of "%post, %postun".
  270. - Changerd "%postun" => "%preun".
  271. * Mon Sep 6 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  272. - First release.