self-build-broadcom-wl-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149
  1. %define pkgname broadcom-wl
  2. %define name self-build-%{pkgname}
  3. %define oname hybrid-portsrc
  4. %define over %(echo %{version} | tr . _)
  5. %ifarch %{ix86}
  6. %define source0path http://www.broadcom.com/docs/linux_sta/hybrid-v35-nodebug-pcoem-%{over}.tar.gz
  7. %endif
  8. %ifarch x86_64
  9. %define source0path http://www.broadcom.com/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-%{over}.tar.gz
  10. %endif
  11. Summary: Package to automatically build %{pkgname} rpm package
  12. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  13. Name: %{name}
  14. Version: 6.30.223.248
  15. Release: 1%{?_dist_release}
  16. Source0: %{pkgname}.spec
  17. Source1: blacklist-broadcom.conf
  18. License: Freeware and GPLv2 with exception
  19. Group: Restricted Software
  20. Requires(pre): self-build-setup >= 0.7-1
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. ExclusiveArch: %{ix86} x86_64
  23. %description
  24. Proprietary hybrid driver for Broadcom wireless adapters.
  25. If you install this package, it automaticaly downloads source
  26. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  27. And the created rpm packages are automatically installed
  28. if installation is executed by apt-get command or synaptic
  29. package manager.
  30. [Note]
  31. This package requires many other packages to compile
  32. targetsoftware. So it consume more disk space than usual.
  33. Also installation takes logner time because of compilation.
  34. (This will take a few minutes to quarter or half of an hour,
  35. depends on building environment)
  36. [About self-build package]
  37. For some kind of software, distributing of binary package
  38. may viorate the patent or law. Therefore we chose self-build
  39. packge, create binary package on your machine, for such kind
  40. of softwares instead of distributing binary package.
  41. Please obey the national law when you use the created binary
  42. packages. And if you want to use the softwares using patented
  43. thechnology, it may be required to get a permission, make an
  44. agreement or purchas a license. Please consider it with your
  45. purpose or way of use and take appropriate action.
  46. %description -l ja
  47. Broadcom ワイヤレスアダプタ用のプロプライエタリドライバです。
  48. このパッケージをインストールすると、自動的にソースコードを
  49. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  50. の rpm パッケージを作成します。
  51. また apt-get コマンドや synaptic パッケージマネージャから実行
  52. した場合は、作成された rpm パッケージのインストールも自動的に
  53. 行います。
  54. [注意]
  55. コンパイルに必要な多くの関連パッケージを要求するので通常より
  56. ディスクの領域を多く消費します。
  57. またインストール時にコンパイルを行うため、通常より時間がかか
  58. る場合があります。(環境にもよりますが数分から数十分程度)
  59. [self-build パッケージについて]
  60. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  61. 違反する可能性があるものがあります。その為、このような問題が
  62. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  63. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  64. ジという方法を採っています。
  65. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  66. アのライセンス、および利用する国の各種法令に従ってください。
  67. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  68. センスの購入などが必要となる場合がありますので、利用する目的
  69. や形態に応じて各自で判断し適切な対応を取ってください。
  70. %install
  71. rm -rf %{buildroot}
  72. install -d %{buildroot}%{_datadir}/%{name}
  73. install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/%{name}
  74. #install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/%{name}
  75. sed -e 's|##VERSION##|%{version}|g' -e 's|##RELEASE##|%{release}|g' \
  76. %{SOURCE0} > %{buildroot}%{_datadir}/%{name}/%{pkgname}.spec
  77. %clean
  78. rm -rf %{buildroot}
  79. %posttrans
  80. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}.spec "%{source0path}"
  81. /usr/lib/rpm/pre-allocate-rpm.sh dkms-%{pkgname}-%{version}-%{release}
  82. %files
  83. %defattr(-,root,root)
  84. %{_datadir}/%{name}/*
  85. %changelog
  86. * Wed Nov 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.30.223.248-1
  87. - new upstream release
  88. - dropped SOURCE2
  89. - updated dmks.conf
  90. * Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.100.82.112-1
  91. - new upstream release.
  92. - dropped an old patch.
  93. - added SOURCE2 to compile for kernel-3.2.x.
  94. * Tue Oct 4 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-3
  95. - update SOURCE1 (see: http://www.broadcom.com/docs/linux_sta/bcma.txt)
  96. * Sun Aug 14 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-2
  97. - add a patch to fix build failure on linux > 2.6.37
  98. * Sun Jan 01 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.100.82.38-1
  99. - new upstream release
  100. * Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-2
  101. - add Source2 to fix build failure on kernel >= 2.6.35
  102. (https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/590924)
  103. * Tue Aug 17 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.60.48.36-1
  104. - new upstream release
  105. * Wed Sep 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9.3-1
  106. - new upstream release
  107. * Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-3
  108. - fix to ensure Source0 has correct version/release numbers
  109. * Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-2
  110. - add ExclusiveArch
  111. * Tue May 05 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.10.91.9-1
  112. - initial build for Vine Linux