cfitsio-vl.spec 8.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260
  1. Name: cfitsio
  2. Version: 3.240
  3. Release: 2%{?_dist_release}
  4. Summary: Library for manipulating FITS data files
  5. Group: System Environment/Libraries
  6. License: GPLv2+
  7. URL: http://heasarc.gsfc.nasa.gov/docs/software/fitsio/fitsio.html
  8. Source0: ftp://heasarc.gsfc.nasa.gov/software/fitsio/c/cfitsio3240.tar.gz
  9. Patch: cfitsio.patch
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: gcc-gfortran
  12. Requires(post): /sbin/ldconfig
  13. Requires(postun): /sbin/ldconfig
  14. %description
  15. CFITSIO is a library of C and FORTRAN subroutines for reading and writing
  16. data files in FITS (Flexible Image Transport System) data format. CFITSIO
  17. simplifies the task of writing software that deals with FITS files by
  18. providing an easy to use set of high-level routines that insulate the
  19. programmer from the internal complexities of the FITS file format. At the
  20. same time, CFITSIO provides many advanced features that have made it the
  21. most widely used FITS file programming interface in the astronomical
  22. community.
  23. %package devel
  24. Group: Development/Libraries
  25. Summary: Headers required when building programs against cfitsio
  26. Requires: %{name} = %{version}-%{release}
  27. Requires: pkgconfig
  28. %description devel
  29. Headers required when building a program against the cfitsio library.
  30. %package static
  31. Group: Development/Libraries
  32. Summary: Static cfitsio library
  33. %description static
  34. Static cfitsio library; avoid use if possible.
  35. %package docs
  36. Summary: Documentation for cfitsio
  37. Group: Development/Libraries
  38. %description docs
  39. Stand-alone documentation for cfitsio.
  40. %prep
  41. %setup -q -n cfitsio
  42. %patch -p1
  43. %build
  44. FC=f95
  45. export FC
  46. export CC=gcc # fixes -O*, -g
  47. %configure
  48. make shared %{?_smp_mflags}
  49. unset FC
  50. # Manually fix pkgconfig .pc file (BZ 436539)
  51. sed 's|${exec_prefix}/lib|${exec_prefix}/%{_lib}|' cfitsio.pc >cfitsio.pc.new
  52. sed 's|${prefix}/include|${prefix}/include/%{name}|' cfitsio.pc.new >cfitsio.pc
  53. rm -f cfitsio.pc.new
  54. # Manually correct pkgconfig .pc file version
  55. sed 's|3.006|%{version}|' cfitsio.pc >cfitsio.pc.new
  56. mv cfitsio.pc.new cfitsio.pc
  57. %check
  58. make testprog
  59. LD_LIBRARY_PATH=. ./testprog > testprog.lis
  60. cmp -s testprog.lis testprog.out
  61. cmp -s testprog.fit testprog.std
  62. %install
  63. rm -rf %{buildroot}
  64. mkdir -p %{buildroot}
  65. mkdir -p %{buildroot}%{_libdir}
  66. mkdir -p %{buildroot}%{_includedir}/%{name}
  67. make LIBDIR=%{_lib} INCLUDEDIR=include/%{name} CFITSIO_LIB=%{buildroot}%{_libdir} \
  68. CFITSIO_INCLUDE=%{buildroot}%{_includedir}/%{name} install
  69. pushd %{buildroot}%{_libdir}
  70. ln -s libcfitsio.so.0 libcfitsio.so
  71. popd
  72. %clean
  73. rm -rf %{buildroot}
  74. %post -p /sbin/ldconfig
  75. %postun -p /sbin/ldconfig
  76. %files
  77. %defattr(-,root,root,-)
  78. %doc README License.txt changes.txt
  79. %{_libdir}/libcfitsio.so.*
  80. %files devel
  81. %defattr(-,root,root,-)
  82. %{_includedir}/%{name}
  83. %{_libdir}/libcfitsio.so
  84. %{_libdir}/pkgconfig/cfitsio.pc
  85. %files static
  86. %defattr(-,root,root,-)
  87. %{_libdir}/libcfitsio.a
  88. %files docs
  89. %defattr(-,root,root,-)
  90. %doc fitsio.doc fitsio.ps cfitsio.doc cfitsio.ps
  91. %changelog
  92. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 3.240-2
  93. - rebuilt with rpm-4.8.1 for pkg-config
  94. * Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.240-1
  95. - new upstream release
  96. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.140-3
  97. - Initial build for Vine Linux
  98. * Fri Jul 24 2009 Matthew Truch <matt at truch.net> - 3.140-2
  99. - Bump to include proper tarball.
  100. * Tue Jul 21 2009 Matthew Truch <matt at truch.net> - 3.140-1
  101. - Update to upstream 3.140 release.
  102. - Bump for mass rebuild.
  103. * Wed Jun 17 2009 Matthew Truch <matt at truch.net> - 3.130-5
  104. - Separate -docs noarch subpackage as per BZ 492438.
  105. - Explicitly set file attributes correctly.
  106. * Tue Mar 10 2009 Matthew Truch <matt at truch.net> - 3.130-4
  107. - Set correct version in pkgconfig .pc file.
  108. * Sun Feb 22 2009 Matthew Truch <matt at truch.net> - 3.130-3
  109. - Re-check testprogram output.
  110. - Build for koji, rpm, gcc upgrade.
  111. * Thu Feb 5 2009 Matthew Truch <matt at truch.net> - 3.130-2
  112. - Fix source file naming typo.
  113. * Wed Feb 4 2009 Matthew Truch <matt at truch.net> - 3.130-1
  114. - Update to 3.130 upstream.
  115. * Sat Sep 20 2008 Matthew Truch <matt at truch.net> - 3.100-2
  116. - Test library with included test-suite.
  117. * Fri Sep 19 2008 Matthew Truch <matt at truch.net> - 3.100-1
  118. - Update to 3.100 upstream.
  119. Includes bugfixes and new compression scheme.
  120. * Fri Mar 7 2008 Matthew Truch <matt at truch.net> - 3.060-3
  121. - Properly indicated include and lib directories in .pc file
  122. (BZ 436539)
  123. - Fix typo in -static descrition.
  124. * Mon Feb 11 2008 Matthew Truch <matt at truch.net> - 3.060-2
  125. - Bump release for rebuild.
  126. * Fri Nov 9 2007 Matthew Truch <matt at truch.net> - 3.060-1
  127. - Update to 3.060 bugfix release.
  128. - Add static package (BZ 372801)
  129. * Tue Aug 21 2007 Matthew Truch <matt at truch.net> - 3.040-3
  130. - Bump release for rebuild (build-id etc.)
  131. * Thu Aug 2 2007 Matthew Truch <matt at truch.net> - 3.040-2
  132. - Update License tag
  133. * Mon Jul 9 2007 Matthew Truch <matt at truch.net> - 3.040-1
  134. - Upgrade to version 3.040 of cfitsio.
  135. * Fri Feb 16 2007 Matthew Truch <matt at truch.net> - 3.030-2
  136. - Require pkgconfig for -devel.
  137. - export CC=gcc so we don't clobber $RPM_OPT_FLAGS, thereby
  138. ruining any -debuginfo packages.
  139. See RedHat Bugzilla 229041.
  140. * Fri Jan 5 2007 Matthew Truch <matt at truch.net> - 3.030-1
  141. - Upgrade to version 3.020 of cfitsio.
  142. * Fri Dec 8 2006 Matthew Truch <matt at truch.net> - 3.020-3
  143. - Commit correct patch to configure and Makefiles.
  144. * Fri Dec 8 2006 Matthew Truch <matt at truch.net> - 3.020-2
  145. - Modify spec file to install to correct directories.
  146. - Package cfitsio.pc file in -devel package.
  147. * Wed Dec 6 2006 Matthew Truch <matt at truch.net> - 3.020-1
  148. - Upgrade to revision 3.020 of cfitsio.
  149. * Mon Aug 28 2006 Matthew Truch <matt at truch.net> - 3.006-6
  150. - Bump release for rebuild in prep. for FC6.
  151. * Thu Mar 30 2006 Matthew Truch <matt at truch.net> - 3.006-5
  152. - Include defattr() for devel package as well - bug 187366
  153. * Sun Mar 19 2006 Matthew Truch <matt at truch.net> - 3.006-4
  154. - Don't use macro {buildroot} in build, only in install as per
  155. appended comments to Bugzilla bug 172042
  156. * Fri Mar 10 2006 Matthew Truch <matt at truch.net> - 3.006-3
  157. - Point to f95 instead of g95 as per bugzilla bug 185107
  158. * Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.006-2
  159. - Fix spelling typo in name of License.txt file.
  160. * Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.006-1
  161. - Use new 3.006 fully official stable (non-beta) upstream package.
  162. * Tue Feb 28 2006 Matthew Truch <matt at truch.net> - 3.005-0.2.beta
  163. - Bump release for FC5 extras rebuild.
  164. * Fri Dec 23 2005 Matthew Truch <matt at truch.net> - 3.005-0.1.beta
  165. - Update to 3.005beta release.
  166. * Mon Nov 14 2005 Matthew Truch <matt at truch.net> - 3.004-0.12.b
  167. - Put in proper URL and Source addresses.
  168. - Sync up spec files.
  169. * Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.11.b
  170. - Clean up unused code in spec file.
  171. * Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.10.b
  172. - Set environment variables correctly.
  173. - Include patch so Makefile will put things where they belong.
  174. * Sun Nov 13 2005 Matthew Truch <matt at truch.net> - 3.004-0.9.b
  175. - Set libdir and includedir correctly for build process.
  176. * Sat Nov 12 2005 Matthew Truch <matt at truch.net> - 3.004-0.8.b
  177. - unset FC once we are done with the build
  178. * Sat Nov 12 2005 Ed Hill <ed@eh3.com> - 3.004-0.7.b
  179. - shared libs and small cleanups
  180. * Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.6.b
  181. - Own include directory created by the devel package.
  182. * Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.5.b
  183. - Shorten summary.
  184. - Improve specfile post and postun syntax.
  185. - Install headers in cfitsio include subdir.
  186. - Include more documentation provided in tarball.
  187. * Sun Nov 06 2005 Matthew Truch <matt at truch.net> - 3.004-0.4.b
  188. - Require cfitsio for cfitsio-devel
  189. * Sat Nov 05 2005 Matthew Truch <matt at truch.net> - 3.004-0.3.b
  190. - Use proper virgin tarball from upstream.
  191. * Sun Oct 30 2005 Matthew Truch <matt at truch.net> - 3.004-0.2.b
  192. - Include gcc-gfortran build requirment and make sure it gets used.
  193. - Use macros instead of hard coded paths.
  194. - Include home page in description
  195. * Sat Oct 29 2005 Matthew Truch <matt at truch.net> - 3.004-0.1.b
  196. - Initial spec file for Fedora Extras.