avant-window-navigator-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236
  1. # -*- coding: utf-8-unix -*-
  2. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  3. Name: avant-window-navigator
  4. Version: 0.2.6
  5. Release: 6%{?_dist_release}
  6. Summary: Fully customisable dock-like window navigator for GNOME
  7. Summary(ja): Gnome + Compiz 向けの Dock 機能を兼ね備えたウィンドウナビゲータ
  8. Group: User Interface/Desktops
  9. #libawn is LGPLv2+, rest is GPLv2+
  10. License: GPLv2+ and LGPLv2+
  11. URL: https://launchpad.net/awn
  12. Source0: https://launchpad.net/awn/0.2/0.2/+download/%{name}-%{version}.tar.gz
  13. #fixes schemas file
  14. Patch0: avant-window-navigator-schemas.patch
  15. #fixes issue where awn only appears on one desktop, #469032
  16. Patch1: avant-window-navigator-0.2.6-sticky.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. BuildRequires: libwnck-devel
  19. BuildRequires: dbus-glib-devel
  20. BuildRequires: gnome-common
  21. BuildRequires: pygtk2-devel
  22. BuildRequires: GConf2-devel
  23. BuildRequires: startup-notification-devel
  24. BuildRequires: gnome-desktop-devel >= 2.26.0
  25. BuildRequires: libgnome-devel
  26. BuildRequires: gnome-vfs2-devel
  27. BuildRequires: gnome-python
  28. BuildRequires: libXdamage-devel libXcomposite-devel libXres-devel
  29. BuildRequires: gettext, intltool
  30. BuildRequires: desktop-file-utils
  31. BuildRequires: pyxdg
  32. BuildRequires: pycairo-devel
  33. Requires: gnome-python-gnomedesktop, pyxdg
  34. #Requires: gnome-python-gconf
  35. Requires(pre): GConf2
  36. Requires(post): GConf2
  37. Requires(preun): GConf2
  38. %description
  39. Avant Window Navgator (Awn) is a dock-like bar which sits at the bottom of
  40. the screen (in all its composited-goodness) tracking open windows.
  41. %description -l ja
  42. Avant Window Navgator (Awn) は、
  43. Gnome + Compiz 向けの Dock 機能を兼ね備えたウィンドウナビゲータバーです。
  44. 起動しているアプリケーションウィンドウを追跡し、
  45. 画面下部に並べます。
  46. %package devel
  47. Summary: Fully customisable dock-like window navigator for GNOME
  48. Group: Development/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. %description devel
  51. This package includes all header files and library of AWN for development.
  52. %prep
  53. %setup -q
  54. %patch0 -p1
  55. %patch1 -p0
  56. #fix permissions
  57. chmod 0644 $RPM_BUILD_DIR/%{name}-%{version}/src/xutils.h
  58. chmod 0644 $RPM_BUILD_DIR/%{name}-%{version}/src/xutils.c
  59. chmod 0644 $RPM_BUILD_DIR/%{name}-%{version}/src/inlinepixbufs.h
  60. %build
  61. %configure \
  62. --disable-static \
  63. --disable-schemas \
  64. ;
  65. #make %{?_smp_mflags}
  66. %__make
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. export GCONF_DISABLE_MAKEFILE_ _INSTALL=1
  70. make install DESTDIR=$RPM_BUILD_ROOT
  71. find ${RPM_BUILD_ROOT} -name '*.la' | xargs rm
  72. %find_lang %{name}
  73. desktop-file-install --vendor vine --delete-original \
  74. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  75. --remove-category Application \
  76. $RPM_BUILD_ROOT%{_datadir}/applications/avant-window-navigator.desktop
  77. desktop-file-install --vendor vine --delete-original \
  78. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  79. --remove-category Application \
  80. $RPM_BUILD_ROOT%{_datadir}/applications/awn-manager.desktop
  81. %pre
  82. if [ "$1" -gt 1 ]; then
  83. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  84. gconftool-2 --makefile-uninstall-rule \
  85. %{_sysconfdir}/gconf/schemas/awn.schemas >/dev/null || :
  86. fi
  87. %post
  88. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  89. gconftool-2 --makefile-install-rule \
  90. %{_sysconfdir}/gconf/schemas/awn.schemas > /dev/null || :
  91. /sbin/ldconfig
  92. touch --no-create %{_datadir}/icons/hicolor
  93. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  94. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  95. fi
  96. %preun
  97. if [ "$1" -eq 0 ]; then
  98. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  99. gconftool-2 --makefile-uninstall-rule \
  100. %{_sysconfdir}/gconf/schemas/awn.schemas > /dev/null || :
  101. fi
  102. %postun
  103. /sbin/ldconfig
  104. touch --no-create %{_datadir}/icons/hicolor
  105. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  106. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  107. fi
  108. %clean
  109. rm -rf $RPM_BUILD_ROOT
  110. %files -f %{name}.lang
  111. %defattr(-,root,root,-)
  112. %doc AUTHORS COPYING COPYING.LIB ChangeLog README
  113. %doc %{_datadir}/gtk-doc/html/libawn
  114. %{_bindir}/*
  115. %{_libdir}/libawn*.so.*
  116. %{_libdir}/awn
  117. %config(noreplace) %{_sysconfdir}/gconf/schemas/awn.schemas
  118. %{_datadir}/applications/*
  119. %{_datadir}/avant-window-navigator
  120. %{_datadir}/icons/hicolor/*/apps/awn-manager*
  121. %{python_sitelib}/awn
  122. %files devel
  123. %defattr(-,root,root,-)
  124. %{_includedir}/libawn
  125. %{_libdir}/libawn*.so
  126. %{_libdir}/pkgconfig/*.pc
  127. %changelog
  128. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.6-6
  129. - rebuilt with rpm-4.8.1 for pkg-config
  130. * Mon Apr 19 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.6-5
  131. - rebuilt with python-2.6
  132. * Mon Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 0.2.6-4
  133. - added Summary(ja) and %%description -l ja
  134. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.6-3
  135. - rebuild with gnome-desktop-2.26.0
  136. * Mon Feb 16 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.2.6-2
  137. - corrected *.desktop
  138. * Mon Feb 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.2.6-1
  139. - initial build
  140. * Sat Dec 20 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-14
  141. - Add missing libXres buildrequires
  142. * Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.6-13
  143. - Rebuild for Python 2.6
  144. * Thu Dec 04 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-12
  145. - Add patch to fix metacity sticky bug, #469032
  146. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.6-11
  147. - Rebuild for Python 2.6
  148. * Fri Nov 28 2008 Caol叩n McNamara <caolanm@redhat.com - 0.2.6-10
  149. - rebuild for dependencies
  150. * Sun Aug 03 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-9
  151. - Add patch to fix empty string in schemas file. #457683
  152. * Sat Mar 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-8
  153. - Add missing pyxdg requires
  154. * Tue Mar 20 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-6
  155. - Incorparate the python package in main, #438411
  156. * Mon Mar 17 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-3
  157. - Fix python package
  158. * Mon Mar 17 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-2
  159. - Add missing pyxdg build depenency
  160. * Mon Mar 17 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.2.6-1
  161. - New release
  162. - Re-enable gconf scriplets
  163. - Add missing scriplets
  164. - Update license
  165. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.2.1-3
  166. - Autorebuild for GCC 4.3
  167. * Thu Nov 04 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.2.1-2
  168. - New Release
  169. * Wed Oct 21 2007 Huang Peng <phuang@redhat.com> - 0.2-1
  170. - Update to 0.2
  171. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.1.1-4
  172. - Rebuild for selinux ppc32 issue.
  173. * Tue Jun 05 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.1.1-3
  174. - Own %%{_datadir}/avant-window-navigator
  175. * Tue Jun 05 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.1.1-2
  176. - Add missing BRs
  177. - Fix gconf scriplets
  178. * Thu May 01 2007 Sindre Pedersen Bj淡rdal <foolish[AT]guezz.net> - 0.1.1-1
  179. - Initial build