aqbanking-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357
  1. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.3)
  2. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
  3. %define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/lib)
  4. %define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/include)
  5. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  6. Name: aqbanking
  7. Summary: A library for online banking functions and financial data import/export
  8. Version: 4.2.4
  9. Release: 2%{?_dist_release}
  10. Group: System Environment/Libraries
  11. License: GPLv2+
  12. URL: http://www.aquamaniac.de/aqbanking/
  13. Source: http://download.sourceforge.net/aqbanking/%{name}-%{version}.tar.gz
  14. Patch2: aqbanking-4.2.4-pkgconfig.patch
  15. Patch3: aqbanking-2.1.0-conflict.patch
  16. # upstreamable, omit inadvertant(?) qt3 linkage q4banking -- Rex
  17. Patch4: aqbanking-4.2.4-q4banking_remove_qt3.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. # qbanking
  20. BuildRequires: qt-devel
  21. BuildRequires: qt4-devel
  22. BuildRequires: gwenhywfar-devel >= 3.10.0
  23. BuildRequires: gmp-devel
  24. BuildRequires: gettext
  25. BuildRequires: libtool
  26. Requires(post): /sbin/ldconfig
  27. Requires(postun): /sbin/ldconfig
  28. Obsoletes: aqhbci <= 1.0.3
  29. Obsoletes: g2banking < 3.7.2-1
  30. Obsoletes: python-aqbanking
  31. %description
  32. The intention of AqBanking is to provide a middle layer between the
  33. program and the various Online Banking libraries (e.g. AqHBCI). The
  34. first backend which is already supported is AqHBCI, a library which
  35. implements a client for the German HBCI (Home Banking Computer
  36. Interface) protocol. Additionally, Aqbanking provides various plugins
  37. to simplify import and export of financial data. Currently there are
  38. import plugins for the following formats: DTAUS (German financial
  39. format), SWIFT (MT940 and MT942).
  40. %package devel
  41. Summary: Development headers for Aqbanking
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: pkgconfig
  45. # for %{_datadir}/aclocal
  46. Requires: automake
  47. Obsoletes: aqhbci-devel <= 1.0.3
  48. Obsoletes: g2banking-devel < %{version}
  49. %description devel
  50. This package contains aqbanking-config and header files for writing and
  51. compiling programs using Aqbanking.
  52. %package -n qbanking
  53. Summary: Qt3 bindings for Aqbanking
  54. Group: System Environment/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. Requires(post): /sbin/ldconfig
  57. Requires(postun): /sbin/ldconfig
  58. Obsoletes: aqhbci-qt-tools <= 1.0.3
  59. Obsoletes: kbanking < %{version}
  60. %description -n qbanking
  61. This package contains the qbanking KDE bindings for the Aqbanking
  62. online banking library.
  63. %package -n qbanking-devel
  64. Summary: Development headers for qbanking
  65. Group: Development/Libraries
  66. Requires: %{name}-devel = %{version}-%{release}
  67. Requires: qbanking = %{version}-%{release}
  68. Requires: pkgconfig
  69. Requires: qt-devel
  70. Obsoletes: kbanking-devel < 3.7.2-1
  71. %description -n qbanking-devel
  72. This package contains qbanking-config and header files for writing and
  73. compiling programs using the qbanking bindings for Aqbanking.
  74. %package -n q4banking
  75. Summary: Qt4 bindings for Aqbanking
  76. Group: System Environment/Libraries
  77. Requires: %{name} = %{version}-%{release}
  78. Requires: qt4 >= %{_qt4_version}
  79. %description -n q4banking
  80. %{summary}.
  81. %package -n q4banking-devel
  82. Summary: Development files for q4banking
  83. Group: Development/Libraries
  84. Requires: %{name}-devel = %{version}-%{release}
  85. Requires: q4banking = %{version}-%{release}
  86. Requires: qt4-devel
  87. %description -n q4banking-devel
  88. %{summary}.
  89. %package -n python-%{name}
  90. Summary: Python bindings for Aqbanking
  91. Group: Development/Libraries
  92. Requires: %{name} = %{version}-%{release}
  93. %description -n python-%{name}
  94. This package contains python bindings for Aqbanking.
  95. %prep
  96. %setup -q
  97. %patch2 -p1 -b .pkgconfig
  98. %patch3 -p1 -b .conflict
  99. %patch4 -p1 -b .q4banking_remove_qt3
  100. # hack to nuke rpaths, slighly less ugly than using overriding LIBTOOL below
  101. %if "%{_libdir}" != "/usr/lib"
  102. sed -i -e 's|"/lib /usr/lib|"/%{_lib} %{_libdir}|' configure
  103. %endif
  104. %build
  105. [ -z "$QTDIR" ] && . /etc/profile.d/qt.sh
  106. %configure \
  107. --disable-static \
  108. --with-frontends="qbanking q4banking" \
  109. --enable-qt4 \
  110. --with-qt4-includes=%{_qt4_headerdir} \
  111. --with-qt4-libs=%{_qt4_libdir} \
  112. --with-qt4-moc=%{_qt4_prefix}/bin/moc \
  113. --with-qt4-uic=%{_qt4_prefix}/bin/uic
  114. # not smp_mflags safe
  115. # override LIBTOOL to quash rpath
  116. make
  117. #make LIBTOOL=/usr/bin/libtool
  118. %install
  119. rm -rf $RPM_BUILD_ROOT
  120. make DESTDIR=$RPM_BUILD_ROOT install
  121. #make DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool install
  122. find $RPM_BUILD_ROOT -name *.la -exec rm -f {} \;
  123. find $RPM_BUILD_ROOT -name *.a -exec rm -f {} \;
  124. cd tutorials
  125. make clean
  126. rm -rf .deps
  127. rm -f Makefile*
  128. cd ..
  129. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
  130. mv $RPM_BUILD_ROOT/%{_datadir}/doc/{aqbanking,aqhbci} $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
  131. cp AUTHORS README COPYING ChangeLog NEWS $RPM_BUILD_ROOT/%{_datadir}/doc/%{name}-%{version}
  132. %find_lang %{name}
  133. # Fix multilib errors. (#602879)
  134. sed -i 's|** Created:.*|** Created |g' $RPM_BUILD_ROOT/%{_includedir}/q4banking/*.ui.h
  135. %clean
  136. rm -rf $RPM_BUILD_ROOT
  137. %post -p /sbin/ldconfig
  138. %postun -p /sbin/ldconfig
  139. %post -n qbanking -p /sbin/ldconfig
  140. %postun -n qbanking -p /sbin/ldconfig
  141. %post -n q4banking -p /sbin/ldconfig
  142. %postun -n q4banking -p /sbin/ldconfig
  143. %files -f %{name}.lang
  144. %defattr(-,root,root)
  145. %doc %{_datadir}/doc/%{name}-%{version}
  146. %{_libdir}/libaq*.so.*
  147. %dir %{_libdir}/aqbanking
  148. %dir %{_libdir}/aqbanking/plugins/
  149. %dir %{_libdir}/aqbanking/plugins/*/
  150. %dir %{_libdir}/aqbanking/plugins/*/debugger/
  151. %dir %{_libdir}/aqbanking/plugins/*/debugger/*/
  152. %dir %{_libdir}/aqbanking/plugins/*/frontends/
  153. %{_libdir}/aqbanking/plugins/*/bankinfo/
  154. %{_libdir}/aqbanking/plugins/*/imexporters/
  155. %{_libdir}/aqbanking/plugins/*/providers/
  156. %{_libdir}/gwenhywfar/plugins/*/dbio/*
  157. %dir %{_datadir}/aqbanking
  158. %dir %{_datadir}/aqbanking/frontends
  159. %{_datadir}/aqbanking/backends/
  160. %{_datadir}/aqbanking/bankinfo/
  161. %{_datadir}/aqbanking/imexporters/
  162. %{_bindir}/aqbanking-cli
  163. %{_bindir}/aqhbci-tool4
  164. %files devel
  165. %defattr(-,root,root)
  166. %doc doc/0[12]* tutorials
  167. %{_bindir}/hbcixml3
  168. %{_bindir}/aqbanking-config
  169. %{_libdir}/libaq*.so
  170. %{_includedir}/aq*/
  171. %{_libdir}/pkgconfig/aqbanking.pc
  172. %{_datadir}/aclocal/aqbanking.m4
  173. %files -n qbanking
  174. %defattr(-,root,root)
  175. %{_bindir}/qb-help8
  176. %{_libdir}/libqbanking.so.*
  177. %{_libdir}/aqbanking/plugins/*/debugger/aqhbci/aqhbci-qt3-debug
  178. %{_libdir}/aqbanking/plugins/*/debugger/aqhbci/qt_debug.xml
  179. %{_libdir}/aqbanking/plugins/*/frontends/qbanking
  180. %{_libdir}/aqbanking/plugins/*/wizards/qt3*
  181. %{_datadir}/aqbanking/i18n
  182. %{_datadir}/aqbanking/frontends/qbanking/
  183. %files -n qbanking-devel
  184. %defattr(-,root,root)
  185. %{_includedir}/qbanking/
  186. %{_libdir}/libqbanking.so
  187. %files -n q4banking
  188. %defattr(-,root,root)
  189. %{_bindir}/q4b-help1
  190. %{_libdir}/aqbanking/plugins/*/debugger/aqhbci/aqhbci-qt4-debug
  191. %{_libdir}/aqbanking/plugins/*/debugger/aqhbci/qt4_debug.xml
  192. %{_libdir}/aqbanking/plugins/*/frontends/q4banking
  193. %{_libdir}/aqbanking/plugins/*/wizards/qt4*
  194. %{_datadir}/aqbanking/frontends/q4banking/
  195. %{_libdir}/libq4banking.so.1*
  196. %files -n q4banking-devel
  197. %defattr(-,root,root)
  198. %{_includedir}/q4banking/
  199. %{_libdir}/libq4banking.so
  200. #%files -n python-%{name}
  201. #%defattr(-,root,root)
  202. #%{python_sitelib}/%{name}
  203. %changelog
  204. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 4.2.4-2
  205. - rebuilt with rpm-4.8.1 for pkg-config
  206. * Mon Sep 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2.4-1
  207. - update to 4.2.4
  208. - added q4banking subpackage
  209. - obsoletes python-aqbanking subpackage
  210. * Sat Oct 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.7.1-1
  211. - update to 3.7.2
  212. - obsolete the no-longer-existing g2banking/kbanking packages
  213. * Mon Jan 21 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.3-0vl1
  214. - update to 2.3.3
  215. * Sat Dec 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.3.2-2vl1
  216. - modify and build for VineSeed
  217. * Wed Aug 29 2007 Bill Nottingham <notting@redhat.com> - 2.3.2-2
  218. - Rebuild for selinux ppc32 issue.
  219. - fix build with current glibc/headers
  220. * Fri Aug 3 2007 Bill Nottingham <notting@redhat.com>
  221. - tweak license tag
  222. * Wed Jul 11 2007 Bill Nottingham <notting@redhat.com> - 2.3.2-1
  223. - update to 2.3.2
  224. * Mon Jun 25 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-3
  225. - fix some build bogosity
  226. * Wed Jun 20 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-2
  227. - add a dist tag
  228. * Mon Mar 19 2007 Bill Nottingham <notting@redhat.com> - 2.2.9-1
  229. - update to 2.2.9
  230. * Wed Jan 17 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-14
  231. - fix docdir, obsoletes for aqhbci-devel, and %%clean
  232. * Tue Jan 16 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-13
  233. - fix docs
  234. - add PyXML buildreq
  235. * Mon Jan 15 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-12
  236. - fix missing %%defattrs
  237. - fix %%excludes
  238. - other cleanups from review
  239. - use %%{_python_sitelib}
  240. - require automake
  241. - twiddle aqhbci obsoletes
  242. * Sat Jan 13 2007 Bill Nottingham <notting@redhat.com> - 2.1.0-11
  243. - split into a variety of packages
  244. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.1.0-10
  245. - rebuild for python 2.5
  246. * Thu Sep 7 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-9
  247. - rebuild for fixed debuginfo (#205248)
  248. * Fri Sep 1 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-8
  249. - fix multilib conficts (#205204)
  250. * Mon Aug 28 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-4
  251. - rebuild against latest libofx
  252. * Tue Aug 1 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-3
  253. - reenable visibility
  254. * Fri Jul 14 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-2
  255. - port *-config to pkgconfig
  256. - don't use -fvisibility=hidden
  257. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.1.0-1.1
  258. - rebuild
  259. * Tue Jul 11 2006 Bill Nottingham <notting@redhat.com> - 2.1.0-1
  260. - update to 2.1.0
  261. * Mon Jun 12 2006 Bill Nottingham <notting@redhat.com> - 1.8.1beta-5
  262. - buildreq autoconf, libtool
  263. * Tue May 30 2006 Bill Nottingham <notting@redhat.com> - 1.8.1beta-4
  264. - add gettext buildreq (#193348)
  265. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.8.1beta-3.1
  266. - bump again for double-long bug on ppc(64)
  267. * Tue Feb 07 2006 Karsten Hopp <karsten@redhat.de> 1.8.1beta-3
  268. - buildrequire libofx-devel instead of libofx (pulls in libofx)
  269. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.8.1beta-2.1
  270. - rebuilt for new gcc4.1 snapshot and glibc changes
  271. * Sun Jan 22 2006 Bill Nottingham <notting@redhat.com> 1.8.1beta-2
  272. - add an obsolete (#178554)
  273. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  274. - rebuilt
  275. * Mon Mar 7 2005 Bill Nottingham <notting@redhat.com> 1.0.4beta-2
  276. - rebuild
  277. * Wed Feb 9 2005 Bill Nottingham <notting@redhat.com> 1.0.4beta-1
  278. - initial packaging, adopt upstream specfile