perl-File-HomeDir-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171
  1. # define bootstrap for initial build
  2. %define perl_bootstrap 1
  3. Name: perl-File-HomeDir
  4. Version: 0.99
  5. Release: 1%{?_dist_release}
  6. Summary: Find your home and other directories on any platform
  7. Group: Development/Libraries
  8. License: GPL+ or Artistic
  9. URL: http://search.cpan.org/dist/File-HomeDir/
  10. Source0: http://www.cpan.org/authors/id/A/AD/ADAMK/File-HomeDir-%{version}.tar.gz
  11. BuildArch: noarch
  12. BuildRequires: perl(Carp)
  13. BuildRequires: perl(Cwd) >= 3.12
  14. BuildRequires: perl(ExtUtils::MakeMaker) >= 6.42
  15. BuildRequires: perl(File::Path) >= 2.01
  16. BuildRequires: perl(File::Spec) >= 3.12
  17. BuildRequires: perl(File::Temp) >= 0.19
  18. BuildRequires: perl(File::Which) >= 0.05
  19. %if !%{defined perl_bootstrap}
  20. BuildRequires: perl(Test::Pod)
  21. BuildRequires: perl(Test::MinimumVersion)
  22. BuildRequires: perl(Test::More) >= 0.47
  23. %endif
  24. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  25. Requires: perl(Cwd) >= 3.12
  26. Requires: perl(File::Path) >= 2.01
  27. Requires: perl(File::Spec) >= 3.12
  28. Requires: perl(File::Temp) >= 0.19
  29. Requires: perl(File::Which) >= 0.05
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. Packager: shaolin
  33. %description
  34. File::HomeDir is a module for locating the directories that are "owned"
  35. by a user (typically your user) and to solve the various issues that
  36. arise trying to find them consistently across a wide variety of
  37. platforms.
  38. %prep
  39. %setup -q -n File-HomeDir-%{version}
  40. %if %{_dist_release} > "vl6"
  41. %{?perl_default_filter}
  42. %global __requires_exclude %{?__requires_exclude}|perl\\(Cwd\\)|perl\\(File::Path\\)|perl\\(File::Spec\\)|perl\\(File::Temp\\)|perl\\(File::Which\\)|perl\\(Mac::
  43. %else
  44. cat << \EOF > %{name}-req
  45. #!/bin/sh
  46. %{__perl_requires} $* |\
  47. sed -e '/perl(Cwd\|File::Path\|File::Spec\|File::Temp\|File::Which)/d' |\
  48. sed -e '/perl(Mac::/d'
  49. EOF
  50. %global __perl_requires %{_builddir}/File-HomeDir-%{version}/%{name}-req
  51. chmod +x %{__perl_requires}
  52. %endif
  53. %build
  54. %{__perl} Makefile.PL INSTALLDIRS=vendor
  55. make %{?_smp_mflags}
  56. %install
  57. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  58. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  59. find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
  60. chmod -R u+w $RPM_BUILD_ROOT/*
  61. %check
  62. # These tests don't do anything really useful. Also, they are broken.
  63. # AUTOMATED_TESTING=1 make test
  64. %files
  65. %doc Changes LICENSE README
  66. %{perl_vendorlib}/File/
  67. %{_mandir}/man3/*.3pm*
  68. %changelog
  69. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.99-1
  70. - initial build for Vine Linux
  71. * Tue Jan 31 2012 Tom Callaway <spot@fedoraproject.org> - 0.99-1
  72. - Update to 0.99
  73. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.98-3
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  75. * Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 0.98-2
  76. - Perl mass rebuild
  77. * Tue Jul 12 2011 Tom Callaway <spot@fedoraproject.org> - 0.98-1
  78. - update to 0.98
  79. * Fri Jun 24 2011 Marcela Maslanova <mmaslano@redhat.com> - 0.97-2
  80. - fix filters for future rebuild
  81. - add perl_bootstrap macro
  82. - rebuild for perl 5.14.1
  83. * Mon Feb 21 2011 Tom Callaway <spot@fedoraproject.org> - 0.97-1
  84. - update to 0.97
  85. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.93-3
  86. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  87. * Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.93-2
  88. - 661697 rebuild for fixing problems with vendorach/lib
  89. * Wed Sep 22 2010 Petr Pisar <ppisar@redhat.com> - 0.93-1
  90. - 0.93 bump
  91. - Consolidate dependencies
  92. - Remove unversioned Requires
  93. - Update Summary and Description
  94. - Remove unneded file permission fixes
  95. * Sat May 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.86-4
  96. - Mass rebuild with perl-5.12.0
  97. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.86-3
  98. - rebuild against perl 5.10.1
  99. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.86-2
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  101. * Mon Jun 1 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.86-1
  102. - update for Padre
  103. * Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.84-1
  104. - update to 0.84
  105. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-2
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  107. * Tue Dec 16 2008 Marcela Mašláňová <mmaslano@redhat.com> - 0.82-1
  108. - update to the latest version for Padre editor
  109. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.67-3
  110. - Rebuild for perl 5.10 (again)
  111. * Fri Jan 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.67-2
  112. - rebuild for new perl
  113. * Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.67-1
  114. - 0.67
  115. * Fri Nov 30 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.66-1
  116. - 0.66
  117. * Wed May 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.65-1
  118. - Update to 0.65.
  119. * Sat Feb 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.64-1
  120. - Update to 0.64.
  121. * Thu Jan 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.63-1
  122. - Update to 0.63.
  123. * Thu Jan 4 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.62-1
  124. - Update to 0.62.
  125. * Thu Aug 03 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.58-1
  126. - First build.