yatex-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. Name: yatex
  4. Version: 1.74
  5. Release: 4%{?_dist_release}
  6. License: Distributable
  7. Source0: http://www.yatex.org/yatex%{version}.tar.gz
  8. #Source0: http://www.yatex.org/yatex10203151806.tar.gz
  9. Source1: %{name}-install.sh
  10. Source2: %{name}-remove.sh
  11. Source3: %{name}-init.el
  12. Source4: vine-default-%{name}.el
  13. Source5: vine-default-yahtml.el
  14. ## pre-formatted info files here
  15. Source10: yatexe
  16. Source11: yatexj
  17. Source12: yahtmle
  18. Source13: yahtmlj
  19. ## Vine Patch(es)
  20. Patch0: yatex-info.diff
  21. Patch1: yatexhlp-emacs.diff
  22. Patch2: yatex-make.diff
  23. # based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
  24. # and modified to suit 1.70 release
  25. Patch3: yahtml-1.70-timestamp.patch
  26. URL: http://www.yatex.org/
  27. Group: Applications/Editors/Emacs
  28. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  29. Summary: YaTeX - Yet Another TeX mode for Emacs
  30. Summary(ja): 野鳥(YaTeX) - Yet Another TeX mode for Emacs
  31. BuildArch: noarch
  32. PreReq: emacsen
  33. %prereq_ge emacsen-common
  34. BuildRequires: emacsen-common
  35. Obsoletes: yatex-xemacs
  36. Distribution: Vine Linux
  37. Vendor: Project Vine
  38. %description
  39. YaTeX is an intelligent, acquisitive and integrated package which reduces
  40. your efforts of composing LaTeX source on GNU Emacs.
  41. %description -l ja
  42. YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
  43. してくれる、LaTeX 入力支援環境です。
  44. %prep
  45. %setup -n yatex%{version}
  46. %patch0 -p1
  47. %patch1 -p1
  48. %patch2 -p1
  49. %patch3 -p1
  50. %build
  51. (cd docs
  52. chmod 644 *
  53. %__install -v -m 644 %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} .
  54. )
  55. %install
  56. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  57. %__mkdir_p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  58. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  59. %__mkdir_p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  60. %__mkdir_p ${RPM_BUILD_ROOT}%{_infodir}
  61. #
  62. # install el files
  63. #
  64. %__cp -a *.el makefile help \
  65. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
  66. %__cp -a %{SOURCE3} %{SOURCE4} %{SOURCE5} \
  67. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
  68. #
  69. # install info files
  70. #
  71. %__install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
  72. ${RPM_BUILD_ROOT}%{_infodir}
  73. #
  74. # install script (bytecompile el and install elc, remove)
  75. #
  76. %_installemacsenscript %{name} %{SOURCE1}
  77. %_removeemacsenscript %{name} %{SOURCE2}
  78. %clean
  79. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  80. %post
  81. #
  82. # bytecompile and install
  83. #
  84. if [ "$1" = 2 ] ; then
  85. %_emacsenPackageRemove %{name}
  86. fi
  87. %_addemacsenlist %{name}
  88. %_emacsenPackageInstall %{name}
  89. /sbin/install-info %{_infodir}/yatexe.gz %{_infodir}/dir \
  90. --section="Emacs"
  91. /sbin/install-info %{_infodir}/yatexj.gz %{_infodir}/dir \
  92. --section="Emacs"
  93. /sbin/install-info %{_infodir}/yahtmle.gz %{_infodir}/dir \
  94. --section="Emacs"
  95. /sbin/install-info %{_infodir}/yahtmlj.gz %{_infodir}/dir \
  96. --section="Emacs"
  97. %preun
  98. if [ "$1" = 0 ]; then
  99. %_emacsenPackageRemove %{name}
  100. %_removeemacsenlist %{name}
  101. /sbin/install-info --delete %{_infodir}/yatexe.gz %{_infodir}/dir \
  102. --section="Emacs"
  103. /sbin/install-info --delete %{_infodir}/yatexj.gz %{_infodir}/dir \
  104. --section="Emacs"
  105. /sbin/install-info --delete %{_infodir}/yahtmle.gz %{_infodir}/dir \
  106. --section="Emacs"
  107. /sbin/install-info --delete %{_infodir}/yahtmlj.gz %{_infodir}/dir \
  108. --section="Emacs"
  109. fi
  110. %files
  111. %defattr(-,root,root)
  112. %doc 00readme install manifest yatex.new
  113. %doc docs
  114. %{_datadir}/emacs/site-lisp/yatex/
  115. %{_infodir}/*
  116. %{emacsen_pkgdir}/install/%{name}
  117. %{emacsen_pkgdir}/remove/%{name}
  118. %changelog
  119. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-4
  120. - updated vine-default-yatex.el
  121. - added (setq YaTeX-inhibit-prefix-letter t) [yatex:04567]
  122. - supported TeX Live
  123. - used "eplatex", "pxdvi", "pdvips" as default commands
  124. - updated yatex-init.el
  125. - output "Loading vine-default-yatex ..." to the buffer *Messages*
  126. - defined vine-default-yahtml
  127. - added vine-default-yahtml.el
  128. * Tue Jan 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-3
  129. - updated vine-default-yatex.el
  130. - added bbl extension in auto-mode-alist to run yatex-mode
  131. * Sun Dec 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-2
  132. - updated vine-default-yatex.el
  133. - supported new vine-default
  134. * Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
  135. - new upstream release
  136. * Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
  137. - updated vine-default-yatex.el
  138. - dropped (setq YaTeX-no-begend-shortcut t)
  139. - use %{emacsen_pkgdir}
  140. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
  141. - updated vine-default-yatex.el
  142. - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
  143. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
  144. - updated yatex-install.sh
  145. - *-init.el: changed from hard copy to symbolic link
  146. on /etc/emacs-XX.YY/site-start.d
  147. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
  148. - fixed yatex-init.el
  149. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
  150. - added yatex-init.el, vine-default-yatex.el
  151. - updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
  152. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
  153. - spec in utf8
  154. * Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
  155. - applied new versioning policy
  156. * Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
  157. - new upstream release
  158. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
  159. - s/Copyright/License/
  160. - changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
  161. * Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
  162. - update yatex-1.72
  163. * Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
  164. - update yatex-1.71
  165. * Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
  166. - added Patch3 to add hhmts timestamp feature
  167. * Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
  168. - update yatex-1.70
  169. * Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
  170. - update yatex10203151806
  171. * Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
  172. - fixed: bytecompile yatex19
  173. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
  174. - now emacsen-common aware
  175. - FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
  176. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  177. - 1.68-0vl2
  178. - no kanji code conversion of documents
  179. * Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  180. - 1.68-0vl1
  181. - update to 1.68
  182. * Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  183. - 1.67-6vl5
  184. - YATEXHLP.{jp,eng} moved to appropriate dir
  185. * Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  186. - 1.67-6vl3
  187. - rebuilt for emacs-20.7
  188. * Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  189. - 1.67-6vl2
  190. - oops ... fixed target dir for help files
  191. * Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  192. - 1.67-6vl1
  193. - rebuilt for emacs-20.6
  194. * Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  195. - 1.67-6
  196. - included forgotten info file for YaHTML
  197. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  198. - 1.67-5
  199. - updated for emacs-20.5a release
  200. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  201. - 1.67-4
  202. - change Group to Applications/Editors/EmacsLisp
  203. * Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  204. - 1.67-3
  205. - %post and %preun section modified
  206. * Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  207. - 1.67-2
  208. - fixed minor problem in the %files section
  209. * Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  210. - 1.67-1
  211. - updated to 1.67 release
  212. - rebuilt for emacs-20.4 on Vine Linux 1.9
  213. - updated URL for the new web site of YaTeX
  214. - some typo fix
  215. * Tue May 4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  216. - Initial Release