pyparted-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202
  1. Summary: Python module for GNU parted
  2. Summary(ja): parted の python モジュール
  3. Name: pyparted
  4. Version: 3.11.2
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Libraries
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Source0: https://fedorahosted.org/releases/p/y/%{name}/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. # https://github.com/dcantrell/pyparted/issues/57
  13. Patch0: use-decimal-instead-of-float.patch
  14. BuildRequires: python-devel
  15. BuildRequires: python-setuptools
  16. BuildRequires: python-rpm-macros
  17. BuildRequires: python-six
  18. BuildRequires: python3-devel
  19. BuildRequires: python3-setuptools
  20. BuildRequires: python3-rpm-macros
  21. BuildRequires: python3-six
  22. BuildRequires: parted-devel >= 3.2
  23. Requires: parted >= 3.2
  24. %description
  25. Python modules for the parted library. It is used for manipulation
  26. partition tables.
  27. %package -n python3-pyparted
  28. Summary: Python 3 module for GNU parted
  29. Summary(ja): parted の python モジュール
  30. Group: System Environment/Libraries
  31. %description -n python3-pyparted
  32. Python 3 modules for the parted library. It is used for manipulation
  33. partition tables.
  34. %prep
  35. %setup -q
  36. %patch0 -p1
  37. rm -rf %{py3dir}
  38. mkdir -p %{py3dir}
  39. cp -a . %{py3dir}
  40. %build
  41. PYTHON=python make %{?_smp_mflags}
  42. pushd %{py3dir}
  43. PYTHON=python3 make %{?_smp_mflags}
  44. popd
  45. %install
  46. rm -rf $RPM_BUILD_ROOT
  47. PYTHON=python %__make install DESTDIR=$RPM_BUILD_ROOT
  48. pushd %{py3dir}
  49. PYTHON=python3 %__make install DESTDIR=$RPM_BUILD_ROOT
  50. popd
  51. %check
  52. PYTHON=python make test
  53. pushd %{py3dir}
  54. PYTHON=python3 make test
  55. popd
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %files
  59. %defattr(-,root,root,-)
  60. %license COPYING
  61. %doc AUTHORS NEWS README TODO
  62. %{python_sitearch}/parted
  63. %{python_sitearch}/*.egg-info
  64. %{python_sitearch}/*.so
  65. %files -n python3-pyparted
  66. %license COPYING
  67. %doc AUTHORS NEWS README TODO
  68. %{python3_sitearch}/_ped.*.so
  69. %{python3_sitearch}/parted
  70. %{python3_sitearch}/%{name}-%{version}-*.egg-info
  71. %changelog
  72. * Mon Sep 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.11.2-1
  73. - new upstream release.
  74. - added python3 support.
  75. - imported Patch0 from upstream.
  76. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-4
  77. - rebuild with VineSeed environment
  78. * Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-3
  79. - rebuild with parted-3.1
  80. * Sat Feb 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-2
  81. - rebuild with python-2.7.2
  82. * Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-1
  83. - new upstream release
  84. * Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.9-3
  85. - rebuild with parted-2.3
  86. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.9-2
  87. - rebuilt with python-2.6.4
  88. * Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.9-1
  89. - new upstream release
  90. - build with parted-1.8.8
  91. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 1.8.1-4vl5
  92. - rebuilt with python-2.5.2
  93. - added pyexeclib macro
  94. - applied new versioning policy and spec in utf-8
  95. * Wed Dec 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.1-3vl1
  96. - rebuilt for VineSeed with parted-1.8.1 and python-2.4
  97. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 1.8.1-3
  98. - rebuild for python 2.5
  99. * Tue Dec 05 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-2
  100. - Rebuild for GNU parted-1.8.1
  101. * Thu Nov 30 2006 David Cantrell <dcantrell@redhat.com> - 1.8.1-1
  102. - Determine Python version to use in %%build so the source RPM is more
  103. easily moved between distribution releases.
  104. * Fri Nov 17 2006 David Cantrell <dcantrell@redhat.com> - 1.8.0-1
  105. - Bump version to 1.8.0 and require parted >= 1.8.0
  106. - Remove python-abi Requires line since rpm handles that automatically
  107. * Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.3-1
  108. - Include parted/constraint.h in required header files
  109. * Wed Aug 30 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-2
  110. - Require parted-1.7.1 or higher
  111. * Tue Jul 25 2006 David Cantrell <dcantrell@redhat.com> - 1.7.2-1
  112. - Add HPSERVICE, PALO, PREP, and MSFT_RESERVED to partition types list
  113. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.1-1.1
  114. - rebuild
  115. * Sun May 28 2006 David Cantrell <dcantrell@redhat.com> - 1.7.1-1
  116. - Bump version to 1.7.1 and require parted >= 1.7.1
  117. * Fri May 19 2006 David Cantrell <dcantrell@redhat.com> - 1.7.0-1
  118. - Bump version to 1.7.0 and require parted >= 1.7.0
  119. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  120. - rebuilt
  121. * Fri Nov 11 2005 Peter Jones <pjones@redhat.com> - 1.6.10-1
  122. - rebuild for new parted.
  123. - add debugging options for make so debuginfo isn't useless
  124. * Wed Nov 9 2005 Jeremy Katz <katzj@redhat.com> - 1.6.9-5
  125. - rebuild for new parted
  126. * Wed Aug 31 2005 Chris Lumens <clumens@redhat.com> 1.6.9-4
  127. - Rebuilt for new parted library.
  128. * Wed Mar 16 2005 Chris Lumens <clumens@redhat.com> 1.6.9-3
  129. - Updated for gcc4 and python2.4. Fixed build warnings.
  130. * Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.9-2
  131. - add support for sx8 devices
  132. * Mon Nov 8 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-3
  133. - rebuild for python 2.4
  134. * Mon Oct 11 2004 Warren Togami <wtogami@redhat.com> - 1.6.8-2
  135. - #135100 req python-abi (Robert Scheck)
  136. * Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 1.6.8-1
  137. - update for new parted ABI
  138. - device -> heads, sectors, cylinders now refer to the bios geometry
  139. - require parted >= 1.6.12
  140. * Thu Jul 22 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-3
  141. - build on ppc64 again
  142. * Thu May 13 2004 Jeremy Katz <katzj@redhat.com> - 1.6.7-1
  143. - fix build for newer versions of gcc (fix from Jeff Law)
  144. * Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 1.6.6-2
  145. - fix PARTITION_PROTECTED definition (#118451)
  146. * Fri Mar 12 2004 Jeremy Katz <katzj@redhat.com>
  147. - Initial build split out into separate source from the parted package.
  148. - Don't build on ppc64 right now due to parted build problems (#118183)