xorg-x11-xinit-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361
  1. %define pkgname xinit
  2. Summary: X.Org X11 X Window System xinit startup scripts
  3. Summary(ja): X.Org X11 X ウィンドウシステム xinit スタートアップスクリプト
  4. Name: xorg-x11-%{pkgname}
  5. Version: 1.4.1
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: MIT/X11
  11. URL: http://www.x.org
  12. Source0: https://www.x.org/archive//individual/app/%{pkgname}-%{version}.tar.bz2
  13. Source10: xinitrc-common
  14. Source11: xinitrc
  15. Source12: Xclients
  16. Source13: Xmodmap
  17. Source14: Xresources
  18. # NOTE: Xsession is used by xdm/kdm/gdm and possibly others, so we keep it
  19. # here instead of the xdm package.
  20. Source16: Xsession
  21. Source17: localuser.sh
  22. Source18: xinit-compat.desktop
  23. Source20: backend-env.sh
  24. Patch1: xinit-1.3.4-client-session.patch
  25. Patch3: xinit-1.0.9-unset.patch
  26. Patch10: xinit-1.3.4-vine.patch
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  28. BuildRequires: pkgconfig
  29. BuildRequires: libX11-devel
  30. BuildRequires: autoconf
  31. BuildRequires: automake
  32. BuildRequires: libtool
  33. BuildRequires: dbus-devel
  34. BuildRequires: xorg-x11-util-macros
  35. # NOTE: startx needs xauth in order to run, but that is not picked up
  36. # automatically by rpm. (Bug #173684)
  37. Requires: xauth
  38. # next two are for localuser.sh
  39. Requires: coreutils
  40. Requires: xorg-x11-server-utils
  41. Requires: dbus-x11
  42. # NOTE: xinit, startx moved to xorg-x11-xinit during the X.Org X11R7
  43. # modularization. These Obsoletes lines ensure upgrades work smoothly.
  44. Obsoletes: XFree86, XOrg
  45. # NOTE: Most of the xinitrc scripts/config files are now in xorg-x11-xinit,
  46. # so the xinitrc package became unnecessary. The xdm configs/scripts move
  47. # to the xdm package.
  48. Obsoletes: xinitrc
  49. Provides: xinitrc
  50. %description
  51. X.Org X11 X Window System xinit startup scripts
  52. %description -l ja
  53. X.Org X11 X Window System の xinit スタートアップ・スクリプト
  54. %package session
  55. Summary: Display manager support for ~/.xsession and ~/.Xclients
  56. Group: User Interface/X
  57. %description session
  58. Allows legacy ~/.xsession and ~/.Xclients files to be used from display managers
  59. %debug_package
  60. %prep
  61. %setup -q -n %{pkgname}-%{version}
  62. %patch1 -p1 -b .client-session
  63. %patch3 -p1 -b .unset
  64. %patch10 -p1 -b .vine
  65. %build
  66. autoreconf -i
  67. %configure
  68. # FIXME: Upstream should default to XINITDIR being this. Make a patch to
  69. # Makefile.am and submit it in a bug report or check into CVS.
  70. make XINITDIR=/etc/X11/xinit
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. # FIXME: Upstream should default to XINITDIR being this. Make a patch to
  74. # Makefile.am and submit it in a bug report or check into CVS.
  75. %makeinstall XINITDIR=$RPM_BUILD_ROOT/etc/X11/xinit
  76. install -m644 -D $RPM_SOURCE_DIR/xinit-compat.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions/xinit-compat.desktop
  77. # Install custom xinitrc, etc.
  78. {
  79. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc-common
  80. for script in %{SOURCE11} %{SOURCE12} %{SOURCE16} ; do
  81. install -m 755 $script $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/${script##*/}
  82. done
  83. install -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xmodmap
  84. install -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xresources
  85. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d
  86. install -m 755 %{SOURCE17} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/localuser.sh
  87. install -m 755 %{SOURCE20} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/05-backend-env.sh
  88. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/Xclients.d
  89. }
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %files
  93. %defattr(-,root,root,-)
  94. %license COPYING
  95. %doc README ChangeLog
  96. %{_bindir}/startx
  97. %{_bindir}/xinit
  98. %dir %{_sysconfdir}/X11
  99. %dir %{_sysconfdir}/X11/xinit
  100. %{_sysconfdir}/X11/xinit/xinitrc
  101. %{_sysconfdir}/X11/xinit/xinitrc-common
  102. %config(noreplace) %{_sysconfdir}/X11/Xmodmap
  103. %config(noreplace) %{_sysconfdir}/X11/Xresources
  104. %dir %{_sysconfdir}/X11/xinit/Xclients.d
  105. %{_sysconfdir}/X11/xinit/Xclients
  106. %{_sysconfdir}/X11/xinit/Xsession
  107. %dir %{_sysconfdir}/X11/xinit/xinitrc.d
  108. %{_sysconfdir}/X11/xinit/xinitrc.d/*
  109. #%dir %{_mandir}/man1
  110. %{_mandir}/man1/startx.1*
  111. %{_mandir}/man1/xinit.1*
  112. %files session
  113. %defattr(-, root, root)
  114. %{_datadir}/xsessions/xinit-compat.desktop
  115. %changelog
  116. * Tue Mar 30 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-1
  117. - new upstream release.
  118. - added backend-env.sh to manage GDK_BACKEND and CLUTTER_BACKEND.
  119. * Sat Jan 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.4-3
  120. - dropped ConsoleKit stuff.
  121. * Sat Apr 8 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.3.4-2
  122. - update Source12: [BTS:0003071]
  123. - add MATE
  124. * Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.4-1
  125. - new upstream release
  126. - update Patch1 (xinit-1.3.4-client-session.patch)
  127. - update Patch10 (xinit-1.3.4-vine.patch)
  128. * Wed Jun 04 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.3-2
  129. - exec startfluxbox instead of fluxbox
  130. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.3-1
  131. - new upstream release
  132. * Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-1
  133. - new upstream release
  134. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
  135. - new upstream release
  136. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
  137. - new upstream release
  138. - update Patch1, Patch10
  139. * Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  140. - new upstream release
  141. - updated SOURCE12, SOURCE100
  142. - Install xinitrc-common non-executable.
  143. - added a new subpackage to add ~/.xsessions and ~/.Xclients
  144. to session list
  145. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  146. - new upstream release
  147. * Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-3
  148. - add Requires: dbus-x11
  149. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-2
  150. - add LXDE to Xclients
  151. * Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
  152. - new upstream release
  153. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
  154. - fix typo in Xsession (<BTS:644>)
  155. * Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
  156. - new upstream release
  157. * Fri Jun 27 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.7-3
  158. - spec in UTF-8
  159. - modify Source16: add CK_XINIT_SESSION calls
  160. * Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-2
  161. - add Patch10 to set display resolution.
  162. * Thu May 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
  163. - initial build for Vine Linux
  164. * Fri Oct 12 2007 Nalin Dahyabhai <nalin@redhat.com> 1.0.7-2
  165. - Try opening the console-kit session after the user's UID has already
  166. been granted access to the server by localuser.sh, so that console-kit-daemon
  167. can connect and ask the server for information just by having switch to the
  168. user's UID (#287941).
  169. * Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.7-1
  170. - xinit 1.0.7
  171. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-27
  172. - Rebuild for build id
  173. * Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-26
  174. - Bump release
  175. * Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-25
  176. - Fix typo: s/unask/umask/ - Bug 250882, Jan ONDREJ (ondrejj@salstar.sk)
  177. * Thu Aug 2 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-24
  178. - Fix bug 212167, CVE-2006-5214
  179. * Sun Jul 29 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-23
  180. - Fix Xsession to run the login shell inside the setgid ssh-agent, rather
  181. than the other way around. This preserves LD_LIBRARY_PRELOAD.
  182. Patch from Stefan Becker, bug 164869.
  183. * Fri Jul 27 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-22
  184. - Remove xinput.sh. Bug 244963.
  185. * Mon May 21 2007 Adam Jackson <ajax@redhat.com> 1.0.2-21
  186. - localuser.sh: Run silently.
  187. * Sun Apr 22 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-20
  188. - Don't install INSTALL
  189. * Thu Apr 19 2007 Warren Togami <wtogami@redhat.com> 1.0.2-19
  190. - disable SCIM by default in non-Asian languages #237054
  191. If you want to use SCIM, use im-chooser to enable it.
  192. * Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-18
  193. - Man pages are now in section 1, not in section 1x
  194. * Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-17
  195. - Also BR xorg-x11-util-macros since we autoreconf
  196. * Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-16
  197. - Add ConsoleKit support (#233183)
  198. * Mon Nov 27 2006 Adam Jackson <ajax@redhat.com> 1.0.2-15
  199. - Bump EVR to fix 6 to 7 updates.
  200. * Fri Nov 10 2006 Ray Strode <rstrode@redhat.com> - 1.0.2-14
  201. - start client in its own session with no controlling tty
  202. (bug 214649)
  203. * Mon Oct 23 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-13
  204. - Update Xsession to not use switchdesk for the hard coded kde and twm
  205. cases.
  206. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-12
  207. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  208. * Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-11.fc6
  209. - Bump and rebuild.
  210. * Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-10.fc6
  211. - Move hardcoded xsetroot background color to fallback cases (#205901).
  212. * Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-9.fc6
  213. - Start ssh-agent for startx also (#169259).
  214. * Sat Jul 22 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-8.fc6
  215. - Fix SourceN line for localuser.sh to not collide.
  216. * Fri Jul 21 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-7.fc6
  217. - Added localuser.sh.
  218. * Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-6.fc6
  219. - Added fix to Xclients script, based on patch from bug (#190799)
  220. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-5.1.fc6
  221. - rebuild
  222. * Wed Jul 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-5.fc6
  223. - Implemented changes to xinput.sh based on suggestions from (#194458)
  224. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4
  225. - Added documentation to doc macro.
  226. * Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
  227. - Added xinit-1.0.2-setuid.diff to fix potential security issue (#196094)
  228. * Tue Jun 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
  229. - Added "BuildRequires: pkgconfig" for bug (#194187)
  230. * Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
  231. - Update xinit to 1.0.2
  232. * Thu Feb 16 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
  233. - Change Conflicts to Obsoletes for xorg-x11 and XFree86 (#181414)
  234. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
  235. - bump again for double-long bug on ppc(64)
  236. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
  237. - rebuilt for new gcc4.1 snapshot and glibc changes
  238. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
  239. - Updated to xinit 1.0.1 from X11R7.0
  240. * Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  241. - Updated to xinit 1.0.0 from X11R7 RC4.
  242. - Changed manpage dir from man1x to man1 to match upstream default.
  243. * Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-6
  244. - Add "Requires: xauth" for startx, to fix bug (#173684)
  245. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.3-5
  246. - Do not provide xinit anymore, gdm has been fixed and that breaks things
  247. with the obsoletes
  248. * Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-4
  249. - Added Xsession script from xinitrc, as it is very similar codebase, which
  250. shares "xinitrc-common" anyway, and all of the display managers use it.
  251. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-3
  252. - Updated to xinit 0.99.3 from X11R7 RC2.
  253. * Mon Nov 07 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
  254. - Added "Provides: xinitrc = 5.0.0-1" for temporary compatibility between
  255. monolithic and modular X. This will be removed however for FC5.
  256. * Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
  257. - Import custom Red Hat xinit scripts from xinitrc package.
  258. - Obsolete xinitrc package, as we include the scripts/configs here now.
  259. - Fix all scripts/configs to avoid the now obsolete /usr/X11R6 prefix.
  260. * Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  261. - Updated to xinit 0.99.2 from X11R7 RC1.
  262. - Change manpage location to 'man1x' in file manifest.
  263. * Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
  264. - Use Fedora-Extras style BuildRoot tag.
  265. - Update BuildRequires to use new library package names.
  266. - Tidy up spec file a bit.
  267. * Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
  268. - Initial build.