colord-vl.spec 9.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345
  1. %bcond_with systemd
  2. %bcond_with firstbuild
  3. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  4. Summary: Color daemon
  5. Name: colord
  6. Version: 1.4.5
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv2+ and LGPLv2+
  12. URL: https://github.com/hughsie/colord
  13. Source0: https://github.com/hughsie/colord/archive/refs/tags/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  14. Patch0: colord-1.4.3-elogind.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: bash-completion
  17. BuildRequires: dbus-devel
  18. BuildRequires: docbook-utils
  19. BuildRequires: docbook5-style-xsl
  20. BuildRequires: gettext
  21. BuildRequires: glib2-devel
  22. BuildRequires: lcms2-devel
  23. BuildRequires: libgudev1-devel
  24. BuildRequires: libgusb-devel
  25. BuildRequires: libxslt
  26. BuildRequires: meson
  27. BuildRequires: polkit-devel
  28. BuildRequires: sqlite3-devel
  29. BuildRequires: vala
  30. %{!?with_firstbuild:BuildRequires: colord-devel, gobject-introspection-devel}
  31. %if %{with systemd}
  32. BuildRequires: systemd-devel
  33. %{?systemd_requires}
  34. %else
  35. BuildRequires: eudev-libudev-devel
  36. BuildRequires: elogind-devel
  37. %endif
  38. Requires: shared-color-profiles
  39. %description
  40. colord is a low level system activated daemon that maps color devices
  41. to color profiles in the system context.
  42. %package devel
  43. Summary: Development package for %{name}
  44. Group: programming
  45. Requires: %{name} = %{version}-%{release}
  46. Requires: glib2-devel
  47. Requires: dbus-devel
  48. Requires: lcms2-devel
  49. %description devel
  50. Files for development with %{name}.
  51. # compat32
  52. %package -n compat32-%{name}
  53. Summary: Color daemon
  54. Group: system,legacy
  55. Requires: %{name} = %{version}-%{release}
  56. %description -n compat32-%{name}
  57. colord is a low level system activated daemon that maps color devices
  58. to color profiles in the system context.
  59. %package -n compat32-%{name}-devel
  60. Summary: Development package for %{name}
  61. Group: programming,legacy
  62. Requires: compat32-%{name} = %{version}-%{release}
  63. %description -n compat32-%{name}-devel
  64. Files for development with %{name}.
  65. %debug_package
  66. %prep
  67. %setup
  68. %if !%{with systemd}
  69. %patch0 -p1
  70. %endif
  71. %build
  72. %meson \
  73. -Ddaemon_user=colord \
  74. %if %{with systemd}
  75. -Dsystemd=true \
  76. %else
  77. -Dsystemd=false \
  78. -Delogind=true \
  79. %endif
  80. -Dargyllcms_sensor=false \
  81. -Dvapi=true \
  82. -Ddocs=false
  83. %meson_build
  84. %install
  85. rm -rf %{buildroot}
  86. %meson_install
  87. # databases
  88. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/mapping.db
  89. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/storage.db
  90. %find_lang %{name}
  91. %triggerin -- colord < 1.4.4
  92. if [ -d %{_localstatedir}/lib/colord ]; then
  93. chown -R colord:colord %{_localstatedir}/lib/colord
  94. fi
  95. %pre
  96. getent group colord >/dev/null || groupadd -r colord
  97. getent passwd colord >/dev/null || \
  98. useradd -r -g colord -d /var/lib/colord -s /sbin/nologin \
  99. -c "User for colord" colord
  100. exit 0
  101. %post
  102. %if %{with systemd}
  103. %systemd_post colord.service
  104. %endif
  105. %if %{with systemd}
  106. %preun
  107. %systemd_preun colord.service
  108. %endif
  109. %postun
  110. %if %{with systemd}
  111. %systemd_postun colord.service
  112. %endif
  113. %files -f %{name}.lang
  114. %defattr(-,root,root,-)
  115. %license COPYING
  116. %doc AUTHORS NEWS README.md
  117. %{_libexecdir}/colord
  118. %{_libexecdir}/colord-session
  119. %attr(755,colord,colord) %dir %{_localstatedir}/lib/colord
  120. %attr(755,colord,colord) %dir %{_localstatedir}/lib/colord/icc
  121. %{_bindir}/*
  122. %{_datadir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
  123. %dir %{_datadir}/bash-completion
  124. %dir %{_datadir}/bash-completion/completions
  125. %{_datadir}/bash-completion/completions/colormgr
  126. %{_datadir}/color
  127. %{_datadir}/colord
  128. %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorHelper.xml
  129. %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
  130. %{_datadir}/dbus-1/services/org.freedesktop.ColorHelper.service
  131. %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
  132. %{_datadir}/glib-2.0/schemas/org.freedesktop.ColorHelper.gschema.xml
  133. %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
  134. %{_datadir}/man/man1/*.1.gz
  135. %{_libdir}/libcolord.so.*
  136. %{_libdir}/libcolordprivate.so.*
  137. %{_libdir}/libcolorhug.so.*
  138. %{_libdir}/colord-plugins/libcolord_sensor_camera.so
  139. %{_libdir}/colord-plugins/libcolord_sensor_scanner.so
  140. %{!?with_firstbuild:%{_libdir}/girepository-1.0/Colord-1.0.typelib}
  141. %{!?with_firstbuild:%{_libdir}/girepository-1.0/Colorhug-1.0.typelib}
  142. /lib/udev/rules.d/*.rules
  143. %{_libdir}/colord-sensors
  144. %ghost %{_localstatedir}/lib/colord/*.db
  145. %if %{with systemd}
  146. %{_unitdir}/*.service
  147. %{_userunitdir}/*.service
  148. %{_tmpfilesdir}/colord.conf
  149. %endif
  150. %files devel
  151. %defattr(-,root,root,-)
  152. %{_includedir}/colord-1
  153. %{_libdir}/libcolord.so
  154. %{_libdir}/libcolordprivate.so
  155. %{_libdir}/libcolorhug.so
  156. %{_libdir}/pkgconfig/colord.pc
  157. %{_libdir}/pkgconfig/colorhug.pc
  158. %{!?with_firstbuild:%{_datadir}/gir-1.0/Colord-1.0.gir}
  159. %{!?with_firstbuild:%{_datadir}/gir-1.0/Colorhug-1.0.gir}
  160. %dir %{_datadir}/vala
  161. %dir %{_datadir}/vala/vapi
  162. %{_datadir}/vala/vapi/*
  163. # compat32
  164. %if %{build_compat32}
  165. %files -n compat32-%{name}
  166. %defattr(-,root,root,-)
  167. %{_libdir}/libcolord.so.*
  168. %{_libdir}/libcolordprivate.so.*
  169. %{_libdir}/libcolorhug.so.*
  170. %files -n compat32-%{name}-devel
  171. %defattr(-,root,root,-)
  172. %{_libdir}/libcolord.so
  173. %{_libdir}/libcolordprivate.so
  174. %{_libdir}/libcolorhug.so
  175. %endif
  176. %changelog
  177. * Tue Mar 30 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.5-1
  178. - new upstream release.
  179. * Mon Aug 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.4-1
  180. - new upstream release.
  181. - added systemd support (disabled as default).
  182. - changed daemon-user to "colord".
  183. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
  184. - new upstream release.
  185. * Fri Dec 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.8-2
  186. - added libcolordprivate and libcolorhug to compat32-* subpackages
  187. * Mon Nov 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.8-1
  188. - new upstream release
  189. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.7-1
  190. - update to 1.1.7
  191. * Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
  192. - new upstream release
  193. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
  194. - new upstream release
  195. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
  196. - new upstream release
  197. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  198. - new upstream release
  199. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  200. - new upstream release
  201. - add BuildRequires: bash-completion
  202. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.33-1
  203. - new upstream release
  204. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.26-1
  205. - new upstream release
  206. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.24-1
  207. - new upstream release
  208. - remove BuildRequires: sane-devel
  209. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.23-1
  210. - new upstream release
  211. - change BuildRequires: libgusb-devel instead of libusb1-devel
  212. - add BuildRequires: gobject-introspection-devel
  213. * Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.21-1
  214. - new upstream release
  215. * Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.19-1
  216. - new upstream release
  217. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.18-1
  218. - new upstream release
  219. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.15-1
  220. - new upstream release
  221. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.14-1
  222. - new upstream release
  223. * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.13-1
  224. - new upstream release
  225. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.12-1
  226. - new upstream release
  227. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.11-1
  228. - new upstream release
  229. - create compat32 sub packages
  230. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-1
  231. - initial build for Vine Linux
  232. * Wed Jul 06 2011 Richard Hughes <richard@hughsie.com> 0.1.10-1
  233. - New upstream version
  234. * Mon Jun 13 2011 Richard Hughes <richard@hughsie.com> 0.1.9-1
  235. - New upstream version
  236. * Thu Jun 02 2011 Richard Hughes <richard@hughsie.com> 0.1.8-1
  237. - New upstream version
  238. - Add a webcam device kind
  239. - Add a timestamp when making profiles default
  240. - Add support for reading and writing ICC profile metadata
  241. - Allow the client to pass file descriptors out of band to CreateProfile
  242. - Prettify the device vendor and model names
  243. - Split out the sensors into runtime-loadable shared objects
  244. - Provide some GIO async variants for the methods in CdClient
  245. - Ensure GPhoto2 devices get added to the device list
  246. * Fri May 06 2011 Richard Hughes <richard@hughsie.com> 0.1.7-1
  247. - New upstream version.
  248. - Create /var/lib/colord at buildtime not runtime for SELinux
  249. - Ensure profiles with embedded profile checksums are parsed correctly
  250. - Move the colorimeter rules to be run before 70-acl.rules
  251. - Stop watching the client when the sensor is finalized
  252. - Ensure the source is destroyed when we unref CdUsb to prevent a crash
  253. - Only enable the volume mount tracking when searching volumes
  254. * Tue Apr 26 2011 Richard Hughes <rhughes@redhat.com> 0.1.6-2
  255. - Own /var/lib/colord and /var/lib/colord/*.db
  256. * Sun Apr 24 2011 Richard Hughes <richard@hughsie.com> 0.1.6-1
  257. - New upstream version.
  258. * Thu Mar 31 2011 Richard Hughes <richard@hughsie.com> 0.1.5-1
  259. - New upstream version.
  260. * Wed Mar 09 2011 Richard Hughes <richard@hughsie.com> 0.1.4-1
  261. - New upstream version.
  262. * Mon Feb 28 2011 Richard Hughes <richard@hughsie.com> 0.1.3-1
  263. - New upstream version.
  264. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3
  265. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  266. * Fri Jan 28 2011 Richard Hughes <richard@hughsie.com> 0.1.1-2
  267. - Rebuild in the vain hope koji isn't broken today.
  268. * Wed Jan 26 2011 Richard Hughes <richard@hughsie.com> 0.1.1-1
  269. - New upstream version.
  270. * Thu Jan 13 2011 Richard Hughes <richard@hughsie.com> 0.1.0-1
  271. - Initial version for Fedora package review.