time-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172
  1. Name: time
  2. Summary: A GNU utility for monitoring a program's use of system resources.
  3. Summary(ja): プログラムのシステムリソース使用をモニタする GNU ユーティリティ
  4. Version: 1.9
  5. Release: 1%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv3+ and GFDL
  10. URL: http://www.gnu.org/software/time/
  11. Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.gz
  12. # Fix measuring time when a clock experiences a jump, bug #1004416,
  13. # <http://lists.gnu.org/archive/html/bug-gnu-utils/2013-09/msg00003.html>
  14. Patch0: time-1.8-Prefer-clock_gettime-CLOCK_MONOTONIC.patch
  15. # Fix info directory entry
  16. Patch1: time-1.9-Improve-info-directory-index-entry-description.patch
  17. # Clarify RSS size as kibibytes in a documentation, proposed to an upstream,
  18. # <https://lists.gnu.org/archive/html/bug-time/2020-07/msg00000.html>
  19. Patch2: time-1.9-Use-kibibytes-instead-of-kilobytes-in-a-documentatio.patch
  20. # Do not leak a file descriptor of the --output argument to a command,
  21. # proposed to an upstream,
  22. # <https://lists.gnu.org/archive/html/bug-time/2020-11/msg00001.html>
  23. Patch3: time-1.9-Close-outfp-before-exec.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildRequires: texinfo
  26. Requires(post): /sbin/install-info
  27. Requires(preun): /sbin/install-info
  28. %description
  29. The GNU time utility runs another program, collects information about
  30. the resources used by that program while it is running, and displays
  31. the results.
  32. %description -l ja
  33. GNU time ユーティリティは,他のプログラムを実行し,そのプログラムが
  34. 実行される際にシステムリソースをどの程度使用したかの情報を表示します.
  35. %debug_package
  36. %prep
  37. %setup -q
  38. %autopatch -p1
  39. # Set time stamp stored in an info page to the latest patch
  40. touch -d "$(sed -n -e '/^Date: /{s/^[^:]*: //;p}' %{PATCH2})" doc/time.texi
  41. # Correct version VERSION flag for doc/time.texi
  42. # <https://lists.gnu.org/archive/html/bug-time/2021-01/msg00000.html>
  43. printf '%{version}\n' > .tarball-version
  44. autoreconf -fi
  45. %build
  46. %configure
  47. make %{?_smp_mflags}
  48. %install
  49. rm -rf %{buildroot}
  50. make install DESTDIR=$RPM_BUILD_ROOT
  51. # Remove info index, it's updated by file triggers
  52. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  53. %check
  54. %{make_build} check
  55. %post
  56. /sbin/install-info %{_infodir}/time.info.gz %{_infodir}/dir \
  57. --entry="* time: (time). GNU time Utility" || :
  58. %preun
  59. if [ "$1" = 0 ]; then
  60. /sbin/install-info --delete %{_infodir}/time.info.gz %{_infodir}/dir \
  61. --entry="* time: (time). GNU time Utility" || :
  62. fi
  63. %files
  64. %defattr(-,root,root)
  65. %license COPYING
  66. %doc AUTHORS ChangeLog NEWS README
  67. %{_bindir}/time
  68. %{_infodir}/time.info*
  69. %changelog
  70. * Sat Mar 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9-1
  71. - new upstream release.
  72. - dropped all patches.
  73. - imported Patch0-3 from rawhide.
  74. * Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-24
  75. - rebuild with VineSeed environment
  76. * Sun Apr 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7-23
  77. - rebuilt with current VineSeed
  78. * Thu Oct 23 2008 Shu KONNO <owa@bg.wakwak.com> 1.7-22
  79. - spec in utf-8
  80. * Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7-21
  81. - applied new versioning policy
  82. - added Patches from Fedora
  83. * Tue Mar 4 2008 Roman Rakus <rrakus@redhat.cz> - 1.7-33
  84. - Added patch from JW (redhat@zacglen.com), less nonverbose output
  85. * Tue Feb 27 2007 Karsten Hopp <karsten@redhat.com> 1.7-29
  86. - use make install DESTDIR=
  87. * Wed Jun 07 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7-20vl2
  88. - rebuilt with new toolchains
  89. - updated source URL
  90. * Wed Dec 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.7-20vl1
  91. - based on 1.7-20 from Rawhide and built for Vine Linux
  92. - added Japanese summary and description
  93. * Tue Nov 19 2002 Tim Powers <timp@redhat.com>
  94. - rebuild on all arches
  95. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  96. - automated rebuild
  97. * Wed Jun 19 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  98. - do not strip apps, do not compress info page
  99. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  100. - automated rebuild
  101. * Mon Feb 25 2002 Elliot Lee <sopwith@redhat.com>
  102. - Remove HAVE_WAIT3 hack, tried to replace it with a requirement for an
  103. autoconf with the fixed test, didn't work, put in another less-bad hack
  104. instead.
  105. * Wed Dec 05 2001 Tom Tromey <tromey@redhat.com>
  106. - Bump release, force HAVE_WAIT3 to be defined at build time
  107. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  108. - Bump release + rebuild.
  109. * Wed Jan 31 2001 Preston Brown <pbrown@redhat.com>
  110. - prereq install-info (#24715)
  111. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  112. - automatic rebuild
  113. * Thu Jun 29 2000 Preston Brown <pbrown@redhat.com>
  114. - using / as the file manifesto has weird results.
  115. * Sun Jun 4 2000 Jeff Johnson <jbj@redhat.com>
  116. - FHS packaging.
  117. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  118. - auto rebuild in the new build environment (release 9)
  119. * Mon Aug 10 1998 Erik Troan <ewt@redhat.com>
  120. - buildrooted and defattr'd
  121. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  122. - translations modified for de, fr, tr
  123. * Mon Oct 27 1997 Cristian Gafton <gafton@redhat.com>
  124. - fixed info handling
  125. * Thu Oct 23 1997 Cristian Gafton <gafton@redhat.com>
  126. - updated the spec file; added info file handling
  127. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  128. - built against glibc