thunderbird-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792
  1. # do not include minor version number in MOZILLA_FIVE_HOME
  2. %define tbmajor 3.1
  3. %define tbversion %{tbmajor}.7
  4. %define tbrelease 1%{?_dist_release}
  5. # The tarball is pretty inconsistent with directory structure.
  6. # Sometimes there is a top level directory. That goes here.
  7. #
  8. # IMPORTANT: If there is no top level directory, this should be
  9. # set to the cwd, ie: '.'
  10. #%define tarballdir .
  11. %define tarballdir comm-1.9.2
  12. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  13. %define moz_objdir objdir-tb
  14. %define version_internal 3.1
  15. %define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
  16. %define desktop_file_utils_version 0.6
  17. %define nspr_version 4.8
  18. %define nss_version 3.12.6
  19. %define cairo_version 1.6.0
  20. %define freetype_version 2.1.9
  21. %define sqlite_version 3.6.14
  22. %define libnotify_version 0.4
  23. %define build_vineseed 0
  24. %define build_vine5 0
  25. %if "%{?_dist_release}" == "vl6"
  26. %define build_vineseed 1
  27. %endif
  28. %if "%{?_dist_release}" == "vl5"
  29. %define build_vine5 1
  30. %endif
  31. Summary: Thunderbird Community Edition, Mail/newsgroup client
  32. Summary(ja): Thunderbirdコミュニティエディション, メール・ニュースクライアント
  33. Name: thunderbird
  34. Version: %{tbversion}
  35. Release: %{tbrelease}
  36. URL: http://www.mozilla.org/projects/thunderbird/
  37. License: MPL
  38. Group: Applications/Internet
  39. Source0: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
  40. #Source1010: mozconfig-thunderbird-vine3
  41. #Source1020: mozconfig-thunderbird-vine4
  42. Source1030: mozconfig-thunderbird-vine5
  43. Source1040: mozconfig-thunderbird-vine6
  44. Source12: thunderbird-vine-default-prefs.js
  45. Source20: thunderbird.desktop
  46. Source21: thunderbird.vine.sh.in
  47. #Source22: thunderbird.png
  48. Source30: thunderbird-open-browser.sh
  49. Source40: thunderbird-unofficial-brandig-tb-brand.properties
  50. Source41: thunderbird-unofficial-brandig-tb-brand.dtd
  51. Source100: find-external-requires
  52. # locale sources
  53. %define MOZ_BUILD_LOCALES "ja"
  54. # get from mercurial repository with command,
  55. # mkdir l10n
  56. # hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
  57. Source1000: thunderbird-%{tbversion}-ja.tar.bz2
  58. # upstream patch
  59. # Fix for version issues
  60. Patch0: thunderbird-version.patch
  61. # Fix for jemalloc
  62. Patch1: mozilla-jemalloc.patch
  63. # Fix for installation fail when building with dynamic linked libraries
  64. Patch2: thunderbird-shared-error.patch
  65. # Fixes gcc complain that nsFrame::delete is protected
  66. Patch4: xulrunner-1.9.2.1-build.patch
  67. # Fix for building with libjpeg-turbo
  68. Patch5: mozilla-libjpeg-turbo.patch
  69. # customization patches
  70. #Patch22: firefox-1.0-psfonts.patch
  71. #Patch24: thunderbird-2.0-default-applications.patch
  72. #Patch25: thunderbird-1.1-software-update.patch
  73. Patch26: firefox-1.5-default-a4-paper.patch
  74. # font system fixes
  75. #Patch81: firefox-nopangoxft.patch
  76. ## Vine patch
  77. # http://bugzilla.mozilla.org/show_bug.cgi?id=179248
  78. Patch1000: thunderbird-3.1-sjisalias.patch
  79. # use /proc/net/netstat for random seed instead of netstat command.
  80. #Patch1010: firefox-nss-no_netstat.patch
  81. # workaround gcc visibility hidden bugs (see gcc#26905)
  82. Patch1020: firefox-2.0.0.3-visibility.patch
  83. # temporary fix for compilation error with PR_STATIC_ASSERT
  84. # refer http://bugs.gentoo.org/show_bug.cgi?id=336413
  85. Patch1030: thunderbird-3.1.3-fix-prlog-include-error.patch
  86. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  87. BuildRequires: pango-devel
  88. BuildRequires: cairo-devel >= %{cairo_version}
  89. %if %{build_vineseed}
  90. BuildRequires: nspr-devel >= %{nspr_version}
  91. BuildRequires: nss-devel >= %{nss_version}
  92. %endif
  93. BuildRequires: pixman-devel
  94. BuildRequires: libpng-devel
  95. BuildRequires: libjpeg-devel
  96. BuildRequires: gtk2-devel
  97. BuildRequires: zlib-devel, gzip, zip, unzip
  98. BuildRequires: libIDL-devel
  99. BuildRequires: freetype2-devel >= %{freetype_version}
  100. ## disabled libnotify support
  101. ## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
  102. #BuildRequires: libnotify-devel >= %{libnotify_version}
  103. BuildRequires: bzip2-devel
  104. BuildRequires: gnome-vfs2-devel
  105. BuildRequires: libgnome-devel
  106. BuildRequires: libgnomeui-devel
  107. BuildRequires: krb5-devel
  108. BuildRequires: pango-devel
  109. BuildRequires: libXt-devel
  110. BuildRequires: libXrender-devel
  111. # hunspell is in plus category for vine
  112. #BuildRequires: hunspell-devel
  113. BuildRequires: sqlite3-devel >= %{sqlite_version}
  114. BuildRequires: startup-notification-devel
  115. BuildRequires: desktop-file-utils
  116. BuildRequires: alsa-lib-devel
  117. Requires: sqlite3 >= %{sqlite_version}
  118. Requires(post): desktop-file-utils >= %{desktop_file_utils_version}
  119. Requires(postun): desktop-file-utils >= %{desktop_file_utils_version}
  120. Obsoletes: MozillaThunderbird
  121. Provides: MozillaThunderbird = %{version}
  122. Packager: daisuke, ryoichi, kazutaka
  123. AutoProv: 0
  124. %define _use_internal_dependency_generator 0
  125. %define __find_requires %{SOURCE100}
  126. %description
  127. Thunderbird is a standalone mail and newsgroup client.
  128. %description -l ja
  129. Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
  130. #===============================================================================
  131. %prep
  132. %setup -q %{name}-%{version} -c -b 1000
  133. cd %{tarballdir}
  134. # Fix for version issue
  135. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
  136. > version.patch
  137. %{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
  138. %patch1 -p0 -b .jemalloc
  139. %patch2 -p1 -b .shared-error
  140. %patch4 -p1 -b .protected
  141. cd mozilla
  142. %patch5 -p1 -b .libjpeg-turbo
  143. #%patch22 -p1
  144. #%patch24 -p1
  145. #%patch25 -p0
  146. %patch26 -p1 -b .default-a4
  147. %patch1000 -p1 -b .sjis-alias
  148. %patch1030 -p3 -b .prlog-fix
  149. cd -
  150. %{__rm} -f .mozconfig
  151. %if %{build_vine5}
  152. %{__cp} %{SOURCE1030} .mozconfig
  153. %endif
  154. %if %{build_vineseed}
  155. %{__cp} %{SOURCE1040} .mozconfig
  156. # cannot build with xulrunner (yet)
  157. # see tracking bugs.
  158. # https://bugzilla.mozilla.org/show_bug.cgi?id=306324
  159. # https://bugzilla.mozilla.org/show_bug.cgi?id=377319
  160. #echo "ac_add_options --with-libxul-sdk=`pkg-config --variable=sdkdir libxul`" >> .mozconfig
  161. %endif
  162. # setup unofficial branding name
  163. %{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
  164. %{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
  165. #===============================================================================
  166. %build
  167. cd %{tarballdir}
  168. INTERNAL_GECKO=%{version_internal}
  169. MOZ_APP_DIR=%{mozappdir}
  170. #MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
  171. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
  172. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  173. export CFLAGS="$RPM_OPT_FLAGS"
  174. export CXXFLAGS="$CFLAGS"
  175. export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
  176. %ifarch ppc ppc64 s390 s390x
  177. %define moz_make_flags -j1
  178. %else
  179. %define moz_make_flags %{?_smp_mflags}
  180. %endif
  181. export PREFIX='%{_prefix}'
  182. export LIBDIR='%{_libdir}'
  183. export LDFLAGS="-Wl,-rpath,%{mozappdir}"
  184. export MAKE="gmake %{moz_make_flags}"
  185. %{__make} -f client.mk build
  186. # build locales
  187. LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  188. sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  189. for dir in $LOCALEDIRS
  190. do
  191. for lang in %{MOZ_BUILD_LOCALES} ; do
  192. make -C $dir/locales AB_CD=$lang
  193. done
  194. done
  195. #===============================================================================
  196. %install
  197. %{__rm} -rf $RPM_BUILD_ROOT
  198. cd %{tarballdir}
  199. INTERNAL_GECKO=%{version_internal}
  200. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  201. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  202. cd %{moz_objdir}
  203. DESTDIR=$RPM_BUILD_ROOT make install
  204. # install unofficial icons
  205. cd -
  206. %{__cp} mail/branding/unofficial/mailicon16.png \
  207. $RPM_BUILD_ROOT/%{mozappdir}/icons/
  208. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
  209. %{__cp} mail/branding/unofficial/mailicon16.png \
  210. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  211. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
  212. %{__cp} mail/branding/unofficial/mailicon22.png \
  213. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  214. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
  215. %{__cp} mail/branding/unofficial//mailicon24.png \
  216. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  217. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  218. %{__cp} mail/branding/unofficial/mailicon32.png \
  219. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  220. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
  221. %{__cp} mail/branding/unofficial/mailicon48.png \
  222. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  223. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
  224. %{__cp} mail/branding/unofficial/mailicon256.png \
  225. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  226. desktop-file-install --vendor vine \
  227. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  228. --add-category Application \
  229. --add-category Network \
  230. %{SOURCE20}
  231. # set up the thunderbird start script
  232. rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  233. %{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
  234. $RPM_BUILD_ROOT%{_bindir}/thunderbird
  235. %{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  236. install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  237. %{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  238. %{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
  239. -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
  240. $RPM_BUILD_ROOT/vine-default-prefs
  241. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
  242. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
  243. %{__rm} $RPM_BUILD_ROOT/vine-default-prefs
  244. %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
  245. # own mozilla plugin dir (#135050)
  246. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
  247. # own extension directories
  248. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
  249. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
  250. # install locales
  251. for lang in %{MOZ_BUILD_LOCALES} ; do
  252. %{__install} -p -D -m 664 %{moz_objdir}/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
  253. done
  254. %clean
  255. %{__rm} -rf $RPM_BUILD_ROOT
  256. #===============================================================================
  257. %post
  258. update-desktop-database &> /dev/null || :
  259. touch --no-create %{_datadir}/icons/hicolor
  260. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  261. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  262. fi
  263. %postun
  264. update-desktop-database &> /dev/null || :
  265. touch --no-create %{_datadir}/icons/hicolor
  266. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  267. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  268. fi
  269. %files
  270. %defattr(-,root,root,-)
  271. %attr(755,root,root) %{_bindir}/thunderbird
  272. %attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
  273. %{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  274. %{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  275. %{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  276. %{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  277. %{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  278. %{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  279. %{mozappdir}
  280. #===============================================================================
  281. %changelog
  282. * Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
  283. - new upstream release with security fix
  284. * Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
  285. - new upstream release with security fix
  286. * Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
  287. - new upstream release with security fix
  288. - add patch5 to fix build failure
  289. * Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
  290. - new upstream release
  291. * Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
  292. - new upstream release with security fix
  293. - add Patch1030 to fix compilation error
  294. * Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
  295. - change mozconfig (Source1030 & 1040): add --enable-jsd
  296. * Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
  297. - new upstream release
  298. * Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
  299. - new upstream release with security fix
  300. - add Patch0 from fedora development: fix version issue
  301. - remove BuildRequires: hunspell-devel
  302. - update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
  303. * Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
  304. - add BuildRequires: alsa-lib-devel
  305. - remove BuildRequires: libnotify-devel
  306. (workaround for known bug)
  307. - update mozconfig to add --disable-libnotify option
  308. * Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
  309. - new upstream release
  310. - update spec entirely
  311. - import patches from fedora (Patch1, 2 & 4)
  312. - drop outdated patches (Patch22, 24)
  313. - update Sources:
  314. - mozconfig (Source1030 & Source1040)
  315. - default prefs.js (Source12)
  316. - unofficial branding (Source40 & Source41)
  317. - japanese translation (Source1000)
  318. - update Patch1000 (sjis-alias)
  319. * Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
  320. - new upstream release
  321. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
  322. - new upstream release
  323. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
  324. - don't install official branding logos
  325. * Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
  326. - add necessary icons in %%{tbdir}/chrome/icons/default
  327. - add Packager tag
  328. * Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
  329. - new upstream release
  330. * Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
  331. - new upstream release
  332. * Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
  333. - new upstream release
  334. * Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
  335. - new upstream release
  336. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
  337. - rebuilt for VineSeed
  338. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
  339. - new upstream release
  340. * Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
  341. - new upstream release
  342. - built for Vine Linux 4.x
  343. - dropped Patch1020 (merged into upstream)
  344. * Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
  345. - added Patch1020 for workaround gcc visibility hidden bugs
  346. * Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
  347. - build with new environment/toolchain
  348. - add build options to build with external nss/nspr libraries
  349. ac_add_options --with-system-nspr
  350. ac_add_options --with-system-nss
  351. * Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
  352. - new upstream release
  353. * Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
  354. - new upstream release
  355. * Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
  356. - new upstream release
  357. * Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
  358. - new upstream release
  359. * Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
  360. - new upstream release
  361. - merge changes from firefox
  362. - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
  363. * Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
  364. - new upstream release
  365. - build en-US locale
  366. - merge changes from firefox
  367. - add upstream patches
  368. - disable pango rendering by default
  369. (workaround fix slow rendering in some page)
  370. * Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
  371. - initial build for Vine Linux based on FC package
  372. - update to 1.5RC2
  373. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
  374. - Fix issue with popup dialogs and other actions causing lockups
  375. * Sat Nov 5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
  376. - Update to 1.5 rc1
  377. * Sat Oct 8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
  378. - Update to 1.5 beta2
  379. * Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
  380. - Update to 1.5 beta1
  381. - Bring the install phase of the spec file up to speed
  382. * Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
  383. - Rebuild
  384. * Sat Aug 6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
  385. - Add patch to make file chooser dialog modal
  386. * Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
  387. - Update to 1.0.6
  388. * Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
  389. - 1.0.6 Release Candidate
  390. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
  391. - Use system NSPR
  392. - Fix crash on 64bit platforms (#160330)
  393. * Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com> 1.0.2-7
  394. - Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
  395. references, fixing the "no fonts" problem.
  396. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
  397. - Change the Exec line in the desktop file to `thunderbird`
  398. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
  399. - Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
  400. * Mon May 9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
  401. - Add temporary workaround to not create files in the user's $HOME (#149664)
  402. * Wed May 4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
  403. - Don't have downloads "disappear" when downloading to desktop (#139015)
  404. - Fix for some more cursor issues in textareas (149991, 150002, 152089)
  405. - Add upstream patch to fix bidi justification of pango
  406. - Add patch to fix launching of helper applications
  407. - Add patch to properly link against libgfxshared_s.a
  408. - Fix multilib conflicts
  409. * Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
  410. - correct confusing PANGO vars in startup script
  411. * Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
  412. - Thunderbird 1.0.2
  413. * Tue Mar 8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
  414. - Add patch to compile against new fortified glibc macros
  415. * Sat Mar 5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
  416. - Rebuild against GCC 4.0
  417. - Add execshield patches
  418. - Minor specfile cleanup
  419. * Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
  420. - Rebuild
  421. * Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
  422. - Add RPM version to useragent
  423. * Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
  424. - Port over pango patches from firefox
  425. * Wed Dec 8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
  426. - Thunderbird 1.0
  427. * Mon Dec 6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
  428. - Fix advanced prefs
  429. * Fri Dec 3 2004 Christopher Aillon <caillon@redhat.com>
  430. - Make this run on s390(x) now for real
  431. * Wed Dec 1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
  432. - Update to 1.0 rc1
  433. * Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
  434. - Add patches to build and run on s390(x)
  435. * Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
  436. - Rebuild to fix file chooser
  437. * Fri Nov 5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
  438. - Update to 0.9
  439. * Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
  440. - Prevent inlining of stack direction detection (#135255)
  441. * Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
  442. - More file chooser fixes (same as in firefox)
  443. - Fix for upstream 28327.
  444. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  445. - Update the pango patch
  446. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  447. - Pull over patches from firefox build:
  448. - disable default application dialog
  449. - don't include software update since it doesn't work
  450. - make external app support work
  451. * Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
  452. - Use pango for rendering
  453. * Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
  454. - Fix for 64 bit crash at startup (b.m.o #256603)
  455. * Sat Oct 9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
  456. - Add patches to fix xremote (#135036)
  457. * Fri Oct 8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
  458. - Add patch to fix button focus issues (#133507)
  459. - Add patch for fix IMAP race issues (bmo #246439)
  460. * Fri Oct 1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
  461. - filter out library Provides: and internal Requires:
  462. * Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
  463. - Backport the GTK+ File Chooser.
  464. - Add fix for JS math on x86_64 systems
  465. - Add pkgconfig patch
  466. * Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
  467. - Update to 0.8.0
  468. - Remove enigmail
  469. - Update BuildRequires
  470. - Remove gcc34 and extension manager patches -- they are upstreamed.
  471. - Fix for gnome-vfs2 error at component registration
  472. * Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
  473. - Build with --disable-xprint
  474. * Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
  475. - remove all Xvfb-related hacks
  476. * Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
  477. - actually apply psfonts
  478. - add mozilla gnome-uriloader patch to prevent build failure
  479. * Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
  480. - rawhide import
  481. - apply NetBSD's freetype 2.1.8 patch
  482. - apply psfonts patch
  483. - remove BR on /usr/bin/ex, breaks beehive
  484. * Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
  485. - oops, fix %%install
  486. * Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
  487. - update to Thunderbird 0.7.3 and Enigmail 0.85.0
  488. - remove XUL.mfasl on startup, add Debian enigmail patches
  489. - add Xvfb hack for -install-global-extension
  490. * Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
  491. - update to 0.7.2, just because it's there
  492. - update gcc-3.4 patch (Kaj Niemi)
  493. - add EM registration patch and remove instdir hack
  494. * Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
  495. - re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
  496. * Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
  497. - update to 0.7.1
  498. - remove Enigmail
  499. * Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
  500. - re-enable Enigmail 0.84.1
  501. - add gcc-3.4 patch (Kaj Niemi)
  502. - use official branding (with permission)
  503. * Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
  504. - update to 0.7
  505. - temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
  506. - specify libdir, change BR for apt (V. Skytt辰, #1617)
  507. * Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
  508. - temporary workaround for enigmail skin "modern" bug
  509. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
  510. - update to Enigmail 0.84.0
  511. - update launch script
  512. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
  513. - installation directory now versioned
  514. - allow root to run the program (for installing extensions)
  515. - remove unnecessary %%pre and %%post
  516. - remove separators, update mozconfig and launch script (M. Schwendt, #1460)
  517. * Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
  518. - include Enigmail, re-add release notes
  519. - delete %{_libdir}/thunderbird in %%pre
  520. * Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
  521. - update to Thunderbird 0.6
  522. * Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
  523. - update to Thunderbird 0.6 RC1
  524. - add new icon, remove release notes
  525. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
  526. - update to latest CVS, update mozconfig and %%build accordingly
  527. - update to Enigmail 0.83.6
  528. - remove x-remote and x86_64 patches
  529. - build with -Os
  530. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
  531. - update x-remote patch
  532. - more startup script fixes
  533. * Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
  534. - startup script fixes, and a minor cleanup
  535. * Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
  536. - Minor cleanups
  537. * Sun Apr 04 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.8
  538. - minor improvements to open-browser.sh and startup script
  539. - update to latest version of Blizzard's x-remote patch
  540. * Thu Mar 25 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.7
  541. - update open-browser.sh, startup script, and BuildRequires
  542. * Sun Mar 14 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.6
  543. - update open-browser script, modify BuildRequires (Warren)
  544. - add Blizzard's x-remote patch
  545. - initial attempt at x-remote-enabled startup script
  546. * Sun Mar 07 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.5
  547. - refuse to run with excessive privileges
  548. * Fri Feb 27 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.4
  549. - add Mozilla x86_64 patch (Oliver Sontag)
  550. - Enigmail source filenames now include the version
  551. - modify BuildRoot
  552. * Thu Feb 26 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.3
  553. - use the updated official tarball
  554. * Wed Feb 18 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.2
  555. - fix %%prep script
  556. * Mon Feb 16 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.1
  557. - update Enigmail to 0.83.3
  558. - use official source tarball (after removing the CRLFs)
  559. - package renamed to thunderbird
  560. * Mon Feb 09 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.0
  561. - update to 0.5
  562. - check for lockfile before launching
  563. * Fri Feb 06 2004 David Hill <djh[at]ii.net>
  564. - update to latest cvs
  565. - update to Enigmail 0.83.2
  566. * Thu Jan 29 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.5
  567. - update to Enigmail 0.83.1
  568. - removed Mozilla/Firebird script patching
  569. * Sat Jan 03 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.4
  570. - add startup notification to .desktop file
  571. * Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
  572. - open-browser.sh release 3
  573. - patch broken /usr/bin/mozilla script during install
  574. - dir ownership
  575. - XXX: Source fails build on x86_64... fix later
  576. * Tue Dec 23 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.2
  577. - update to Enigmail 0.82.5
  578. - add Warren's open-browser.sh (#1113)
  579. * Tue Dec 09 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.1
  580. - use Thunderbird's mozilla-xremote-client to launch browser
  581. * Sun Dec 07 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.0
  582. - update to 0.4
  583. - make hyperlinks work (with recent versions of Firebird/Mozilla)
  584. * Thu Dec 04 2003 David Hill <djh[at]ii.net>
  585. - update to 0.4rc2
  586. * Wed Dec 03 2003 David Hill <djh[at]ii.net>
  587. - update to 0.4rc1 and Enigmail 0.82.4
  588. * Thu Nov 27 2003 David Hill <djh[at]ii.net>
  589. - update to latest CVS and Enigmail 0.82.3
  590. * Sun Nov 16 2003 David Hill <djh[at]ii.net>
  591. - update to latest CVS (0.4a)
  592. - update Enigmail to 0.82.2
  593. - alter mozconfig for new build requirements
  594. - add missing BuildReq (#987)
  595. * Thu Oct 16 2003 David Hill <djh[at]ii.net> 0:0.3-0.fdr.0
  596. - update to 0.3
  597. * Sun Oct 12 2003 David Hill <djh[at]ii.net> 0:0.3rc3-0.fdr.0
  598. - update to 0.3rc3
  599. - update Enigmail to 0.81.7
  600. * Thu Oct 02 2003 David Hill <djh[at]ii.net> 0:0.3rc2-0.fdr.0
  601. - update to 0.3rc2
  602. * Wed Sep 17 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.2
  603. - simplify startup script
  604. * Wed Sep 10 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.1
  605. - add GPG support (Enigmail 0.81.6)
  606. - specfile fixes (#679)
  607. * Thu Sep 04 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.0
  608. - update to 0.2
  609. * Mon Sep 01 2003 David Hill <djh[at]ii.net>
  610. - initial RPM
  611. (based on the fedora MozillaFirebird-0.6.1 specfile)