libproxy-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317
  1. %bcond_with mozjs
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: A library handling all the details of proxy configuration
  4. Name: libproxy
  5. Version: 0.4.15
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: LGPLv2+
  9. URL: http://libproxy.github.io/libproxy
  10. Source0: https://github.com/libproxy/libproxy/releases/download/%{version}/libproxy-%{version}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. BuildRequires: python-devel
  13. BuildRequires: python3-devel
  14. #Virtual Provides - We need either mozjs or WebKit
  15. %if %{with mozjs}
  16. Requires: %{name}-pac >= %{version}
  17. %endif
  18. #
  19. Requires: libproxy-python = %{version}-%{release}
  20. Requires: libproxy-bin = %{version}-%{release}
  21. Obsoletes: %{name}-mozjs < 1.4.15
  22. Obsoletes: %{name}-webkitgtk3 < 1.4.15
  23. BuildRequires: cmake
  24. # gnome
  25. BuildRequires: GConf2-devel
  26. %if %{with mozjs}
  27. # mozjs
  28. BuildRequires: mozjs >= 38
  29. %endif
  30. # NetworkManager
  31. BuildRequires: NetworkManager-devel
  32. BuildRequires: dbus-devel
  33. BuildRequires: glib2
  34. # webkit (gtk)
  35. BuildRequires: webkitgtk4-devel
  36. # kde
  37. BuildRequires: kdelibs-devel
  38. BuildRequires: libXmu-devel
  39. BuildRequires: libX11-devel
  40. BuildRequires: python-rpm-macros
  41. BuildRequires: python3-rpm-macros
  42. Provides: %{name}-webkit = %{version}-%{release}
  43. Obsoletes: %{name}-webkit < %{version}-%{release}
  44. Vendor: Project Vine
  45. Distribution: Vine Linux
  46. %description
  47. libproxy offers the following features:
  48. * extremely small core footprint (< 35K)
  49. * no external dependencies within libproxy core
  50. (libproxy plugins may have dependencies)
  51. * only 3 functions in the stable external API
  52. * dynamic adjustment to changing network topology
  53. * a standard way of dealing with proxy settings across all scenarios
  54. * a sublime sense of joy and accomplishment
  55. Non-default rpmbuild options:
  56. --with webkit: Enable WebKit-gtk support
  57. %package bin
  58. Summary: Binary to test %{name}
  59. Group: Applications/System
  60. Requires: %{name} = %{version}-%{release}
  61. %description bin
  62. The %{name}-bin package contains the proxy binary for %{name}
  63. %package python
  64. Summary: Binding for %{name} and python
  65. Group: System Environment/Libraries
  66. Requires: %{name} = %{version}-%{release}
  67. %description python
  68. The %{name}-python package contains the python binding for %{name}
  69. %package python3
  70. Summary: Binding for %{name} and python
  71. Group: System Environment/Libraries
  72. Requires: %{name} = %{version}-%{release}
  73. %description python3
  74. The %{name}-python package contains the python binding for %{name}
  75. %package gnome
  76. Summary: Plugin for %{name} and gnome
  77. Group: System Environment/Libraries
  78. Requires: %{name} = %{version}-%{release}
  79. %description gnome
  80. The %{name}-gnome package contains the %{name} plugin for gnome.
  81. %package kde
  82. Summary: Plugin for %{name} and kde
  83. Group: System Environment/Libraries
  84. Requires: %{name} = %{version}-%{release}
  85. %description kde
  86. The %{name}-kde package contains the %{name} plugin for kde.
  87. %if %{with mozjs}
  88. %package mozjs
  89. Summary: Plugin for %{name} and mozjs
  90. Group: System Environment/Libraries
  91. Requires: %{name} = %{version}
  92. #Tweak this according to the current gecko-libs version
  93. Requires: js
  94. Provides: %{name}-pac = %{version}-%{release}
  95. %description mozjs
  96. The %{name}-mozjs package contains the %{name} plugin for mozjs.
  97. %package webkitgtk4
  98. Summary: Plugin for %{name} and webkitgtk4
  99. Group: System Environment/Libraries
  100. Requires: %{name} = %{version}
  101. Provides: %{name}-pac = %{version}-%{release}
  102. %description webkitgtk4
  103. The %{name}-webkitgtk3 package contains the %{name} plugin for
  104. webkitgtk3.
  105. %endif
  106. %package devel
  107. Summary: Development files for %{name}
  108. Group: Development/Libraries
  109. Requires: %{name} = %{version}-%{release}
  110. Requires: pkgconfig
  111. %description devel
  112. The %{name}-devel package contains libraries and header files for
  113. developing applications that use %{name}.
  114. %prep
  115. %setup -q
  116. #sed -i "s|mozjs185>=1.8.5|mozjs185|" libproxy/cmake/modules/pacrunner_mozjs.cmk
  117. %build
  118. %cmake \
  119. -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
  120. -DMODULE_INSTALL_DIR=%{_libdir}/%{name}/%{version}/modules \
  121. -DWITH_PERL=OFF \
  122. -DWITH_WEBKIT3=ON \
  123. -DWITH_KDE=ON \
  124. .
  125. make VERBOSE=1 %{?_smp_mflags}
  126. %install
  127. rm -rf $RPM_BUILD_ROOT
  128. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  129. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  130. %clean
  131. rm -rf $RPM_BUILD_ROOT
  132. %post -p /sbin/ldconfig
  133. %postun -p /sbin/ldconfig
  134. %files
  135. %defattr(-,root,root,-)
  136. %doc AUTHORS COPYING README
  137. %{_libdir}/*.so.*
  138. %dir %{_libdir}/%{name}
  139. %dir %{_libdir}/%{name}/%{version}
  140. %dir %{_libdir}/%{name}/%{version}/modules
  141. %{_libdir}/%{name}/%{version}/modules/network_networkmanager.so
  142. %files bin
  143. %defattr(-,root,root,-)
  144. %{_bindir}/proxy
  145. %files python
  146. %defattr(-,root,root,-)
  147. %{python_sitelib}/libproxy.py
  148. %files python3
  149. %defattr(-,root,root,-)
  150. %{python3_sitelib}/libproxy.py
  151. %files gnome
  152. %defattr(-,root,root,-)
  153. %{_libdir}/%{name}/%{version}/modules/config_gnome3.so
  154. %{_libexecdir}/pxgsettings
  155. %files kde
  156. %defattr(-,root,root,-)
  157. %{_libdir}/%{name}/%{version}/modules/config_kde.so
  158. # Build the pacrunner into libproxy unless we are building for multiple engines
  159. %if %{with mozjs}
  160. %files mozjs
  161. %defattr(-,root,root,-)
  162. %{_libdir}/%{name}/%{version}/modules/pacrunner_mozjs.so
  163. %files webkitgtk4
  164. %defattr(-,root,root,-)
  165. %{_libdir}/%{name}/%{version}/modules/pacrunner_webkit.so
  166. %endif
  167. %files devel
  168. %defattr(-,root,root,-)
  169. %{_includedir}/proxy.h
  170. %{_libdir}/*.so
  171. %{_libdir}/pkgconfig/libproxy-1.0.pc
  172. %{_datadir}/cmake/Modules/Findlibproxy.cmake
  173. %changelog
  174. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.15-1
  175. - updated to 0.4.15.
  176. - enabled python3 support.
  177. - disabled mozjs as default.
  178. - switched to webkitgtk4.
  179. * Thu Jul 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-2
  180. - rebuild with gcc-5.4.0
  181. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
  182. - update to 0.4.11
  183. - remove Patch0 (libproxy-0.4.7-cmake-modules.patch)
  184. * Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-2
  185. - rebuild with python-2.7.2
  186. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.7-1
  187. - new upstream release
  188. - change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
  189. - change BuildRequires: js-devel instead of gecko-devel
  190. - replace Patch0 (libproxy-0.4.7-cmake-modules.patch)
  191. - detele -webkit sub package
  192. - create -webkitgtk3 sub package
  193. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.6-1
  194. - new upstream release
  195. - drop Patch0
  196. - add BuildRequires: cmake, kdelibs-devel
  197. - fix %files (from %{_libdir}/%{name}/%{version}/plugins to %{_libdir}/%{name}/%{version}/modules)
  198. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.3-5
  199. - rebuild with rpm-4.8.1 for pkg-config file
  200. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.2.3-4
  201. - rebuild with python-2.6
  202. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-3
  203. - rebuild with gecko-1.9.1
  204. * Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-2
  205. - rebuild with WebKit-gtk-1.0.0-8.svn41944
  206. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.3-1
  207. - initial build for Vine Linux
  208. * Mon Mar 9 2009 kwizart < kwizart at gmail.com > - 0.2.3-10
  209. - Rebuild for webkit
  210. - Raise requirement for xulrunner to 1.9.1
  211. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-9
  212. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  213. * Thu Jan 22 2009 kwizart < kwizart at gmail.com > - 0.2.3-8
  214. - Merge NetworkManager module into the main libproxy package
  215. - Main Requires the -python and -bin subpackage
  216. (splitted for multilibs compliance).
  217. * Fri Oct 24 2008 kwizart < kwizart at gmail.com > - 0.2.3-7
  218. - Disable Gnome/KDE default support via builtin modules.
  219. (it needs to be integrated via Gconf2/neon instead).
  220. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-6
  221. - Disable Obsoletes.
  222. - Requires ev instead of evr for optionnals sub-packages.
  223. * Tue Oct 21 2008 kwizart < kwizart at gmail.com > - 0.2.3-5
  224. - Use conditionals build.
  225. * Mon Sep 15 2008 kwizart < kwizart at gmail.com > - 0.2.3-4
  226. - Remove plugin- in the name of the packages
  227. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-3
  228. - Move proxy.h to libproxy/proxy.h
  229. This will prevent it to be included in the default include path
  230. - Split main to libs and util and use libproxy to install all
  231. * Mon Aug 4 2008 kwizart < kwizart at gmail.com > - 0.2.3-2
  232. - Rename binding-python to python
  233. - Add Requires: gecko-libs >= %%{gecko_version}
  234. - Fix some descriptions
  235. - Add plugin-webkit package
  236. * Fri Jul 11 2008 kwizart < kwizart at gmail.com > - 0.2.3-1
  237. - Convert to Fedora spec
  238. * Fri Jun 6 2008 - dominique-rpm@leuenberger.net
  239. - Updated to version 0.2.3
  240. * Wed Jun 4 2008 - dominique-rpm@leuenberger.net
  241. - Extended spec file to build all available plugins
  242. * Tue Jun 3 2008 - dominique-rpm@leuenberger.net
  243. - Initial spec file for Version 0.2.2