ltris-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. ## -*- coding: utf-8-unix -*-
  2. Summary: Tetlis game with multiplayer mode
  3. Summary(ja): 対戦型テトリス
  4. Name: ltris
  5. Version: 1.0.18
  6. Release: 1%{?_dist_release}
  7. Source0: %{name}-%{version}.tar.gz
  8. License: GPL
  9. Group: Applications/Games
  10. URL: http://lgames.sourceforge.net/
  11. Requires(post,postun): desktop-file-utils
  12. Requires: SDL
  13. Requires: SDL_mixer
  14. BuildRequires: SDL-devel
  15. BuildRequires: SDL_mixer-devel
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. Packager: munepi
  18. %description
  19. LTris as a tetris clone: differently shaped blocks are falling down the
  20. rectangular playing field and can be moved sideways or rotated by 90 degree
  21. units with the aim of building lines without gaps which then disappear
  22. (causing any block above the deleted line to fall down). LTris has three
  23. game modes: In Classic you play until the stack of blocks reaches the top
  24. of the playing field and no new blocks can enter. In Figures the playing
  25. field is reset to a new figure each level and later on tiles and lines
  26. suddenly appear. In Multiplayer up to three players (either human or CPU)
  27. compete with each other sending removed lines to all opponents. And in
  28. Demo you can watch your CPU playing while enjoying a cup of tea!
  29. %prep
  30. %__rm -rf ${RPM_BUILD_ROOT}
  31. %setup -q
  32. %build
  33. %configure --prefix=%{_prefix} \
  34. --localstatedir=%{_localstatedir}/games \
  35. ;
  36. %__make
  37. %install
  38. %__rm -rf ${RPM_BUILD_ROOT}
  39. %__make DESTDIR=${RPM_BUILD_ROOT} install
  40. %find_lang %{name}
  41. %clean
  42. %__rm -rf ${RPM_BUILD_ROOT}
  43. %post
  44. # touch --no-create %{_datadir}/icons/hicolor
  45. # if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  46. # %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  47. # fi
  48. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
  49. %postun
  50. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications
  51. # touch --no-create %{_datadir}/icons/hicolor
  52. # if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  53. # %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  54. # fi || :
  55. %files -f %{name}.lang
  56. %defattr(-,root,root)
  57. %doc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
  58. %{_bindir}/ltris
  59. %{_datadir}/applications/ltris.desktop
  60. %{_datadir}/icons/ltris48.gif
  61. %{_datadir}/%{name}/figures
  62. %{_datadir}/%{name}/gfx
  63. %{_datadir}/%{name}/sounds
  64. %ghost %{_localstatedir}/games/ltris.hscr
  65. %changelog
  66. * Mon Feb 13 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.18-1
  67. - new upstream release
  68. - fixed License tag
  69. - added Requires(post,postun): desktop-file-utils
  70. - moved game score file to /var/games
  71. * Sun Aug 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.17-1
  72. - new upstream release
  73. * Tue Mar 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.16-1
  74. - new upstream release
  75. * Mon Jan 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.15-1
  76. - new upstream release
  77. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0.14-1
  78. - new upstream release
  79. * Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.11-1vl5
  80. - applied new versioning policy, spec in utf-8
  81. * Sun Jun 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.11-0vl2
  82. - rebuild for VineSeed
  83. * Tue Mar 9 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.11-0vl1
  84. - initial build for Vine Linux
  85. # * Thu Oct 6 2005 1.0.11-0vl1
  86. # - initial build for Vine Linux
  87. # * Mon May 9 2005 1.0.10-0vl1
  88. # - initial build for Vine Linux
  89. # end of file