texlive-collection-langspanish-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199
  1. ## -*- coding: utf-8-unix -*-
  2. ## NOTE: This spec file is generated by tlpdb2rpmspec.sh 2009-1:
  3. ## tlpdb2rpmspec.sh collection-basic
  4. %bcond_with firstbuild
  5. %define tex_destdir %{_datadir}
  6. %define texmf %{tex_destdir}/texmf
  7. %define texlive_src %{tex_destdir}/texlive-sources
  8. %define build_tex_destdir %{buildroot}%{tex_destdir}
  9. %define build_texmf %{buildroot}%{texmf}
  10. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  11. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  12. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  13. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
  14. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  15. %define vartexfonts %{_var}/lib/texmf
  16. %define __find_provides %{nil}
  17. %define __find_requires %{nil}
  18. %define __perl_provides %{nil}
  19. %define __perl_requires %{nil}
  20. Autoreq: 0
  21. Summary: TeX Live: Spanish
  22. Summary(ja): TeX Live: Spanish
  23. Name: texlive-collection-langspanish
  24. Version: 2009
  25. Release: 1%{?_dist_release}
  26. License: LPPL
  27. Group: Applications/Publishing
  28. URL:http://www.tug.org/texlive/
  29. Requires: texlive = %{version}
  30. Requires: texlive-collection-basic = %{version}
  31. Requires(post): texlive = %{version}
  32. Requires(postun): texlive = %{version}
  33. BuildRequires: texlive-sources = %{version}
  34. BuildArch: noarch
  35. Buildroot: %{_tmppath}/%{name}-%{version}-root
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. Packager: munepi
  39. %description
  40. The TeX Live software distribution offers a complete TeX system for a
  41. variety of Unix, Macintosh, Windows and other platforms. It
  42. encompasses programs for editing, typesetting, previewing and printing
  43. of TeX documents in many different languages, and a large collection
  44. of TeX macros and font libraries.
  45. The distribution includes extensive general documentation about TeX,
  46. as well as the documentation for the included software packages.
  47. This package is a collection of Spanish:
  48. This package contains the following CTAN packages:
  49. hyphen-spanish: Standard hyphenation rules for Spanish.
  50. hyphen-catalan:
  51. hyphen-galician:
  52. spanish: Spanish in Babel.
  53. spanish-mx: Typeset Spanish as in Mexico.
  54. %description -l ja
  55. TeX Live ソフトウェアディストリビューションは、
  56. さまざまな Unix, Macintosh, Windows、および
  57. 他のプラットホームに対して完全な TeX システムを提供します。
  58. 多くの異なった言語を含む TeX ドキュメントの
  59. 編集、組版、閲覧、印刷するためのプログラム、
  60. そして、TeX マクロやフォントライブラリの大きなコレクションを
  61. 同梱しています。
  62. このディストリビューションは
  63. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  64. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  65. このパッケージは以下のようなパッケージ集です。
  66. Spanish:
  67. このパッケージは以下の CTAN パッケージを含んでいます:
  68. hyphen-spanish: Standard hyphenation rules for Spanish.
  69. hyphen-catalan:
  70. hyphen-galician:
  71. spanish: Spanish in Babel.
  72. spanish-mx: Typeset Spanish as in Mexico.
  73. %package doc
  74. Summary: TeX Live: Documentation files of %{name}
  75. Group: Applications/Publishing
  76. Requires: %{name} = %{version}-%{release}
  77. %description doc
  78. This package contains documentation files of %{name}.
  79. %prep
  80. %build
  81. %install
  82. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  83. PREF=%{buildroot}%{tex_destdir}
  84. manifest=(
  85. texmf-dist/doc/latex/spanish/README
  86. texmf-dist/doc/latex/spanish/doc/spanish.pdf
  87. texmf-dist/doc/latex/spanish/source/spanish.dtx
  88. texmf-dist/doc/latex/spanish/source/spanish.ins
  89. texmf-dist/doc/latex/spanish/tex/romanidx.sty
  90. texmf-dist/doc/latex/spanish/tex/spanish.ldf
  91. texmf-dist/doc/latex/spanish-mx/README
  92. texmf-dist/tex/latex/spanish-mx/esmx.cfg
  93. texmf-dist/tex/latex/spanish-mx/spanishmx.ldf
  94. texmf-dist/tex/latex/spanish-mx/spanishmx.sty
  95. )
  96. %__mkdir_p ${PREF}/texmf-dist
  97. for i in "${manifest[@]}"; do
  98. %__install -D %{texlive_src}/$i ${PREF}/$i
  99. done
  100. ## info
  101. %__rm -f %{buildroot}%{_infodir}/dir
  102. %__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
  103. ## man
  104. ## man t1* files are provided by t1utils
  105. for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
  106. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  107. done
  108. ## man some files are provided by psutils
  109. for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
  110. %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
  111. done
  112. ## remove asymptote directries, which provides asymptote package
  113. find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
  114. # find %{buildroot} -name "Makefile" | xargs %__rm -f
  115. # ## remove xindy
  116. # find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
  117. # ## remove tex4ht
  118. # find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
  119. ## remove unpackaging files
  120. find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
  121. find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
  122. ## Files list
  123. find %{buildroot} -type f -or -type l | \
  124. %__sed -e "s|%{buildroot}||g" > filelist.full
  125. find %{buildroot}%{texmf}-dist -type d | \
  126. %__sed -e "s|^%{buildroot}|%dir |" \
  127. -e "s|$|/|" >> filelist.full
  128. ## subpackages
  129. grep "/texmf-dist/doc/" filelist.full > filelist.doc
  130. cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
  131. %__mv -f filelist.tmp filelist.full
  132. %clean
  133. %__rm -rf %{buildroot}
  134. %post
  135. %{exec_texhash}
  136. echo -n " "
  137. echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  138. exit 0
  139. %postun
  140. if [ "$1" = 0 ]; then
  141. %{exec_texhash}
  142. fi
  143. exit 0
  144. %files -f filelist.full
  145. %defattr(-,root,root)
  146. %files -f filelist.doc doc
  147. %defattr(-,root,root)
  148. %changelog
  149. * Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  150. - generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langspanish