calibre-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Name: calibre
  3. Version: 0.8.50
  4. Release: 1%{?_dist_release}
  5. Summary: E-book converter and library management
  6. Group: Applications/Multimedia
  7. License: GPLv3
  8. URL: http://calibre-ebook.com/
  9. # SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  10. # Upstream packages some unfree fonts which we cannot redistribute.
  11. # While we're at it, also delete the liberation fonts which we already have.
  12. #
  13. # Download the upstream tarball and invoke this script while in the tarball's
  14. # directory:
  15. # ./generate-tarball.sh %{version}
  16. Source0: %{name}-%{version}-nofonts.tar.xz
  17. Source1: generate-tarball.sh
  18. Source2: calibre-mount-helper
  19. Patch0: %{name}-manpages.patch
  20. Patch1: %{name}-no-update.patch
  21. Patch2: calibre-0.8.21-poppler.patch
  22. Patch10: calibre-0.8.41-python27.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  24. BuildRequires: python >= 2.7.1
  25. BuildRequires: python-devel >= 2.7.1
  26. BuildRequires: ImageMagick-devel >= 6.5.9
  27. BuildRequires: python-setuptools
  28. BuildRequires: qt4-devel >= 4.7.0
  29. BuildRequires: PyQt4-devel >= 4.8.2
  30. BuildRequires: poppler-qt4-devel >= 0.12
  31. BuildRequires: podofo-devel >= 0.8.2
  32. BuildRequires: desktop-file-utils
  33. BuildRequires: python-mechanize >= 0.1.1
  34. BuildRequires: python-lxml >= 2.2.1
  35. BuildRequires: python-cssutils >= 0.9.6
  36. BuildRequires: python-dateutil >= 1.4.1
  37. BuildRequires: python-imaging >= 1.1.6
  38. BuildRequires: xdg-utils >= 1.0.2
  39. BuildRequires: python-BeautifulSoup >= 3.0.5
  40. BuildRequires: xz
  41. BuildRequires: unzip
  42. BuildRequires: libwmf-devel >= 0.2.8
  43. BuildRequires: chmlib-devel >= 0.40
  44. BuildRequires: python-cssutils > 0.9.6
  45. BuildRequires: sqlite3-devel
  46. BuildRequires: libicu-devel >= 4.4
  47. Requires: PyQt4
  48. Requires: pyPdf
  49. Requires: python-cherrypy
  50. Requires: python-cssutils
  51. Requires: ImageMagick
  52. Requires: python-odf
  53. Requires: python-django-tagging
  54. Requires: python-lxml
  55. Requires: python-imaging
  56. Requires: python-mechanize
  57. Requires: python-dateutil
  58. Requires: python-genshi
  59. Requires: python-BeautifulSoup
  60. ## vine
  61. Requires: TrueType-liberation
  62. %description
  63. Calibre is meant to be a complete e-library solution. It includes library
  64. management, format conversion, news feeds to ebook conversion as well as
  65. e-book reader sync features.
  66. Calibre is primarily a ebook cataloging program. It manages your ebook
  67. collection for you. It is designed around the concept of the logical book,
  68. i.e. a single entry in the database that may correspond to ebooks in several
  69. formats. It also supports conversion to and from a dozen different ebook
  70. formats.
  71. Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
  72. RTF, TXT, PDF and LRS.
  73. %prep
  74. %setup -q -n %{name}
  75. # don't append calibre1 to the name of the manpages. No need to compress either
  76. # upstream won't fix: http://bugs.calibre-ebook.com/ticket/3770#comment:7
  77. %patch0 -p1 -b .manpages
  78. # don't check for new upstream version (that's what packagers do)
  79. %patch1 -p1 -b .no-update
  80. # modify poppler checks
  81. %patch2 -p1 -b .poppler
  82. # use python2.7
  83. %patch10 -p1 -b .vine
  84. # dos2unix newline conversion
  85. %{__sed} -i 's/\r//' src/calibre/web/feeds/recipes/*
  86. # remove shebangs
  87. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
  88. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
  89. %{__sed} -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
  90. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*.py
  91. %{__sed} -i -e '/^#!\//, 1d' src/templite/*.py
  92. %{__sed} -i -e '/^#!\//, 1d' resources/default_tweaks.py
  93. %{__sed} -i -e '/^#!\//, 1d' resources/catalog/section_list_templates.py
  94. %{__chmod} -x src/calibre/*/*/*/*.py
  95. %{__chmod} -x src/calibre/*/*/*.py
  96. %{__chmod} -x src/calibre/*/*.py
  97. %{__chmod} -x src/calibre/*.py
  98. %build
  99. OVERRIDE_CFLAGS="%{optflags}" QMAKE=%{_libdir}/qt4/bin/qmake python setup.py build
  100. %install
  101. %__rm -rf %{buildroot}
  102. %__mkdir -p %{buildroot}%{_datadir}
  103. # create directories for xdg-utils
  104. %__mkdir_p %{buildroot}%{_datadir}/icons
  105. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor
  106. %__mkdir_p %{buildroot}%{_datadir}/packages
  107. %__mkdir_p %{buildroot}%{_datadir}/mime
  108. %__mkdir_p %{buildroot}%{_datadir}/mime/packages
  109. %__mkdir_p %{buildroot}%{_datadir}/applications
  110. %__mkdir_p %{buildroot}%{_datadir}/desktop-directories
  111. # create directory for calibre environment module
  112. # the install script assumes it's there.
  113. %__mkdir_p %{buildroot}%{python_sitelib}
  114. XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
  115. XDG_UTILS_INSTALL_MODE="system" \
  116. LIBPATH="%{_libdir}" \
  117. python setup.py install --root=%{buildroot}%{_prefix} \
  118. --prefix=%{_prefix} \
  119. --libdir=%{_libdir} \
  120. --staging-libdir=%{buildroot}%{_libdir}
  121. # remove shebang from init_calibre.py here because
  122. # it just got spawned by the install script
  123. %{__sed} -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
  124. # icons
  125. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
  126. %__cp -p resources/images/library.png \
  127. %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
  128. %__cp -p resources/images/viewer.png \
  129. %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
  130. # every file is empty here
  131. find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f|xargs %__rm -f
  132. # packages aren't allowed to register mimetypes like this
  133. %__rm -f %{buildroot}%{_datadir}/applications/{defaults.list,mimeinfo.cache}
  134. desktop-file-validate \
  135. %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
  136. desktop-file-validate \
  137. %{buildroot}%{_datadir}/applications/calibre-gui.desktop
  138. desktop-file-validate \
  139. %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
  140. %__mv %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes \
  141. %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes.xml
  142. # mimetype icon for lrf
  143. %__rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
  144. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable
  145. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
  146. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
  147. %__cp -p resources/images/mimetypes/lrf.png \
  148. %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
  149. %__cp -p resources/images/viewer.png \
  150. %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
  151. # don't put bash completions in /usr/etc
  152. %__mv %{buildroot}%{_prefix}%{_sysconfdir} %{buildroot}
  153. # these are provided as separate packages
  154. %__rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,pyPdf,encutils,cssutils}
  155. %__rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
  156. %__rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
  157. # link to system fonts after we have deleted (see Source0) the non-free ones
  158. # http://bugs.calibre-ebook.com/ticket/3832
  159. %__mkdir_p %{buildroot}%{_datadir}/%{name}/fonts/prs500/
  160. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSans-Regular.ttf \
  161. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0003m_.ttf
  162. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSerif-Regular.ttf \
  163. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0011m_.ttf
  164. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationMono-Regular.ttf \
  165. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0419m_.ttf
  166. # http://bugs.calibre-ebook.com/ticket/3770#comment:7
  167. # man pages
  168. %__mv %{buildroot}%{_datadir}/%{name}/man %{buildroot}%{_mandir}
  169. # delete locales, calibre stores them in a zip file now
  170. rm -rf %{buildroot}%{_datadir}/%{name}/localization/locales/
  171. %{__rm} -f %{buildroot}%{_bindir}/%{name}-uninstall
  172. %__install -m 755 %{SOURCE2} %{buildroot}%{_bindir}/calibre-mount-helper
  173. %clean
  174. %{__rm} -rf %{buildroot}
  175. %post
  176. update-desktop-database &> /dev/null ||:
  177. update-mime-database %{_datadir}/mime &> /dev/null || :
  178. touch --no-create %{_datadir}/icons/hicolor || :
  179. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  180. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  181. fi
  182. %postun
  183. update-desktop-database &> /dev/null ||:
  184. update-mime-database %{_datadir}/mime &> /dev/null || :
  185. touch --no-create %{_datadir}/icons/hicolor || :
  186. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  187. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  188. fi
  189. %files
  190. %defattr(-,root,root,-)
  191. %doc COPYRIGHT LICENSE Changelog.yaml
  192. %{_bindir}/calibre
  193. %{_bindir}/calibre-complete
  194. %{_bindir}/calibre-customize
  195. %{_bindir}/calibre-debug
  196. %{_bindir}/calibre-parallel
  197. %{_bindir}/calibre-server
  198. %{_bindir}/calibre-smtp
  199. %{_bindir}/calibre-mount-helper
  200. %{_bindir}/calibredb
  201. %{_bindir}/ebook-convert
  202. %{_bindir}/ebook-device
  203. %{_bindir}/ebook-meta
  204. %{_bindir}/ebook-viewer
  205. %{_bindir}/epub-fix
  206. %{_bindir}/fetch-ebook-metadata
  207. %{_bindir}/lrf2lrs
  208. %{_bindir}/lrfviewer
  209. %{_bindir}/lrs2lrf
  210. %{_bindir}/markdown-calibre
  211. %{_bindir}/pdfmanipulate
  212. %{_bindir}/web2disk
  213. %config(noreplace) %{_sysconfdir}/bash_completion.d/
  214. %{_libdir}/%{name}
  215. %{_datadir}/%{name}
  216. %{_datadir}/pixmaps/*
  217. %{_datadir}/applications/*.desktop
  218. %{_datadir}/mime/packages/*
  219. %{_datadir}/icons/hicolor/scalable/mimetypes/*
  220. %{_datadir}/icons/hicolor/scalable/apps/*
  221. %{python_sitelib}/init_calibre.py*
  222. %{_mandir}/man1/*
  223. %changelog
  224. * Tue May 8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.50-1
  225. - new upstream release
  226. - BuildRequires: qt4-devel >= 4.8.0
  227. - BuildRequires: PyQt4-devel >= 4.9.1
  228. * Fri Mar 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.44-1
  229. - new upstream release
  230. * Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.8.41-1
  231. - new upstream release
  232. * Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.50-2
  233. - rebuild with ImageMagick-6.7.5.10
  234. * Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.50-1
  235. - new upstream release
  236. * Sat Feb 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.46-1
  237. - new upstream release
  238. * Thu Feb 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.44-1
  239. - new upstream release
  240. * Fri Feb 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.42-1
  241. - new upstream release
  242. * Fri Jan 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.40-1
  243. - new upstream release
  244. * Mon Dec 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.35-1
  245. - new upstream release
  246. * Sun Dec 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.34-1
  247. - new upstream release
  248. * Mon Dec 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.33-1
  249. - new upstream release
  250. - added BuildRequires: libicu-devel
  251. * Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.32-1
  252. - new upstream release
  253. * Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
  254. - new upstream release
  255. * Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
  256. - new upstream release
  257. * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
  258. - Update to 0.7.24
  259. * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
  260. - Update to 0.7.23
  261. - Fix up mount helper with our own local script.
  262. - Change files to list binaries so missing ones can more easily be noted.
  263. * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
  264. - Update to 0.7.22
  265. * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
  266. - Update to 0.7.21
  267. * Wed Sep 29 2010 jkeating - 0.7.20-2
  268. - Rebuilt for gcc bug 634757
  269. * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
  270. - Update to 0.7.20
  271. * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
  272. - Rebuild for new ImageMagick
  273. * Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
  274. - new upstream release
  275. - Fix svg/png changes.
  276. * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
  277. - Fix svg/png changes.
  278. * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
  279. - Update to 0.7.18
  280. - Require > 0.9.6 cssutils
  281. * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
  282. - Update to 0.7.17
  283. * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
  284. - Update to 0.7.16
  285. * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
  286. - initial build based on Fedora development
  287. * Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
  288. - Update to 0.7.15
  289. * Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
  290. - rebuild (poppler)
  291. * Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
  292. - Update to 0.7.14
  293. * Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
  294. - Update to 0.7.13
  295. * Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
  296. - Update to 0.7.12
  297. * Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
  298. - Update to 0.7.11
  299. * Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
  300. - Rebuilt for python2.7
  301. * Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
  302. - Update to 0.7.10
  303. * Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
  304. - Update to 0.7.9
  305. * Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
  306. - Update to 0.7.8
  307. - build tar.xz instead of tar.bz2
  308. * Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
  309. - Update to 0.7.7
  310. * Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
  311. - Update to 0.7.6
  312. * Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
  313. - Update to 0.7.5
  314. * Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
  315. - Update to 0.7.4
  316. * Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
  317. - rebuilt with podofo 0.8.1
  318. * Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
  319. - Update to 0.7.1
  320. - Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
  321. * Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
  322. - Update to 0.7.0
  323. * Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
  324. - Update to 0.6.55
  325. * Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
  326. - Update to 0.6.54
  327. * Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
  328. - Update to 0.6.53
  329. * Wed May 5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
  330. - Rebuild against new poppler
  331. * Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
  332. - new upstream release 0.6.47
  333. - new chmlib requirement
  334. - create directory for calibre's environment module
  335. - use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
  336. - remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
  337. * Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
  338. - new upstream release 0.6.42
  339. - remove shebang from default_tweaks.py
  340. * Mon Feb 1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
  341. - new upstream release 0.6.37
  342. * Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
  343. - new upstream release 0.6.36
  344. - fixed a cssprofiles issue with loading the profiles
  345. * Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
  346. - added -cssprofiles patch to cvs
  347. * Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
  348. - remove python-cssutils 0.9.6 dependency
  349. * Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
  350. - new upstream release
  351. - fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
  352. - removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
  353. * Wed Jan 6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
  354. - fix for package tagged without adding new patch to cvs
  355. * Wed Jan 6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
  356. - new upstream release 0.6.32
  357. - project website has changed
  358. - added python-BeautifulSoup BuildRequire
  359. - new patch to fix full buildpath in binary files
  360. * Sun Dec 6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
  361. - New upstream version
  362. - Regenerated no-update patch because of code relocation
  363. * Wed Dec 2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
  364. - New upstream release
  365. * Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
  366. - New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
  367. * Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
  368. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
  369. - patch to stop checking for new upstream version
  370. * Sat Nov 7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
  371. - new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
  372. - added python-BeautifulSoup requirement
  373. * Wed Nov 4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
  374. - new upstream version:
  375. http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
  376. - upstream now ships correct .desktop files
  377. - fixed missing dependency: PyQt4
  378. - fixed calibre-gui icon
  379. * Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
  380. - removed unfree fonts from source package
  381. * Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
  382. - readability enhancements
  383. - added python-genshi requires
  384. - removed libwmf require since ImageMagick provides libwmf-lite as a
  385. dependency and that's what we actually need
  386. * Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
  387. - new upstream version:
  388. http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
  389. - delete fonts, calibre can find the system fonts
  390. - specify libdir as an install option, so calibre will link properly
  391. even on 64bit
  392. * Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
  393. - updated requires list
  394. - new upstream release
  395. - can override CFLAGS now
  396. - removed trac and genshi duplicates
  397. - use xdg env variables to do desktop integration in the buildroot
  398. - added xdg-utils buildrequire
  399. - install udev rules in /usr/lib even on 64bit and don't own the whole dir
  400. - removed wrongly used Version field from .desktop files
  401. * Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
  402. - mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
  403. - removed unneeded INSTALL file
  404. - marked bash completion file as config(noreplace) and take ownership of the dir
  405. * Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
  406. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
  407. - the install process changed significantly
  408. - locales were added
  409. * Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
  410. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
  411. - minor path fixes
  412. - rearranged files section
  413. * Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
  414. - handle desktop files
  415. - don't compress manpages and don't list them as duplicates
  416. - added lrfviewer icon
  417. * Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
  418. - Initial RPM release