libxcb-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define xpyb_version 1.2
  3. Summary: A C binding to the X11 protocol
  4. Summary(ja): X11 プロトコルの C による実装
  5. Name: libxcb
  6. Version: 1.15
  7. Release: 1%{?_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: MIT
  12. URL: https://xcb.freedesktop.org/
  13. Source0: https://xcb.freedesktop.org/dist/%{name}-%{version}.tar.xz
  14. # This is stolen straight from the pthread-stubs source:
  15. # http://cgit.freedesktop.org/xcb/pthread-stubs/blob/?id=6900598192bacf5fd9a34619b11328f746a5956d
  16. # we don't need the library because glibc has working pthreads, but we need
  17. # the pkgconfig file so libs that link against libxcb know this...
  18. Source1: pthread-stubs.pc.in
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: autoconf
  21. BuildRequires: automake
  22. BuildRequires: libtool
  23. BuildRequires: pkgconfig
  24. #BuildRequires: doxygen
  25. #BuildRequires: graphviz
  26. BuildRequires: libXau-devel
  27. BuildRequires: libxslt
  28. BuildRequires: xcb-proto >= 1.6
  29. BuildRequires: xorg-x11-proto-devel
  30. BuildRequires: xorg-x11-util-macros
  31. BuildRequires: python3-devel
  32. Obsoletes: %{name}-python < 1.8
  33. %description
  34. The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
  35. small footprint, latency hiding, direct access to the protocol, improved
  36. threading support, and extensibility.
  37. %package devel
  38. Summary: Development files for %{name}
  39. Summary(ja): %{name} の開発用ファイル
  40. Group: programming
  41. Requires: %{name} = %{version}-%{release}
  42. Requires: pkgconfig
  43. %description devel
  44. The %{name}-devel package contains libraries and header files for
  45. developing applications that use %{name}.
  46. %package doc
  47. Summary: Documentation for %{name}
  48. Group: documentation
  49. %description doc
  50. The %{name}-doc package contains documentation for the %{name} library.
  51. %package -n compat32-%{name}
  52. Summary: A C binding to the X11 protocol
  53. Summary(ja): X11 プロトコルの C による実装
  54. Group: system,legacy
  55. %description -n compat32-%{name}
  56. The X protocol C-language Binding (XCB) is a replacement for Xlib featuring a
  57. small footprint, latency hiding, direct access to the protocol, improved
  58. threading support, and extensibility.
  59. %package -n compat32-%{name}-devel
  60. Summary: Development files for %{name}
  61. Summary(ja): %{name} の開発用ファイル
  62. Group: programming,legacy
  63. Requires: compat32-%{name} = %{version}-%{release}
  64. Requires: %{name}-devel = %{version}-%{release}
  65. %description -n compat32-%{name}-devel
  66. The %{name}-devel package contains libraries and header files for
  67. developing applications that use %{name}.
  68. %debug_package
  69. %prep
  70. %setup -q
  71. %build
  72. sed -i 's/pthread-stubs //' configure.ac
  73. autoreconf -v --install
  74. export PYTHON=%{__python3}
  75. %configure \
  76. --disable-static \
  77. --docdir=%{_pkgdocdir} \
  78. --disable-selinux \
  79. --enable-xkb \
  80. --disable-xprint \
  81. --disable-silent-rules
  82. # Remove rpath from libtool (extra insurance if autoreconf is ever dropped)
  83. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  84. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  85. make %{?_smp_mflags}
  86. %install
  87. rm -rf $RPM_BUILD_ROOT
  88. make install DESTDIR=$RPM_BUILD_ROOT
  89. sed 's,@libdir@,%{_libdir},;s,@prefix@,%{_prefix},;s,@exec_prefix@,%{_exec_prefix},' %{SOURCE1} > $RPM_BUILD_ROOT%{_libdir}/pkgconfig/pthread-stubs.pc
  90. find $RPM_BUILD_ROOT -name '*.la' -delete
  91. %clean
  92. rm -rf $RPM_BUILD_ROOT
  93. %files
  94. %defattr(-,root,root,-)
  95. %license COPYING
  96. %doc NEWS README.md
  97. %{_libdir}/*.so.*
  98. %files devel
  99. %defattr(-,root,root,-)
  100. %{_includedir}/xcb
  101. %{_libdir}/*.so
  102. %{_libdir}/pkgconfig/*.pc
  103. %files doc
  104. %defattr(-,root,root,-)
  105. %doc %{_pkgdocdir}/tutorial
  106. %{_mandir}/man3/*
  107. %if %{build_compat32}
  108. %files -n compat32-%{name}
  109. %defattr(-,root,root,-)
  110. %{_libdir}/*.so.*
  111. %files -n compat32-%{name}-devel
  112. %defattr(-,root,root,-)
  113. %{_libdir}/*.so
  114. %endif
  115. %changelog
  116. * Tue Sep 13 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15-1
  117. - new upstream release.
  118. - dropped ldconfig scriptlets.
  119. * Fri Aug 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14-1
  120. - new upstream release.
  121. * Thu Sep 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13-1
  122. - new upstream release.
  123. * Fri Oct 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.11-1
  124. - new upstream release
  125. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10-1
  126. - new upstream release
  127. * Sun Jun 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.1-1
  128. - new upstream release
  129. (including security fix for CVE-2013-2064)
  130. * Sat Nov 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-2
  131. - add Source1: pthread-stubs.pc, remove patch10
  132. * Mon Oct 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9-1
  133. - new upstream release
  134. * Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
  135. - new upstream release
  136. - update Patch10 (libxcb-1.8.1-no-pthread-stubs.patch)
  137. * Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
  138. - new upstream release
  139. - remove Source2
  140. - remove python sub package
  141. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-1
  142. - new upstream release
  143. - update Patch10
  144. * Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-3
  145. - add BuildRequires: python-devel
  146. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.5-2
  147. - build with rpm-4.8.1-1 for pkg-config file
  148. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
  149. - new upstream release
  150. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.4-2
  151. - rebuild with python-2.6
  152. * Tue Nov 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-1
  153. - new upstream release
  154. - add libxcb python binding (xpyb)
  155. * Sun May 03 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-2
  156. - added compat32 package for x86_64 arch support
  157. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
  158. - new upstream release
  159. * Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 1.1-2
  160. - spec in utf-8
  161. - added japanese summary
  162. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-1
  163. - new versioning policy
  164. * Sun Jan 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
  165. - initial build for Vine Linux
  166. * Mon Nov 12 2007 Adam Jackson <ajax@redhat.com> 1.1-1
  167. - libxcb 1.1
  168. * Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 1.0-3
  169. - libxcb-1.0-abstract-socket.patch: When connecting to the X server, prefer
  170. abstract-namespace unix sockets to filesystem-bound sockets.
  171. * Wed Aug 22 2007 Adam Jackson <ajax@redhat.com> - 1.0-2
  172. - Rebuild for PPC toolchain bug
  173. * Fri Jun 29 2007 Adam Jackson <ajax@redhat.com> 1.0-1
  174. - Initial revision.