keepalived-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174
  1. Summary: HA monitor built upon LVS, VRRP and services poller
  2. Name: keepalived
  3. Version: 1.2.19
  4. Release: 1%{?_dist_release}
  5. License: GPL
  6. Group: Applications/System
  7. URL: http://www.keepalived.org/
  8. Source0: http://www.keepalived.org/software/keepalived-%{version}.tar.gz
  9. Patch0: keepalived-1.2.7-dont-respawn-children.patch
  10. Patch1: keepalived-1.2.7-cleanup-duplicate-option-code.patch
  11. Patch2: keepalived-1.2.7-generate-usage-message-from-popt.patch
  12. Patch3: keepalived-1.2.7-update-keepalived-man-page.patch
  13. Patch4: keepalived-1.2.7-fix-pointer-arithmetic-vrrp-packet.patch
  14. Patch8: keepalived-1.2.7-fix-primary-ip-address-comparison.patch
  15. Patch5: keepalived-1.2.7-fix-ssl-certificate-load.patch
  16. Patch6: keepalived-1.2.7-fix-error-message.patch
  17. Patch7: keepalived-1.2.7-update-gpl-license.patch
  18. Patch9: keepalived-1.2.7-remove-debug-messages.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  20. BuildRequires: openssl-devel
  21. BuildRequires: kernel-devel
  22. BuildRequires: popt-devel
  23. BuildRequires: libnl-devel
  24. BuildRequires: net-snmp-devel
  25. BuildRequires: rpm-devel
  26. BuildRequires: tcp_wrappers
  27. Requires(post): /sbin/chkconfig
  28. Requires(preun): /sbin/service, /sbin/chkconfig
  29. Requires(postun): /sbin/service
  30. %description
  31. The main goal of the keepalived project is to add a strong & robust keepalive
  32. facility to the Linux Virtual Server project. This project is written in C with
  33. multilayer TCP/IP stack checks. Keepalived implements a framework based on
  34. three family checks : Layer3, Layer4 & Layer5/7. This framework gives the
  35. daemon the ability to check the state of an LVS server pool. When one of the
  36. servers of the LVS server pool is down, keepalived informs the linux kernel via
  37. a setsockopt call to remove this server entry from the LVS topology. In
  38. addition keepalived implements an independent VRRPv2 stack to handle director
  39. failover. So in short keepalived is a userspace daemon for LVS cluster nodes
  40. healthchecks and LVS directors failover.
  41. %prep
  42. %setup
  43. %build
  44. %configure \
  45. --enable-snmp \
  46. --enable-sha1
  47. %{__make} %{?_smp_mflags} STRIP=/bin/true
  48. %install
  49. %{__rm} -rf %{buildroot}
  50. %{__make} install DESTDIR=%{buildroot}
  51. # Remove "samples", as we include them in %%doc
  52. %{__rm} -rf %{buildroot}%{_sysconfdir}/keepalived/samples/
  53. %check
  54. # A build could silently have LVS support disabled if the kernel includes can't
  55. # be properly found, we need to avoid that.
  56. if ! grep -q "IPVS_SUPPORT='_WITH_LVS_'" config.log; then
  57. echo "ERROR: We do not want keeepalived lacking LVS support."
  58. exit 1
  59. fi
  60. %clean
  61. %{__rm} -rf %{buildroot}
  62. %post
  63. /sbin/chkconfig --add keepalived
  64. %preun
  65. if [ $1 -eq 0 ]; then
  66. /sbin/service keepalived stop &>/dev/null || :
  67. /sbin/chkconfig --del keepalived
  68. fi
  69. %postun
  70. if [ $1 -ge 1 ]; then
  71. /sbin/service keepalived condrestart &>/dev/null || :
  72. fi
  73. %files
  74. %defattr(-, root, root, -)
  75. %doc AUTHOR ChangeLog CONTRIBUTORS COPYING README TODO
  76. %doc doc/keepalived.conf.SYNOPSIS doc/samples/
  77. %dir %{_sysconfdir}/keepalived/
  78. %attr(0644, root, root) %config(noreplace) %{_sysconfdir}/keepalived/keepalived.conf
  79. %attr(0644, root, root) %config(noreplace) %{_sysconfdir}/sysconfig/keepalived
  80. %{_sysconfdir}/rc.d/init.d/keepalived
  81. %{_bindir}/genhash
  82. %attr(0755,root,root) %{_sbindir}/keepalived
  83. %{_datadir}/snmp/mibs/*
  84. %{_mandir}/man1/genhash.1*
  85. %{_mandir}/man5/keepalived.conf.5*
  86. %{_mandir}/man8/keepalived.8*
  87. %changelog
  88. * Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.19-1
  89. - new upstream release.
  90. * Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  91. - initial build for Vine Linux
  92. * Thu Sep 13 2007 Alexandre Cassen <acassen@linux-vs.org> 1.1.14
  93. - Merge work done by freshrpms.net... Thanks guys !!! ;)
  94. * Wed Feb 14 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-5
  95. - Add missing scriplet requirements.
  96. * Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-4
  97. - Add missing \n to the kernel define, for when multiple kernels are installed.
  98. - Pass STRIP=/bin/true to "make" in order to get a useful debuginfo package.
  99. * Tue Feb 13 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-3
  100. - Add %%check section to make sure any build without LVS support will fail.
  101. * Mon Feb 5 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-2
  102. - Use our own init script, include a sysconfig entry used by it for options.
  103. * Thu Jan 25 2007 Matthias Saou <http://freshrpms.net/> 1.1.13-1
  104. - Update to 1.1.13.
  105. - Change mode of configuration file to 0600.
  106. - Don't include all of "doc" since it meant re-including all man pages.
  107. - Don't include samples in the main configuration path, they're in %%doc.
  108. - Include patch to add an optional label to interfaces.
  109. * Sat Apr 08 2006 Dries Verachtert <dries@ulyssis.org> - 1.1.12-1.2
  110. - Rebuild for Fedora Core 5.
  111. * Sun Mar 12 2006 Dag Wieers <dag@wieers.com> - 1.1.12-1
  112. - Updated to release 1.1.12.
  113. * Fri Mar 04 2005 Dag Wieers <dag@wieers.com> - 1.1.11-1
  114. - Updated to release 1.1.11.
  115. * Wed Feb 23 2005 Dag Wieers <dag@wieers.com> - 1.1.10-2
  116. - Fixed IPVS/LVS support. (Joe Sauer)
  117. * Tue Feb 15 2005 Dag Wieers <dag@wieers.com> - 1.1.10-1
  118. - Updated to release 1.1.10.
  119. * Mon Feb 07 2005 Dag Wieers <dag@wieers.com> - 1.1.9-1
  120. - Updated to release 1.1.9.
  121. * Sun Oct 17 2004 Dag Wieers <dag@wieers.com> - 1.1.7-2
  122. - Fixes to build with kernel IPVS support. (Tim Verhoeven)
  123. * Fri Sep 24 2004 Dag Wieers <dag@wieers.com> - 1.1.7-1
  124. - Updated to release 1.1.7. (Mathieu Lubrano)
  125. * Mon Feb 23 2004 Dag Wieers <dag@wieers.com> - 1.1.6-0
  126. - Updated to release 1.1.6.
  127. * Mon Jan 26 2004 Dag Wieers <dag@wieers.com> - 1.1.5-0
  128. - Updated to release 1.1.5.
  129. * Mon Dec 29 2003 Dag Wieers <dag@wieers.com> - 1.1.4-0
  130. - Updated to release 1.1.4.
  131. * Fri Jun 06 2003 Dag Wieers <dag@wieers.com> - 1.0.3-0
  132. - Initial package. (using DAR)