expat-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define name expat
  3. %define version 2.0.1
  4. %define release 7%{?_dist_release}
  5. Summary: Expat is an XML 1.0 parser written in C
  6. Summary(ja): C で書かれた XML 1.0 パーサ
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. License: MIT/X
  11. Group: Applications/Text
  12. URL: http://www.libexpat.org/
  13. Source: http://download.sourceforge.net/expat/%{name}-%{version}.tar.gz
  14. Patch100: expat-2.0.1_CVE-2009-3560.patch
  15. Patch110: expat-2.0.1_CVE-2009-3720.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. Requires: lib%{name} = %{version}-%{release}
  18. BuildRequires: libtool
  19. %description
  20. This is Expat, a C library for parsing XML, written by James Clark.
  21. Expat is a stream-oriented XML parser. This means that you register
  22. handlers with the parser before starting the parse. These handlers
  23. are called when the parser discovers the associated structures in the
  24. document being parsed. A start tag is an example of the kind of
  25. structures for which you may register handlers.
  26. %package -n lib%{name}
  27. Summary: Runtime library of expat
  28. Summary(ja): Expat のための実行ライブラリ
  29. Group: System Environment/Libraries
  30. %description -n lib%{name}
  31. This package contains the runtime, shared library of expat, the C
  32. library for parsing XML.
  33. %description -n lib%{name} -l ja
  34. Expat を動作させるために必用となるライブラリです.
  35. %package devel
  36. Summary: Development environment for the expat XML parser
  37. Summary(ja): expat XML パーサ用開発環境
  38. Group: Development/Libraries
  39. Requires: lib%{name} = %{version}-%{release}
  40. %description devel
  41. Development environment for the expat XML parser
  42. %description devel -l ja
  43. expat XML パーサ用開発環境です.
  44. ## to build compat32 for x86_64 architecture support
  45. %package -n compat32-lib%{name}
  46. Summary: Runtime library of expat
  47. Summary(ja): Expat のための実行ライブラリ
  48. Group: System Environment/Libraries
  49. Requires: lib%{name} = %{version}-%{release}
  50. %description -n compat32-lib%{name}
  51. This package contains the runtime, shared library of expat, the C
  52. library for parsing XML.
  53. %description -n compat32-lib%{name} -l ja
  54. Expat を動作させるために必用となるライブラリです.
  55. %package -n compat32-%{name}-devel
  56. Summary: Development environment for the expat XML parser
  57. Summary(ja): expat XML パーサ用開発環境
  58. Group: Development/Libraries
  59. Requires: %{name}-devel = %{version}-%{release}
  60. Requires: compat32-lib%{name} = %{version}-%{release}
  61. %description -n compat32-%{name}-devel
  62. Development environment for the expat XML parser
  63. %description -n compat32-%{name}-devel -l ja
  64. expat XML パーサ用開発環境です.
  65. %prep
  66. %setup -q
  67. %patch100 -p1 -b .CVE-2009-3560
  68. %patch110 -p1 -b .CVE-2009-3720
  69. %build
  70. export CFLAGS="$RPM_OPT_FLAGS -fPIC"
  71. %configure --enable-shared
  72. make %{?_smp_mflags}
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. rm -f examples/*.dsp
  76. chmod 644 README COPYING Changes doc/* examples/*
  77. make DESTDIR=$RPM_BUILD_ROOT install
  78. rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
  79. %clean
  80. rm -rf $RPM_BUILD_ROOT
  81. %post -n lib%{name} -p /sbin/ldconfig
  82. %postun -n lib%{name} -p /sbin/ldconfig
  83. %post -n compat32-lib%{name} -p /sbin/ldconfig
  84. %postun -n compat32-lib%{name} -p /sbin/ldconfig
  85. %files
  86. %defattr(-,root,root)
  87. %doc COPYING Changes README
  88. %{_bindir}/xmlwf
  89. %{_mandir}/man1/xmlwf.1*
  90. %files -n lib%{name}
  91. %defattr(-,root,root)
  92. %doc COPYING Changes README
  93. %{_libdir}/libexpat.so.*
  94. %files devel
  95. %defattr(-,root,root)
  96. %doc COPYING Changes README doc/* examples
  97. %{_includedir}/*
  98. %{_libdir}/libexpat.a
  99. %{_libdir}/libexpat.so
  100. ## to build compat32 for x86_64 architecture support
  101. %if %{build_compat32}
  102. %files -n compat32-lib%{name}
  103. %defattr(-,root,root)
  104. %{_libdir}/libexpat.so.*
  105. %files -n compat32-%{name}-devel
  106. %defattr(-,root,root)
  107. %{_libdir}/libexpat.a
  108. %{_libdir}/libexpat.so
  109. %endif
  110. %changelog
  111. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
  112. - rebuilt with rpm-4.8.1-3
  113. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
  114. - rebuilt with gcc-4.4.3-3 on ppc
  115. * Mon Feb 1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
  116. - rebuilt with new toolchains (for VineSeed)
  117. * Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
  118. - add patch110 for fix CVE-2009-3720 (xml parser)
  119. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
  120. - add Patch100 for fix CVE-2009-3560 (xml parser)
  121. * Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
  122. - added Requires: tag to compat32-* sub-packages.
  123. - removed unnecessary %%configure CC='gcc -m32' option
  124. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
  125. - applied new versioning policy and spec in utf-8
  126. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
  127. - removed %%if !%%{build_compat32} case condition
  128. * Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
  129. - new upstream release
  130. - drop Patch0
  131. - drop .la
  132. - chmod 644 the documentation
  133. - strip DSP files from examples
  134. - update description and drop description-ja
  135. - add -fPIC
  136. * Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
  137. - rebuilt
  138. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
  139. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  140. * Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
  141. - added compat32* packages for x86_64 architecture support
  142. * Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
  143. - add missing header file (expat_external.h) to %%files.
  144. * Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
  145. - updated/revised Patch1 (%%install will fail without this patch)
  146. * Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
  147. - new upstream release
  148. -- dropped patch1
  149. * Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
  150. - updated to 1.95.7
  151. - changed URL and Group
  152. - fixed License to MIT/X (based on rpm package at sourceforge)
  153. * Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
  154. - version up to 1.95.6
  155. - drop expat-xmlwf-dynamiclink.patch (Patch0)
  156. - add expat-1.95.6-mandir.patch for installing manpage (Patch0)
  157. - add manpage (xmlwf.1)
  158. * Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
  159. - fixed license ( s/MPL or GPL/distributable/ )
  160. - use License tag
  161. * Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
  162. - new sub-package libexpat.
  163. - added BuildPreReq: libtool
  164. * Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
  165. - updated to 1.95.2 release
  166. * Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  167. - 1.95.1-3vl1
  168. - based on 1.95.1-3mdk from Mandrake 8.0
  169. - added Japanese summary and description
  170. - modified spec macros for Vine
  171. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
  172. - real version is 1.95.1
  173. - reenable optimisations
  174. * Thu Feb 15 2001 Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
  175. - release .
  176. * Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
  177. - Don't try to use optimizations
  178. - Bzip2 sources
  179. * Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
  180. - first version