dev86-vl.spec 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162
  1. Summary: A real mode 80x86 assembler and linker
  2. Summary(ja): リアルモード 80x86 アセンブラとリンカ
  3. Name: dev86
  4. Version: 0.16.17
  5. Release: 3%{?_dist_release}
  6. License: GPL
  7. Group: Development/Languages
  8. URL: http://homepage.ntlworld.com/robert.debath/
  9. Source: http://homepage.ntlworld.com/robert.debath/dev86/Dev86src-%{version}.tar.gz
  10. Patch0: dev86-noelks.patch
  11. Patch1: dev86-x86_64.patch
  12. Patch2: dev86-nostrip.patch
  13. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. Obsoletes: bin86
  15. BuildRequires: gawk
  16. %define __os_install_post /usr/lib/rpm/brp-compress /usr/lib/rpm/brp-strip %{__strip} /usr/lib/rpm/brp-strip-comment-note %{__strip} %{__objdump} %{nil}
  17. %description
  18. The dev86 package provides an assembler and linker for real mode 80x86
  19. instructions. You'll need to have this package installed in order to
  20. build programs that run in real mode, including LILO and the kernel's
  21. bootstrapping code, from their sources.
  22. You should install dev86 if you intend to build programs that run in real
  23. mode from their source code.
  24. %description -l ja
  25. dev86 パッケージは リアルモード 80x86 命令のアセンブラとリンカを提供
  26. します。LILO や kernel のブートストラップコードを含むリアルモードで
  27. 走るプログラムをソースから作成するときにはこのパッケージがインストー
  28. ルされている必要があります。
  29. リアルモードで走るプログラムをソースから作成するつもりなら dev86 を
  30. インストールしてください。
  31. %prep
  32. %setup -q
  33. %patch0 -p1 -b .noelks
  34. %ifarch x86_64
  35. %patch1 -p1 -b .x86_64
  36. %endif
  37. %patch2 -p1 -b .nostrip
  38. %build
  39. make <<EOF
  40. 5
  41. quit
  42. EOF
  43. %install
  44. rm -rf ${RPM_BUILD_ROOT}
  45. make DIST=${RPM_BUILD_ROOT} \
  46. MANDIR=%{_mandir} \
  47. LIBDIR=%{_libdir}/bcc \
  48. INCLDIR=%{_libdir}/bcc \
  49. LOCALPREFIX=%{_prefix} \
  50. install install-man
  51. # preserve READMEs
  52. for i in bootblocks copt dis88 unproto bin86 ; do cp $i/README README.$i ; done
  53. cp bin86/README-0.4 README-0.4.bin86
  54. cp bin86/ChangeLog ChangeLog.bin86
  55. pushd ${RPM_BUILD_ROOT}%{_bindir}
  56. rm -f nm86 size86
  57. ln -s objdump86 nm86
  58. ln -s objdump86 size86
  59. popd
  60. %clean
  61. rm -rf ${RPM_BUILD_ROOT}
  62. %files
  63. %defattr(-,root,root,-)
  64. %doc README MAGIC Contributors README.bootblocks README.copt README.dis88
  65. %doc README.unproto README-0.4.bin86 README.bin86 ChangeLog.bin86
  66. %dir %{_libdir}/bcc
  67. %{_bindir}/bcc
  68. %{_bindir}/ar86
  69. %{_bindir}/as86
  70. %{_bindir}/ld86
  71. %{_bindir}/objdump86
  72. %{_bindir}/nm86
  73. %{_bindir}/size86
  74. %{_libdir}/bcc/*
  75. %{_mandir}/man1/*
  76. %changelog
  77. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 0.16.17-3
  78. - rebuilt with rpm-4.8.1-3
  79. * Tue Jan 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.16.17-2
  80. - remove ExclusiveArch to allow to run dev86 on different arches
  81. * Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.17-1vl5
  82. - applied new versioning policy, spec in utf-8
  83. * Tue Nov 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.16.17-0vl1
  84. - new upstream release
  85. * Sat Sep 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.16.3-9vl1
  86. - based on Rawhide 0.16.3-9
  87. * Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 0.16.3-9
  88. - preserve README files with separate names
  89. * Fri Jan 31 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  90. - do not strip static archive to get rebuild working again
  91. * Sat Aug 10 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  92. - add ar86 to filelist
  93. * Wed Jun 19 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  94. - do not strip apps
  95. - rebuild with new toolchains
  96. - s/Copyright/License/
  97. * Sat Jul 14 2001 <sagami@vinelinux.org>
  98. - 0.15.5-1vl2: use %%{ix86} for ExclusiveArch instead of i386
  99. - enabled %%clean (why was it disabled?)
  100. * Sun May 27 2001 <sagami@vinelinux.org>
  101. - 0.15.5-1vl1: added Japanese summary and description
  102. * Mon May 7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.15.5-1
  103. - Update to 0.15.5, lots of fixes
  104. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  105. - automatic rebuild
  106. * Mon Jun 19 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  107. - add defattr
  108. * Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
  109. - use %%{_mandir}
  110. * Fri Feb 04 2000 Nalin Dahyabhai <nalin@redhat.com>
  111. - change default header directory to match libs and fix bug #9121
  112. * Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
  113. - version 0.15.0
  114. - man pages are compressed
  115. * Mon Sep 20 1999 Donnie Barnes <djb@redhat.com>
  116. - removed "Distribution:" line (was RHCN)
  117. - changed description and summary to the ones from bin86 with s/bin/dev/
  118. done throughout
  119. - added patch to keep from installing in /usr/bcc and simply in /usr
  120. - moved include files to /usr/lib/bcc/include
  121. * Tue Sep 07 1999 Erik Troan <ewt@redhat.com>
  122. - updated to Dev86src
  123. - included in Red Hat 6.1
  124. * Sat Nov 14 1998 Simon Weijgers <simon@mbit.doa.org>
  125. - First release of this package to be shipped to rhcn.
  126. - To be fixed: Bug in Makefile which installs headerfiles
  127. double. E.g. /usr/bcc/include/arch is also installed under
  128. /usr/bcc/include/arch/arch. This doesn't hinder operation,
  129. just eats a tiny bit of diskspace.