nettle-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A low-level cryptographic library
  3. Summary(ja): 低レベル暗号化ライブラリ
  4. Name: nettle
  5. Version: 3.7
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv3+ or GPLv2+
  11. URL: http://www.lysator.liu.se/~nisse/nettle/
  12. Source0: https://ftp.gnu.org/gnu/nettle/nettle-%{version}.tar.gz
  13. Patch0: nettle-3.4-annocheck.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gettext-devel
  16. BuildRequires: gmp-devel
  17. BuildRequires: m4
  18. Requires(post): /sbin/install-info
  19. Requires(preun): /sbin/install-info
  20. %description
  21. Nettle is a cryptographic library that is designed to fit easily in more
  22. or less any context: In crypto toolkits for object-oriented languages
  23. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  24. kernel space.
  25. %package devel
  26. Summary: Development headers for a low-level cryptographic library
  27. Summary(ja): 低レベル暗号化ライブラリの開発ヘッダ
  28. Group: programming
  29. Requires: %{name} = %{version}-%{release}
  30. Requires: gmp-devel
  31. %description devel
  32. Nettle is a cryptographic library that is designed to fit easily in more
  33. or less any context: In crypto toolkits for object-oriented languages
  34. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  35. kernel space. This package contains kernel headers.
  36. %if %{build_compat32}
  37. %package -n compat32-%{name}
  38. Summary: A low-level cryptographic library
  39. Summary(ja): 低レベル暗号化ライブラリ
  40. Group: system
  41. Requires: %{name} = %{version}-%{release}
  42. %description -n compat32-%{name}
  43. Nettle is a cryptographic library that is designed to fit easily in more
  44. or less any context: In crypto toolkits for object-oriented languages
  45. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  46. kernel space.
  47. %package -n compat32-%{name}-devel
  48. Summary: Development headers for a low-level cryptographic library
  49. Summary(ja): 低レベル暗号化ライブラリの開発ヘッダ
  50. Group: programming
  51. Requires: %{name}-devel = %{version}-%{release}
  52. Requires: compat32-%{name} = %{version}-%{release}
  53. Requires: compat32-gmp-devel
  54. %description -n compat32-%{name}-devel
  55. Nettle is a cryptographic library that is designed to fit easily in more
  56. or less any context: In crypto toolkits for object-oriented languages
  57. (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
  58. kernel space. This package contains compat libraries.
  59. %endif
  60. %debug_package
  61. %prep
  62. %autosetup -p1
  63. %build
  64. autoreconf -ifv
  65. %configure --enable-shared --enable-fat
  66. make %{?_smp_mflags}
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  70. make install-shared DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
  71. mkdir -p $RPM_BUILD_ROOT%{_infodir}
  72. install -p -m 644 nettle.info $RPM_BUILD_ROOT%{_infodir}/
  73. chmod 755 $RPM_BUILD_ROOT%{_libdir}/libhogweed.so.*
  74. chmod 755 $RPM_BUILD_ROOT%{_libdir}/libnettle.so.*
  75. rm -rf %{buildroot}/%{_libdir}/*.a
  76. rm -rf %{buildroot}/%{_infodir}/dir
  77. %check
  78. make check
  79. %clean
  80. rm -rf $RPM_BUILD_ROOT
  81. %files
  82. %defattr(-,root,root,-)
  83. %license COPYING*
  84. %doc AUTHORS ChangeLog NEWS README TODO
  85. %{_infodir}/nettle.info.gz
  86. %{_bindir}/nettle-hash
  87. %{_bindir}/nettle-lfib-stream
  88. %{_bindir}/pkcs1-conv
  89. %{_bindir}/sexp-conv
  90. %{_bindir}/nettle-pbkdf2
  91. %{_libdir}/libhogweed.so.*
  92. %{_libdir}/libnettle.so.*
  93. %files devel
  94. %defattr(-,root,root,-)
  95. %doc descore.README nettle.html nettle.pdf
  96. %{_libdir}/libhogweed.so
  97. %{_libdir}/libnettle.so
  98. %{_includedir}/nettle
  99. %{_libdir}/pkgconfig/*
  100. # compat32
  101. %if %{build_compat32}
  102. %files -n compat32-%{name}
  103. %defattr(-, root, root, 0755)
  104. %{_libdir}/libhogweed.so.*
  105. %{_libdir}/libnettle.so.*
  106. %files -n compat32-%{name}-devel
  107. %defattr(-, root, root, 0755)
  108. %{_libdir}/libhogweed.so
  109. %{_libdir}/libnettle.so
  110. %endif
  111. %post
  112. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
  113. /sbin/ldconfig
  114. %preun
  115. if [ $1 = 0 ]; then
  116. /sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
  117. fi
  118. %postun -p /sbin/ldconfig
  119. %if %{build_compat32}
  120. %post -n compat32-%{name} -p /sbin/ldconfig
  121. %postun -n compat32-%{name} -p /sbin/ldconfig
  122. %endif
  123. %changelog
  124. * Tue Feb 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.7-1
  125. - new upstream release.
  126. * Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.6-1
  127. - new upstream release.
  128. - imported Patch0 from rawhide.
  129. * Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4.1-1
  130. - new upstream release.
  131. * Thu Nov 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.4-1
  132. - new upstream release.
  133. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2-1
  134. - new upstream release.
  135. * Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.1.1-1
  136. - new upstream release
  137. * Thu Dec 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-4
  138. - fixed Requires typo of compat32-nettle-devel package
  139. * Sun Oct 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.7.1-3
  140. - moved nettle to System Environment/Libraries Group
  141. * Sun Feb 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.7.1-2
  142. - add compat32,compat32-devel packages
  143. * Sun Jan 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.7.1-1
  144. - update to 2.7.1
  145. * Fri Dec 02 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.4-1
  146. - initial build for VineSeed
  147. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-7
  148. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  149. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-6
  150. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  151. * Thu Apr 10 2008 Ian Weller <ianweller@gmail.com> 1.15-5
  152. - Moved static lib to -static
  153. * Mon Mar 24 2008 Ian Weller <ianweller@gmail.com> 1.15-4
  154. - Added libraries and ldconfig
  155. * Mon Feb 18 2008 Ian Weller <ianweller@gmail.com> 1.15-3
  156. - Added provides -static to -devel
  157. * Sun Feb 17 2008 Ian Weller <ianweller@gmail.com> 1.15-2
  158. - Removed redundant requires
  159. - Removed redundant documentation between packages
  160. - Fixed license tag
  161. - Fixed -devel description
  162. - Added the static library back to -devel
  163. - Added make clean
  164. * Fri Feb 08 2008 Ian Weller <ianweller@gmail.com> 1.15-1
  165. - First package build.