libusb1-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library which allows userspace access to USB devices
  3. Summary(ja): USB デバイスにユーザスペースからアクセスするためのライブラリ
  4. Name: libusb1
  5. Version: 1.0.24
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: https://libusb.info/
  12. Source0: https://github.com/libusb/libusb/releases/download/v%{version}/libusb-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. ExcludeArch: s390 s390x
  15. BuildRequires: libudev-devel
  16. BuildRequires: doxygen
  17. %global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
  18. %description
  19. This package provides a way for applications to access USB devices. Note that
  20. this library is not compatible with the original libusb-0.1 series.
  21. %description -l ja
  22. このパッケージはアプリケーションが USB デバイスにアクセスする方法を提供します。
  23. このライブラリはオリジナルの libusb-0.1 シリーズと互換性がないことに注意してください。
  24. %package devel
  25. Summary: Development files for libusb
  26. Summary(ja): libusb の開発用ファイル
  27. Group: programming
  28. Requires: %{name} = %{version}-%{release}
  29. Requires: pkgconfig
  30. Provides: pkgconfig(libusb-1.0) = %{version}
  31. %description devel
  32. This package contains the header files, libraries and documentation needed to
  33. develop applications that use libusb1.
  34. %description devel -l ja
  35. このパッケージは libusb1 を使うアプリケーションを開発するために
  36. 必要なヘッダファイル、ライブラリ、ドキュメントを含んでいます。
  37. %package static
  38. Summary: Static development files for libusb
  39. Summary(ja): libusb の静的開発ファイル
  40. Group: programming
  41. Requires: %{name}-devel = %{version}-%{release}
  42. %description static
  43. This package contains static libraries to develop applications that use libusb1.
  44. %description static -l ja
  45. このパッケージは libusb1 を使うアプリケーションを開発するための
  46. 静的ライブラリを含んでいます。
  47. # compat32
  48. %package -n compat32-%{name}
  49. Summary: A library which allows userspace access to USB devices
  50. Summary(ja): USB デバイスにユーザスペースからアクセスするためのライブラリ
  51. Group: system
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: compat32-eudev-libudev
  54. %description -n compat32-%{name}
  55. This package provides a way for applications to access USB devices. Note that
  56. this library is not compatible with the original libusb-0.1 series.
  57. %description -n compat32-%{name} -l ja
  58. このパッケージはアプリケーションが USB デバイスにアクセスする方法を提供します。
  59. このライブラリはオリジナルの libusb-0.1 シリーズと互換性がないことに注意してください。
  60. %package -n compat32-%{name}-devel
  61. Summary: Development files for libusb
  62. Summary(ja): libusb の開発用ファイル
  63. Group: programming
  64. Requires: %{name}-devel = %{version}-%{release}
  65. Requires: compat32-%{name} = %{version}-%{release}
  66. Requires: compat32-pkgconfig
  67. %description -n compat32-%{name}-devel
  68. This package contains the header files, libraries and documentation needed to
  69. develop applications that use libusb1.
  70. %description -n compat32-%{name}-devel -l ja
  71. このパッケージは libusb1 を使うアプリケーションを開発するために
  72. 必要なヘッダファイル、ライブラリ、ドキュメントを含んでいます。
  73. %debug_package
  74. %prep
  75. %setup -q -n libusb-%{version}
  76. %build
  77. %configure
  78. make CFLAGS="$RPM_OPT_FLAGS"
  79. pushd doc
  80. make docs
  81. popd
  82. %install
  83. rm -rf $RPM_BUILD_ROOT
  84. make install DESTDIR=$RPM_BUILD_ROOT
  85. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  86. %clean
  87. rm -rf $RPM_BUILD_ROOT
  88. %post -p /sbin/ldconfig
  89. %postun -p /sbin/ldconfig
  90. %if %{build_compat32}
  91. %post -n compat32-%{name} -p /sbin/ldconfig
  92. %postun -n compat32-%{name} -p /sbin/ldconfig
  93. %endif
  94. %files
  95. %defattr(-,root,root)
  96. %license COPYING
  97. %doc AUTHORS README*
  98. %{_libdir}/libusb-1.0.so.*
  99. %files devel
  100. %defattr(-,root,root)
  101. %doc doc/html examples/*.c
  102. %{_includedir}/libusb-1.0
  103. %{_libdir}/libusb-1.0.so
  104. %{_libdir}/pkgconfig/libusb-1.0.pc
  105. %files static
  106. %defattr(-,root,root)
  107. %{_libdir}/libusb-1.0.a
  108. # compat32
  109. %if %{build_compat32}
  110. %files -n compat32-%{name}
  111. %defattr(-,root,root,-)
  112. %{_libdir}/libusb-1.0.so.*
  113. %files -n compat32-%{name}-devel
  114. %defattr(-,root,root,-)
  115. %{_libdir}/libusb-1.0.so
  116. %{_libdir}/pkgconfig/libusb-1.0.pc
  117. %endif
  118. %changelog
  119. * Tue Feb 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.24-1
  120. - new upstream release.
  121. * Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.23-1
  122. - new upstream release.
  123. * Fri Jan 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.21-1
  124. - new upstream release.
  125. * Sat Dec 13 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.19-2
  126. - added compat32 subpackages
  127. * Sat Jul 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.19-1
  128. - new upstream release
  129. - add BuildRequires: eudev-libudev-devel
  130. * Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.9-1
  131. - new upstream release
  132. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-2
  133. - rebuild with rpm-4.8.1 for pkg-config file
  134. * Tue May 25 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.8-1
  135. - new upstream release
  136. * Thu Dec 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.6-1
  137. - new upstream release
  138. * Wed Sep 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.3-1
  139. - new upstream release
  140. * Mon Aug 3 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.2-1
  141. - new upstream release
  142. * Sun Jun 14 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1-1
  143. - new upstream release
  144. - fixed BuildRoot
  145. - added Japanese description, summary
  146. * Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  147. - initial build for Vine Linux
  148. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  149. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  150. * Mon Dec 15 2008 - Bastien Nocera <bnocera@redhat.com> - 1.0.0-1
  151. - Update to 1.0.0
  152. * Fri Nov 21 2008 - Bastien Nocera <bnocera@redhat.com> - 0.9.4-1
  153. - Update to 0.9.4
  154. * Tue Sep 23 2008 Jindrich Novy <jnovy@redhat.com> 0.9.3-0.1
  155. - update to 0.9.3
  156. * Sun Jul 06 2008 - Bastien Nocera <bnocera@redhat.com> - 0.9.1
  157. - Update to 0.9.1
  158. * Mon May 26 2008 Jindrich Novy <jnovy@redhat.com> 0.9.0-0.4
  159. - update to official beta
  160. * Fri May 23 2008 Jindrich Novy <jnovy@redhat.com> 0.9.0-0.3.gitbef33bb
  161. - update comment on how the tarball was created
  162. - use abbreviated git hash within package name to avoid conflicts
  163. - add to %%description that libusb1 is incompatible with libsub-0.1
  164. * Thu May 22 2008 Jindrich Novy <jnovy@redhat.com> 0.9.0-0.2.gitbef33bb
  165. - add info on how the snapshot tarball was created
  166. * Wed May 21 2008 Jindrich Novy <jnovy@redhat.com> 0.9.0-0.1.gitbef33bb
  167. - use proper version to denote it is a git snapshot
  168. * Thu May 15 2008 Jindrich Novy <jnovy@redhat.com> 0.9.0-0.1
  169. - initial packaging