self-build-mplayer-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455
  1. %global with_faac 1
  2. %global with_vaapi 1
  3. %global with_libvpx 1
  4. # define with_ffmpeg 1
  5. %global pkgname mplayer
  6. %global name self-build-%{pkgname}
  7. %global version 1.0
  8. #% global extver rc4
  9. %global svndate 20120525
  10. %global release 47%{?extver:.%extver}%{?svndate:.%svndate}%{?_dist_release}
  11. %global source0path MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
  12. %global source1path MPlayer/skins/Blue-1.8.tar.bz2
  13. Summary: Package to automatically build %{pkgname} rpm package
  14. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  15. Name: %{name}
  16. Version: %{version}
  17. Release: %{release}
  18. Source0: %{pkgname}-vl.spec
  19. Source10: %{pkgname}-snapshot-vine.sh
  20. #Source102: %{pkgname}-config.patch
  21. Source102: %{pkgname}-config-20120525-vine.patch
  22. Source108: %{pkgname}-manlinks.patch
  23. Source114: %{pkgname}-nodvdcss.patch
  24. Source118: %{pkgname}-ffmpeg.patch
  25. License: GPLv2+
  26. Group: Restricted Software
  27. Obsoletes: mplayer < %{version}-%{release}
  28. Obsoletes: self-build-mplayer < %{version}-%{release}
  29. Requires(post): self-build-setup >= 0.9.9
  30. Requires(post): subversion
  31. # (build)requies of target package.
  32. Requires(post): SDL-devel
  33. Requires(post): aalib-devel
  34. Requires(post): alsa-lib-devel
  35. Requires(post): cdparanoia-devel
  36. Requires(post): desktop-file-utils
  37. Requires(post): libdvdnav-devel
  38. Requires(post): enca-devel
  39. Requires(post): freetype2-devel >= 2.0.9
  40. Requires(post): fribidi-devel
  41. Requires(post): fontconfig-devel
  42. Requires(post): giflib-devel
  43. Requires(post): gtk2-devel
  44. Requires(post): mesa-libGL-devel
  45. Requires(post): libXinerama-devel
  46. Requires(post): libXScrnSaver-devel
  47. Requires(post): libXv-devel
  48. Requires(post): libXvMC-devel
  49. Requires(post): libXxf86dga-devel
  50. Requires(post): libXxf86vm-devel
  51. Requires(post): libass-devel
  52. Requires(post): libpng-devel
  53. Requires(post): libjpeg-devel
  54. Requires(post): libdvdread
  55. Requires(post): libmpcdec-devel >= 1.2.1
  56. Requires(post): librtmp-devel >= 2.3
  57. Requires(post): speex-devel >= 1.1
  58. %{?with_vaapi:Requires(post):libva-devel}
  59. Requires(post): libvdpau-devel
  60. Requires(post): libvorbis-devel
  61. %{?with_libvpx:Requires(post): libvpx-devel >= 0.9.6}
  62. Requires(post): lzo-devel >= 2
  63. Requires(post): pulseaudio-lib-devel
  64. Requires(post): speex-devel >= 1.1
  65. Requires(post): twolame-devel
  66. Requires(post): xorg-x11-devel
  67. Requires(post): yasm
  68. Requires(post): zlib-devel
  69. Requires(post): self-build-mplayer-codecs
  70. ##!!Requires(post): self-build-libdvdcss
  71. Requires(post): self-build-faac
  72. Requires(post): self-build-faad2 >= 2.6.1
  73. Requires(post): self-build-lame
  74. Requires(post): self-build-libdca
  75. Requires(post): self-build-libmad
  76. Requires(post): self-build-x264 >= 0.120
  77. Requires(post): self-build-xvidcore >= 0.9.2
  78. Requires(post): self-build-libmpeg2
  79. Requires: TrueType-vlgothic
  80. Requires: mesa-libGL
  81. BuildArch: noarch
  82. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  83. Packager: munepi
  84. %description
  85. MPlayer can play most standard video formats out of the box and almost
  86. all others with the help of external codecs.
  87. MPlayer currently works best from the command line, but visual feedback
  88. for many functions is available from its onscreen status display (OSD),
  89. which is also used for displaying subtitles.
  90. MPlayer also has a GUI with skin support and several unofficial alternative
  91. graphical frontends are available.
  92. MEncoder is a command line video encoder for advanced users that can
  93. be built from the MPlayer source tree. Unofficial graphical frontends
  94. exist but arenot included.
  95. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  96. support for some newer codecs are not yet inpmlemented.
  97. You should install mplayer-codecs package if you want to play videos
  98. using those new codecs.
  99. Additional function is automatically included if following
  100. packages are installed in advance.
  101. samba-libsmbclient-devel: SMB file system support
  102. [Note]
  103. This package requires many other packages to compile
  104. targetsoftware. So it consume more disk space than usual.
  105. Also installation takes logner time because of compilation.
  106. (This will take a few minutes to quarter or half of an hour,
  107. depends on building environment)
  108. [About self-build package]
  109. For some kind of software, distributing of binary package
  110. may viorate the patent or law. Therefore we chose self-build
  111. packge, create binary package on your machine, for such kind
  112. of softwares instead of distributing binary package.
  113. Please obey the national law when you use the created binary
  114. packages. And if you want to use the softwares using patented
  115. thechnology, it may be required to get a permission, make an
  116. agreement or purchas a license. Please consider it with your
  117. purpose or way of use and take appropriate action.
  118. %description -l ja
  119. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  120. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
  121. で再生できます。
  122. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
  123. は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
  124. 面上で確認できます。
  125. MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
  126. 非公式なフロントエンドも利用できます。
  127. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  128. 非公式な GUI フロントエンドもありますが、このパッケージには含まれて
  129. いません。
  130. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  131. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  132. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  133. をインストールする必要があります。
  134. このパッケージより前に以下の関連パッケージをインストールして
  135. おくと、%{pkgname} が対応できる機能が自動的に追加されます。
  136. samba-libsmbclient-devel: SMB ファイルシステムのサポート
  137. [注意]
  138. コンパイルに必要な多くの関連パッケージを要求するので通常より
  139. ディスクの領域を多く消費します。
  140. またインストール時にコンパイルを行うため、通常より時間がかか
  141. る場合があります。(環境にもよりますが数分から数十分程度)
  142. [self-build パッケージについて]
  143. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  144. 違反する可能性があるものがあります。その為、このような問題が
  145. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  146. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  147. ジという方法を採っています。
  148. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  149. アのライセンス、および利用する国の各種法令に従ってください。
  150. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  151. センスの購入などが必要となる場合がありますので、利用する目的
  152. や形態に応じて各自で判断し適切な対応を取ってください。
  153. %prep
  154. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  155. %install
  156. %{__rm} -rf ${RPM_BUILD_ROOT}
  157. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  158. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  159. %{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  160. %{__install} -m 644 \
  161. %{SOURCE102} %{SOURCE108} %{SOURCE114} %{SOURCE118} \
  162. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  163. %clean
  164. %{__rm} -rf ${RPM_BUILD_ROOT}
  165. %posttrans
  166. # ## official tarball
  167. # /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
  168. # http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source0path} \
  169. # http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} \
  170. # 635000
  171. # exit 0
  172. ## svn checkout
  173. # set locale
  174. case $LANG in
  175. ja*)LOCALE=ja ;;
  176. *) LOCALE=C ;;
  177. esac
  178. GetSrc_C(){
  179. echo -n " "
  180. echo "Download source file with Subversion..."
  181. }
  182. GetSrc_ja(){
  183. echo -n " "
  184. echo "Subversion を用いてソースファイルをダウンロードしています..."
  185. }
  186. GetSrc_$LOCALE
  187. # svn checkout
  188. . /etc/self-build.conf
  189. (cd $TEMP_DIR
  190. su $BUILD_USER -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
  191. %__mv %{pkgname}-export-%{svndate}.tar.xz %{_datadir}/%{name}/ || exit 1
  192. )
  193. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
  194. http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} 1368000
  195. %files
  196. %defattr(-,root,root)
  197. %{_datadir}/%{name}
  198. %changelog
  199. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-47.20120525
  200. - updated snapshot 20120525 with ffmpeg 0.11
  201. - dropped Requires(post): self-build-libdvdcss
  202. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111217
  203. - updated snapshot 20111217 (with ffmpeg 0.9)
  204. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
  205. - s/self-build-libdvdnav/libdvdnav/
  206. * Fri Oct 7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
  207. - updated %%source1path
  208. - update to 1.8
  209. * Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
  210. - dropped Requires(post): esound-devel
  211. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
  212. - new upstream release
  213. - ready for Vine Linux 6
  214. - revived support for Vine Linux 5
  215. - added Requires(post):
  216. - libass-devel
  217. - librtmp-devel >= 2.3
  218. - speex-devel >= 1.1
  219. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
  220. - added BuildRequires:
  221. - aalib-devel
  222. - enca-devel
  223. - lzo-devel
  224. - speex-devel
  225. * Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
  226. - updated fixed %{name}-config.patch
  227. - applied %{name}-config-20100709-vine.patch
  228. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  229. - unpacked source archives
  230. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  231. - updated source snapshot 20100709
  232. - renamed %%Source10 to mplayer-snapshot-vine.sh
  233. - added Requires(post): libva-devel, libvpx-devel >= 0.9.1
  234. - dropped vl4 support
  235. - updated %%description
  236. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  237. - updated source snapshot 20100621
  238. - added Requires(post): libXinerama-devel
  239. - dropped vl4 support
  240. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  241. - updated source snapshot 20100401
  242. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  243. - updated source snapshot 20100317
  244. - renamed %%{Source0} to mplayer-vl.spec
  245. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  246. - updated source snapshot 20100216
  247. - dropped obsolete patches
  248. - added Requires(post): libvdpau-devel libXScrnSaver-devel
  249. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  250. - update mplayer-config-20091215-vine.patch
  251. - update mplayer-20091215-x86_32-compile.patch
  252. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  253. - source snapshot 20091031
  254. - updated mplayer-20091031-x86_32-compile.patch
  255. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  256. - source snapshot 20091003
  257. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  258. - added some if conditions for "vl6"
  259. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  260. - source snapshot 20090905
  261. - added settings for vl6
  262. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  263. - source snapshot 20090821
  264. - replaced BR: libungif-devel with BR: giflib-devel
  265. - mentioned VDPAU support in %%description
  266. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  267. - source snapshot 20090722
  268. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  269. - source snapshot 20090702
  270. - check version between original spec and self-build spec in %%prep
  271. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  272. - source snapshot 20090611
  273. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  274. - added Requires: TrueType-vlgothic
  275. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  276. - source snapshot 20090522
  277. - build with x264 >= 0.0.0-9.20090522
  278. - updated mplayer-20090502-nodvdcss.patch
  279. - avoided to execute self-build-rpm.sh on RPM transaction
  280. - moved %%post actions to %%posttrans
  281. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  282. - added PreReq: self-build-mplayer-codecs
  283. * Tue May 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  284. - added BuildArch: noarch
  285. - source snapshot 20090502
  286. - updated mplayer-20090503-x86_32-compile.patch
  287. - updated mplayer-20090502-nodvdcss.patch
  288. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  289. - included source archives:
  290. - mplayer-export-20090327.tar.bz2
  291. - Blue-1.7.tar.bz2
  292. - applied mplayer-config-vine.patch
  293. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  294. - source snapshot 20090327
  295. - updated mplayer-20090327-x86_32-compile.patch
  296. - updated mplayer-20090325-nodvdcss.patch
  297. - dropped gmplayer-about-vine.patch
  298. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  299. - source snapshot 20090206
  300. - dropped mplayer-man-zh_CN.patch
  301. - updated mplayer-20090206-nodvdcss.patch
  302. - changed to PreReq: self-build-faad2 from faad2-devel
  303. - added PreReq: self-build-libmad
  304. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  305. - source snapshot 20090131
  306. - fixed %%files section
  307. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  308. - fixed %%post: added rm -f "$pwd"/%{pkgname}-export-%{svndate}.tar.bz2
  309. * Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  310. - source snapshot
  311. - update mplayer-nodvdcss.patch: mplayer-20090122-nodvdcss.patch
  312. - added PreReq:
  313. - faad2-devel
  314. - libmpcdec-devel
  315. - twolame-devel
  316. - yasm
  317. - self-build-libdvdcss
  318. - self-build-libdvdnav
  319. - self-build-faac
  320. - self-build-lame
  321. - self-build-libdca
  322. - self-build-x264 >= 0.0.0-4.20090110
  323. - self-build-xvidcore >= 0.9.2
  324. - move %%define source0Exists() from %%post section to header
  325. - fixed %%post section: clean up source archive
  326. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  327. - source snapshot
  328. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  329. --disable-faad-internal in configure options
  330. - dropped gmplayer-add-flv-extension.patch
  331. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  332. - source snapshot
  333. - fixed License
  334. - added some patches from RPM Fusion
  335. - updated gmplayer-about-vine.patch for 20081001 snapshot
  336. - added BuildRequires: libdvdread
  337. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  338. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  339. in configure options
  340. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  341. - added PreReq: subversion
  342. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  343. - fixed License
  344. - added some devel packages to support OpenGL
  345. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  346. - spec in utf8
  347. - fix sybolic link of subfont for vl5
  348. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  349. - add "Source105: CVE-2008-1558.patch".
  350. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  351. - build with new versioning policy.
  352. - add "Source200: gmplayer-about-vine.patch".
  353. - add "Source201: gmplayer-add-flv-extension.patch".
  354. - fix <BTS:VineLinux:603>.
  355. - add ">= 0.7-1vl4" to "PreReq: self-build-setup".
  356. - add mirror URLs to self-build-rpm.sh.
  357. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  358. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  359. CVE-2008-0629, CVE-2008-0630)
  360. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  361. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  362. - change source download URL. <BTS:VineLinux:603>
  363. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  364. - fix CONFDIR for make install in mplayer.spec. <BTS:wishes:33>
  365. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  366. - initial build for Vine Linux.