OpenImageIO-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299
  1. %global subname oiio
  2. Name: OpenImageIO
  3. Version: 2.0.11
  4. Release: 1%{?_dist_release}
  5. Summary: Library for reading and writing images
  6. Group: System Environment/Libraries
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: BSD
  10. URL: https://sites.google.com/site/openimageio/home
  11. Source0: https://github.com/%{name}/%{subname}/archive/Release-%{version}/%{subname}-Release-%{version}.tar.gz
  12. # Images for test suite
  13. #Source1: oiio-images.tar.gz
  14. BuildRequires: cmake
  15. BuildRequires: git
  16. BuildRequires: txt2man
  17. BuildRequires: qt5-qtbase-devel
  18. BuildRequires: libboost-devel
  19. BuildRequires: libboost-python3
  20. BuildRequires: libboost-filesystem
  21. BuildRequires: glew-devel
  22. BuildRequires: OpenEXR-devel
  23. BuildRequires: python3-devel
  24. BuildRequires: python3-rpm-macros
  25. # BuildRequires: openssl-devel
  26. BuildRequires: libpng-devel libtiff-devel openjpeg2-devel giflib-devel
  27. BuildRequires: libwebp-devel
  28. BuildRequires: Field3D-devel
  29. BuildRequires: hdf5-devel
  30. BuildRequires: zlib-devel
  31. BuildRequires: jasper-devel
  32. BuildRequires: LibRaw-devel
  33. BuildRequires: pugixml-devel
  34. # WARNING: OpenColorIO and OpenImageIO are cross dependent.
  35. # If an ABI incompatible update is done in one, the other also needs to be
  36. # rebuilt.
  37. BuildRequires: OpenColorIO-devel
  38. Obsoletes: python-OpenImageIO
  39. # We don't want to provide private python extension libs
  40. %{?filter_setup:
  41. %filter_provides_in %{python3_sitearch}/.*\.so$
  42. %filter_setup
  43. }
  44. %description
  45. OpenImageIO is a library for reading and writing images, and a bunch of related
  46. classes, utilities, and applications. Main features include:
  47. - Extremely simple but powerful ImageInput and ImageOutput APIs for reading and
  48. writing 2D images that is format agnostic.
  49. - Format plugins for TIFF, JPEG/JFIF, OpenEXR, PNG, HDR/RGBE, Targa, JPEG-2000,
  50. DPX, Cineon, FITS, BMP, ICO, RMan Zfile, Softimage PIC, DDS, SGI,
  51. PNM/PPM/PGM/PBM, Field3d.
  52. - An ImageCache class that transparently manages a cache so that it can access
  53. truly vast amounts of image data.
  54. %package -n python3-%{name}
  55. Summary: Python 3 bindings for %{name}
  56. Requires: %{name} = %{version}-%{release}
  57. %description -n python3-%{name}
  58. Python3 bindings for %{name}.
  59. %package utils
  60. Summary: Command line utilities for %{name}
  61. Requires: %{name} = %{version}-%{release}
  62. %description utils
  63. Command-line tools to manipulate and get information on images using the
  64. %{name} library.
  65. %package iv
  66. Summary: %{name} based image viewer
  67. Requires: %{name} = %{version}-%{release}
  68. %description iv
  69. A really nice image viewer, iv, based on %{name} classes (and so will work
  70. with any formats for which plugins are available).
  71. %package devel
  72. Summary: Documentation for %{name}
  73. Group: Development/Libraries
  74. Requires: %{name} = %{version}-%{release}
  75. %description devel
  76. Development files for package %{name}
  77. %prep
  78. %setup -q -n oiio-Release-%{version}
  79. # Remove bundled pugixml
  80. %{__rm} -f src/include/pugixml.hpp \
  81. src/include/pugiconfig.hpp \
  82. src/libutil/pugixml.cpp
  83. # Remove bundled tbb
  84. %{__rm} -rf src/include/tbb
  85. # Install test images
  86. #rm -rf ../oiio-images && mkdir ../oiio-images && pushd ../oiio-images
  87. #tar --strip-components=1 -xzf %{SOURCE1}
  88. %build
  89. %{__rm} -rf build/linux && %{__mkdir_p} build/linux && pushd build/linux
  90. export PYTHON=%{__python3}
  91. export PYTHON_LIBRARIES=%(%{__python3} -c "import distutils.sysconfig as sysconfig; print(sysconfig.get_config_var('LIBDIR'))")
  92. export PYTHON_INCLUDE_DIRS=%(%{__python3} -c "from distutils.sysconfig import get_python_inc; print(get_python_inc())")
  93. # CMAKE_SKIP_RPATH is OK here because it is set to FALSE internally and causes
  94. # CMAKE_INSTALL_RPATH to be cleared, which is the desiered result.
  95. %cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  96. -DCMAKE_SKIP_RPATH:BOOL=TRUE \
  97. -DINCLUDE_INSTALL_DIR:PATH=/usr/include/%{name} \
  98. -DPYTHON_VERSION=3.5 \
  99. -DPYTHON_EXECUTABLE=%{__python3} \
  100. -DPYTHON_LIBRARY=$PYTHON_LIBRARIES \
  101. -DPYLIB_INSTALL_DIR:PATH=%{python3_sitearch} \
  102. -DINSTALL_DOCS:BOOL=FALSE \
  103. -DINSTALL_FONTS:BOOL=FALSE \
  104. -DUSE_EXTERNAL_PUGIXML:BOOL=TRUE \
  105. -DUSE_TBB:BOOL=FALSE \
  106. -DUSE_OPENSSL:BOOL=TRUE \
  107. -DSTOP_ON_WARNING:BOOL=FALSE \
  108. -DUSE_CPP:STRING=14 \
  109. %ifarch ppc ppc64
  110. -DNOTHREADS:BOOL=FALSE \
  111. %endif
  112. -DJPEG_INCLUDE_DIR=%{_includedir} \
  113. -DVERBOSE=TRUE \
  114. ../../
  115. %{__make} %{?_smp_mflags}
  116. popd
  117. %install
  118. pushd build/linux
  119. %{make_install}
  120. popd
  121. # # Move man pages to the right directory
  122. # mkdir -p %{buildroot}%{_mandir}/man1
  123. # cp -a src/doc/*.1 %{buildroot}%{_mandir}/man1
  124. %post -p %{_syssbindir}/ldconfig
  125. %postun -p %{_syssbindir}/ldconfig
  126. %files
  127. %license LICENSE*
  128. %doc CHANGES.md CONTRIBUTING.md README.md
  129. %{_libdir}/libOpenImageIO.so.*
  130. %{_libdir}/libOpenImageIO_Util.so.*
  131. %files -n python3-%{name}
  132. %{python3_sitearch}/OpenImageIO.so
  133. %files utils
  134. %exclude %{_bindir}/iv
  135. %{_bindir}/*
  136. # %exclude %{_mandir}/man1/iv.1.gz
  137. # %{_mandir}/man1/*.1.gz
  138. %files iv
  139. %{_bindir}/iv
  140. # %{_mandir}/man1/iv.1.gz
  141. %files devel
  142. %doc src/doc/*.pdf
  143. %{_libdir}/libOpenImageIO.so
  144. %{_libdir}/libOpenImageIO_Util.so
  145. %dir %{_libdir}/pkgconfig
  146. %{_libdir}/pkgconfig/OpenImageIO.pc
  147. %dir %{_datadir}/cmake
  148. %dir %{_datadir}/cmake/Modules
  149. %{_datadir}/cmake/Modules/FindOpenImageIO.cmake
  150. %{_includedir}/*
  151. %changelog
  152. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.11-1
  153. - new upstream release.
  154. * Sun Sep 08 2019 Toshiaki Ara <ara_t@384.jp> 1.8.17-1
  155. - update to 1.8.17
  156. * Tue Nov 06 2018 Toshiaki Ara <ara_t@384.jp> 1.8.16-1
  157. - update to 1.8.16
  158. - change BuildRequires: qt4-devel to qt5-qtbase-devel
  159. - drop BuildRequires: openssl-devel
  160. * Fri Aug 24 2018 Toshiaki Ara <ara_t@384.jp> 1.7.19-3
  161. - update to 1.7.19
  162. - using macro
  163. * Sat Aug 04 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-2
  164. - rebuild with hdf5-1.8.20
  165. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.7.17-1
  166. - update to 1.7.17
  167. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.14-3
  168. - rebuilt with LibRaw-0.17.2.
  169. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-2
  170. - rebuild with gcc-5.4.0
  171. * Mon Jun 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
  172. - new upstream release
  173. * Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.13-1
  174. - new upstream release
  175. - remove Patch0
  176. - create python-%%{name} subpackage
  177. * Thu Oct 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-2
  178. - rebuild with glew-1.13.0
  179. * Sun Jan 18 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.15-1
  180. - initial build for Vine Linux
  181. - add Patch0 (oiio-Release-1.4.15-sign-compare.patch)
  182. * Wed Nov 26 2014 Rex Dieter <rdieter@fedoraproject.org> 1.4.15-2
  183. - rebuild (openexr)
  184. * Tue Nov 25 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.15-1
  185. - Update to latest upstream release.
  186. * Fri Nov 14 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.14-1
  187. - Update to latest upstream release.
  188. * Fri Sep 5 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-4
  189. - Rebuild for Field3D 1.4.3.
  190. * Thu Sep 04 2014 Orion Poplawski <orion@cora.nwra.com> - 1.4.12-3
  191. - Rebuild for pugixml 1.4
  192. * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.12-2
  193. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  194. * Fri Aug 1 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.12-1
  195. - Update to latest upstream release.
  196. * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-4
  197. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  198. * Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 1.4.7-3
  199. - Rebuild for boost 1.55.0
  200. * Fri May 23 2014 David Tardon <dtardon@redhat.com> - 1.4.7-2
  201. - rebuild for boost 1.55.0
  202. * Mon May 19 2014 Richard Shaw <hobbes1069@gmail.com> - 1.4.7-1
  203. - Update to latest upstream release.
  204. * Tue Jan 7 2014 Richard Shaw <hobbes1069@gmail.com> - 1.3.10-1
  205. - Update to latest upstream release.
  206. - Add libgif as build requirement.
  207. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> - 1.2.3-3
  208. - rebuild (openexr)
  209. * Mon Nov 18 2013 Dave Airlie <airlied@redhat.com> - 1.2.3-2
  210. - rebuilt for GLEW 1.10
  211. * Wed Nov 6 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.3-1
  212. - Update to latest upstream release.
  213. - Fix ppc builds (BZ#1021977).
  214. - Add conditionals to build requirements for EPEL 6.
  215. * Wed Oct 2 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.2-1
  216. - Update to latest upstream release.
  217. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 1.2.1-2
  218. - rebuild (ilmbase/openexr)
  219. * Thu Aug 8 2013 Richard Shaw <hobbes1069@gmail.com> - 1.2.1-1
  220. - Update to latest upstream release.
  221. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
  222. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  223. * Sun Jul 28 2013 Petr Machata <pmachata@redhat.com> - 1.2.0-2
  224. - Rebuild for boost 1.54.0