OpenColorIO-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239
  1. %bcond_with doc
  2. # Filter provides from Python libraries
  3. %{?filter_setup:
  4. %filter_provides_in %{python3_sitearch}.*\.so$
  5. %filter_setup
  6. }
  7. Name: OpenColorIO
  8. Version: 1.1.1
  9. Release: 1%{?_dist_release}
  10. Summary: Enables color transforms and image display across graphics apps
  11. Summary(ja): アプリケーション間での色変換と画像表示を行うためのライブラリ
  12. Group: System Environment/Libraries
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. License: BSD
  16. URL: https://opencolorio.org/
  17. # Github archive was generated on the fly using the following URL:
  18. # https://github.com/imageworks/OpenColorIO/tarball/v1.0.8
  19. Source0: https://github.com/AcademySoftwareFoundation/OpenColorIO/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  20. Patch1: OpenColorIO-yaml_cpp3.patch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: cmake
  23. BuildRequires: git
  24. BuildRequires: help2man
  25. %if %{with doc}
  26. BuildRequires: texlive-collection-fontsrecommended
  27. BuildRequires: texlive-collection-latexextra
  28. BuildRequires: texlive-collection-latexrecommended
  29. %endif
  30. # Libraries
  31. BuildRequires: python3-devel
  32. BuildRequires: python3-rpm-macros
  33. BuildRequires: mesa-libGL-devel mesa-libGLU-devel
  34. BuildRequires: libX11-devel libXmu-devel libXi-devel
  35. BuildRequires: freeglut-devel
  36. BuildRequires: glew-devel
  37. BuildRequires: zlib-devel
  38. #######################
  39. # Unbundled libraries #
  40. #######################
  41. BuildRequires: tinyxml-devel
  42. BuildRequires: lcms2-devel
  43. #BuildRequires: yaml-cpp-devel
  44. # The following bundled projects are only used for document generation.
  45. #BuildRequires: python-docutils
  46. #BuildRequires: python-jinja2
  47. #BuildRequires: python-pygments
  48. #BuildRequires: python-setuptools
  49. #BuildRequires: python-sphinx
  50. %if ! %{with doc}
  51. Obsoletes: %{name}-doc < %{version}-%{release}
  52. %endif
  53. %description
  54. OCIO enables color transforms and image display to be handled in a consistent
  55. manner across multiple graphics applications. Unlike other color management
  56. solutions, OCIO is geared towards motion-picture post production, with an
  57. emphasis on visual effects and animation color pipelines.
  58. %package devel
  59. Summary: Development libraries and headers for %{name}
  60. Summary(ja): %{name} の開発用ライブラリおよびヘッダファイル
  61. Group: Development/Libraries
  62. Requires: %{name} = %{version}-%{release}
  63. %description devel
  64. Development libraries and headers for %{name}.
  65. %package doc
  66. Summary: API Documentation for %{name}
  67. Summary(ja): %{name} API のドキュメント
  68. Group: Documentation
  69. BuildArch: noarch
  70. Requires: %{name} = %{version}-%{release}
  71. %description doc
  72. API documentation for %{name}.
  73. %prep
  74. %setup -q
  75. #patch1 -p1 -b .yaml3
  76. # Remove what bundled libraries
  77. rm -f ext/lcms*
  78. rm -f ext/tinyxml*
  79. #rm -f ext/yaml*
  80. %build
  81. rm -rf build && mkdir build && pushd build
  82. export CXXFLAGS="%{optflags} -Wno-deprecated-declarations -Wno-cast-function-type -Wno-unused-function"
  83. %cmake \
  84. -DPYTHON=%{__python3} \
  85. -DPYLIB_INSTALL_DIR:PATH=%{python3_sitearch} \
  86. -DOCIO_BUILD_STATIC=OFF \
  87. %if %{with doc}
  88. -DOCIO_BUILD_DOCS=ON \
  89. %else
  90. -DOCIO_BUILD_DOCS=OFF \
  91. %endif
  92. -DOCIO_BUILD_TESTS=ON \
  93. -DOCIO_PYGLUE_SONAME=OFF \
  94. -DUSE_EXTERNAL_YAML=FALSE \
  95. -DUSE_EXTERNAL_TINYXML=TRUE \
  96. -DUSE_EXTERNAL_LCMS=TRUE \
  97. %ifnarch x86_64
  98. -DOCIO_USE_SSE=OFF \
  99. %endif
  100. -DCMAKE_SKIP_RPATH=OFF \
  101. ..
  102. # -DUSE_EXTERNAL_YAML=FALSE \
  103. make %{_smp_mflags}
  104. %install
  105. rm -rf %{buildroot}
  106. pushd build
  107. %make_install
  108. # Generate man pages
  109. mkdir -p %{buildroot}%{_mandir}/man1
  110. help2man -N -s 1 --version-string=%{version} \
  111. -o %{buildroot}%{_mandir}/man1/ociocheck.1 \
  112. src/apps/ociocheck/ociocheck
  113. help2man -N -s 1 --version-string=%{version} \
  114. -o %{buildroot}%{_mandir}/man1/ociobakelut.1 \
  115. src/apps/ociobakelut/ociobakelut
  116. # Move installed documentation back so it doesn't conflict with the main package
  117. popd
  118. %if %{with doc}
  119. rm -rf _tmpdoc
  120. mkdir -p _tmpdoc
  121. mv %{buildroot}%{_docdir}/%{name}/* _tmpdoc/
  122. %endif
  123. mv -f %{buildroot}%{_prefix}/cmake %{buildroot}%{_libdir}/
  124. mv -f %{buildroot}%{_prefix}/*.cmake %{buildroot}%{_libdir}/cmake/
  125. %check
  126. # Testing passes locally in mock but fails on the fedora build servers.
  127. #pushd build && make test
  128. %post -p /sbin/ldconfig
  129. %postun -p /sbin/ldconfig
  130. %clean
  131. rm -rf %{buildroot}
  132. %files
  133. %license LICENSE
  134. %doc CHANGELOG* README*
  135. %{_bindir}/*
  136. %{_libdir}/*.so.*
  137. %dir %{_datadir}/ocio
  138. %{_datadir}/ocio/setup_ocio.sh
  139. %{_mandir}/man1/*
  140. %{python3_sitearch}/*.so
  141. %files devel
  142. %{_includedir}/OpenColorIO/
  143. %{_includedir}/PyOpenColorIO/
  144. %{_libdir}/*.so
  145. %dir %{_libdir}/pkgconfig
  146. %{_libdir}/pkgconfig/%{name}.pc
  147. %dir %{_libdir}/cmake
  148. %{_libdir}/cmake/*
  149. %if %{with doc}
  150. %files doc
  151. %doc _tmpdoc/*
  152. %endif
  153. %changelog
  154. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.1-1
  155. - new upstream release.
  156. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.8-8
  157. - rebuild with gcc-5.4.0
  158. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.0.8-7
  159. - Initial build for Vine Linux
  160. - used bundled yaml-cpp
  161. * Mon Sep 23 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-6
  162. - Rebuild against yaml-cpp03 compatibility package.
  163. * Mon Aug 26 2013 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-5
  164. - Fix for new F20 feature, unversion doc dir. Fixes BZ#1001264
  165. * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-3
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  167. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.8-2
  168. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  169. * Tue Dec 11 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.8-1
  170. - Update to latest upstream release.
  171. * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.7-5
  172. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  173. * Thu Apr 26 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-4
  174. - Only use SSE instructions on x86_64.
  175. * Wed Apr 25 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-3
  176. - Misc spec cleanup for packaging guidelines.
  177. - Disable testing for now since it fails on the build servers.
  178. * Wed Apr 18 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.7-1
  179. - Latest upstream release.
  180. * Thu Apr 05 2012 Richard Shaw <hobbes1069@gmail.com> - 1.0.6-1
  181. - Latest upstream release.
  182. * Wed Nov 16 2011 Richard Shaw <hobbes1069@gmail.com> - 1.0.2-1
  183. - Initial release.