libgit2-vl.spec 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485
  1. Summary: C implementation of the Git core methods as a library with a solid API
  2. Name: libgit2
  3. Version: 0.22.2
  4. Release: 1%{?_dist_release}
  5. License: GPLv2
  6. Group: System Environment/Libraries
  7. URL: https://libgit2.github.com/
  8. # https://github.com/libgit2/libgit2/archive/v0.22.2.tar.gz
  9. Source0: %{name}-%{version}.tar.gz
  10. BuildRequires: cmake
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: Takemikaduchi
  15. %description
  16. libgit2 is a portable, pure C implementation of the Git core methods
  17. provided as a re-entrant linkable library with a solid API, allowing
  18. you to write native speed custom Git applications in any language
  19. which supports C bindings.
  20. %package devel
  21. Summary: Development tools for %{name}
  22. Summary(ja): %{name} の開発環境
  23. Group: Development/Libraries
  24. Requires: %{name} = %{version}-%{release}
  25. Requires: pkgconfig
  26. %description devel
  27. Header files and libraries for building a extension library for the %{name}.
  28. %prep
  29. %setup -q
  30. %build
  31. rm -rf build && mkdir build && pushd build
  32. %cmake -DINSTALL_DOCS=OFF \
  33. ../
  34. make %{?_smp_mflags}
  35. popd
  36. %install
  37. rm -rf ${RPM_BUILD_ROOT}
  38. pushd build
  39. make install DESTDIR=${RPM_BUILD_ROOT}
  40. popd
  41. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
  42. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  43. %clean
  44. %{__rm} -rf ${RPM_BUILD_ROOT}
  45. %post -p /sbin/ldconfig
  46. %postun -p /sbin/ldconfig
  47. %files
  48. %defattr(-,root,root,-)
  49. %doc COPYING CHANGELOG.md README.md
  50. %{_libdir}/%{name}.so.*
  51. %files devel
  52. %defattr(-,root,root,-)
  53. %{_includedir}/git2/
  54. %{_includedir}/git2.h
  55. %{_libdir}/%{name}.so
  56. %{_libdir}/pkgconfig/%{name}.pc
  57. %changelog
  58. * Wed Apr 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.2-1
  59. - initial build