zlib-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: The zlib compression and decompression library.
  3. Summary(ja): zlib 圧縮/展開ライブラリ
  4. Name: zlib
  5. Version: 1.2.3
  6. Release: 7%{?_dist_release}
  7. Group: System Environment/Libraries
  8. Source: http://www.zlib.net/zlib-%{version}.tar.bz2
  9. Requires(post): /sbin/ldconfig
  10. Requires(postun): /sbin/ldconfig
  11. URL: http://www.zlib.net/
  12. License: BSD
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. %description
  15. The zlib compression library provides in-memory compression and
  16. decompression functions, including integrity checks of the
  17. uncompressed data. This version of the library supports only one
  18. compression method (deflation), but other algorithms may be added
  19. later, which will have the same stream interface. The zlib library is
  20. used by many different system programs.
  21. %description -l ja
  22. zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
  23. のデータの整合性チェックを行う関数を提供します。今バージョンのラ
  24. イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
  25. ートしていますが、今後同じストリームインターフェースを持つ他の圧
  26. 縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
  27. 用されています。
  28. %package devel
  29. Summary: Header files and libraries for developing apps which will use zlib.
  30. Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. %description devel
  34. The zlib-devel package contains the header files and libraries needed
  35. to develop programs that use the zlib compression and decompression
  36. library.
  37. %package static
  38. Summary: Static libraries for %{name}
  39. Summary(ja): %{name} のスタティックライブラリ
  40. Group: Development/Libraries
  41. Requires: %{name}-devel = %{version}-%{release}
  42. %description static
  43. The zlib-static package contains the static library for %{name}
  44. ## to build compat32 for x86_64 architecture support
  45. %package -n compat32-%{name}
  46. Summary: The zlib compression and decompression library.
  47. Summary(ja): zlib 圧縮/展開ライブラリ
  48. Group: System Environment/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. Requires(post): /sbin/ldconfig
  51. Requires(postun): /sbin/ldconfig
  52. %description -n compat32-%{name}
  53. The zlib compression library provides in-memory compression and
  54. decompression functions, including integrity checks of the
  55. uncompressed data. This version of the library supports only one
  56. compression method (deflation), but other algorithms may be added
  57. later, which will have the same stream interface. The zlib library is
  58. used by many different system programs.
  59. %description -n compat32-%{name} -l ja
  60. zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
  61. のデータの整合性チェックを行う関数を提供します。今バージョンのラ
  62. イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
  63. ートしていますが、今後同じストリームインターフェースを持つ他の圧
  64. 縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
  65. 用されています。
  66. %package -n compat32-%{name}-devel
  67. Summary: Header files and libraries for developing apps which will use zlib.
  68. Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
  69. Group: Development/Libraries
  70. Requires: %{name} = %{version}-%{release}
  71. Requires: %{name}-devel = %{version}-%{release}
  72. %description -n compat32-%{name}-devel
  73. The zlib-devel package contains the header files and libraries needed
  74. to develop programs that use the zlib compression and decompression
  75. library.
  76. Install the zlib-devel package if you want to develop applications that
  77. will use the zlib library.
  78. %prep
  79. %setup -q
  80. %build
  81. mkdir static shared
  82. # build shared lib
  83. CFLAGS="$RPM_OPT_FLAGS -fPIC" ./configure --shared --prefix=%{_prefix}
  84. make
  85. mv -f Makefile zconf.h *.o *.so* shared/
  86. # build static lib
  87. CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
  88. make
  89. mv -f Makefile zconf.h *.o *.a static/
  90. %install
  91. rm -rf ${RPM_BUILD_ROOT}
  92. mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
  93. mv -f shared/* .
  94. make install prefix=${RPM_BUILD_ROOT}%{_prefix}
  95. mv -f Makefile zconf.h *.o *.so* shared/
  96. mv -f static/* .
  97. make install prefix=${RPM_BUILD_ROOT}%{_prefix}
  98. install -m644 zutil.h ${RPM_BUILD_ROOT}%{_includedir}/zutil.h
  99. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
  100. install -m644 zlib.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
  101. if [ "%{_prefix}/lib" != "%{_libdir}" ]; then
  102. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  103. mv ${RPM_BUILD_ROOT}%{_prefix}/lib/* ${RPM_BUILD_ROOT}%{_libdir}
  104. rmdir ${RPM_BUILD_ROOT}%{_prefix}/lib
  105. fi
  106. %clean
  107. rm -rf ${RPM_BUILD_ROOT}
  108. %post -p /sbin/ldconfig
  109. %postun -p /sbin/ldconfig
  110. %post -n compat32-%{name} -p /sbin/ldconfig
  111. %postun -n compat32-%{name} -p /sbin/ldconfig
  112. %files
  113. %defattr(-,root,root)
  114. %doc README
  115. %{_libdir}/libz.so.*
  116. %files devel
  117. %defattr(-,root,root)
  118. %doc ChangeLog algorithm.txt minigzip.c example.c
  119. %{_libdir}/*.so
  120. %{_includedir}/*
  121. %{_mandir}/man3/zlib.3*
  122. %files static
  123. %defattr(-,root,root)
  124. %{_libdir}/*.a
  125. %if %{build_compat32}
  126. %files -n compat32-%{name}
  127. %defattr(-,root,root)
  128. %{_libdir}/libz.so.*
  129. %files -n compat32-%{name}-devel
  130. %defattr(-,root,root)
  131. %{_libdir}/*.so
  132. %endif
  133. %changelog
  134. * Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-7
  135. - add Requires(post,pre): /sbin/ldconfig
  136. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-6
  137. - rebuilt with gcc-4.4.3-3 on ppc
  138. * Mon Feb 8 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-5
  139. - rebuilt with new toolchain
  140. * Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-4
  141. - split static library to zlib-static
  142. - needed by tuxonice-userui
  143. * Wed Dec 17 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-3
  144. - change spec into UTF-8
  145. * Sun May 18 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.3-2
  146. - removed %%if !%%{build_compat32} case condition
  147. * Sat May 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
  148. - applied new versioning policy
  149. - rebuilt with new toolchains
  150. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl5
  151. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  152. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl4
  153. - added compat32-* packages for x86_64 architecture support
  154. * Tue Oct 25 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.3-0vl3
  155. - added compat32- packages for x86_64 architecture support
  156. * Tue Oct 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl2
  157. - clean up specfile (do not build twice..)
  158. * Tue Jul 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
  159. - new upstream release
  160. * Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.2-0vl1
  161. - new upstream release
  162. - add Patch1 for CAN-2005-2096
  163. * Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
  164. - new upstream version
  165. - add translated descriptions (thanks to spec file translation project)
  166. * Sun Apr 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.1.4-0vl3
  167. - fixed buffer overrun on gzprintf
  168. -- added zlib-1.1.4-vsnprintf.patch from http://archives.neohapsis.com/archives/bugtraq/2003-02/0290.html
  169. * Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.4-0vl2
  170. - changed URL to more preferable site
  171. * Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.4-0vl1
  172. - upstream release
  173. * Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  174. - 1.1.3-14vl1
  175. - based on 1.1.3-14 from Rawhide
  176. - added Japanese summary
  177. * Fri Sep 15 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  178. - add -fPIC for shared libs (patch by Fritz Elfert)
  179. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  180. - on 64bit systems, make sure libraries are located correctly.
  181. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  182. - summaries from specspo.
  183. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  184. - automatic rebuild
  185. * Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
  186. - rebuild
  187. * Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
  188. - FHS packaging to build on solaris2.5.1.
  189. * Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
  190. - use %%{_mandir} and %%{_tmppath}
  191. * Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
  192. - updated URL and source location
  193. - moved README to main package
  194. * Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
  195. - compress man page.
  196. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  197. - auto rebuild in the new build environment (release 5)
  198. * Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
  199. - link against glibc
  200. * Mon Jul 27 1998 Jeff Johnson <jbj@redhat.com>
  201. - upgrade to 1.1.3
  202. * Fri May 08 1998 Prospector System <bugs@redhat.com>
  203. - translations modified for de, fr, tr
  204. * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
  205. - upgraded to 1.1.2
  206. - buildroot
  207. * Tue Oct 07 1997 Donnie Barnes <djb@redhat.com>
  208. - added URL tag (down at the moment so it may not be correct)
  209. - made zlib-devel require zlib
  210. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  211. - built against glibc