ldns-vl.spec 8.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287
  1. %{?!with_python: %global with_python 1}
  2. %if %{with_python}
  3. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  4. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  5. %endif
  6. Summary: Lowlevel DNS(SEC) library with API
  7. Summary(ja): 低レベルな DNS(SEC) ライブラリと API
  8. Name: ldns
  9. Version: 1.6.6
  10. Release: 1%{?_dist_release}
  11. License: BSD
  12. Url: http://www.nlnetlabs.nl/%{name}/
  13. Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
  14. Group: System Environment/Libraries
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
  17. BuildRequires: perl, libpcap-devel, openssl-devel
  18. Requires: libpcap, openssl
  19. Distribution: Vine Linux
  20. Vendor: Project Vine
  21. Packager: iwaim
  22. %if %{with_python}
  23. BuildRequires: python-devel, swig
  24. %endif
  25. %description
  26. ldns is a library with the aim to simplify DNS programing in C. All
  27. lowlevel DNS/DNSSEC operations are supported. We also define a higher
  28. level API which allows a programmer to (for instance) create or sign
  29. packets.
  30. %package devel
  31. Summary: Development package that includes the ldns header files
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. %description devel
  35. The devel package contains the ldns library and the include files
  36. %if %{with_python}
  37. %package python
  38. Summary: Python extensions for ldns
  39. Group: Applications/System
  40. Requires: %{name} = %{version}-%{release}
  41. %description python
  42. Python extensions for ldns
  43. %endif
  44. %prep
  45. %setup -q
  46. %build
  47. %configure --disable-rpath --disable-static --with-sha2 \
  48. %if %{with_python}
  49. --with-pyldns
  50. %endif
  51. (cd drill ; %configure --disable-rpath --disable-static --with-ldns=%{buildroot}/lib/ )
  52. (cd examples ; %configure --disable-rpath --disable-static --with-ldns=%{buildroot}/lib/ )
  53. make %{?_smp_mflags}
  54. ( cd drill ; make %{?_smp_mflags} )
  55. ( cd examples ; make %{?_smp_mflags} )
  56. make %{?_smp_mflags} doc
  57. %install
  58. rm -rf %{buildroot}
  59. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
  60. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
  61. %if %{with_python}
  62. # remove execute perms from python files
  63. chmod a-x %{buildroot}%{python_sitelib}/*py
  64. %endif
  65. # don't package building script in doc
  66. rm doc/doxyparse.pl
  67. #remove doc stubs
  68. rm -rf doc/.svn
  69. #remove double set of man pages
  70. rm -rf doc/man
  71. # remove .la files
  72. rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitelib}/*.la
  73. (cd drill ; make DESTDIR=%{buildroot} install)
  74. (cd examples; make DESTDIR=%{buildroot} install)
  75. %clean
  76. rm -rf %{buildroot}
  77. %files
  78. %defattr(-,root,root)
  79. %{_libdir}/libldns*so.*
  80. %{_bindir}/drill
  81. %{_bindir}/ldnsd
  82. #%{_bindir}/ldns-*
  83. %{_bindir}/ldns-chaos
  84. %{_bindir}/ldns-compare-zones
  85. %{_bindir}/ldns-[d-z]*
  86. %doc README LICENSE
  87. %{_mandir}/*/*
  88. %files devel
  89. %defattr(-,root,root,-)
  90. %{_libdir}/libldns*so
  91. %{_bindir}/ldns-config
  92. %dir %{_includedir}/ldns
  93. %{_includedir}/ldns/*.h
  94. %doc doc Changelog README
  95. %if %{with_python}
  96. %files python
  97. %defattr(-,root,root)
  98. %{python_sitelib}/*
  99. %endif
  100. %post -p /sbin/ldconfig
  101. %postun -p /sbin/ldconfig
  102. %changelog
  103. * Thu Sep 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
  104. - new upstream release
  105. * Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
  106. - new upstream release
  107. - drop unnecessary installfix patch (Patch1): upstream merged
  108. - drop unnecessary rpathfix patch (Patch2): upstream merged
  109. * Thu Jun 3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
  110. - rebuild with libpcap 1.1.1 on VineSeed
  111. * Wed May 5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
  112. - initial build for Vine Linux: based Fedora 1.6.4-2.fc13
  113. * Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
  114. - Fix missing _ldns.so causing ldns-python to not work
  115. - Patch for installing ldns-python files
  116. - Patch for rpath in ldns-python
  117. - Don't install .a file for ldns-python
  118. * Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
  119. - Upgraded to 1.6.4.
  120. - Added ldns-python sub package
  121. * Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
  122. - Upgraded to 1.6.3, which has minor bugfixes
  123. * Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
  124. - Upgraded to 1.6.2. This fixes various bugs.
  125. (upstream released mostly to default with sha2 for the imminent
  126. signed root, but we already enabled that in our builds)
  127. * Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
  128. - rebuilt with new openssl
  129. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
  130. - Added openssl dependancy back in, since we get more functionality
  131. when using openssl. Especially in 'drill'.
  132. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
  133. - Updated to 1.6.1
  134. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
  135. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  136. * Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
  137. - Fixed the ssl patch so it can now compile --without-ssl
  138. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
  139. - Added patch to compile with --without-ssl
  140. - Removed openssl dependancies
  141. - Recompiled with --without-ssl
  142. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
  143. - Updated to 1.6.0
  144. - (did not yet compile with --without-ssl due to compile failures)
  145. * Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
  146. - Updated to 1.6.0
  147. - Compile without openssl
  148. * Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
  149. - Memory management bug when generating a sha256 key, see:
  150. https://bugzilla.redhat.com/show_bug.cgi?id=493953
  151. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
  152. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  153. * Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
  154. - Updated to new version, 1.5.0 had a bug preventing
  155. zone signing.
  156. * Mon Feb 9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
  157. - Updated to new version
  158. * Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
  159. - fixed configure flags
  160. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
  161. - rebuild with new openssl
  162. * Fri Nov 7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
  163. - Updated to 1.4.0
  164. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
  165. - enable SHA2 functionality
  166. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  167. - re-tag (don't do builds while renaming local repo dirs)
  168. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  169. - Updated to latest release
  170. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
  171. - Autorebuild for GCC 4.3
  172. * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
  173. - Rebuild for new libcrypto
  174. * Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
  175. - Upgraded to 1.2.2. Removed no longer needed race workaround
  176. * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
  177. - Try to fix racing ln -s statements in parallel builds
  178. * Fri Nov 9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
  179. - Added patch for ldns-read-zone that does not put @. in RRDATA
  180. * Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
  181. - Use install -p to work around multilib conflicts for .h files
  182. * Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
  183. - Updated to 1.2.1
  184. - Removed patches that got moved into upstream
  185. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
  186. - Patch for ldns-key2ds to write to stdout
  187. - Again remove extra set of man pages from doc
  188. - own /usr/include/ldns (bug 233858)
  189. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
  190. - Added sha256 DS record patch to ldns-key2ds
  191. - Minor tweaks for proper doc/man page installation.
  192. - Workaround for parallel builds
  193. * Mon Aug 6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
  194. - Own the /usr/include/ldns directory (bug #233858)
  195. - Removed obsoleted patch
  196. - Remove files form previous libtool run accidentally packages by upstream
  197. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
  198. - Commented out 1.1.0 make targets, put make 1.0.1 targets.
  199. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
  200. - Fixed changelog typo in date
  201. - Rebuild requested for PT_GNU_HASH support from gcc
  202. - Did not upgrade to 1.1.0 due to compile issues on x86_64
  203. * Fri Jan 6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
  204. - Upgraded to 1.0.1. Removed temporary clean hack from spec file.
  205. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
  206. - Cannot use make clean because there are no Makefiles. Use hardcoded rm.
  207. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
  208. - Patched 'make clean' target to get rid of object files shipped with 1.0.0
  209. * Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
  210. - added a make clean for 2.3.3 since .o files were left behind upstream,
  211. causing failure on ppc platform
  212. * Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
  213. - minor cleanups
  214. * Wed Oct 5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
  215. - reworked for svn version
  216. * Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
  217. - Initial version