popt-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: C library for parsing command line parameters
  3. Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
  4. Name: popt
  5. Version: 1.14
  6. Release: 5%{?_dist_release}
  7. License: MIT
  8. Group: System Environment/Libraries
  9. URL: http://www.rpm5.org/
  10. Source0: http://www.rpm5.org/files/%{name}/%{name}-%{version}.tar.gz
  11. BuildRequires: gettext, doxygen, graphviz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. %description
  14. Popt is a C library for parsing command line parameters. Popt was
  15. heavily influenced by the getopt() and getopt_long() functions, but
  16. it improves on them by allowing more powerful argument expansion.
  17. Popt can parse arbitrary argv[] style arrays and automatically set
  18. variables based on command line arguments. Popt allows command line
  19. arguments to be aliased via configuration files and includes utility
  20. functions for parsing arbitrary strings into argv[] arrays using
  21. shell-like rules.
  22. %description -l ja
  23. Poptはコマンドパラメータを文法解析するためのCライブラリです。
  24. Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
  25. もっと強力な引数の拡張を施すことによって、それらをもっと進化
  26. させています。Poptは 任意の argv[]形式配列を解析して、コマンド
  27. ライン引数に基づいて変数を自動的に設定します。
  28. Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
  29. 許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
  30. てargv[]配列に変換したりするユーティリティ関数を含んでいます。
  31. %package devel
  32. Summary: Development files for the popt library
  33. Summary(ja): popt ライブラリの開発ファイル
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. The popt-devel package includes header files and libraries necessary
  38. for developing programs which use the popt C library. It contains the
  39. API documentation of the popt library, too.
  40. %package -n compat32-%{name}
  41. Summary: A C library for parsing command line parameters.
  42. Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description -n compat32-%{name}
  46. Popt is a C library for parsing command line parameters. Popt was
  47. heavily influenced by the getopt() and getopt_long() functions, but it
  48. improves on them by allowing more powerful argument expansion. Popt
  49. can parse arbitrary argv[] style arrays and automatically set
  50. variables based on command line arguments. Popt allows command line
  51. arguments to be aliased via configuration files and includes utility
  52. functions for parsing arbitrary strings into argv[] arrays using
  53. shell-like rules.
  54. %description -n compat32-%{name} -l ja
  55. Poptはコマンドパラメータを文法解析するためのCライブラリです。
  56. Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
  57. もっと強力な引数の拡張を施すことによって、それらをもっと進化
  58. させています。Poptは 任意の argv[]形式配列を解析して、コマンド
  59. ライン引数に基づいて変数を自動的に設定します。
  60. Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
  61. 許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
  62. てargv[]配列に変換したりするユーティリティ関数を含んでいます。
  63. %package -n compat32-%{name}-devel
  64. Summary: Development files for the popt library
  65. Summary(ja): popt ライブラリの開発ファイル
  66. Group: Development/Libraries
  67. Requires: compat32-%{name} = %{version}-%{release}
  68. Requires: %{name}-devel = %{version}-%{release}
  69. %description -n compat32-%{name}-devel
  70. The popt-devel package includes header files and libraries necessary
  71. for developing programs which use the popt C library. It contains the
  72. API documentation of the popt library, too.
  73. %prep
  74. %setup -q
  75. %build
  76. %configure --libdir=/%{_lib}
  77. make %{?_smp_mflags}
  78. doxygen
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. make DESTDIR=$RPM_BUILD_ROOT install
  82. # Move libpopt.{so,a} to %{_libdir}
  83. rm -f $RPM_BUILD_ROOT/%{_lib}/libpopt.{la,so}
  84. pushd $RPM_BUILD_ROOT/%{_lib}
  85. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  86. ln -sf ../../%{_lib}/$(ls libpopt.so.?.?.?) $RPM_BUILD_ROOT%{_libdir}/libpopt.so
  87. popd
  88. mv -f $RPM_BUILD_ROOT/%{_lib}/libpopt.a $RPM_BUILD_ROOT%{_libdir}/libpopt.a
  89. # Multiple popt configurations are possible
  90. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/popt.d
  91. %find_lang %{name}
  92. %clean
  93. rm -rf $RPM_BUILD_ROOT
  94. %post -p /sbin/ldconfig
  95. %postun -p /sbin/ldconfig
  96. %post -n compat32-%{name} -p /sbin/ldconfig
  97. %postun -n compat32-%{name} -p /sbin/ldconfig
  98. %files -f %{name}.lang
  99. %defattr(-,root,root)
  100. %doc CHANGES COPYING
  101. %{_sysconfdir}/popt.d
  102. /%{_lib}/libpopt.so.*
  103. %files devel
  104. %defattr(-,root,root)
  105. %doc README doxygen/html
  106. %{_libdir}/libpopt.so
  107. %{_libdir}/libpopt.a
  108. %{_includedir}/popt.h
  109. %{_mandir}/man3/popt.3*
  110. %if %{build_compat32}
  111. %files -n compat32-%{name}
  112. %defattr(-,root,root)
  113. /%{_lib}/libpopt.so.*
  114. %files -n compat32-%{name}-devel
  115. %defattr(-,root,root)
  116. %{_libdir}/libpopt.so
  117. %{_libdir}/libpopt.a
  118. %endif
  119. %changelog
  120. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 1.14-5
  121. - rebuilt with rpm-4.8.1-3
  122. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.14-4
  123. - rebuilt with new toolchain
  124. * Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.14-3
  125. - updated Requires: and %%files section on compat32 subpackages
  126. * Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.14-2
  127. - added %%define build_compat32
  128. - fixed compat32 directories
  129. * Mon Aug 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-1
  130. - initial build for Vine Linux
  131. - splitted out from rpm, based on rpm5.org source.
  132. - move libpopt to /lib[64] from /usr/lib[64]
  133. - initscripts-8 uses libpopt.
  134. * Sun May 25 2008 Robert Scheck <robert@fedoraproject.org> 1.13-4
  135. - Solved multilib problems at doxygen generated files (#342921)
  136. * Wed Feb 20 2008 Robert Scheck <robert@fedoraproject.org> 1.13-3
  137. - Revert the broken bind_textdomain_codeset() patch (#433324)
  138. * Thu Feb 14 2008 Robert Scheck <robert@fedoraproject.org> 1.13-2
  139. - Added patch to work around missing bind_textdomain_codeset()
  140. * Sun Dec 30 2007 Robert Scheck <robert@fedoraproject.org> 1.13-1
  141. - Upgrade to 1.13 (#290531, #332201, #425803)
  142. - Solved multilib problems at doxygen generated files (#342921)
  143. * Thu Aug 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-3
  144. - Added buildrequirement to graphviz (#249352)
  145. - Backported bugfixes from CVS (#102254, #135428 and #178413)
  146. * Sun Aug 12 2007 Robert Scheck <robert@fedoraproject.org> 1.12-2
  147. - Move libpopt to /lib[64] (#249814)
  148. - Generate API documentation, added buildrequirement to doxygen
  149. * Mon Jul 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-1
  150. - Changes to match with Fedora Packaging Guidelines (#249352)
  151. * Tue Jul 10 2007 Jeff Johnson <jbj@rpm5.org>
  152. - release popt-1.12 through rpm5.org.
  153. * Sat Jun 9 2007 Jeff Johnson <jbj@rpm5.org>
  154. - release popt-1.11 through rpm5.org.
  155. * Thu Dec 10 1998 Michael Johnson <johnsonm@redhat.com>
  156. - released 1.2.2; see CHANGES
  157. * Tue Nov 17 1998 Michael K. Johnson <johnsonm@redhat.com>
  158. - added man page to default install
  159. * Thu Oct 22 1998 Erik Troan <ewt@redhat.com>
  160. - see CHANGES file for 1.2
  161. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  162. - added ./configure step to spec file