libghc-haddock-library.spec 2.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101
  1. %define pkg_name haddock-library
  2. %define pkg_version 1.6.0
  3. %define pkg_release 2%{?_dist_release}
  4. Summary: Haskell libraries: %{pkg_name}
  5. Name: libghc-%{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: BSD3
  9. Group: Applications/Text
  10. URL: http://hackage.haskell.org
  11. Source0: packages
  12. Source11: haddock-library-1.6.0.tar.gz
  13. Source12: haddock-library.cabal
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: ghc haskell-platform
  16. BuildRequires: libffi-devel gmp-devel zlib-devel
  17. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  18. Requires: ghc haskell-platform
  19. Requires: haskell-platform-dep
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: ara_t
  23. %description
  24. Haskell libraries: %{pkg_name}-%{version}
  25. %prep
  26. %{__rm} -rf ${RPM_BUILD_ROOT}
  27. %build
  28. %ghc_pkg_init
  29. cd %{_builddir}
  30. for pkg in `cat %{SOURCE0}`; do
  31. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  32. pushd ${pkg}
  33. %ghc_fix_dependencies ${pkg}
  34. %cabal_configure1 ${pkg}
  35. %cabal_build
  36. %cabal_haddock
  37. %cabal_copy_resister ${pkg}
  38. popd
  39. done
  40. %install
  41. # move conf files to correct site
  42. pushd ${RPM_BUILD_ROOT}/%{_libdir}/ghc-%{ghc_version}/package.conf.d
  43. %{__mv} %{pkg_name}-%{version}.conf/* .
  44. for conf in *-%{pkg_name}-%{version}-*; do
  45. %{__mv} ${conf} `echo ${conf} | sed -e "s/[0-9.]\+-//"`.conf
  46. done
  47. %{__rm} -rf %{pkg_name}-%{version}.conf
  48. popd
  49. # copy documents
  50. pushd %{_builddir}/%{pkg_name}-%{version}
  51. %{__cp} CHANGES.md \
  52. ${RPM_BUILD_ROOT}%{_docdir}/%{pkg_name}-%{version}
  53. popd
  54. %clean
  55. %{__rm} -rf ${RPM_BUILD_ROOT}
  56. %post
  57. %ghc_pkg_recache
  58. %postun
  59. %ghc_pkg_recache
  60. %files
  61. %defattr(-, root, root)
  62. %{_libdir}/ghc-%{ghc_version}/
  63. %{_libdir}/ghc-lib/
  64. %{_datadir}/
  65. %changelog
  66. * Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 1.6.0-2
  67. - rebuild with ghc-8.4.3-2
  68. * Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 1.6.0-1
  69. - update to 1.6.0
  70. - build using ghc-8.4.3
  71. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 1.5.0.1-1
  72. - new package