libghc-build-pandoc-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180
  1. %define pkg_name build-pandoc
  2. %define pkg_version 2.2.3.2
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: Haskell libraries: %{pkg_name} and dependent libraries
  5. Name: libghc-%{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: BSD3
  9. Group: Applications/Text
  10. URL: http://hackage.haskell.org
  11. Source0: packages
  12. Source11: Glob-0.9.2.tar.gz
  13. Source12: Glob.cabal
  14. Source13: HsYAML-0.1.1.2.tar.gz
  15. Source14: HsYAML.cabal
  16. Source15: JuicyPixels-3.3.tar.gz
  17. Source16: JuicyPixels.cabal
  18. Source17: SHA-1.6.4.4.tar.gz
  19. Source18: SHA.cabal
  20. Source19: base64-bytestring-1.0.0.1.tar.gz
  21. Source20: base64-bytestring.cabal
  22. Source21: blaze-markup-0.8.2.1.tar.gz
  23. Source22: blaze-markup.cabal
  24. Source23: cmark-gfm-0.1.4.tar.gz
  25. Source24: cmark-gfm.cabal
  26. Source25: cmdargs-0.10.20.tar.gz
  27. Source26: cmdargs.cabal
  28. Source27: colour-2.3.4.tar.gz
  29. Source28: colour.cabal
  30. Source29: digest-0.0.1.2.tar.gz
  31. Source30: digest.cabal
  32. Source31: fail-4.9.0.0.tar.gz
  33. Source32: fail.cabal
  34. Source33: hxt-charproperties-9.2.0.1.tar.gz
  35. Source34: hxt-charproperties.cabal
  36. Source35: pandoc-types-1.17.5.1.tar.gz
  37. Source36: pandoc-types.cabal
  38. Source37: regex-pcre-builtin-0.94.4.8.8.35.tar.gz
  39. Source38: regex-pcre-builtin.cabal
  40. Source39: safe-0.3.17.tar.gz
  41. Source40: safe.cabal
  42. Source41: tagsoup-0.14.6.tar.gz
  43. Source42: tagsoup.cabal
  44. Source43: temporary-1.3.tar.gz
  45. Source44: temporary.cabal
  46. Source45: utf8-string-1.0.1.1.tar.gz
  47. Source46: utf8-string.cabal
  48. Source47: xml-1.3.14.tar.gz
  49. Source48: xml.cabal
  50. Source49: blaze-html-0.9.1.1.tar.gz
  51. Source50: blaze-html.cabal
  52. Source51: aeson-pretty-0.8.7.tar.gz
  53. Source52: aeson-pretty.cabal
  54. Source53: ansi-terminal-0.8.0.4.tar.gz
  55. Source54: ansi-terminal.cabal
  56. Source55: zip-archive-0.3.3.tar.gz
  57. Source56: zip-archive.cabal
  58. Source57: hslua-0.9.5.2.tar.gz
  59. Source58: hslua.cabal
  60. Source59: hxt-unicode-9.0.2.4.tar.gz
  61. Source60: hxt-unicode.cabal
  62. Source61: hxt-regex-xmlschema-9.2.0.3.tar.gz
  63. Source62: hxt-regex-xmlschema.cabal
  64. Source63: texmath-0.11.0.1.tar.gz
  65. Source64: texmath.cabal
  66. Source65: doctemplates-0.2.2.1.tar.gz
  67. Source66: doctemplates.cabal
  68. Source67: hslua-module-text-0.1.2.1.tar.gz
  69. Source68: hslua-module-text.cabal
  70. Source69: hxt-9.3.1.16.tar.gz
  71. Source70: hxt.cabal
  72. Source71: skylighting-core-0.7.2.tar.gz
  73. Source72: skylighting-core.cabal
  74. Source73: skylighting-0.7.2.tar.gz
  75. Source74: skylighting.cabal
  76. BuildRequires: ghc haskell-platform
  77. BuildRequires: libghc-data-default-class
  78. BuildRequires: libghc-dlist
  79. BuildRequires: libghc-old-locale
  80. BuildRequires: libghc-data-default
  81. BuildRequires: libghc-aeson
  82. BuildRequires: libghc-semigroups
  83. BuildRequires: libghc-http-client-tls
  84. BuildRequires: libghc-haddock-library
  85. BuildRequires: zlib-devel
  86. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  87. Requires: ghc haskell-platform
  88. Requires: haskell-platform-dep
  89. Requires: libghc-data-default-class
  90. Requires: libghc-dlist
  91. Requires: libghc-old-locale
  92. Requires: libghc-data-default
  93. Requires: libghc-aeson
  94. Requires: libghc-semigroups
  95. Requires: libghc-http-client-tls
  96. Requires: libghc-haddock-library
  97. Vendor: Project Vine
  98. Distribution: Vine Linux
  99. Packager: ara_t
  100. %description
  101. Haskell libraries: %{pkg_name}
  102. %build
  103. %ghc_pkg_init
  104. cd %{_builddir}
  105. for pkg in `cat %{SOURCE0}`; do
  106. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  107. pushd ${pkg}
  108. %ghc_fix_dependencies ${pkg}
  109. %cabal_configure2 %{name} ${pkg}
  110. %cabal_build
  111. %cabal_haddock
  112. %cabal_copy_resister %{name}_${pkg}
  113. popd
  114. done
  115. %clean
  116. %{__rm} -rf ${RPM_BUILD_ROOT}
  117. %post
  118. %ghc_pkg_recache
  119. %postun
  120. %ghc_pkg_recache
  121. %files
  122. %defattr(-, root, root)
  123. %{_bindir}/
  124. %{_libdir}/ghc-%{ghc_version}/
  125. %{_libdir}/ghc-lib/
  126. %{_datadir}/%{name}/
  127. %{_docdir}/%{name}/
  128. %changelog
  129. * Thu Aug 09 2018 Toshiaki Ara <ara_t@384.jp> 2.2.3.2-1
  130. - update to 2.2.3.2
  131. - drop BuildRequires: and Requires: yaml
  132. * Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 2.2.2-1
  133. - update to 2.2.2
  134. - build using ghc-8.4.3
  135. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 2.2.1-2
  136. - correct BuildRequires and Requires (add libghc-data-default)
  137. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 2.2.1-1
  138. - update to 2.2.1
  139. - rebuild using ghc-8.4.2
  140. - rewrite using macro
  141. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 2.0.6-1
  142. - update to 2.0.6
  143. - build using ghc-8.2.2
  144. * Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 1.19.2.1-1
  145. - update to 1.19.2.1
  146. - build using ghc-8.0.2
  147. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 1.17.1-1
  148. - update to 1.17.1
  149. - build using ghc-8.0.1
  150. * Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 1.17.0.3-1
  151. - new package