pcsc-lite-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362
  1. Summary: PC/SC Lite smart card framework and applications
  2. Summary(ja): PC/SC Lite スマートカードフレームワークおよびアプリケーション
  3. Name: pcsc-lite
  4. Version: 1.8.25
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Daemons
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: BSD
  10. URL: https://pcsclite.apdu.fr/
  11. Source0: https://pcsclite.apdu.fr/files/%{name}-%{version}.tar.bz2
  12. Source1: org.debian.pcsc-lite.policy
  13. Source2: pcscd.init
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: eudev-libudev-devel
  16. BuildRequires: polkit-devel
  17. BuildRequires: doxygen
  18. BuildRequires: flex
  19. BuildRequires: python3
  20. BuildRequires: python3-rpm-macros
  21. Requires(post): initscripts
  22. Requires(post): /sbin/chkconfig
  23. Requires(preun): /sbin/chkconfig
  24. Requires(preun): initscripts
  25. Requires(postun): initscripts
  26. Requires: pcsc-ifd-handler
  27. # 390 does not have libusb or smartCards
  28. ExcludeArch: s390 s390x
  29. %description
  30. The purpose of PC/SC Lite is to provide a Windows(R) SCard interface
  31. in a very small form factor for communicating to smartcards and
  32. readers. PC/SC Lite uses the same winscard API as used under
  33. Windows(R). This package includes the PC/SC Lite daemon, a resource
  34. manager that coordinates communications with smart card readers and
  35. smart cards that are connected to the system, as well as other command
  36. line tools.
  37. %package libs
  38. Summary: PC/SC Lite libraries
  39. Summary(ja): PC/SC Lite libraries
  40. Group: System Environment/Libraries
  41. Provides: libpcsc-lite = %{version}-%{release}
  42. %description libs
  43. PC/SC Lite libraries.
  44. %package devel
  45. Summary: PC/SC Lite development files
  46. Summary(ja): PC/SC Lite development files
  47. Group: Development/Libraries
  48. Requires: %{name}-libs = %{version}-%{release}
  49. Requires: pkgconfig
  50. Provides: libpcsc-lite-devel = %{version}-%{release}
  51. %description devel
  52. PC/SC Lite development files.
  53. %package spy
  54. Summary: PC/SC API spy
  55. Summary(ja): PC/SC API spy
  56. Group: Development/Tools
  57. Requires: %{name}-libs = %{version}-%{release}
  58. Requires: python3
  59. %description spy
  60. The purpose of pcsc-spy is to spy all the calls between the PC/SC client
  61. and the PC/SC library.
  62. %package doc
  63. Summary: PC/SC Lite developer documentation
  64. Summary(ja): PC/SC Lite developer documentation
  65. Group: Documentation
  66. %description doc
  67. %{summary}.
  68. %prep
  69. %setup -q
  70. # Convert to utf-8
  71. for file in ChangeLog; do
  72. iconv -f ISO-8859-1 -t UTF-8 -o $file.new $file && \
  73. touch -r $file $file.new && \
  74. mv $file.new $file
  75. done
  76. %build
  77. #autoreconf -if
  78. %configure \
  79. --disable-dependency-tracking \
  80. --disable-static \
  81. --disable-libsystemd \
  82. --enable-polkit \
  83. --enable-runpid=%{_localstatedir}/run/pcscd.pid \
  84. --enable-ipcdir=%{_localstatedir}/run \
  85. --enable-usbdropdir=%{_libdir}/pcsc/drivers
  86. make %{?_smp_mflags}
  87. doxygen doc/doxygen.conf ; rm -f doc/api/*.{map,md5}
  88. %{_libdir}/python3.5/Tools/scripts/pathfix.py -i "%{__python3} %{py3_shbang_opts}" -p src/spy/pcsc-spy
  89. %install
  90. rm -rf $RPM_BUILD_ROOT
  91. make install DESTDIR=$RPM_BUILD_ROOT
  92. rm -f $RPM_BUILD_ROOT%{_datadir}/polkit-1/actions/org.debian.pcsc-lite.policy
  93. mkdir -p $RPM_BUILD_ROOT%{_datadir}/polkit-1/actions/
  94. install -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/polkit-1/actions/
  95. install -dm 755 $RPM_BUILD_ROOT%{_libdir}/pcsc/drivers
  96. install -Dpm 755 %{SOURCE2} $RPM_BUILD_ROOT%{_initrddir}/pcscd
  97. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/reader.conf.d
  98. rm -f $RPM_BUILD_ROOT{%{_sysconfdir}/reader.conf.d/reader.conf,%{_libdir}/lib*.la}
  99. rm -f $RPM_BUILD_ROOT%{_docdir}/%{name}/README.DAEMON
  100. # formaticc doesn't exist any more, don't include the man page
  101. #rm -f $RPM_BUILD_ROOT%{_mandir}/man1/formaticc.1*
  102. %clean
  103. rm -rf $RPM_BUILD_ROOT
  104. %post
  105. /sbin/chkconfig --add pcscd
  106. %preun
  107. if [ $1 = 0 ] ; then
  108. /sbin/service pcscd stop >/dev/null 2>&1 || :
  109. /sbin/chkconfig --del pcscd
  110. fi
  111. %postun
  112. if [ "$1" -ge "1" ]; then
  113. /sbin/service pcscd condrestart >/dev/null 2>&1 || :
  114. fi
  115. %post libs -p /sbin/ldconfig
  116. %postun libs -p /sbin/ldconfig
  117. %files
  118. %defattr(-,root,root,-)
  119. %license COPYING
  120. %doc AUTHORS ChangeLog HELP README SECURITY TODO
  121. %dir %{_sysconfdir}/reader.conf.d/
  122. %{_initrddir}/pcscd
  123. %{_sbindir}/pcscd
  124. %{_libdir}/pcsc/
  125. %{_datadir}/polkit-1/actions/org.debian.%{name}.policy
  126. %{_mandir}/man5/reader.conf.5*
  127. %{_mandir}/man8/pcscd.8*
  128. %files libs
  129. %defattr(-,root,root,-)
  130. %license COPYING
  131. %{_libdir}/libpcsclite.so.*
  132. %{_libdir}/libpcscspy.so.*
  133. %files devel
  134. %defattr(-,root,root,-)
  135. %{_includedir}/PCSC/
  136. %{_libdir}/libpcsclite.so
  137. %{_libdir}/libpcscspy.so
  138. %{_libdir}/pkgconfig/libpcsclite.pc
  139. %files spy
  140. %defattr(-,root,root,-)
  141. %{_bindir}/pcsc-spy
  142. %{_mandir}/man1/pcsc-spy.1*
  143. %files doc
  144. %defattr(-,root,root,-)
  145. %doc doc/api/ doc/example/pcsc_demo.c
  146. %{_docdir}/pcsc-lite/README.polkit
  147. %changelog
  148. * Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.25-1
  149. - new upstream release.
  150. * Mon May 04 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.13-1
  151. - new upstream release
  152. - updata Patch0 (pcsc-lite-1.8.13-docinst.patch)
  153. - updata Patch1 (pcsc-lite-1.8.13-etc.patch)
  154. - add Source1 from fedora
  155. - add BuildRequires: polkit-devel
  156. * Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-2
  157. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  158. * Sun Jun 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.3-1
  159. - new upstream release
  160. - add Patch1 (pcsc-lite-1.8.3-etc.patch)
  161. - create -spy sub package
  162. * Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-2
  163. - fix Patch1
  164. * Sat Jan 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
  165. - new upstream release
  166. - remove BuildRequires: hal-devel, libusb-devel
  167. - add BuildRequires: libudev-devel, flex
  168. - add Patch1 (pcsc-lite-1.8.1-etc.patch)
  169. * Fri Oct 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.5-2
  170. - rebuilt with rpm-4.8.1 for pkg-config
  171. * Sun Feb 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.5-1
  172. - new upstream release
  173. * Mon Mar 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.102-1
  174. - initial build for Vine Linux
  175. * Mon Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-3
  176. - bump tag becaue the build system can't deal with mistakes.
  177. * Mon Aug 18 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-2
  178. - mock build changes
  179. * Sun Aug 17 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.102-1
  180. - Pick up 1.4.102
  181. * Tue May 6 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.101-1
  182. - Pick up 1.4.101
  183. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-3
  184. - Autorebuild for GCC 4.3
  185. * Wed Jan 16 2008 Bob Relyea <rrelyea@redhat.com> - 1.4.4-2
  186. - Silence libpcsc-lite even when the daemon isn't running.
  187. - fix typo in init file which prevents the config file from being read.
  188. * Thu Nov 22 2007 Bob Relyea <rrelyea@redhat.com> - 1.4.4-1
  189. - Pick up 1.4.4
  190. * Tue Feb 06 2007 Bob Relyea <rrelyea@redhat.com> - 1.3.3-1
  191. - Pick up 1.3.3
  192. * Thu Nov 02 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.2-1
  193. - Pick up 1.3.2
  194. * Thu Sep 14 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-7
  195. - Incorporate patch from Ludovic to stop the pcsc daemon from
  196. unnecessarily waking up.
  197. * Mon Jul 31 2006 Ray Strode <rstrode@redhat.com> - 1.3.1-6
  198. - follow packaging guidelines for setting up init service
  199. (bug 200778)
  200. * Mon Jul 24 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-5
  201. - start pcscd when pcsc-lite is installed
  202. * Sun Jul 16 2006 Florian La Roche <laroche@redhat.com> - 1.3.1-4
  203. - fix excludearch line
  204. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3.1-3.1
  205. - rebuild
  206. * Mon Jul 10 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-3
  207. - remove s390 from the build
  208. * Mon Jun 5 2006 Bob Relyea <rrelyea@redhat.com> - 1.3.1-2
  209. - Move to Fedora Core.
  210. - Remove dependency on graphviz.
  211. - Removed %%{_dist}
  212. * Sat Apr 22 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.1-1
  213. - 1.3.1.
  214. * Sun Mar 5 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.3.0-1
  215. - 1.3.0, init script and reader.conf updater included upstream.
  216. - Split developer docs into a -doc subpackage, include API docs.
  217. - libmusclecard no longer included, split into separate package upstream.
  218. * Mon Feb 13 2006 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-14
  219. - Avoid standard rpaths on multilib archs.
  220. - Fine tune dependencies.
  221. * Fri Nov 11 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-13
  222. - Don't ship static libraries.
  223. - Don't mark the init script as a config file.
  224. - Use rm instead of %%exclude.
  225. - Specfile cleanups.
  226. * Thu May 19 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.0-12
  227. - Rebuild.
  228. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.0-11
  229. - rebuilt
  230. * Tue Aug 17 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-10
  231. - Disable dependency tracking to speed up the build.
  232. - Drop reader.conf patch, it's not needed any more.
  233. - Rename update-reader-conf to update-reader.conf for consistency with Debian,
  234. and improve it a bit.
  235. * Sat Jul 31 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.9
  236. - Add update-reader-conf, thanks to Fritz Elfert.
  237. * Thu Jul 1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.8
  238. - Own the %%{_libdir}/pcsc hierarchy.
  239. * Thu May 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.7
  240. - Make main package require pcsc-ifd-handler (idea from Debian).
  241. * Wed May 12 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.6
  242. - Improve package summary.
  243. - Improvements based on suggestions from Ludovic Rousseau:
  244. - Don't install pcsc_demo but do include its source in -devel.
  245. - Sync reader.conf with current upstream CVS HEAD (better docs, less
  246. intrusive in USB-only setups where it's not needed).
  247. * Fri Apr 16 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.5
  248. - Move PDF API docs to -devel.
  249. - Improve main package and init script descriptions.
  250. * Thu Jan 29 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.4
  251. - Init script fine tuning.
  252. * Fri Jan 9 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.3
  253. - BuildRequires libusb-devel 0.1.6 or newer.
  254. * Thu Oct 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.2
  255. - s/pkgconfi/pkgconfig/ in -devel requirements.
  256. * Tue Oct 28 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.1
  257. - Update to 1.2.0.
  258. - Add libpcsc-lite and libmusclecard provides to -libs and -devel.
  259. * Thu Oct 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc3
  260. - Update to 1.2.0-rc3.
  261. - Trivial init script improvements.
  262. - Enable %%{_smp_mflags}.
  263. - Don't bother trying to enable SCF.
  264. * Sun Sep 14 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.2.rc2
  265. - Specfile cleanups.
  266. * Fri Sep 5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc2
  267. - Update to 1.2.0-rc2.
  268. * Wed Aug 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.2.0-0.fdr.0.1.rc1
  269. - Update to 1.2.0-rc1.
  270. * Sun Jun 1 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta5
  271. - Update to 1.1.2beta5.
  272. * Sat May 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.1.2-0.fdr.0.1.beta4
  273. - First build, based on PLD's 1.1.1-2.