iputils-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341
  1. Summary: Network monitoring tools including ping.
  2. Summary(ja): ping 等のネットワークモニタツール集
  3. Name: iputils
  4. Version: 20190709
  5. Release: 1%{?_dist_release}
  6. # some parts are under the original BSD (ping.c)
  7. # some are under GPLv2+ (tracepath.c)
  8. License: BSD and GPLv2+
  9. Group: System Environment/Daemons
  10. URL: https://github.com/iputils/iputils
  11. Source0: https://github.com/iputils/iputils/archive/s%{version}.tar.gz#/%{name}-s%{version}.tar.gz
  12. Source1: ifenslave.tar.gz
  13. Source3: rdisc.initd
  14. Source5: rdisc.sysconfig
  15. Source6: ninfod.initd
  16. Source7: ninfod.sysconfig
  17. Source10: bsd.txt
  18. Source11: https://www.gnu.org/licenses/old-licenses/gpl-2.0.txt
  19. Patch1: iputils-ifenslave.patch
  20. # Vine Source(s)/Patch(es)
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: docbook-utils perl-SGMLSpm
  23. BuildRequires: glibc-kernheaders >= 2.4-8.19
  24. BuildRequires: libidn2-devel
  25. BuildRequires: openssl-devel
  26. BuildRequires: libcap-devel
  27. BuildRequires: libxslt
  28. BuildRequires: docbook5-style-xsl
  29. BuildRequires: meson
  30. Requires(post): chkconfig
  31. Requires(preun): chkconfig
  32. Requires(preun): initscripts
  33. Requires(postun): initscripts
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. %description
  37. The iputils package contains basic utilities for monitoring a network,
  38. including ping. The ping command sends a series of ICMP protocol
  39. ECHO_REQUEST packets to a specified network host to discover whether
  40. the target machine is alive and receiving network traffic.
  41. %prep
  42. %setup -q -a 1 -n %{name}-s%{version}
  43. cp %{SOURCE10} %{SOURCE11} .
  44. %patch1 -p1
  45. %build
  46. %ifarch s390 s390x
  47. export CFLAGS="$RPM_OPT_FLAGS -fPIE"
  48. %else
  49. export CFLAGS="$RPM_OPT_FLAGS -fpie"
  50. %endif
  51. export LDFLAGS="-pie -Wl,-z,relro,-z,now"
  52. %meson
  53. %meson_build
  54. %ninja_build -C %{_target_platform} iputils-gmo
  55. gcc -Wall $RPM_OPT_FLAGS $CFLAGS $LDFLAGS ifenslave.c -o ifenslave
  56. %install
  57. rm -rf ${RPM_BUILD_ROOT}
  58. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  59. mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
  60. mkdir -p ${RPM_BUILD_ROOT}/{bin,sbin}
  61. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  62. pushd %{_target_platform}
  63. install -c clockdiff ${RPM_BUILD_ROOT}%{_sbindir}/
  64. install -cp arping ${RPM_BUILD_ROOT}/sbin/
  65. ln -s /sbin/arping ${RPM_BUILD_ROOT}%{_sbindir}/arping
  66. install -cp ping ${RPM_BUILD_ROOT}/bin/
  67. install -cp ../ifenslave ${RPM_BUILD_ROOT}/sbin/
  68. install -cp rdisc ${RPM_BUILD_ROOT}/sbin/
  69. install -cp tracepath ${RPM_BUILD_ROOT}/bin/
  70. install -cp ninfod/ninfod ${RPM_BUILD_ROOT}/sbin/
  71. ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}
  72. ln -sf /bin/ping ${RPM_BUILD_ROOT}%{_sbindir}/ping6
  73. ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}
  74. ln -sf /bin/tracepath ${RPM_BUILD_ROOT}%{_sbindir}/tracepath6
  75. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
  76. install -cp doc/clockdiff.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  77. install -cp doc/arping.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  78. install -cp doc/ping.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  79. install -cp doc/rdisc.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  80. install -cp doc/tracepath.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  81. install -cp doc/ninfod.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  82. install -cp ../ifenslave.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  83. ln -s ping.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/ping6.8.gz
  84. ln -s tracepath.8.gz ${RPM_BUILD_ROOT}%{_mandir}/man8/tracepath6.8.gz
  85. install -dp ${RPM_BUILD_ROOT}%{_datadir}/locale/ja/LC_MESSAGES
  86. install -m 644 po/ja.gmo $RPM_BUILD_ROOT%{_datadir}/locale/ja/LC_MESSAGES/iputils.mo
  87. popd
  88. find ${RPM_BUILD_ROOT}%{_mandir} -type f | xargs chmod 644
  89. install -dp ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d
  90. install -m 755 -p %{SOURCE3} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/rdisc
  91. install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/rdisc
  92. install -m 755 -p %{SOURCE6} ${RPM_BUILD_ROOT}%{_sysconfdir}/rc.d/init.d/ninfod
  93. install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/ninfod
  94. %find_lang %{name}
  95. %post
  96. /sbin/chkconfig --add rdisc
  97. /sbin/chkconfig --add ninfod
  98. %preun
  99. if [ $1 = 0 ]; then
  100. service rdisc stop >/dev/null 2>&1
  101. service ninfod stop >/dev/null 2>&1
  102. /sbin/chkconfig --del rdisc
  103. /sbin/chkconfig --del ninfod
  104. fi
  105. %postun
  106. if [ "$1" -ge "1" ]; then
  107. service rdisc condrestart >/dev/null 2>&1 || :
  108. service ninfod condrestart >/dev/null 2>&1 || :
  109. fi
  110. %clean
  111. rm -rf ${RPM_BUILD_ROOT}
  112. %files -f %{name}.lang
  113. %defattr(-,root,root)
  114. %license LICENSE*
  115. %doc README.*
  116. %{_sbindir}/clockdiff
  117. /sbin/arping
  118. %{_sbindir}/arping
  119. %attr(4755,root,root) /bin/ping
  120. /sbin/ifenslave
  121. /sbin/rdisc
  122. /bin/tracepath
  123. /sbin/ninfod
  124. %{_sbindir}/ping
  125. %{_sbindir}/ping6
  126. %{_sbindir}/tracepath
  127. %{_sbindir}/tracepath6
  128. %{_mandir}/man8/*
  129. %{_sysconfdir}/rc.d/init.d/rdisc
  130. %{_sysconfdir}/rc.d/init.d/ninfod
  131. %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/rdisc
  132. %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/ninfod
  133. %changelog
  134. * Tue Oct 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20190709-1
  135. - updated to 20190709.
  136. - dropped Source1000 and Patch1000: merged into upstream.
  137. - switched buildsystem to meson.
  138. - dropped Patch0: Makefile is deprecated.
  139. * Sat Nov 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20180629-1
  140. - updated to 20180629.
  141. - dropped Patch2-5 (fixed in upstream).
  142. - updated gettext patch and translation.
  143. - added BR:libxslt.
  144. - added BR:docbook-style-xsl.
  145. * Sat Feb 24 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-2
  146. - fixed initscripts.
  147. * Fri Feb 23 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20161105-1
  148. - updated to 20161105.
  149. - updated gettext patch and translation.
  150. - updated license.
  151. * Sun Jul 13 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 20140519-1
  152. - update to 20140519
  153. - update URL to new upstream
  154. - update gettext patch and translation
  155. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 20101006-1
  156. - new upstream release
  157. - merget with fedora/20101006-8
  158. - update gettext patch and ja.po
  159. * Fri Apr 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-2
  160. - rebuild to add sign..
  161. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 20071127-1
  162. - new upstream release
  163. - spec in utf-8
  164. * Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-41vl1
  165. - remove traceroute6 that is now provided by traceroute package.
  166. - merge changes from FC
  167. * Sat Jul 31 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20020927-13vl2
  168. - ppc patch (Patch110) removed (it's no necessary now)
  169. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 20020927-13vl1
  170. - update to 20020927 merged with 20020927-13
  171. - update i18n patch, ja.po
  172. * Thu Oct 02 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-12
  173. - Fixed unaligned access problem on ia64 (#101417)
  174. * Wed Sep 10 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-11
  175. - Dont use own headers, use glibc and kernheaders.
  176. * Thu Sep 04 2003 Bill Nottingham <notting@redhat.com> 20020927-10
  177. - fix build with new glibc-kernheaders
  178. * Wed Sep 03 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-9
  179. - Start icmp_seq from 0 instead of 1 (Conform with debian and Solaris #100609).
  180. * Thu Jul 31 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-8
  181. - One more update to ifenslave.c
  182. * Mon Jun 16 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-7
  183. - Updated ifenslave.c and README.bonding to latest version.
  184. * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-5
  185. - Bumped release and rebuilt
  186. * Thu May 15 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-4
  187. - Fixed DNS lookup problems (#68212).
  188. - Added warning if binding problem failed on subinterface (#81640).
  189. * Tue May 13 2003 Phil Knirsch <pknirsch@redhat.com> 20020927-3
  190. - Removed bonding tarball and replaced it with ifenslave.c and README
  191. - FHS compliance for all tools, now to be found in /bin with compat symlinks to
  192. old places.
  193. * Fri Nov 29 2002 Phil Knirsch <pknirsch@redhat.com> 20020927-1
  194. - Updated to latest upstream version.
  195. * Tue Jun 18 2002 Phil Knirsch <pknirsch@redhat.com> 20020124-7
  196. - Added new BuildPreReqs for docbook-utils and perl-SGMLSpm (#66661)
  197. - Fixed ipv6 error printing problem (#66659).
  198. * Tue May 21 2002 Phil Knirsch <pknirsch@redhat.com>
  199. - Added a patch to activate the rdisc server (#64270).
  200. - Display the countermeasures warning only in verbose (#55236)
  201. * Thu Apr 18 2002 Bill Nottingham <notting@redhat.com>
  202. - quit trying to build HTML versions of the man pages
  203. * Thu Mar 14 2002 Phil Knirsch <pknirsch@redhat.com>
  204. - Added fix by Tom "spot" Callaway to fix buffer overflow problems in stats.
  205. * Wed Feb 27 2002 Phil Knirsch <pknirsch@redhat.com>
  206. - Update to iputils-ss020124.
  207. * Sat Feb 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl2
  208. - changed Patch110 to have clear_bit() within the ipv6 source for ppc
  209. * Sun Jan 27 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 20001110-7vl1
  210. - based on 20001110-7 from Rawhide
  211. - merged Vine changes from 20001010-1vl4
  212. --- Mon Jul 16 2001 <sagami@vinelinux.org>
  213. - 20001010-1vl4
  214. - use %%{find_lang} to fix so as not to own locale dir
  215. --- Thu Jun 07 2001 <sagami@vinelinux.org>
  216. - 20001010-1vl3: rebuilt for %%{_mandir}
  217. --- Fri Oct 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  218. - 20001010-1vl2
  219. - remove ping6 for ppc
  220. - added Japanese summary and description
  221. --- Thu Oct 26 2000 Jun Nishii <jun@vinelinux.org>
  222. - added ja.po and nls patch
  223. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  224. - automated rebuild
  225. * Mon Aug 27 2001 Philipp Knirsch <pknirsch@redhat.de> 20001110-6
  226. - Fixed buffer overflow problem in traceroute6.c (#51135)
  227. * Sun Jul 01 2001 Philipp Knirsch <pknirsch@redhat.de>
  228. - Made ping6 and traceroute6 setuid (safe as they drop it VERY early) (#46769)
  229. * Thu Jun 28 2001 Philipp Knirsch <pknirsch@redhat.de>
  230. - Fixed ping statistics overflow bug (#43801)
  231. * Tue Jun 26 2001 Philipp Knirsch <pknirsch@redhat.de>
  232. - Fixed a bunch of compiler warnings (#37131)
  233. - Fixed wrong exit code for no packets and deadline (#40323)
  234. - Moved arping to /sbin from /usr/sbin due to ifup call (#45785). Symlink from
  235. /usr/sbin/ provided for backwards compatibility.
  236. * Mon Apr 30 2001 Preston Brown <pbrown@redhat.com>
  237. - install in.rdisc.8c as rdisc.8
  238. * Tue Jan 16 2001 Jeff Johnson <jbj@redhat.com>
  239. - update to ss001110
  240. - doco fixes (#23844).
  241. * Sun Oct 8 2000 Jeff Johnson <jbj@redhat.com>
  242. - update to ss001007.
  243. * Tue Aug 8 2000 Tim Waugh <twaugh@redhat.com>
  244. - fix spelling mistake (#15714).
  245. * Tue Aug 8 2000 Tim Waugh <twaugh@redhat.com>
  246. - turn on -U on machines without TSC (#15223).
  247. * Tue Aug 1 2000 Jeff Johnson <jbj@redhat.com>
  248. - better doco patch (#15050).
  249. * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
  250. - fix include-glibc/ to work with new glibc 2.2 resolver headers
  251. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  252. - automatic rebuild
  253. * Sun Jun 18 2000 Jeff Johnson <jbj@redhat.com>
  254. - FHS packaging.
  255. - update to ss000418.
  256. - perform reverse DNS lookup only once for same input.
  257. * Sun Mar 5 2000 Jeff Johnson <jbj@redhat.com>
  258. - include README.ifenslave doco.
  259. - "ping -i N" was broke for N >= 3 (#9929).
  260. - update to ss000121:
  261. -- clockdiff: preserve raw socket errno.
  262. -- ping: change error exit code to 1 (used to be 92,93, ...)
  263. -- ping,ping6: if -w specified, transmit until -c limit is reached.
  264. -- ping,ping6: exit code non-zero if some packets not received within deadline.
  265. * Tue Feb 22 2000 Jeff Johnson <jbj@redhat.com>
  266. - man page corrections (#9690).
  267. * Wed Feb 9 2000 Jeff Johnson <jbj@jbj.org>
  268. - add ifenslave.
  269. * Thu Feb 3 2000 Elliot Lee <sopwith@redhat.com>
  270. - List /usr/sbin/rdisc in %files list.
  271. * Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
  272. - add remaining binaries.
  273. - casts to remove compilation warnings.
  274. - terminate if -w deadline is reached exactly (#8724).
  275. * Fri Dec 24 1999 Jeff Johnson <jbj@redhat.com>
  276. - create (only ping for now, traceroute et al soon).